Fedora Linux Support Community & Resources Center
  #1  
Old 1st October 2010, 03:21 AM
dismas Offline
Registered User
 
Join Date: Oct 2010
Posts: 2
windows_7chrome
Building vim with gui on Fedora 13

Hi, I am having trouble building vim with gui from source on Fedora 13. I am using
Code:
./configure --enable-gui=auto --with-features=huge --prefix=$HOME/myvim
but I get
Quote:
checking for X... (cached) no
checking if X11 header files can be found... no
checking --enable-gui argument... no GUI support.
I have installed GTK and X11 dev packages. What's missing?

configure output: http://pastebin.com/Z98KrXrR
installed packages: http://pastebin.com/NvJEcM7V

I'm building from source because the packaged Vim doesn't have all the features I want.

Thanks
Reply With Quote
  #2  
Old 1st October 2010, 04:17 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 5,902
linuxfedorafirefox
Re: Building vim with gui on Fedora 13

Do you have libXi-devel ?
Reply With Quote
  #3  
Old 1st October 2010, 04:24 AM
dismas Offline
Registered User
 
Join Date: Oct 2010
Posts: 2
windows_7chrome
Re: Building vim with gui on Fedora 13

Yes, it's in the list of installed packages. I eventually just installed all the dev packages that looked even remotely necessary, and that fixed my dependency issue.
Reply With Quote
  #4  
Old 1st October 2010, 05:28 PM
monramax Offline
Registered User
 
Join Date: Sep 2010
Posts: 2
linuxchrome
Re: Building vim with gui on Fedora 13

I read your configure output.....
Try to install these packages: libXaw, libXau-devel libxcb-devel libX11-devel libICE-devel libSM-devel libXt-devel lib.

btw: you should check the "configure" file itself, and to see what files it looks for.
Reply With Quote
Reply

Tags
building, fedora, gui, vim

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Building new Fedora Machine JValeck Hardware & Laptops 2 14th January 2010 10:13 PM
Building STLPort in Fedora polpak Programming & Packaging 2 10th April 2006 02:44 PM
Fedora kernel rpm building jwspring Using Fedora 0 13th February 2006 02:51 PM
Building my own version of Fedora cruiseoveride Using Fedora 4 26th April 2005 07:11 PM


Current GMT-time: 18:53 (Thursday, 24-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat