Fedora Linux Support Community & Resources Center
  #1  
Old 11th September 2010, 07:07 AM
BrillianceLin Offline
Registered User
 
Join Date: Jan 2007
Posts: 143
linuxchrome
How do I install X11 development package?

As topic, I have trouble with compiling brlcad as this thread.
http://forums.fedoraforum.org/showthread.php?t=249899

I assume the last problem I encounter was lack of development package in the system. Hence, I tried "yum install Xorg-devel" and the terminal reply"No package xorg-x11-devel available."

So, can any one offer some help?
__________________
If Microsoft is god, then now it is time for me to bring it down to hell!
Reply With Quote
  #2  
Old 11th September 2010, 11:55 AM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
linuxkonqueror
Re: How do I install X11 development package?

Try:
su
yum groupinstall "X Software Development"


V
Reply With Quote
  #3  
Old 11th September 2010, 09:35 PM
BrillianceLin Offline
Registered User
 
Join Date: Jan 2007
Posts: 143
linuxchrome
Re: How do I install X11 development package?

Quote:
Originally Posted by Hlingler View Post
Try:
su
yum groupinstall "X Software Development"


V
Thanks for the reply, the command helped. The installation of development package seems like solved the x.org problem.
But there is another problem surface.
This is the terminal feed back.
/usr/bin/ar: .libs/librt_nil.a: Error reading .libs/bezier_2d_isect.o: Input/output error
make[2]: *** [librt_nil.la] Error 1
make[2]: Leaving directory `/home/Lin/Documents/brlcad-7.16.10/src/librt'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/Lin/Documents/brlcad-7.16.10/src'
make: *** [all-recursive] Error 1

Is there some other package missing?
__________________
If Microsoft is god, then now it is time for me to bring it down to hell!
Reply With Quote
  #4  
Old 11th September 2010, 11:23 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,865
linuxfedorafirefox
Re: How do I install X11 development package?

That doesn't look like a missing library, but one that may have been created in
an earlier failed compile.

Try a "make clean" or perhaps a "make allclean", and try again.

The error is from reading a local library being built or already made that has an
internal error. I've seen this when building a Kerberos kit when something
aborts the build. Usually the make clean will delete the file, and all object files
that may contribute to the problem.

You can also just try deleting the library and just run "make" again. Sometimes
this can fix such problems.

It points to a possible error in the/a makefile specification (as in the library didn't
get rebuilt when it should have).
Reply With Quote
  #5  
Old 12th September 2010, 11:14 PM
BrillianceLin Offline
Registered User
 
Join Date: Jan 2007
Posts: 143
linuxchrome
Re: How do I install X11 development package?

Quote:
Originally Posted by jpollard View Post
That doesn't look like a missing library, but one that may have been created in
an earlier failed compile.

Try a "make clean" or perhaps a "make allclean", and try again.

The error is from reading a local library being built or already made that has an
internal error. I've seen this when building a Kerberos kit when something
aborts the build. Usually the make clean will delete the file, and all object files
that may contribute to the problem.

You can also just try deleting the library and just run "make" again. Sometimes
this can fix such problems.

It points to a possible error in the/a makefile specification (as in the library didn't
get rebuilt when it should have).
Thanks for the reply, however I had tried to clean the make or even delete the whole directory from config to make, and it still does not work.... but thanks anyway.
__________________
If Microsoft is god, then now it is time for me to bring it down to hell!
Reply With Quote
  #6  
Old 13th September 2010, 12:32 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,865
linuxfedorafirefox
Re: How do I install X11 development package?

One last note: The filenames shown begin with a ".", These are hidden
files (in this case .libs), so it may depend on how you deleted the whole
directory. If you did a "rm -rf *" then the .libs directory would not have been
removed.
Quote:
/usr/bin/ar: .libs/librt_nil.a: Error reading .libs/bezier_2d_isect.o: Input/output error
Reply With Quote
  #7  
Old 13th September 2010, 11:02 PM
BrillianceLin Offline
Registered User
 
Join Date: Jan 2007
Posts: 143
linuxchrome
Re: How do I install X11 development package?

Quote:
Originally Posted by jpollard View Post
One last note: The filenames shown begin with a ".", These are hidden
files (in this case .libs), so it may depend on how you deleted the whole
directory. If you did a "rm -rf *" then the .libs directory would not have been
removed.
Oops... I just delete the source directory... but if the whole compiling process started from the beginning, the new file will overwrite this one right?
__________________
If Microsoft is god, then now it is time for me to bring it down to hell!
Reply With Quote
  #8  
Old 14th September 2010, 02:53 AM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,865
linuxfedorafirefox
Re: How do I install X11 development package?

Quote:
Originally Posted by BrillianceLin View Post
Oops... I just delete the source directory... but if the whole compiling process started from the beginning, the new file will overwrite this one right?
It should, unless there is an error in the makefile that misses that dependency.

Most such directories are not hidden - that is one reason this may be
an error.
Reply With Quote
  #9  
Old 16th September 2010, 03:06 AM
BrillianceLin Offline
Registered User
 
Join Date: Jan 2007
Posts: 143
linuxchrome
Re: How do I install X11 development package?

Quote:
Originally Posted by jpollard View Post
It should, unless there is an error in the makefile that misses that dependency.

Most such directories are not hidden - that is one reason this may be
an error.
Oh well.... I think I have to tried after the later version come out.... Thanks anyway....
__________________
If Microsoft is god, then now it is time for me to bring it down to hell!
Reply With Quote
Reply

Tags
development, install, package, x11

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to add "sw development" package after Install user4 Using Fedora 2 27th November 2009 06:10 PM
Package Kit Installed 64 Bit Wine Package into a 32 Bit Base Install dd_wizard Using Fedora 0 23rd November 2009 10:15 PM
install 586 kernel module development package pbk Installation, Upgrades and Live Media 8 17th December 2008 06:49 PM
Need to install OpenOffice 2.1 off Development... Jim March Using Fedora 24 26th January 2007 09:06 PM


Current GMT-time: 13:35 (Tuesday, 21-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Brentwood Instagram Photos - Neu-Hohenschoenhausen - Taman Senai Travel Photos on Instagram