Fedora Linux Support Community & Resources Center
  #1  
Old 6th September 2010, 12:32 AM
craig_panama Offline
Registered User
 
Join Date: Dec 2007
Posts: 25
windows_7firefox
FD13 Apache localhost yes www no

SOLVED: IPtables was blocking port 80

I can connect to http://locahost/phpinfo.php I'm using phpinfo.php to illustrate my current situation

[B]BUT I can not connect from outside on the internet... WHY????B]


Where you see "home.biz" or "home" I have changed this from the real website name for the sake of privacy.

error_log


[Wed Sep 08 06:52:17 2010] [notice] Graceful restart requested, doing restart
[Wed Sep 08 06:52:17 2010] [notice] Digest: generating secret for digest authentication ...
[Wed Sep 08 06:52:17 2010] [notice] Digest: done
[Wed Sep 08 06:52:17 2010] [notice] Apache/2.2.16 (Unix) DAV/2 PHP/5.3.3 configured -- resuming normal operations
[Wed Sep 08 06:52:17 2010] [warn] ./mod_dnssd.c: No services found to register
[Wed Sep 08 06:52:17 2010] [warn] long lost child came home! (pid 3358)


presently the computer is connected directly to a static IP, there no router in this configuration

access_log
::1 - - [08/Sep/2010:06:52:17 -0500] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.16 (Fedora) (internal dummy connection)"
::1 - - [08/Sep/2010:06:52:17 -0500] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.16 (Fedora) (internal dummy connection)"
::1 - - [08/Sep/2010:06:52:17 -0500] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.16 (Fedora) (internal dummy connection)"
::1 - - [08/Sep/2010:06:52:17 -0500] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.16 (Fedora) (internal dummy connection)"
::1 - - [08/Sep/2010:06:52:17 -0500] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.16 (Fedora) (internal dummy connection)"
::1 - - [08/Sep/2010:06:52:17 -0500] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.16 (Fedora) (internal dummy connection)"
::1 - - [08/Sep/2010:06:52:17 -0500] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.16 (Fedora) (internal dummy connection)"
::1 - - [08/Sep/2010:06:52:17 -0500] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.16 (Fedora) (internal dummy connection)"


After executing on the firefox that is running on the server:> http://localhost/phpinfo.php

error_log

[Wed Sep 08 07:01:35 2010] [error] [client 127.0.0.1] PHP Warning: phpinfo(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /var/www/html/home/phpinfo.php on line 2
[Wed Sep 08 07:01:38 2010] [error] [client 127.0.0.1] File does not exist: /var/www/html/home/favicon.ico

access_log

127.0.0.1 - - [08/Sep/2010:06:59:06 -0500] "GET /phpinfo.php HTTP/1.1" 200 59340 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100723 Fedora/3.6.7-1.fc13 Firefox/3.6.7"
127.0.0.1 - - [08/Sep/2010:06:59:06 -0500] "GET /phpinfo.php?=PHPE9568F34-D428-11d2-A769-00AA001ACF42 HTTP/1.1" 200 2524 "http://localhost/phpinfo.php" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100723 Fedora/3.6.7-1.fc13 Firefox/3.6.7"
127.0.0.1 - - [08/Sep/2010:06:59:06 -0500] "GET /phpinfo.php?=PHPE9568F35-D428-11d2-A769-00AA001ACF42 HTTP/1.1" 200 2146 "http://localhost/phpinfo.php" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100723 Fedora/3.6.7access_log

httpd.conf settings:

Listen 80
DocumentRoot "/var/www/html/home"
<Directory "/var/www/html/home">
DirectoryIndex index.html index.php index.html.var

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Craig>ping home.biz

Pinging home.biz [69.84.26.236] with 32 bytes of data:
Reply from 69.84.26.236: bytes=32 time=139ms TTL=46
Reply from 69.84.26.236: bytes=32 time=141ms TTL=46
Reply from 69.84.26.236: bytes=32 time=147ms TTL=46
Reply from 69.84.26.236: bytes=32 time=141ms TTL=46

Ping statistics for 69.84.26.236:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 139ms, Maximum = 147ms, Average = 142ms

I've also set SELINUX to Permission because for some reason it's blocking access to critical folders that I need to execute to setup my website with s9y a php website engine I am trying to install.

more info from this problem machine

# ip add
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
link/ether b8:ac:6f:8c:42:63 brd ff:ff:ff:ff:ff:ff
inet 69.84.26.236/29 brd 69.84.26.239 scope global eth0
inet6 fe80::baac:6fff:fe8c:4263/64 scope link
valid_lft forever preferred_lft forever

/sbin/ifconfig
eth0 Link encap:Ethernet HWaddr B8:AC:6F:8C:42:63
inet addr:69.84.26.236 Bcast:69.84.26.239 Mask:255.255.255.248
inet6 addr: fe80::baac:6fff:fe8c:4263/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:59582 errors:0 dropped:0 overruns:0 frame:0
TX packets:63266 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:19609889 (18.7 MiB) TX bytes:38384388 (36.6 MiB)
Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:452 errors:0 dropped:0 overruns:0 frame:0
TX packets:452 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:302325 (295.2 KiB) TX bytes:302325 (295.2 KiB)

Last edited by craig_panama; 10th September 2010 at 12:59 AM. Reason: SOLVED
Reply With Quote
  #2  
Old 9th September 2010, 02:12 AM
craig_panama Offline
Registered User
 
Join Date: Dec 2007
Posts: 25
windows_7firefox
Re: FD13 Apache localhost yes www no

Presently the computer is connected directly to the internet on a static IP for test purposes, until I figure out what is my problem

the static ip is 69.84.26.236

As I'v said I'm only connecting to Apache on this machine from localhost
Reply With Quote
Reply

Tags
apache, fd13, localhost, www

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
apache localhost works but not the ip? Beagleboy Servers & Networking 5 30th March 2009 12:19 PM
Apache & SSL - localhost.localdomain? savage Servers & Networking 10 13th December 2005 08:04 PM
How to change apache email address apache@localhost to admin@proporta.lk niloshima Servers & Networking 2 17th November 2005 11:36 AM
apache@localhost.com pannet1 Servers & Networking 4 9th November 2005 10:46 PM
No localhost: Apache misconfigured? llanitedave Servers & Networking 6 23rd January 2005 03:03 AM


Current GMT-time: 03:26 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Mogi Guacu Instagram Photos - Tlaquiltenango - Pak Phanang Travel Photos on Instagram