Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Other Versions > EOL (End Of Life) Versions
FedoraForum Search

Forgot Password? Join Us!

EOL (End Of Life) Versions This is a Forum to discuss problems and workarounds for versions of Fedora that have passed End of Life.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 1st June 2010, 12:36 AM
fedorafanPL Offline
Registered User
 
Join Date: Jun 2010
Location: Poland
Posts: 2
linuxfedorafirefox
Question Fedora 13, synaptics touchpad, how to enable tapping?

Hello,
After many months of using Debian I switched to the latest Fedora distro. Unfortunately I have a small problem with the Synaptics touchpad, I can't enable tapping function. On Debian Squeeze solution was simple, generate a new xorg.conf file, modify it slightly, and everything working good, but on Fedora 13 (with XFCE environment) it is not so simple.
To resolve this issue I try:
1) In the location / etc/X11/xorg.conf.d/ I created the file synaptics.conf with the formula from Debian (copied xorg touchpad section), but unfortunately after restarting X server, no results, double "smack" is not working :/
2) I also tried to create 10-synaptics.fdi file in /etc/hal/FDI/policy/, but it didn't solve my problem.
3) I also run gpointing-device-settings, however, touchpad tapping still not working.
I can force tapping with synclient (synclient TapButton1 = 1) but it must be a better solution, I don't want to add bash scripts to autorun.
How to solve this problem?
Thanks for any suggestions

Last edited by fedorafanPL; 30th April 2011 at 03:53 PM.
Reply With Quote
  #2  
Old 1st June 2010, 01:48 AM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
windows_7opera
Re: Fedora 13, synaptics touchpad, how to enable tapping?

Try installing gpointing-device-settings. Otherwise, see the following. You may have to install xorg-x11-apps and use xinput. I use xinput with my TrackPoint in F13.
http://www.thinkwiki.org/wiki/How_to...the_TrackPoint
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #3  
Old 1st June 2010, 04:06 AM
oupsemma Offline
Registered User
 
Join Date: Sep 2009
Posts: 41
linuxopera
Re: Fedora 13, synaptics touchpad, how to enable tapping?

Had a similar problem with Fedora Lxde spin and Synaptics, and been doing the same as you, fedorafanPL.

Now I've re-installed, this time with Gnome, and the touchpad is working flawlessly.
I've been checking on the Gnome system:
The first file containing "synaptics" word is /usr/share/X11/xorg.conf.d/50-synaptics.conf, which has the following output:
Code:
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
EndSection
The other file is in /usr/share/doc/xorg-x11-drv-synaptics-1.2.2; it's the README:
Code:
Synaptics touchpad driver for X.Org
-----------------------------------

FAQ
---

* Is this free software?

    Yes, the source code is released under the MIT license.

* When will the driver be included in the XOrg distribution?

    It is already.

* How do I use this driver with Linux kernel 2.6.x?

    You need to have the "evdev" driver loaded or compiled into the
    kernel (CONFIG_INPUT_EVDEV). Set the "Protocol" parameter in the X
    configuration file to "auto-dev". Also, if you set the "Device"
    parameter to "/dev/psaux", the same X configuration file should
    work for a 2.4.x kernel.

    When configuring the kernel, enable PS/2 mouse support
    (CONFIG_MOUSE_PS2).

* It still doesn't work with a 2.6 kernel.

    Some distributions come with an incomplete /dev directory. The
    driver needs the /dev/input/eventX device nodes. Try to create
    them manually if they don't exist already. (Look at
    /proc/bus/input/devices to figure out how many nodes you need.)

	     # mknod /dev/input/event0 c 13 64
	     # mknod /dev/input/event1 c 13 65
	     # mknod /dev/input/event2 c 13 66
	     ...

* How can I configure tap-to-click behavior?

    If you set MaxTapTime=0 in the X config file then the touchpad
    will not use tapping at all, i.e. touching/tapping will not be
    taken as a mouse click.

    If, instead, you set MaxTapMove=0 in the X config file, then the
    touchpad will not use tapping for a single finger tap (left mouse
    button click) but will for the two and three finger tap (middle
    and right button click).

* Why did tap-to-click stop working after I upgraded from an old version?

    Time is now measured in milliseconds instead of "number of
    packets". In practice, this means that if you are upgrading from
    an old version, you need to change MaxTapTime and
    EmulateMidButtonTime to make "tap to click" work. Good values are
    180 and 75 respectively.

* Gnome scrollbars scroll too much when using tap-to-click. Why?

    The ClickTime parameter is probably too big. Try setting it to
    100. Gnome scrollbars use auto repeat, ie if you press the left
    mouse button and keep it pressed, the scroll bar will move until
    you release the button. This will lead to problems if the tap time
    is longer than the delay before auto repeat starts.

* Vertical and horizontal scrolling events are mixed up. How come?

    Probably because some X startup/login script uses xmodmap to remap
    the mouse buttons. Correct settings for the touchpad are:

	xmodmap -e 'pointer = 1 2 3 4 5 6 7'

    You can check the current settings by running:

	xmodmap -pp

* Horizontal scrolling doesn't work in some programs. Is it a driver
  bug?

    No, probably not. Support for horizontal scroll events must be
    handled by the application programs. Not all programs do that
    yet. Ask the authors of the application in question to implement
    support for horizontal scroll events.

    You can use the "xev" program to check if the synaptics driver
    generates the horizontal scroll events.

    If you are having problems with Mozilla, try this link:

	http://lists.debian.org/debian-laptop/2004/08/msg00167.html

* Can the driver be used together with gpm?

    No, not reliably, if you are using a 2.4.x kernel. The gpm driver
    and the X driver both try to read data from the touchpad, and if
    they try to read at the same time, both drivers see incomplete
    data and don't know how to interpret it.

    If you are running a 2.6.x kernel though, there should be no
    conflict, because the kernel driver will make sure both user space
    drivers receive all events from the touchpad.

* Can I use this driver with an ALPS Glidepoint device?

    Yes, see the README.alps file for more information.

* The driver says "reset failed" and the touchpad doesn't work. What
  can I do?

    This problem has been reported for some Compaq models. It's
    currently not known why it happens, but removing the reset command
    from the driver appears to make it work. If you use a 2.4 linux
    kernel, replace the contents of the ps2_synaptics_reset() function
    in ps2comm.c with a "return TRUE;" statement. If you use a 2.6
    linux kernel, remove the while loop in synaptics_query_hardware()
    in the file drivers/input/mouse/synaptics.c in the linux kernel
    source code.


Authors
-------

Many people have contributed to this driver. Look at the top of
synaptics.c and ps2comm.c for details.

The current maintainer is Christoph Brill <egore911@egore911.de>.
Hope that'll help!
__________________
eeepc 1000H Fuduntu
eeepc 901 Crunchbang Statler
Reply With Quote
  #4  
Old 1st June 2010, 12:58 PM
axel668 Offline
Registered User
 
Join Date: Jun 2009
Location: /home/axel
Posts: 27
windows_xp_2003safari
Re: Fedora 13, synaptics touchpad, how to enable tapping?

Could enable it in F13 LXDE spin by adding these two lines to /usr/share/X11/xorg.conf.d/50-synaptics.conf:

Code:
Option "TapButton1" "1"
Option "RBCornerButton" "3"
(Line 1: left mouse tap / Line 2: right mouse tap in lower right corner)

Scrolling worked out of the box for me.
__________________
"A computer lets you make more mistakes faster than any invention in human history - with the possible exceptions of handguns and tequila." - Mitch Ratcliffe
Reply With Quote
  #5  
Old 1st June 2010, 06:49 PM
fedorafanPL Offline
Registered User
 
Join Date: Jun 2010
Location: Poland
Posts: 2
linuxfedorafirefox
Re: Fedora 13, synaptics touchpad, how to enable tapping?

Thanks guys!
Adding these two lines do the job, everything works fine

Last edited by fedorafanPL; 30th April 2011 at 03:53 PM.
Reply With Quote
  #6  
Old 31st October 2010, 12:17 PM
stefansimply Offline
Registered User
 
Join Date: Oct 2010
Posts: 1
linuxopera
Re: Fedora 13, synaptics touchpad, how to enable tapping?

The easiest way is to go in: System - Preferences - Mouse - Touch-pad, and there you will have: "Enable mouse clicks with touch-pad". The other 2 lines didn't work for me. I'm using fedora 13 on an net-book from e machines. Cheers
Reply With Quote
  #7  
Old 31st October 2010, 01:54 PM
smr54 Online
Registered User
 
Join Date: Jan 2010
Posts: 5,528
linuxopera
Re: Fedora 13, synaptics touchpad, how to enable tapping?

I believe there are also options in the openbox menu, similar to what's mentioned for Gnome. (So, they might also be in the LXDE menu.)
Reply With Quote
  #8  
Old 6th November 2010, 02:31 PM
bonedome Offline
Registered User
 
Join Date: Apr 2010
Location: uk
Posts: 727
linuxfirefox
Re: Fedora 13, synaptics touchpad, how to enable tapping?

Hello
I just tried the fedora 14 lxde live usb and like what I see, well apart from lack of touchpad tapping and side scrolling or any menu item (like gnome) to enable it.
Quote:
Could enable it in F13 LXDE spin by adding these two lines to /usr/share/X11/xorg.conf.d/50-synaptics.conf:

Code:

Option "TapButton1" "1"
Option "RBCornerButton" "3"
/xorg.conf.d/50-synaptics.conf: there is no such file as yet do I need to create one ? if so anyone know the line for edge scrolling
This readme /usr/share/doc/xorg-x11-drv-synaptics-1.2.2; it's the README: is about as clear as mud
I had to add this line to my fluxbox startup file
Code:
synclient TapButton1=1 & synclient VertEdgeScroll=1
not sure if that's just applicable to fluxbox though, anyone got this working with 14 ?
I'm going to try the lxde forums to see if there's any solutions there.
__________________
fedora 14 fluxbox and gnome2 hp compaq nx9030 laptop 2Gb ram, helicopter landing pad, jacuzzi, mini fridge, gateway to alternative dimension
Reply With Quote
  #9  
Old 6th November 2010, 11:22 PM
jbkt23 Offline
Registered User
 
Join Date: Mar 2006
Posts: 552
linuxfedorafirefox
Re: Fedora 13, synaptics touchpad, how to enable tapping?

Go to the link below for the new way.

https://fedoraproject.org/wiki/Input..._configuration
__________________
jbkt23
Reply With Quote
  #10  
Old 14th January 2011, 10:06 PM
yetiramb Offline
Registered User
 
Join Date: Jan 2011
Posts: 1
linuxfedorafirefox
Re: Fedora 13, synaptics touchpad, how to enable tapping?

En Fedora 14 LXDE una forma de activar el click del touchpad en utilizado synclient
"synclient TapButton1=1"
Reply With Quote
  #11  
Old 21st January 2011, 01:20 AM
new2fedor Offline
Registered User
 
Join Date: Jan 2011
Posts: 21
linuxfedorafirefox
Re: Fedora 13, synaptics touchpad, how to enable tapping?

it works very well with Gnome, but what about KDE? do we follow the same step??
i have a similar problem with my KDE desktop...
Reply With Quote
  #12  
Old 21st January 2011, 09:19 PM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,370
linuxopera
Re: Fedora 13, synaptics touchpad, how to enable tapping?

Hello new2fedor

In KDE there is a "System Settings" application. In Fedora 14 and 13 it lies in the main "Settings" menu.

That has a section for "Input Devices" which in turn has a section for "Touchpad".

There is a section for enabling tapping there.

There was a time when the KDE tool lacked the ability to enable tapping.

If that is so on your Fedora 13 then you need to update it to get the most up to date KDE.

If that is impractical for you, there is another manual way to do it by editing files. Post back if you need that.
Reply With Quote
  #13  
Old 10th February 2011, 05:00 PM
garyfh Offline
Registered User
 
Join Date: Aug 2009
Posts: 1
linuxfedorafirefox
Smile Re: Fedora 13, synaptics touchpad, how to enable tapping?

Thanks, all in this forum for help. Have Asus 900 touchpad working with Fedora 14 LXDE due to reading this thread. Awesome.
Used the following in lxterm:

su -
your root password here
cd /etc/X11/xorg.conf.d
nano mouse.conf
Section "InputClass"
Identifier "tap-by-default"
MatchIsTouchpad "on"
Option "TapButton1" "1"
EndSection

Part of the above was obtained from the equally informative Fedora Documentation website, also awesome.

Fedora was the first Gnu/Linux distro I ever got to work on my netbook, glad I came back from distro-hopping.

Last edited by garyfh; 10th February 2011 at 05:06 PM. Reason: scattered typing
Reply With Quote
  #14  
Old 2nd March 2011, 07:30 AM
new2fedor Offline
Registered User
 
Join Date: Jan 2011
Posts: 21
linuxfedorafirefox
Re: Fedora 13, synaptics touchpad, how to enable tapping?

hi bbfuller,
thanks a lot for ur help and thanks to ohters too....
however, as u mentioned, it seems my fedora 13 does not have a section for touchpad at all....
perhaps i need to upgrade, but in the interim, is there any other solution - perhaps the manual one u suggested???
Reply With Quote
  #15  
Old 3rd March 2011, 12:15 AM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,370
linuxopera
Re: Fedora 13, synaptics touchpad, how to enable tapping?

Hello new2fedor

That's a coincidence. I'd just disposed of my last Fedora 13 installation this weekend and put F14 in its place.

However, I've just run up the Fedora LiveCD's for F13 to check what the position was.

That is, as Fedora 13 was released, the KDE desktop had a touchpad configuration area as I described.

However, Gnome - and I assume any of the other desktops - didn't.

Can I assume you are using Gnome?

There is yet another complication in the shape of which type of touchpad you have.

If you have a standard "Synaptics" touchpad, the usual manual configuration will work.

If you have the slightly less common "Alps" touchpad then you may have extra work to do.

You should be able to determine what sort of touchpad you have from the command:

Code:
cat /proc/input/devices
run at a command prompt.

I've seen about three different ways of enabling the touchpad manually.

I've not got an easy way of testing now, but I think what "garyfh" suggested a couple of posts back should work.

That is:

In a terminal, issue the command:

Code:
su -
When you tap the "enter" key, that will prompt for your root password and give you full root control over your machine.

In the same terminal, move to the folder where you want to create the configuration file by issuing the command:

Code:
cd /etc/X11/xorg.conf.d
You can copy and paste these commands by the way to save typing them.

Then in the terminal type:

Code:
nano mouse.conf
"nano" is a command line text editor and will create the file if one of the correct name doesn't exist, as in this case. I don't think the name of the file matters. Xorg should read any ".conf" files as it starts up. It's the parameters in the file that matter.

You can then copy this text:

Code:
Section "InputClass"
      Identifier "tap-by-default"
      MatchIsTouchpad "on"
      Option "TapButton1" "1"
EndSection
and paste it into the file.

Hold down "Ctrl" and tap "o" to write the file into the folder and "Ctrl" and "x" to exit the editor.

Reboot the machine and tapping should work.

Post back with questions or problems - or reports of success!
Reply With Quote
Reply

Tags
enable, fedora, synaptics, tapping, touchpad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
not able to enable synaptics touchpad angelbeast Hardware & Laptops 1 8th May 2010 10:55 PM
F13 how to enable system-wide tapping kto Fedora 13 Development Branch 1 17th April 2010 02:20 PM
Enable touchpad tapping and circular scrolling on F11 with XFCE STEELBAS Hardware & Laptops 2 17th June 2009 03:21 AM
Can't run Synaptics Touchpad on Fedora 8 Doug_Vitale Hardware & Laptops 5 10th March 2009 08:31 PM
Fedora 8 : disable tapping on ALPS touchpad udutronik Hardware & Laptops 11 23rd April 2008 07:05 AM


Current GMT-time: 10:48 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
China Photos - Kirzhach Photos on Instagram - Zharkent