Fedora Linux Support Community & Resources Center
  #1  
Old 27th January 2010, 01:35 PM
fairmonk Offline
Registered User
 
Join Date: Dec 2009
Location: Romania, Cluj
Posts: 33
linuxfedorafirefox
Unknown monitor

Hi, I have Uknown monitor under System->Preferences->Display, also when I chose System->Administration->Display it shows nothing to me (no window will open).
How can I fix this problem? (Fedora 12)
Reply With Quote
  #2  
Old 28th January 2010, 02:19 PM
coffee412 Offline
Registered User
 
Join Date: Aug 2005
Location: Ask the Government.
Posts: 447
linuxfedorafirefox
Quote:
Originally Posted by fairmonk View Post
Hi, I have Uknown monitor under System->Preferences->Display, also when I chose System->Administration->Display it shows nothing to me (no window will open).
How can I fix this problem? (Fedora 12)

1. What video card are you using?

Quote:
/sbin/lspci -v |grep VGA
I have the same issue. But its kinda a "no issue" thing. I just choose the resolution that I want and (1024x768) and Im happy. I wouldnt worry about the "undetected monitor".

Just make sure you are running the correct driver for your video card to get the resolutions you want / can support.
__________________
Fedora20 AMD X6 1090T - 8GIG RAM - Nvidia GTX-650 - LXDE. Linux since 1995 - No Gnomes allowed.
Mythbuntu - Mythtv .27 - AMD 6core- 8 gigs ram Nvidia GTX-650 Ceton 4 port tunner
Mint 17 64bit - Dual Core AMD 5200 2gig ram -GT 9400
Galaxy Blaze 4G ICS ClockworkMOD :)
Reply With Quote
  #3  
Old 29th January 2010, 05:06 PM
nvinicio67 Offline
Registered User
 
Join Date: Sep 2006
Posts: 8
linuxfedorafirefox
Hi have the same problem with FC12
I have a monitor Acer AL1714 and the display is only 800 x 600
What can I do?

/sbin/lspci -v |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
Reply With Quote
  #4  
Old 29th January 2010, 05:54 PM
coffee412 Offline
Registered User
 
Join Date: Aug 2005
Location: Ask the Government.
Posts: 447
linuxfedorafirefox
Quote:
Originally Posted by nvinicio67 View Post
Hi have the same problem with FC12
I have a monitor Acer AL1714 and the display is only 800 x 600
What can I do?

/sbin/lspci -v |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
Could you post your /etc/X11/xorg.conf file? I have seen posts that sometimes the video card does not read the monitor settings correctly and will fall back to 800x600 resolution.

---------- Post added at 12:54 PM CST ---------- Previous post was at 12:48 PM CST ----------

Quote:
Originally Posted by nvinicio67 View Post
Hi have the same problem with FC12
I have a monitor Acer AL1714 and the display is only 800 x 600
What can I do?

/sbin/lspci -v |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
I also ran across this:

Open a term window and issue the command:

Quote:
/usr/bin/xrandr
Paste the output so I can see it.

coffee
__________________
Fedora20 AMD X6 1090T - 8GIG RAM - Nvidia GTX-650 - LXDE. Linux since 1995 - No Gnomes allowed.
Mythbuntu - Mythtv .27 - AMD 6core- 8 gigs ram Nvidia GTX-650 Ceton 4 port tunner
Mint 17 64bit - Dual Core AMD 5200 2gig ram -GT 9400
Galaxy Blaze 4G ICS ClockworkMOD :)
Reply With Quote
  #5  
Old 1st February 2010, 03:20 PM
nvinicio67 Offline
Registered User
 
Join Date: Sep 2006
Posts: 8
linuxfedorafirefox
$ /usr/bin/xrandr
Screen 0: minimum 320 x 200, current 800 x 600, maximum 4096 x 4096
VGA1 connected 800x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
800x600 60.3* 56.2
640x480 59.9

---------- Post added at 12:07 PM CST ---------- Previous post was at 10:45 AM CST ----------

The file /etc/X11/xorg.conf seem that doesn't exist!!!


$ pwd
/etc/X11


$ ll
total 24
drwxr-xr-x 2 root root 4096 2009-08-25 20:06 applnk
drwxr-xr-x 2 root root 4096 2010-02-01 11:46 fontpath.d
-rwxr-xr-x 1 root root 1332 2009-12-05 16:14 prefdm
drwxr-xr-x 5 root root 4096 2010-02-01 10:47 xinit
-rw-r--r-- 1 root root 547 2009-11-10 22:08 Xmodmap
-rw-r--r-- 1 root root 493 2009-11-10 22:08 Xresources

---------- Post added at 04:20 PM CST ---------- Previous post was at 12:07 PM CST ----------

I have installed
yum install system-config-display
to generate xorg.conf



# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"

# keyboard added by system-config-display
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Acer AL1714"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "intel"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
Reply With Quote
  #6  
Old 1st February 2010, 03:37 PM
coffee412 Offline
Registered User
 
Join Date: Aug 2005
Location: Ask the Government.
Posts: 447
linuxfedorafirefox
A Quick google check shows this as a working mode line you might need in the xorg.conf specifically in the "Section Screen" area.

Modes "1280x768" "1024x768" "800x600" "640x480"

For your reference here is the link to the posting about your video card and someone that had the same type of problem and how they solved it.


http://www.linuxforums.org/forum/red...82g33-g31.html


Hope this helps,

coffee
__________________
Fedora20 AMD X6 1090T - 8GIG RAM - Nvidia GTX-650 - LXDE. Linux since 1995 - No Gnomes allowed.
Mythbuntu - Mythtv .27 - AMD 6core- 8 gigs ram Nvidia GTX-650 Ceton 4 port tunner
Mint 17 64bit - Dual Core AMD 5200 2gig ram -GT 9400
Galaxy Blaze 4G ICS ClockworkMOD :)
Reply With Quote
  #7  
Old 8th February 2010, 01:04 PM
fairmonk Offline
Registered User
 
Join Date: Dec 2009
Location: Romania, Cluj
Posts: 33
linuxfedorafirefox
refresh rate

Quote:
Originally Posted by coffee412 View Post
1. What video card are you using?



I have the same issue. But its kinda a "no issue" thing. I just choose the resolution that I want and (1024x768) and Im happy. I wouldnt worry about the "undetected monitor".

Just make sure you are running the correct driver for your video card to get the resolutions you want / can support.
Hi,
this is the output from
Code:
/sbin/lspci -v |grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 SE] (rev a1) (prog-if 00 [VGA controller])
the resolution of my display is ok 1280x1024, but it's the refresh rate that I'm concerned about: only 50Hz.
Isn't harmful for eyes ?
Reply With Quote
  #8  
Old 8th February 2010, 01:28 PM
coffee412 Offline
Registered User
 
Join Date: Aug 2005
Location: Ask the Government.
Posts: 447
linuxfedorafirefox
Quote:
Originally Posted by fairmonk View Post
Hi,
this is the output from
Code:
/sbin/lspci -v |grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 SE] (rev a1) (prog-if 00 [VGA controller])
the resolution of my display is ok 1280x1024, but it's the refresh rate that I'm concerned about: only 50Hz.
Isn't harmful for eyes ?
Do your eyes hurt or have you noticed any tendencies like unusual hair growth or abnormal skin color? - just kidding here.

In your menus see if you have the nvidia config utility installed. Look in applications/system tools / nvidia display properties. See if you can change it there.

Make sure your nvidia driver for that card is running. I think with the age of that card you are going to be using something other than kmod-nvidia. Most likely a legacy driver. Check with mjmwired below:

http://www.mjmwired.net/resources/mj...ra-nvidia.html


coffee
__________________
Fedora20 AMD X6 1090T - 8GIG RAM - Nvidia GTX-650 - LXDE. Linux since 1995 - No Gnomes allowed.
Mythbuntu - Mythtv .27 - AMD 6core- 8 gigs ram Nvidia GTX-650 Ceton 4 port tunner
Mint 17 64bit - Dual Core AMD 5200 2gig ram -GT 9400
Galaxy Blaze 4G ICS ClockworkMOD :)
Reply With Quote
  #9  
Old 9th February 2010, 12:31 PM
fairmonk Offline
Registered User
 
Join Date: Dec 2009
Location: Romania, Cluj
Posts: 33
linuxfedorafirefox
Thanks

yes, I found that there is an option from that NVIDIA control panel (some MetaMode ) which allows me to set resolution and refresh rate. I managed to set it to 75 Hz.
Thank you again.
Reply With Quote
  #10  
Old 3rd March 2010, 06:57 PM
jason_tilley Offline
Registered User
 
Join Date: Jun 2008
Posts: 12
windows_xp_2003ie
im having the same issue on a HP Pavilion Laptop - that has a
ATI MOBILITY RADEON 4X AGP and 3D architecture

the output from /sbin/lspci -v|grep VGA

VGA Compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M(prog -if 00 [vga controller])

the /usr/bin/xrandr output is -
Screen 0: minimum 640x480, curent 800x600, maximum 800x600
defulty connected 800x600+0+0 0mm x 0mm
800x600 61.0*
640x480 60.0

so - how do I configure it to 1024x768 (not quite sure on the frequency)

thanks for the help.
Reply With Quote
  #11  
Old 3rd March 2010, 08:24 PM
BugRocks1 Offline
Registered User
 
Join Date: Jan 2010
Posts: 894
linuxfedorafirefox
Quote:
Originally Posted by jason_tilley View Post
im having the same issue on a HP Pavilion Laptop - that has a
ATI MOBILITY RADEON 4X AGP and 3D architecture

the output from /sbin/lspci -v|grep VGA

VGA Compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M(prog -if 00 [vga controller])

the /usr/bin/xrandr output is -
Screen 0: minimum 640x480, curent 800x600, maximum 800x600
defulty connected 800x600+0+0 0mm x 0mm
800x600 61.0*
640x480 60.0

so - how do I configure it to 1024x768 (not quite sure on the frequency)

thanks for the help.
Problems with resolution settings generally are a problem with loaded drivers.

Checking which driver is load on your system

lsmod

look for a video driver name.

Check the boot log to see if there is any problems /var/log/boot.log

cat /var/log/boot.log

The most important file to check is the Xorg.0.log it generally gives good clues about what is going wrong.

cat /var/log/Xorg.0.log
Reply With Quote
  #12  
Old 3rd March 2010, 09:10 PM
jason_tilley Offline
Registered User
 
Join Date: Jun 2008
Posts: 12
windows_xp_2003ie
well - for the lsmod - lots of stuff... but from what I can tell pertains to video -

Video 19088 0
output 2468 1 video
Radeon 448688 0

boot.log -not seeing anything that relates to video

xorg.0.log - lots of info -not sure how to post it here.... but the stuff that stands out is -

No device specified for screen "default screen section"

and

no monitor specified for screen "default screen section"
Reply With Quote
  #13  
Old 3rd March 2010, 09:35 PM
desertrat Offline
Registered User
 
Join Date: Mar 2010
Location: Gilbert, Az
Posts: 41
linuxfedorafirefox
Cool

Drop on down to where it says Section "Device"

Quote:
Originally Posted by nvinicio67 View Post
$ /usr/bin/xrandr
Screen 0: minimum 320 x 200, current 800 x 600, maximum 4096 x 4096
VGA1 connected 800x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
800x600 60.3* 56.2
640x480 59.9[COLOR="Silver"]


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"

# keyboard added by system-config-display
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Acer AL1714"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "intel"
EndSection

Where it says Driver "intel" change intel to fbdev

next section now

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
put your curser right behind the 24
click enter
type modes '1280x1024" "1024x768" "800x600" "640x480"
click enter

I do this all in mc (midnight commander) which has a built in editor that is real easy to use.
also you need to be in sudo mode (ie sudo mc /etc/X11/)

This works real nice if your drivers for your video card are no longer available. I have one computer that has an ATI RagePro 128 card in it. No drivers. This was how I was able to use it with Fedora. I run Fedora 12 on that machine with no problems. (other than what I create myself by changing settings and stuff, Just can't leave well enough alone!)
Reply With Quote
  #14  
Old 3rd March 2010, 11:18 PM
BugRocks1 Offline
Registered User
 
Join Date: Jan 2010
Posts: 894
linuxfedorafirefox
The Radeon driver is not being loaded the zero there is telling that it is not being used by any service or device.

That is why you don't get higher resolutions.

Solutions I can think of:

- Change the driver to VESA or something else(the open drivers) it should work as a work around but you won't get any 3D acceletarion with VESA which you can confirm typing "glxinfo | grep -i rendering"

ps: First you should see if the VESA driver is load with "lsmod | grep -i vesa", if it shows nothing it is not loaded so you should try that the which driver is being used with "lspci -k | grep -i radeon", the lspci also will give you all the other drivers that are installed and you can use for the radeon card.

- Try and find out if the Radeon driver you are using is the one for your Radeon IGP 330M/340/, if you are lucky is just the wrong driver and you just need to install one that works if it is not that, be prepared to endure a lot of pain probably.

You may see what it is happening using "cat /var/log/Xorg.0.log | grep -i radeon" (maybe not sure) also there may be errors with the flag (EE) so if you do "cat /var/log/Xorg.0.log | grep -i \(EE\)" you should get all the errors and also there are warnings and notices.

here are the markers the Xorg.0.log uses

Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

I can't really help you with the Radeon thing as I don't use that but I can point you to some places where there may be some answers.

http://ati.amd.com/products/catalyst/linux.html
http://gofedora.com/fedora-12-ati-catalyst-drivers/
http://gofedora.com/how-to-install-a...ers-fedora-11/

The R100 series includes the IGP 340M if your card is that one you should use the open source drivers.
http://en.wikipedia.org/wiki/Radeon_R100

To try and get the exact model you could try "lsmod -vv | grep -i radeon" or "lspci -k | grep -i radeon"

which should give you something like this:

Subsystem: nVidia Corporation Device 0545
Kernel driver in use: nvidia
Kernel modules: nvidia, nouveau, nvidiafb

If everything else fails go to the here:
https://bugzilla.redhat.com/

And under X-Server file a bug report.
Reply With Quote
  #15  
Old 4th March 2010, 12:08 AM
desertrat Offline
Registered User
 
Join Date: Mar 2010
Location: Gilbert, Az
Posts: 41
linuxfedorafirefox
Cool

This is what my ATI Radeon 9000 xorg.conf looks like:


# Xorg configuration created by system-config-display

Section "ServerLayout"
<------>Identifier "single head configuration"
<------>Screen 0 "Screen0" 0 0
<------>InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"

# keyboard added by system-config-display
<------>Identifier "Keyboard0"
<------>Driver "kbd"
<------>Option<> "XkbModel" "pc105+inet"
<------>Option<> "XkbLayout" "us"
EndSection

Section "Device"
<------>Identifier "Videocard0"
<------>Driver "radeon"
EndSection

Section "Screen"
<------>Identifier "Screen0"
<------>Device "Videocard0"
<------>DefaultDepth 24
<------>SubSection "Display"
<------><------>Viewport 0 0
<------><------>Depth 24
<------>EndSubSection
EndSection

Does this help?
Reply With Quote
Reply

Tags
display, fedora 14, monitor, noveau, unknown monitor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11 Problem with Monitor. System > Preferences>Display Shows unknown monitor manchandap Using Fedora 5 17th October 2009 10:36 AM
Unknown Monitor Almost Fixed fbt Installation, Upgrades and Live Media 3 10th April 2006 08:25 AM
unknown monitor frostedjinx Hardware & Laptops 1 13th June 2005 04:17 AM
unknown monitor HugOwl Hardware & Laptops 4 17th April 2005 09:17 PM
unknown monitor during install stargazer1 Installation, Upgrades and Live Media 1 30th November 2004 11:48 PM


Current GMT-time: 20:22 (Tuesday, 23-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat