Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Servers & Networking
FedoraForum Search

Forgot Password? Join Us!

Servers & Networking Discuss any Fedora server problems and Networking issues such as dhcp, IP numbers, wlan, modems, etc.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 29th December 2009, 10:00 AM
solveitsimply Offline
Registered User
 
Join Date: Dec 2009
Posts: 8
linuxfedorafirefox
Intel PRO/Wireless 2915ABG not working on Acer Travelmate 8100 Fedora 12

Hi folks,

I have installed Fedora 12 on my laptop and subsequently spent most of the day trying to get the wireless connection to work. Looks like I am not alone with Wireless issues

Through searching and reading today I think the problem lies with the fact that the wireless on/off switch is not working. Under Windows, when I press the wifi toggle switch it starts flashing orange. I haven't managed to get it to do anything under Fedora.

Here is some info that may help anyone who is kindly able to help:

# lspci | grep Wireless
06:03.0 Network controller: Intel Corporation PRO/Wireless 2915ABG [Calexico2] Network Connection (rev 05)


# iwconfig
lo no wireless extensions.

eth1 unassociated Mode:Managed Channel=0
Access Point: Not-Associated Bit Rate:0 kb/s Tx-Power=20 dBm
Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.


I tried to load acpi-wmi:

acer-wmi: Acer Laptop ACPI-WMI Extras
acer-wmi: No or unsupported WMI interface, unable to load
ADDRCONF(NETDEV_UP): eth1: link is not ready
ipw2200: Failed to send SCAN_ABORT: Command timed out.


# dmesg | grep -i ipw
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
ipw2200: Copyright(c) 2003-2006 Intel Corporation
ipw2200 0000:06:03.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ipw2200: Detected Intel PRO/Wireless 2915ABG Network Connection
ipw2200 0000:06:03.0: firmware: requesting ipw2200-bss.fw
ipw2200: Radio Frequency Kill Switch is On:
ipw2200: Detected geography ZZE (13 802.11bg channels, 19 802.11a channels)
ipw2200: Failed to send SCAN_ABORT: Command timed out.
ipw2200: Failed to send CARD_DISABLE: Command timed out.


As much as I am learning through this process, I would like to simply get on and start using this installation so any assistance would be very much appreciated.

Thanks
Andy

Last edited by solveitsimply; 29th December 2009 at 10:02 AM. Reason: adding OS version
Reply With Quote
  #2  
Old 29th December 2009, 11:52 AM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
windows_xp_2003opera
See if this is any help.

http://debianletters.blogspot.com/20...reless-on.html

EDIT: There is this too regarding an Acer TravelMate C200
Quote:
There is a radio kill switch in /sys/class/net/eth1/acpi/power/state or something. Must be set to 1 (or press the wireless_radio button on the front) for wireless radio to work. A bit confusing that led there.
http://ubuntuforums.org/archive/index.php/t-451888.html

You might be able to use the echo command to change the state of /sys/class/net/eth1/acpi/power/state or something.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)

Last edited by David Batson; 29th December 2009 at 12:01 PM.
Reply With Quote
  #3  
Old 29th December 2009, 06:44 PM
solveitsimply Offline
Registered User
 
Join Date: Dec 2009
Posts: 8
linuxfedorafirefox
Drivers seem to be working but wifi interface is not

It seems that the kill switch is working even though nothing else seems to be happening when I toggle between on and off:

_KILL SWITCH OFF_

[root@solveitlt02 ~]# cat /sys/bus/pci/drivers/ipw2200/*/rf_kill
0
[root@solveitlt02 ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated Mode:Managed Channel=0
Access Point: Not-Associated Bit Rate:0 kb/s Tx-Power=20 dBm
Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

_KILL SWITCH ON_

[root@solveitlt02 ~]# cat /sys/bus/pci/drivers/ipw2200/*/rf_kill
2
[root@solveitlt02 ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 radio off Mode:Managed Channel:0
Access Point: Not-Associated Bit Rate:0 kb/s Tx-Power=off
Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I am using the button on the front of the laptop to toggle the wifi kill switch, this worked fine under Windows and would appear to be working under Fedora 12.

In which case can anyone give me some pointers on how to configure the wireless interface please? I have tried using Network Manager but the 'Activate and Deactivate buttons are greyed out. This is the case for both eth0 (ethernet) and eth1 (wifi). However eth0 works fine when I plug in the network cable.

Please treat any response as if I am a complete beginner as that is essentially the case for most of this stuff.

Thanks
Reply With Quote
  #4  
Old 29th December 2009, 07:21 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
Try this command in terminal as root:

Code:
echo 1 > /sys/bus/pci/drivers/ipw2200/*/rf_kill
Now try and see if you can use iwconfig.

EDIT: I have not had to set mine up manually, so I am a bit unsure how you would do this from terminal. You might be able to use Network Applet after the above "echo" command.

EDIT 2: One other idea. If you still have trouble, try rebooting after using the "echo" command and see if rfkill is still at 1. Hopefully it will stay at 1, then you could set up your connection normally. I was just thinking it is possible you will need to reboot after the "echo" command for the adapter to be recognized. Don't really know.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)

Last edited by David Batson; 29th December 2009 at 07:31 PM.
Reply With Quote
  #5  
Old 29th December 2009, 07:21 PM
solveitsimply Offline
Registered User
 
Join Date: Dec 2009
Posts: 8
linuxfedorafirefox
I can see the wireless network

OK, now it allows me to scan:

[root@solveitlt02 ~]# iwlist eth1 scan
eth1 Scan completed :
Cell 01 - Address: 00:1F:9F12:1D
ESSID:"FireBrush"
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.462 GHz (Channel 11)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=98/100 Signal level=-24 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 873ms ago


How do I get it to actually connect? Network Manager does not seem to be up to the job!
Reply With Quote
  #6  
Old 29th December 2009, 07:28 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
windows_vistaie
Right click the the NetworkManager icon and click on "edit connections" click on the wireless tab and select edit. Check the settings one setting to look for is the type of wireless, look for the "Managed" option.

If you can't find it there look at the "system->administration->network " tabs. If you can't find it, open a terminal window and change to root using:

su -

then type:

yum install system-config-network

then look for it again. When using the system config network interface you have a few options. One of them is too allow control by NetworkManager. But some other settings are available also. You want to select "Controlled by NM", "Allow users to enable/disable device" and DESELECT "Activate on boot" as NM will do this automatically. Also look for the wireless type and set it to "Managed" save the settings and reboot.

Another settting that might be causing some issue is SELinux, set it to "Permissive" and see if that fixes it after you try the settings mentioned above.

Mike
Reply With Quote
  #7  
Old 29th December 2009, 07:30 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
windows_vistaie
Set it "Managed" and see it NM can control it then.
Reply With Quote
  #8  
Old 29th December 2009, 08:34 PM
solveitsimply Offline
Registered User
 
Join Date: Dec 2009
Posts: 8
linuxfedorafirefox
NM configuration

I have attached some screen shots of the NM config screens. These were installed by default as part of the original installation, I have not had to install anything separately.

Originally there was only one network connection in the Network Configuration screen. Yesterday I right clicked on the network icon, clicked Edit Connections and added in a Wireless connection because this was blank. It added a connection to the Network Configuration settings which I have deselected but when I right click on the icon again it is still blank. very confusing.

any other ideas? I'm not quite sure where to go from here.
Attached Thumbnails
Click image for larger version

Name:	Screenshot-Network Configuration.png
Views:	121
Size:	41.3 KB
ID:	18833   Click image for larger version

Name:	Screenshot-Network Connections2.png
Views:	103
Size:	19.3 KB
ID:	18834   Click image for larger version

Name:	Screenshot-Wireless Device Configuration.jpg
Views:	116
Size:	53.2 KB
ID:	18835   Click image for larger version

Name:	Screenshot-Wireless Device Configuration-1.jpg
Views:	107
Size:	32.2 KB
ID:	18836  
Reply With Quote
  #9  
Old 29th December 2009, 09:07 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
windows_vistaie
The screenshots look right. Just to save a possible conflict highlight the top "wireless" profile and delete it. Now under the NM edit connection, enter your wireless device again and save it. Reboot. Is your entry still listed? If not set SELinux to "permissive" or "disabled" and enter your wireless device again and reboot. Is it listed now?

In some instances, NM likes to have the SSID set to broadcast from the wireless router another thing to look at.

I have the exact same 2915abg as you and it works fine with NM and F12.

Last edited by Iron_Mike; 29th December 2009 at 09:11 PM.
Reply With Quote
  #10  
Old 29th December 2009, 09:19 PM
solveitsimply Offline
Registered User
 
Join Date: Dec 2009
Posts: 8
linuxfedorafirefox
SELinux settings

Thanks Iron_Mike. I haven't worked out how to delete the top setting. Delete is greyed out in the configuration screen. Any idea how I can do this manually?

I assume the SELinux settings you mention are as per the screenshot?

I have also added a screen shot of the wireless connection I just added through 'Edit Connections' by right clicking on the network icon. I can go in and out of the Network Connections window and it still seems to be there. I'll try a reboot and see if it holds it.
Attached Thumbnails
Click image for larger version

Name:	Screenshot-SELinux Administration.jpg
Views:	88
Size:	34.7 KB
ID:	18837   Click image for larger version

Name:	Screenshot-Network Configuration-1.png
Views:	85
Size:	49.3 KB
ID:	18838  

Last edited by solveitsimply; 29th December 2009 at 09:30 PM. Reason: adding screenshot
Reply With Quote
  #11  
Old 29th December 2009, 09:22 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
windows_vistaie
Yep, that's it.

For the wireless profile, put a check mark in the box first.
Reply With Quote
  #12  
Old 29th December 2009, 09:52 PM
solveitsimply Offline
Registered User
 
Join Date: Dec 2009
Posts: 8
linuxfedorafirefox
OK, SELinux is disabled, have checked box and rebooted twice but still no joy.

The new wireless connection is no longer showing under Edit Connections, but it is still visible in Network Configuration.

Where should I be looking to get some more info on what is happening/not happening when the wireless should be coming up?

The Kill switch is still turned off but the wireless interface is not being configured:

[root@solveitlt02 ~]# cat /sys/bus/pci/drivers/ipw2200/*/rf_kill
0
[root@solveitlt02 ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated Mode:Managed Channel=0
Access Point: Not-Associated Bit Rate:0 kb/s Tx-Power=20 dBm
Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

---------- Post added at 10:52 AM CST ---------- Previous post was at 10:49 AM CST ----------

Is this info from dmesg relevant:?

acerhdf: Acer Aspire One Fan driver, v.0.5.16
acerhdf: unknown (unsupported) BIOS version Acer, inc./TravelMate 8100 /3C23, please report, aborting!
Reply With Quote
  #13  
Old 29th December 2009, 11:05 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
linuxfedorafirefox
Solveit,

When you left click the NM icon, does it show your wireless access point? If it does click on the entry. If it doesn't click on "create new wireless network" or if the SSID is hidden, click the "connect to hidden wireless network" and see what happens.
Reply With Quote
  #14  
Old 29th December 2009, 11:15 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
Quote:
Originally Posted by solveitsimply View Post
The Kill switch is still turned off but the wireless interface is not being configured:

[root@solveitlt02 ~]# cat /sys/bus/pci/drivers/ipw2200/*/rf_kill
0
[root@solveitlt02 ~]# iwconfig
lo no wireless extensions.
According to that article I linked above, the killswitch setting needs to be 1 not 0. When I gave the echo command earlier, it was to set the killswitch setting to 1. Did it work after using that echo command?
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #15  
Old 29th December 2009, 11:34 PM
solveitsimply Offline
Registered User
 
Join Date: Dec 2009
Posts: 8
linuxfedorafirefox
Be patient I'm new to this OS :)

Quote:
Originally Posted by Iron_Mike View Post
Solveit,

When you left click the NM icon, does it show your wireless access point? If it does click on the entry. If it doesn't click on "create new wireless network" or if the SSID is hidden, click the "connect to hidden wireless network" and see what happens.
Iron_Mike, you're a legend, or I'm a complete half wit I have just left clicked (for the first time) on the network icon and saw all the options of which one was the wireless AP that I was trying to connect to. Selected it, entered the passwd and waddayano!?

I am right now running through the wireless connection and it's going beautifully. I can't believe it has been something so simple all along.

Thanks for all your help!!

---------- Post added at 12:34 PM CST ---------- Previous post was at 12:25 PM CST ----------

Quote:
Originally Posted by David Batson View Post
According to that article I linked above, the killswitch setting needs to be 1 not 0. When I gave the echo command earlier, it was to set the killswitch setting to 1. Did it work after using that echo command?
[root@solveitlt02 ~]# cat /sys/bus/pci/drivers/ipw2200/*/rf_kill
0

Definitely running at 0. Is working brilliantly and I am currently sitting down at my computer for the first time in about a day and a half (no longer standing with it on a book shelf next to the router)

According to this article 0 is kill switch disabled - radio on:

http://ipw2100.sourceforge.net/

The reported values mean:

0 = RF kill not enabled (radio on)
1 = SW based RF kill active (radio off)
2 = HW based RF kill active (radio off)
3 = Both HW and SW RF kill active (radio off)

Thanks for your help.
Reply With Quote
Reply

Tags
2915abg, 8100, acer, fedora, intel, pro or wireless, travelmate, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
reader memory card on laptop acer travelmate 8100 ivan_m Hardware & Laptops 4 6th August 2008 01:53 PM
wireless with Fedora 7 on Acer Travelmate with Intel PRO/Wireless 3945ABG daboheny Servers & Networking 3 13th June 2007 08:59 PM
Intel PRO/Wireless 2915ABG Whatshisface Hardware & Laptops 2 26th April 2007 06:43 AM
Intel Wireless 2915abg on FC5 LOwrestling2001 Servers & Networking 1 30th April 2006 02:16 PM
Installation of FC3 on Acer Travelmate 8100-Series fearism Hardware & Laptops 1 6th June 2005 09:01 PM


Current GMT-time: 05:30 (Saturday, 23-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat