Fedora Linux Support Community & Resources Center
  #1  
Old 28th December 2009, 03:01 AM
boarder428 Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
linuxfedorafirefox
Question Dual display setup - only one display works

I was curious if anyone had any insight on this problem, I'm running F12 with Nvidia 8400GTS card, I'm trying to run dual displays but only the display plugged into the vga port is comming on when booting up. If I only have 1 monitor hooked up to DVI port that monitor will come on.
Reply With Quote
  #2  
Old 28th December 2009, 02:59 PM
kbs1 Offline
Registered User
 
Join Date: Oct 2008
Posts: 91
linuxopera
do you want to run the display as separate X display or expanded X screen? [like expanded desktop]. Either way you need to edit xorg.conf, I had a similar setup on my old computer on FC9.
Reply With Quote
  #3  
Old 28th December 2009, 07:55 PM
boarder428 Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
windows_vistaie
Quote:
Originally Posted by kbs1 View Post
do you want to run the display as separate X display or expanded X screen? [like expanded desktop]. Either way you need to edit xorg.conf, I had a similar setup on my old computer on FC9.
I'd like to run it as an expanded desktop
Reply With Quote
  #4  
Old 28th December 2009, 08:00 PM
kbs1 Offline
Registered User
 
Join Date: Oct 2008
Posts: 91
linuxopera
well if you install the nvidia official driver, there should be a program named "nvidia-config-display" or "nvidia-display-config" or something like that, I don't remember exactly. Just run it and it can create a pretty good xorg.conf file for you, with expanded desktop settings
Reply With Quote
  #5  
Old 29th December 2009, 02:16 AM
boarder428 Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
linuxfedorafirefox
Thumbs up

Quote:
Originally Posted by kbs1 View Post
well if you install the nvidia official driver, there should be a program named "nvidia-config-display" or "nvidia-display-config" or something like that, I don't remember exactly. Just run it and it can create a pretty good xorg.conf file for you, with expanded desktop settings
ok, I found it, it said I was'nt using the Nvidia driver, I installed it and re-started and it let me configure the second monitor. It is working now, thanks for the response!
I do have another issue though concerning compiz. I cannot seem to get any of the compiz features to work, when I click on Desktop effects it says "Accelerated 3D graphics is not avaliable Desktop effects require hardware 3d support" I do not see anything about 3D support in the nvidia settings, I have had no problems in the past running compiz effects on this hardware under Ubuntu os's.

Last edited by boarder428; 29th December 2009 at 03:34 AM.
Reply With Quote
  #6  
Old 29th December 2009, 12:09 PM
kbs1 Offline
Registered User
 
Join Date: Oct 2008
Posts: 91
linuxopera
so how did you install the nvidia driver? are you sure you're using the correct one?
Reply With Quote
  #7  
Old 29th December 2009, 01:29 PM
boarder428 Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
linuxfirefox
I can't remember the exact command! I'll have to try to go thru the terminal history and find it. When I clicked on the Nvidia settings under the system tools menu it said that the settings were disabled and gave me a command to run as root to change. After running the command and re-starting Inow have configurable options under the Nvidia settings dialog which I did'nt have before so I am just assuming that it worked due to the changes! I am also haveing a problem with the computer retaining the settings after rebooting. I have to enable my 2nd monitor each time I boot. I would choose the option to "Save to X Conguration file" and it would return with the error "Unable to create new X config backup file '/etc/X11/xorg.conf.backup'."

Don't know if this helps...
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (mockbuild@)  Sun Nov 22 21:05:17 EST 2009

# Xorg configuration created by livna-config-display

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    ModulePath      "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
    Option         "AIGLX" "on"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

Last edited by boarder428; 29th December 2009 at 07:33 PM.
Reply With Quote
  #8  
Old 30th December 2009, 02:01 AM
kbs1 Offline
Registered User
 
Join Date: Oct 2008
Posts: 91
linuxopera
you have to run that utility as root. try that, the file you have posted does not provide configuration for expanded desktop or dual screens.
Reply With Quote
  #9  
Old 30th December 2009, 02:14 AM
boarder428 Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
linuxfedorafirefox
Quote:
Originally Posted by kbs1 View Post
you have to run that utility as root. try that, the file you have posted does not provide configuration for expanded desktop or dual screens.
I can't seem to figure out how to run it from root! I tried the recomendations listed above and none of them worked. Then I tried the following...
Code:
[root@spyder1 ~]# nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'
after adjusting the settings here...



but still does'nt seem to work!

I am wondering if I should try running some of the commands in this Nvidia post? http://forums.fedoraforum.org/showthread.php?t=204752

Also wondering how to tell if I have a PAE Kernel, I do have 4gb of ram.

Last edited by boarder428; 30th December 2009 at 04:38 AM. Reason: added info
Reply With Quote
  #10  
Old 30th December 2009, 12:07 PM
kbs1 Offline
Registered User
 
Join Date: Oct 2008
Posts: 91
linuxopera
it should work now, just press the save to x configuration file button

PAE kernel not necessary for this.
Reply With Quote
  #11  
Old 31st December 2009, 03:05 AM
boarder428 Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
linuxfirefox
Quote:
Originally Posted by kbs1 View Post
it should work now, just press the save to x configuration file button

PAE kernel not necessary for this.
thats what I thought but this is when I get the error "Unable to create new X config backup file '/etc/X11/xorg.conf.backup'."
Reply With Quote
  #12  
Old 1st January 2010, 12:44 PM
kbs1 Offline
Registered User
 
Join Date: Oct 2008
Posts: 91
linuxopera
from what you post here:

[root@spyder1 ~]# nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

it seems the file was written ok. You have to run that utility as root.
Reply With Quote
  #13  
Old 1st January 2010, 07:31 PM
boarder428 Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
windows_vistaie
Post

Well thanks for the reply, I did run it from root I just did'nt include the su - command when I copied the text from the terminal window. I think i'm beating a dead horse here, everything looks to be in order but it still does'nt work correctly as with compiz as well. I previously strayed away from fedora for a while when I was having similar issues in F10 but decided to give it a try again. I'm tring to get a feel for the red hat like distro but have always had much better luck with Ubuntu. Compiz and everything runs fine on this machine when booted to Ubuntu or Mint so I am pretty sure it is'nt a hardware issue. I'm frustrated with this issue and think it's time to give it a rest. The dual displays work I just have to re-enable the second display every time I boot up and I can live without compiz.
Thanks again for the effort!
Corey

Last edited by boarder428; 1st January 2010 at 07:35 PM.
Reply With Quote
  #14  
Old 1st January 2010, 10:09 PM
kbs1 Offline
Registered User
 
Join Date: Oct 2008
Posts: 91
linuxopera
okay no problem, just post the contents of file /etc/X11/xorg.conf AFTER you press the "save to X configuration file button". Does the message that it failed appear even if you run the utility as root? I'm curious, this feature always worked for me back in times of Fedora 9. Now I have a new PC, and only a single monitor output, so no extended desktop for me
Reply With Quote
  #15  
Old 2nd January 2010, 03:45 AM
boarder428 Offline
Registered User
 
Join Date: Apr 2009
Posts: 51
linuxfedorafirefox
Thumbs up

All I can figure is that I am not actually running the config utility as root. When I type the following
Code:
[corey@spyder1 ~]$ su -
Password: 
[root@spyder1 ~]# nvidia-xconfig
I do not actually get the nvidia X Server settings window, I get the following return
Code:
Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'
I actually have to go to Applications>System Tools>nVidia Display Settings to get the nVidia window.

the /etc/X11/xorg.conf is exactly as I posted above.
I am obviously having a problem figuring out how to run the utility as root unless I have a permissions issue that is not allowing the config utility to back up and/or write to the file(s)

EDIT: I don't know why I did'nt figure this out before but I found a simple work around, When choosing the "Save to Config" option there is an option to preview the config before saving, I just simply copied the text from the preview window, opened a terminal and pasted the text into the xorg.conf file under root priveleges, saved it and it worked.
Not that it matters but here is a copy of the file now and the computer is retaining the settings upon re-booting.
Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (mockbuild@builder.wilsonet.com)  Sun Nov 22 21:43:09 EST 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (mockbuild@)  Sun Nov 22 21:05:17 EST 2009
# Xorg configuration created by livna-config-display

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    ModulePath      "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
    Option         "AIGLX" "on"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SVA 905W"
    HorizSync       31.0 - 80.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
    Monitor        "Monitor0"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1440+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
thanks for all the help:-)
Corey

Last edited by boarder428; 2nd January 2010 at 04:03 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual display - menus wont go -> DISPLAY:0.1 martypants Using Fedora 0 25th June 2009 02:40 AM
I can't setup my display to more than 800 x 600 FelixT Using Fedora 6 3rd April 2008 03:04 AM
Invert single monitor on dual display setup shadowwyvern Hardware & Laptops 1 4th November 2007 01:42 AM
Display setup issue chapter Installation, Upgrades and Live Media 1 27th February 2007 12:01 AM
How do I setup display resolutions? muzicman82 Hardware & Laptops 1 27th September 2006 09:37 PM


Current GMT-time: 16:09 (Friday, 24-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Hunt Valley Photos - Victoria Instagram Photos - Mosopa Travel Photos