Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 24/25 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 8th December 2009, 03:11 PM
al_chem Offline
Registered User
 
Join Date: Jun 2007
Posts: 73
linuxfedorafirefox
Question F12 - Entering Unicode characters in Gnome via Ctrl+Shift+u, no longer works

For some unknown (to me) reason, "Ctrl+Shift+u, <unicode number>" doesn't work in F12. I had gotten quite used to this method in order to input several symbols and if you know what you want, it is a lot faster compared to using the character map. This was working in all recent Fedora versions.

Does anyone know how to enable this functionality?
Reply With Quote
  #2  
Old 8th December 2009, 11:59 PM
DavidMcCann Offline
Registered User
 
Join Date: Jul 2008
Location: London
Posts: 459
linuxfedorafirefox
This method works with the Gnome input module, but not with the default xim. You need to set
GTK_IM_MODULE=gtk-im-context-simple
I think it goes in /etc/environment.
If that doesn't work, try /etc/X11/xinit/xinput.d/none.conf.
Reply With Quote
  #3  
Old 9th December 2009, 01:33 AM
al_chem Offline
Registered User
 
Join Date: Jun 2007
Posts: 73
linuxfedorafirefox
Thanks a lot for the pointer, you've been most helpful. I decided to create startup scripts containing "export GTK_IM_MODULE=gtk-im-context-simple" for gedit, OOo Writer and pidgin and made the launchers point to the scripts instead of applying the change system wide. (Was there an easier way to integrate that into the launchers?)
Reply With Quote
  #4  
Old 12th December 2009, 02:15 PM
al_chem Offline
Registered User
 
Join Date: Jun 2007
Posts: 73
linuxfedorafirefox
Edit: I discovered that when I had my keyboard turned to greek, I was unable to enter certain doubly accented characters, such as " ΐ ", so I was forced to change GTK_IM_MODULE for my account. I accomplished that by changing xim to gtk-im-context-simple in ~/.gconf/desktop/gnome/interface/%gconf.xml. I 'll wait to see if that survives any future updates and I 'll report back.
Reply With Quote
  #5  
Old 20th December 2009, 11:40 AM
xchris Offline
Registered User
 
Join Date: Dec 2009
Posts: 13
linuxsafari
Hi,

You must enable the 'input method'

System->Preferences->Input method

Then edit the 'enable or disable' to control-shift-u

Chris
Reply With Quote
Reply

Tags
ctrl+shift+u, gtk+, unicode

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unicode characters by code. Thetargos Using Fedora 2 15th May 2008 05:42 PM
Unicode Characters in copying Jeff Sadowski Using Fedora 0 10th July 2007 04:11 PM
vim ctrl + shift + u ileshy Using Fedora 4 14th February 2007 03:51 PM


Current GMT-time: 22:46 (Monday, 29-05-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat