Fedora Linux Support Community & Resources Center
  #1  
Old 18th November 2009, 02:30 AM
volgon Offline
Registered User
 
Join Date: May 2005
Posts: 14
windows_7ie
F12 i686 install hang

I'm trying to install Fedora 12 32-bit on an HP Mini 110 netbook and the system hangs at "waiting for hardware to initialize...". Using the nomodeset kernel parameter does not help. I have tried both the PAE and non-PAE kernels through PXE booting and I have the same problem. I have also tried booting from the boot.iso off of the hard disk and that hangs at the same place as well.

Fedora 11 runs fine on this system.

Does anyone have any other ideas?

Thanks!
Reply With Quote
  #2  
Old 18th November 2009, 02:42 AM
marcrblevins Offline
Registered User
 
Join Date: Jun 2006
Location: Texas
Age: 43
Posts: 4,168
linuxfedorafirefox
Tried noprobe option?
Reply With Quote
  #3  
Old 18th November 2009, 03:09 AM
volgon Offline
Registered User
 
Join Date: May 2005
Posts: 14
windows_7ie
Quote:
Originally Posted by marcrblevins View Post
Tried noprobe option?
Thank you very much! The noprobe kernel parameter got anaconda to start. Hopefully the remainder of the install will go smoothly.

Thanks again!
Reply With Quote
  #4  
Old 18th November 2009, 06:09 AM
julkie Offline
Registered User
 
Join Date: Nov 2009
Posts: 2
windows_7firefox
volgon its works for you? i have the same netbook and i just cant run de livecd via usb...
thanks.
Reply With Quote
  #5  
Old 18th November 2009, 06:22 AM
nparafe Offline
Registered User
 
Join Date: Aug 2009
Posts: 16
linuxfedorafirefox
add this to the boot options ssb.blacklist=1. Put this option at the parameters at the first boot after installation and then install wl-kmod from rpm fusion. That worked for me.
Reply With Quote
  #6  
Old 18th November 2009, 07:01 AM
julkie Offline
Registered User
 
Join Date: Nov 2009
Posts: 2
windows_7firefox
[install cd] not look with 'noprobe' when its asks for the image of the instalation directory no sdb option for my usb is in the list...

[live cd] just dont boot...

im running the isos from a pendrive with fedora liveusb creator.
and my netbook is a hp mini 110

some help?

Edit:
Quote:
Originally Posted by nparafe View Post
add this to the boot options ssb.blacklist=1. Put this option at the parameters at the first boot after installation and then install wl-kmod from rpm fusion. That worked for me.
thats works with the livecd thanks now im just configuring my fedora 12 desktop...
thanks again.
Reply With Quote
  #7  
Old 19th November 2009, 04:07 AM
volgon Offline
Registered User
 
Join Date: May 2005
Posts: 14
windows_7ie
Quote:
Originally Posted by nparafe View Post
add this to the boot options ssb.blacklist=1. Put this option at the parameters at the first boot after installation and then install wl-kmod from rpm fusion. That worked for me.
Thank you nparafe! Adding just the ssb.blacklist=1 kernel parameter on my system worked also. I did a PXE network install and it went fine.
Reply With Quote
  #8  
Old 20th November 2009, 11:26 AM
kraseef Offline
Registered User
 
Join Date: Apr 2008
Posts: 34
linuxfedorafirefox
Hi All,

I am facing exactly the same problem with my HP mini 110. I am attempting to install Fedora 12 from USB. It also hangs at the "waiting for hardware to initialize". I am not as experienced as you guys.

Volgon, could you perhaps explain to me how did you fix the problem either by noprobe or with the ssb.balcklist=1. In other words how and where do you specify these parameters?

Thanks in advance.

Edit: Ok guyes

I have done it using bbs.back.... . However, when installing packages and reaching to post-installation activity, it starts writing the boot loader but it stucks at that point. nothing works then and I will have to hard boot it.

Tried the process serveral times but with no success.

My mini is system less now ... can any body help !!!

Thanks.

Last edited by kraseef; 20th November 2009 at 07:12 PM.
Reply With Quote
  #9  
Old 21st November 2009, 02:28 AM
volgon Offline
Registered User
 
Join Date: May 2005
Posts: 14
linuxfedorafirefox
Setting the kernel parameter of "noprobe" seemed to cause other problems for me. Anaconda generally failed before as it tried to install packages. However setting just "ssb.blacklist=1" made the install go without an errors or problems. The system booted up fine. After install the package kmod-wl from rpmfusion.org the wireless worked. All of the other hardware worked out of the box.
Reply With Quote
  #10  
Old 29th November 2009, 03:55 AM
jockeyshift Offline
Registered User
 
Join Date: Nov 2009
Posts: 1
windows_vistafirefox
Quote:
Originally Posted by kraseef View Post
...
I am facing exactly the same problem with my HP mini 110. I am attempting to install Fedora 12 from USB. It also hangs at the "waiting for hardware to initialize". ....
My HP mini 110 did the same thing except I was booting from an external DVD drive. Even with ssb.blacklist=1 added to the boot options, it would hang at "waiting for hardware to initialize. What fixed mine, believe it or not, was to pull the battery out. I rebooted from the DVD, added ssb.blacklist=1 back to the boot options, and all was well. I tried it several times with the battery in and it failed every time. Once the OS was loaded on the hdd, I put the battery back in and Fedora 12 operated normally. Hope this helps.
Reply With Quote
  #11  
Old 29th November 2009, 04:10 AM
marcrblevins Offline
Registered User
 
Join Date: Jun 2006
Location: Texas
Age: 43
Posts: 4,168
linuxfedorafirefox
Ok, first of all, I don't care for Live CD, Been using CD/DVD before "Live CDs" came out since Fedora Core 1. Please try the DVD and use noprobe option as it worked for the OP.

Went DVD to begin with, less to download/updates up front.
Noprobe, you could google it, if needed:
Code:
linux noprobe


---------- Post added at 08:10 PM CST ---------- Previous post was at 08:09 PM CST ----------

If installing Live CD did work for you, please share your trick, which Live CD flavor was it? KDE or Gnome, etc.
Reply With Quote
  #12  
Old 11th December 2009, 08:52 AM
rez84 Offline
Registered User
 
Join Date: Dec 2009
Posts: 1
linuxfedorafirefox
What worked for me in the installation was in the boot options for the kernel I deleted the rhgb and then quiet, then put ssb.blacklist=1 for me it didn't matter if I was using the 'LiveCD' or the USB method, both booted into the live image using this. After I installed F12 I was having issues with udev where it would hang. reboot and then put in the kernel options ignore_loglevel and ssb.blacklist=1. F12 was then able to boot correctly. After setting up the user accounts and other settings install the rpmfusion repositories and run yum update. There is a patch for udev to be on the safe side I did yum search broadcom-wl for the wireless card. When it's all said and done you will be able to start the os without any boot options.


I hope this can help someone who is experiencing the same issues

Last edited by rez84; 17th December 2009 at 02:57 PM.
Reply With Quote
  #13  
Old 16th December 2009, 07:17 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 36
Posts: 4,423
linuxfedorafirefox
I just got my HP Mini 110, and I don't seem to be able to use any of those options, at the point where udev should start, All I get is "No root device found" Twice then "Boot failed, sleeping forever"...

If I use no options, but delete rhgb and quiet from the kernel command line (and add nomodeset) I still see this, at this point it doesn't matter what options I use or don't use... Very strange.

I have to use a liveCD image on a USB stick as I do not have a USB-CD/DVD drive for regular installation. Any pointers would be much appreciated... I utterly hated Windows 7 on this machine, and miss my Fedora so much!
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
  #14  
Old 14th January 2010, 05:37 PM
erroneus Offline
Registered User
 
Join Date: Apr 2004
Posts: 595
linuxfedorafirefox
Just weighing in here:

HP Mini 1101. Using ssb.blacklist=1 did the trick here. Installing using a USB DVD writer (LG GP08). So far so good. I have not done more than get beyond the initial hanging problem at this time.
Reply With Quote
  #15  
Old 24th February 2010, 04:12 PM
JBLoudG20 Offline
Registered User
 
Join Date: Feb 2008
Posts: 70
macosfirefox
FWIW, ssb.blacklist=1 also did the rick for me on my HP Mini 210HD

Thanks guys! I was scared I was going to have to give Ubuntu a shot!
__________________
Fedora 12 on:
HP Mini 1000, HP Mini 210HD, Various Dell Optiplex's, MacBook Pro 4,1
Reply With Quote
Reply

Tags
f12, hang, i686, install

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot install Fedora-11-i686-Live-KDE on VMware thomas2004ch Installation, Upgrades and Live Media 1 5th October 2009 04:41 PM
Remove kernel.i686 and install kernel.i686 ikaruss Using Fedora 2 19th February 2007 07:35 PM
Cant install kmod-ntfs i686 version! borbs Using Fedora 3 27th November 2006 07:04 PM


Current GMT-time: 06:05 (Sunday, 21-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat