Fedora Linux Support Community & Resources Center
  #1  
Old 8th November 2009, 09:42 PM
enthdegree Offline
Registered User
 
Join Date: Jul 2009
Posts: 4
linuxfedorafirefox
Can't click on anything in flash elements: Firefox, F12

I've been having some trouble getting help for this problem in the IRC channels, so here goes.

Nothing responds when I click on anything in flash elements. ( The sole exception being the music player at Playlist.com, which might not even be flash-based. ) Buttons do glow properly when you hover over them, though.

I'm running Firefox 3.5.4 on 32 bit Fedora 12 that I upgraded from F11. All of my packages are up to date, and I'm getting the Flash plugin from the Adobe repo. It's version 10.0.32.18.

This wasn't happening before I upgraded.
  #2  
Old 8th November 2009, 11:23 PM
typerlc Offline
Registered User
 
Join Date: Apr 2009
Posts: 109
linuxfedorafirefox
I have the same setup as you without problems. Do you have any other ff plugins?
  #3  
Old 8th November 2009, 11:26 PM
Demz
Guest
 
Posts: n/a
windows_7firefox
isnt there Firefox-3.5.5 in the rawhide repo?

its here in koji http://koji.fedoraproject.org/koji/b...buildID=139861 just use rpm -Uvh to get it
  #4  
Old 8th November 2009, 11:40 PM
enthdegree Offline
Registered User
 
Join Date: Jul 2009
Posts: 4
linuxfedorafirefox
I have these addons installed:
Adblock+
Adblock Element Hiding Helper
Automatic Save Folder
Aviary
Classic Compact Options
Download Statusbar
DragDropUpload
FEBE
FireFTP
Greasefire
Greasemonkey
Nuke Anything Enhanced
OPIE
User Agent Switcher
Vimperator
WOT

I'm installing FF 3.5.5 as I type...
  #5  
Old 8th November 2009, 11:48 PM
Demz
Guest
 
Posts: n/a
windows_7firefox
have you tried disabling all the Addons an see if it works?.. GreaseMonkey might be a problem, try disabling that
  #6  
Old 10th November 2009, 10:07 PM
enthdegree Offline
Registered User
 
Join Date: Jul 2009
Posts: 4
linuxfedorafirefox
Still nothing. )c:
  #7  
Old 11th November 2009, 05:59 AM
5hady Offline
Registered User
 
Join Date: Jul 2009
Posts: 46
linuxopera
**

Try holding down your right-click then left-click on the button. I have to do this in Ubuntu 9.10 for whatever reason.
  #8  
Old 11th November 2009, 01:48 PM
enthdegree Offline
Registered User
 
Join Date: Jul 2009
Posts: 4
linuxfedorafirefox
Hey, it works!
Still kind of annoying you have to do that.

Thanks for the workaround. (c:
  #9  
Old 11th November 2009, 02:57 PM
Gödel Offline
Registered User
 
Join Date: Jul 2009
Location: London,England
Posts: 1,102
linuxfedorafirefox
I think that's compiz related, I have the same problem with compiz desktop effects enabled, eg try selecting a game at

http://www.ferryhalim.com/orisinal/

but no problem if I disable effects (I'm in Fedora 12 now, ubuntu enables basic effects by default)

I may play with this later and let you know if I get a fix, someone probably knows the trick.

Bump: Ah, there you go https://bugs.edge.launchpad.net/ubun...7/comments/153

translating the fix to Fedora 12 (i686)

Code:
su -
cd /usr/lib/nspluginwrapper/
mv npviewer.bin npviewer.bin.real
echo \#\!/bin/sh > npviewer.bin
echo GDK_NATIVE_WINDOWS=true /usr/lib/nspluginwrapper/npviewer.bin.real \$\* >> npviewer.bin
chmod 755 npviewer.bin
restart firefox

Last edited by Gödel; 11th November 2009 at 03:17 PM.
  #10  
Old 13th November 2009, 06:28 AM
kubuniu Offline
Registered User
 
Join Date: Nov 2009
Posts: 2
linuxfedorafirefox
Thumbs up

Quote:
Originally Posted by Gödel View Post
I think that's compiz related, I have the same problem with compiz desktop effects enabled, eg try selecting a game at

http://www.ferryhalim.com/orisinal/

but no problem if I disable effects (I'm in Fedora 12 now, ubuntu enables basic effects by default)

I may play with this later and let you know if I get a fix, someone probably knows the trick.

Bump: Ah, there you go https://bugs.edge.launchpad.net/ubun...7/comments/153

translating the fix to Fedora 12 (i686)

Code:
su -
cd /usr/lib/nspluginwrapper/
mv npviewer.bin npviewer.bin.real
echo \#\!/bin/sh > npviewer.bin
echo GDK_NATIVE_WINDOWS=true /usr/lib/nspluginwrapper/npviewer.bin.real \$\* >> npviewer.bin
chmod 755 npviewer.bin
restart firefox
works for me, thanks for the tip!
 

Tags
clicking, fedora 12, flash plugin

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash Player Disables Key Presses On Click andorians-rule Using Fedora 2 5th May 2009 12:01 AM
firefox crashes on click Wiles Using Fedora 3 6th February 2007 11:00 PM
Firefox and Adobe Flash site don't agree on Flash version schwim Using Fedora 11 6th February 2007 03:02 AM
middle click in firefox pennylane Using Fedora 8 30th July 2006 10:55 PM


Current GMT-time: 11:28 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Abbottabad - Gloucester Instagram Photos - Al Jubayhah Photos on Instagram