Fedora Linux Support Community & Resources Center
  #1  
Old 29th October 2009, 05:44 PM
Reindeer Offline
Registered User
 
Join Date: Feb 2005
Posts: 116
linuxfedorafirefox
Volume control keys on keyboard don't control volume anymore

Volume up, volume down and mute keys on the keyboard don't control the volume any longer. They worked before. Hitting the keys brings up a progress bar widget with the volume level unchangeable, set at 0% (which is not accurate at all).
It looks like the key mappings or key bindings are working, but there is a disconnect with actual functionality. The volume cannot be changed or muted anymore from the keyboard.

This worked just fine in KDE on Fedora 11 before upgrading KDE components yesterday with Yumex. I am now using KDE 4.3.2
I don't think that it's a coincidence that it stopped working after doing an update.
I updated the kernel and nVidia drivers too, but this problem exists when I went back and tested with the previous kernel, so I don't suspect the kernel upgrade. No info in Xorg.conf about the keyboard. Is there a setting that I am missing?

Sound works just fine. I can listen to whatever source I like. This is not a problem with the sound drivers as far as I can tell.
I just want to be able to control the volume with the keys on my Logitech Illuminated Keyboard, model Y-UY95.

Is anyone else experiencing this? I can adjust the volume with Kmix 3.5 or GNOME Volume Control V2.1

Kinfocenter reports:
PHP Code:
Sound Driver:3.8.1a-980706 (ALSA v1.0.20 emulation code)
KernelLinux hostname 2.6.30.9-90.fc11.i686.PAE #1 SMP Sat Oct 17 11:24:32 EDT 2009 i686
Installed driversType 10ALSA emulation
Card config
HDA Intel at 0xf9ff8000 irq 22
Audio devices
NOT ENABLED IN CONFIG
Synth devices
NOT ENABLED IN CONFIG
Midi devices
NOT ENABLED IN CONFIG
Timers
:  31system timer
Mixers
NOT ENABLED IN CONFIG 
__________________
Registered Linux User #456652
Smolt Profile
Reply With Quote
  #2  
Old 30th October 2009, 08:46 PM
Reindeer Offline
Registered User
 
Join Date: Feb 2005
Posts: 116
linuxfedorafirefox
I know that this is a minor issue, but... am I the only one seeing this?
__________________
Registered Linux User #456652
Smolt Profile
Reply With Quote
  #3  
Old 4th January 2010, 02:06 PM
Reindeer Offline
Registered User
 
Join Date: Feb 2005
Posts: 116
linuxsafari
/etc/sysconfig/keyboard file says:
Quote:
KEYBOARDTYPE="pc"
KEYTABLE="us"
LAYOUT="us"
MODEL="pc105+inet"
OPTIONS=""
VARIANT=""
Is there anything missing that I need to have to get the sound volume keys working again?
__________________
Registered Linux User #456652
Smolt Profile
Reply With Quote
  #4  
Old 4th January 2010, 02:22 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
See if issuing the following command in terminal as root will fix this.

Code:
/etc/rc.d/init.d/acpid restart
EDITED typo.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)

Last edited by David Batson; 4th January 2010 at 02:56 PM.
Reply With Quote
  #5  
Old 4th January 2010, 07:44 PM
Reindeer Offline
Registered User
 
Join Date: Feb 2005
Posts: 116
linuxsafari
Thanks for replying David.
I tried running the command, but it didn't work.

[root@hostname ]# /etc/rc.d/init.d/acpid restart
Stopping acpi daemon: [ OK ]
Starting acpi daemon: [ OK ]

Thanks for trying David. I appreciate it.
__________________
Registered Linux User #456652
Smolt Profile
Reply With Quote
  #6  
Old 4th January 2010, 08:16 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 36
Posts: 295
linuxfedorafirefox
have a look in the kde system settings, and goto advanced tab and look in "Service Manager"

is KHotKeys running??

if it is, then go back to system setting main window and look in "Keyboard & Mouse"

goto the "Global Keyboard Shortcuts" and select "Kmix" in the "KDE Component" drop down box

see if the button is assigned in there, you can assign it if not

Hope that helps

Martin

have look at this: http://airs.me.uk/Videos/hotkeys.ogg
__________________
Processor: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
Memory: 16GB
OpenGL Renderer: GeForce GTX 550 Ti/PCIe/SSE2
Operating System: Fedora release 20 (Heisenbug)
Desktop Environment: KDE 4.1.12

Last edited by Camberwell; 4th January 2010 at 08:23 PM.
Reply With Quote
  #7  
Old 5th January 2010, 10:47 AM
Reindeer Offline
Registered User
 
Join Date: Feb 2005
Posts: 116
linuxsafari
Camberwell,
Thank you for the help! Thank you, thank you thank you!
Fiddling with the Global Keyboard Shortcuts / Configuration of Keybindings] fixed the problem.
(it should be noted that I have fiddled with this before with no success, many times.)
Apparently, from what I could gather, Amarok and Kmix were set in such a way as to ensure that the volume control keybindings didn't work for either app, or for the keys.
So, I changed the bindings for Amarok, which were set to "Meta +-" for volume down and "Meta++" for volume up to use the same bindings for the actual keys ("Input"+ press key) and say "yes" to apply, ignoring a warning about overriding the Kmix keybindings. I had to do this about half a dozen times before I figured out what was going on. It worked, and then not, and then worked again, and then not... very frustrating. Each time I reopened Amarok, the settings got erased! Then, somehow the settings took and were stored. Not sure why it didn't work the first five times or so. Maybe because I had Amarok open? Not sure.
I don't know if it's Amarok that is the culprit, or Kmix, but... Kmix was the last thing to be updated before the problem arose, but...
Amarok was compiled from source at one time so that I could upgrade to 2.0, but then I reverted back to using Fedora's repo version when that version proved buggy.
Interestingly enough, Amarok used to take a *long* time to load compared to what it used to do before I "upgraded" and then downgraded to version 2. It now snaps into place very quickly, just like it used to, instead of taking upwards of 30 seconds and throwing an error saying that it can't find the "file protocol". Whatever the keybindings fixed, apparently fixed Amarok settings for other things, or at least that's my guess.
I have learned my lesson and will now stick to Fedora repo versions and not try to upgrade.
I just wanted to say, thanks again to you Camberwell and all who have helped me within this forum over the years. I'm really grateful.

KDE 4.3.3
Amarok 2.2.1
Kmix 3.5
__________________
Registered Linux User #456652
Smolt Profile

Last edited by Reindeer; 5th January 2010 at 10:49 AM.
Reply With Quote
  #8  
Old 5th January 2010, 05:07 PM
Camberwell Offline
Registered User
 
Join Date: Mar 2006
Location: Wallingford, Oxfordshire, UK
Age: 36
Posts: 295
linuxfedorafirefox
no probs, happy to help
__________________
Processor: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz
Memory: 16GB
OpenGL Renderer: GeForce GTX 550 Ti/PCIe/SSE2
Operating System: Fedora release 20 (Heisenbug)
Desktop Environment: KDE 4.1.12
Reply With Quote
Reply

Tags
bindings, key, keyboard, map, volume

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Volume control with keys alram Hardware & Laptops 0 28th November 2008 05:40 PM
volume control not responing to keys bike_head Using Fedora 2 20th June 2008 03:59 PM
Volume and CD control on keyboard? drewnoidea Hardware & Laptops 8 30th October 2007 07:59 PM
Windows media player volume and track control keys Navi Hardware & Laptops 3 24th September 2007 08:43 PM
FC4 and keyboard volume control? xme Using Fedora 0 27th June 2005 08:33 AM


Current GMT-time: 12:59 (Saturday, 20-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram