Fedora Linux Support Community & Resources Center
  #1  
Old 24th October 2009, 04:33 AM
caf4926 Offline
Registered User
 
Join Date: Jun 2007
Location: The English Lakes
Posts: 125
linuxsusefirefox
fsck at boot - How?

Following a recent install of F11, I get a slowish boot, so I hit Esc. to get verbose and noticed some badblocks but the strange thing was it was reporting fd0
So I didn't get all the blurb and whilst it still slows at boot because of bad blocks, it's not doing a check and doesn't report the info like earlier.

Would it be wise to run fsck at boot and what options can I use. Or could I use a live utility disc like Parted Magic?

Here is my fdisk

Code:
fdisk -l                                    

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x44b844b7

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        5099    40957686    7  HPFS/NTFS
/dev/sda2   *        5100       38912   271602922+   f  W95 Ext'd (LBA)
/dev/sda5            5100       24221   153597433+   b  W95 FAT32
/dev/sda6           24222       27485    26218048+  83  Linux
/dev/sda7           27486       38582    89136621   83  Linux
/dev/sda8           38583       38912     2650693+  82  Linux swap / Solaris

Disk /dev/sdb: 160.0 GB, 160000000000 bytes
255 heads, 63 sectors/track, 19452 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0009cead

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       19452   156248158+   7  HPFS/NTFS

Disk /dev/sdc: 500.1 GB, 500107862016 bytes
1 heads, 63 sectors/track, 15504336 cylinders
Units = cylinders of 63 * 512 = 32256 bytes
Disk identifier: 0x9c9027d1

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           2    15504304   488385531+   c  W95 FAT32 (LBA)
Thanks
__________________
Novell Knowledge Partner
Reply With Quote
  #2  
Old 24th October 2009, 07:00 AM
Keldorn Offline
Registered User
 
Join Date: Jun 2008
Location: Russia
Age: 26
Posts: 517
linuxfedorafirefox
Code:
touch /forcefsck
And the filesystem will be checked on boot, but only once (you can change automatic filesystem checks parameters using tune2fs)
Reply With Quote
  #3  
Old 24th October 2009, 08:05 AM
caf4926 Offline
Registered User
 
Join Date: Jun 2007
Location: The English Lakes
Posts: 125
linuxfedoramozilla
Quote:
Originally Posted by Keldorn View Post
Code:
touch /forcefsck
And the filesystem will be checked on boot, but only once (you can change automatic filesystem checks parameters using tune2fs)
Thanks
I look at this when I get home later
Is there a repair parameter?
__________________
Novell Knowledge Partner
Reply With Quote
  #4  
Old 24th October 2009, 08:19 AM
kyryder
Guest
 
Posts: n/a
linuxfedorafirefox
Hello caf4926,
Never run fsck on mounted drives it can cause big problems. When I have to run fsck I always try to do it from a live cd.
see
Code:
man fsck
for more info

edit: PS. Don't forget about swapoff!

Last edited by kyryder; 24th October 2009 at 08:23 AM.
Reply With Quote
  #5  
Old 25th October 2009, 11:50 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
if you do the touch /forcefsck then the filesystem check is done before the volumes are mounted. no need in running from a live cd.
Reply With Quote
  #6  
Old 26th October 2009, 10:20 AM
caf4926 Offline
Registered User
 
Join Date: Jun 2007
Location: The English Lakes
Posts: 125
linuxfedoramozilla
I still get a delay at boot
This is info from that part

Code:
%G		Welcome to [0;34mFedora[0;39m 
		Press 'I' to enter interactive startup.
Starting udev: %G[60G[[0;32m  OK  [0;39m]

Setting hostname localhost.localdomain:  [60G[[0;32m  OK  [0;39m]

mdadm: No arrays found in config file or automatically
Setting up Logical Volume Management: [60G[[0;32m  OK  [0;39m]

Checking filesystems
/dev/sda6: clean, 197756/1640160 files, 1510904/6554512 blocks
/dev/sda7: clean, 10075/5578752 files, 3728433/22284155 blocks
[60G[[0;32m  OK  [0;39m]
Remounting root filesystem in read-write mode:  [  OK  ]

Mounting local filesystems:  [  OK  ]

Enabling local filesystem quotas:  [  OK  ]

Enabling /etc/fstab swaps:  [  OK  ]

Entering non-interactive startup
Enabling ondemand cpu frequency scaling: [  OK  ]
Any advice welcome
__________________
Novell Knowledge Partner
Reply With Quote
  #7  
Old 26th October 2009, 12:57 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
how much of a delay and where is the delay at? that output you show there is normal, not a thing wrong. I don't see anything about bad blocks.
Reply With Quote
  #8  
Old 26th October 2009, 01:41 PM
caf4926 Offline
Registered User
 
Join Date: Jun 2007
Location: The English Lakes
Posts: 125
linuxfedoramozilla
Well I'm going off having just moved from F10, which was quicker. I noticed a long pause toward the end of the progress loading bar (30secs)
So a reboot and hit Esc to get verbose. I quickly get: Starting udev: (the first one)
Then in verbose just a long pause, then the remained follows quickly enough.
__________________
Novell Knowledge Partner
Reply With Quote
  #9  
Old 26th October 2009, 09:15 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
Quote:
Originally Posted by caf4926 View Post
Well I'm going off having just moved from F10, which was quicker. I noticed a long pause toward the end of the progress loading bar (30secs)
So a reboot and hit Esc to get verbose. I quickly get: Starting udev: (the first one)
Then in verbose just a long pause, then the remained follows quickly enough.
This has nothing to do with bad blocks in your filesystem.

Does this machine have a floppy drive? If not, this could be the cause of your problem. On machines that have no floppy drive installed, yet have it enabled in the bios cause this sort of delay in udev.

If you have no floppy drive, then you can solve this problem by blacklisting the floppy module so it doesn't try to load.

open a terminal window.

su -
(root password)
echo "blacklist floppy" > /etc/modprobe.d/blacklist-floppy.conf

then logout and close the terminal window.
reboot to see if this fixes the problem.

also, if you installed the nvidia drivers instead of using nouveau, then you should blacklist nouveau as well. You should know if you installed the nvidia drivers because they are not installed by default. If you didn't install then don't do this.

su -
(root password)
echo "blacklist nouveau" > /etc/modprobe.d/blacklist-nouveau.conf

These can also just be added to the /etc/modprobe.d/blacklist.conf file as well if you don't want to create new files for them.

Last edited by DBelton; 26th October 2009 at 09:26 PM.
Reply With Quote
  #10  
Old 26th October 2009, 10:19 PM
caf4926 Offline
Registered User
 
Join Date: Jun 2007
Location: The English Lakes
Posts: 125
linuxfedoramozilla
No floppy. So I'll try the suggestion and yes I manually install nvidia, so I'll see to that also. Thanks

I'll get back when I get round to this, thank you so much.
__________________
Novell Knowledge Partner
Reply With Quote
  #11  
Old 26th October 2009, 10:23 PM
caf4926 Offline
Registered User
 
Join Date: Jun 2007
Location: The English Lakes
Posts: 125
linuxfedoramozilla
@DBelton
It worked a treat.
It's blindingly fast now!

Thanks!!
__________________
Novell Knowledge Partner
Reply With Quote
  #12  
Old 27th October 2009, 02:32 AM
kyryder
Guest
 
Posts: n/a
linuxmozilla
Quote:
Originally Posted by DBelton View Post
if you do the touch /forcefsck then the filesystem check is done before the volumes are mounted. no need in running from a live cd.
I was unaware of that fact, Thanks for the correction.
Reply With Quote
  #13  
Old 27th October 2009, 06:54 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
Quote:
Originally Posted by DBelton View Post
if you do the touch /forcefsck then the filesystem check is done before the volumes are mounted. no need in running from a live cd.
I was unaware of that fact, Thanks for the correction.


Yes, the root filesystem is mounted read only during the boot process. If the /forcefsck file is present, then the filesystem is checked before is it remounted read/write.
Reply With Quote
  #14  
Old 27th October 2009, 06:56 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfedorafirefox
Quote:
Originally Posted by caf4926 View Post
@DBelton
It worked a treat.
It's blindingly fast now!

Thanks!!
That's great I ran into the same problem and spent time pulling out my hair myself. That's how I knew what to try on that one. Glad it worked for you.
Reply With Quote
Reply

Tags
fsck

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it possible to run fsck on shut down instead of boot up? MuadNu Using Fedora 12 25th February 2009 10:13 PM
fsck on boot -- how to set it up? garrincha Using Fedora 2 16th April 2007 07:23 AM
fsck on boot joeljkp Using Fedora 10 22nd July 2005 08:03 PM


Current GMT-time: 18:59 (Thursday, 24-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat