Fedora Linux Support Community & Resources Center
  #1  
Old 9th October 2009, 09:33 PM
MichaelS-R Offline
Registered User
 
Join Date: Sep 2004
Location: Berkshire, UK
Posts: 168
linuxfedorafirefox
Dependency problems after F9->F11 Upgrade

I have just upgraded from F9 to F11. There are a lot of problems I appear to be having with dependencies.

yum update produces the following (the bits before appear ok):
Code:
Processing Dependency: libslapd_db-4.4.so()(64bit) for package: openldap-debuginfo
--> Finished Dependency Resolution
vlc-core-0.9.9-2.fc9.1.x86_64 from installed has depsolving problems
  --> Missing Dependency: libass.so.3()(64bit) is needed by package vlc-core-0.9.9-2.fc9.1.x86_64 (installed)
openldap-debuginfo-2.4.10-2.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: libslapd_db-4.4.so()(64bit) is needed by package openldap-debuginfo-2.4.10-2.fc9.x86_64 (installed)
vlc-0.9.9-2.fc9.1.x86_64 from installed has depsolving problems
  --> Missing Dependency: dejavu-fonts is needed by package vlc-0.9.9-2.fc9.1.x86_64 (installed)
devede-3.12c-3.fc9.noarch from installed has depsolving problems
  --> Missing Dependency: dejavu-fonts is needed by package devede-3.12c-3.fc9.noarch (installed)
Error: Missing Dependency: libass.so.3()(64bit) is needed by package vlc-core-0.9.9-2.fc9.1.x86_64 (installed)
Error: Missing Dependency: dejavu-fonts is needed by package devede-3.12c-3.fc9.noarch (installed)
Error: Missing Dependency: libslapd_db-4.4.so()(64bit) is needed by package openldap-debuginfo-2.4.10-2.fc9.x86_64 (installed)
Error: Missing Dependency: dejavu-fonts is needed by package vlc-0.9.9-2.fc9.1.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
I tried the suggestions at the end but they don't work either.

TIA,

Michael.
__________________
Michael S-R

F12 x86_64 -
Dual Opteron 280, Tyan Thunder K8WE (SCSI), 4Gb RAM, 2 x 36Gb Raptor, 3Ware 9500S RAID controller with 5T HDs, GeForce 6600. :cool:
Reply With Quote
  #2  
Old 9th October 2009, 09:45 PM
Janl Offline
Registered User
 
Join Date: Sep 2006
Location: Kentucky, USA
Age: 33
Posts: 309
windows_xp_2003firefox
I believe there is a suggested command when upgrading. If I remember correctly it was
Code:
package-cleanup --orphans
which will remove orphaned packages.

Not sure if that would help in this case though since I doubt that VLC would have been orphaned.

You could also try a quick
Code:
yum clean all
to see if that might resolve the problems in case you have an old yum cache messing things up.
Reply With Quote
  #3  
Old 9th October 2009, 10:26 PM
MichaelS-R Offline
Registered User
 
Join Date: Sep 2004
Location: Berkshire, UK
Posts: 168
linuxfedorafirefox
Thanks - tried both of those but problem persists:

Code:
---> Package python-smbios.x86_64 0:2.2.16-2.1.fc11 set to be updated
---> Package rb_libtorrent.x86_64 0:0.14.3-2.fc11 set to be updated
--> Running transaction check
---> Package openbios-common.noarch 0:1.0-1.fc11 set to be updated
--> Processing Dependency: libslapd_db-4.4.so()(64bit) for package: openldap-debuginfo
--> Finished Dependency Resolution
openldap-debuginfo-2.4.10-2.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: libslapd_db-4.4.so()(64bit) is needed by package openldap-debuginfo-2.4.10-2.fc9.x86_64 (installed)
Error: Missing Dependency: libslapd_db-4.4.so()(64bit) is needed by package openldap-debuginfo-2.4.10-2.fc9.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Other suggestions welcome!

TIA,

Michael
__________________
Michael S-R

F12 x86_64 -
Dual Opteron 280, Tyan Thunder K8WE (SCSI), 4Gb RAM, 2 x 36Gb Raptor, 3Ware 9500S RAID controller with 5T HDs, GeForce 6600. :cool:
Reply With Quote
  #4  
Old 9th October 2009, 10:57 PM
MichaelS-R Offline
Registered User
 
Join Date: Sep 2004
Location: Berkshire, UK
Posts: 168
linuxfedorafirefox
I just ran
Code:
package-cleanup --problems
and got
Code:
Missing dependencies:
Package java-1.5.0-gcj-devel requires java-1.5.0-gcj = 1.5.0.0-21.fc9
Package java-1.5.0-gcj-devel requires python(abi) = 2.5
Package hugin-base requires libboost_thread-mt.so.3()(64bit)
Package hugin-base requires libexiv2.so.2()(64bit)
Package google-gadgets-qt requires libltdl.so.3()(64bit)
Package preupgrade requires python(abi) = 2.5
Package evolution-debuginfo requires liborg-gnome-evolution-hula-account-setup.so()(64bit)
Package evolution-debuginfo requires liborg-gnome-mark-calendar-offline.so()(64bit)
Package evolution-debuginfo requires liborg-gnome-print-message.so()(64bit)
Package libgnomeprintui22-devel requires libgnomeprintui22 = 2.18.2-1.fc9
Package evolution-bogofilter requires evolution = 2.22.3.1-1.fc9
Package apcupsd requires libcrypto.so.7()(64bit)
Package openldap-servers requires libcrypto.so.7()(64bit)
Package openldap-servers requires libltdl.so.3()(64bit)
Package openldap-servers requires libssl.so.7()(64bit)
Package openldap-servers requires openldap = 2.4.10-2.fc9
Package djvulibre requires libdjvulibre.so.15()(64bit)
Package python-sqlite2 requires libpython2.5.so.1.0()(64bit)
Package python-sqlite2 requires python(abi) = 2.5
Package gnome-vfs2-smb requires gnome-vfs2 = 2.22.0-1.fc9
Package mysql++ requires libmysqlclient_r.so.15()(64bit)
Package mysql++ requires libmysqlclient_r.so.15(libmysqlclient_15)(64bit)
Package openldap-servers-sql requires libodbc.so.1()(64bit)
Package mysql-query-browser requires libcrypto.so.7()(64bit)
Package mysql-query-browser requires libmysqlclient_r.so.15()(64bit)
Package mysql-query-browser requires libmysqlclient_r.so.15(libmysqlclient_15)(64bit)
Package mysql-query-browser requires libssl.so.7()(64bit)
Package eel2 requires libgnome-desktop-2.so.2()(64bit)
Package esound-devel requires esound-libs = 1:0.2.38-7.fc9
Package vcdimager requires libcdio.so.7()(64bit)
Package vcdimager requires libcdio.so.7(CDIO_7)(64bit)
Package vcdimager requires libiso9660.so.5()(64bit)
Package gstreamer-devel requires gstreamer = 0.10.20-1.fc9
Package libgcj-src requires libgcj = 4.3.0-8
Package libbtctl requires libbluetooth.so.2()(64bit)
Package libbtctl requires python(abi) = 2.5
Package google-gadgets requires libltdl.so.3()(64bit)
Package gtk2-debuginfo requires im-am-et.so()(64bit)
Package gtk2-debuginfo requires im-cedilla.so()(64bit)
Package gtk2-debuginfo requires im-cyrillic-translit.so()(64bit)
Package gtk2-debuginfo requires im-inuktitut.so()(64bit)
Package gtk2-debuginfo requires im-ipa.so()(64bit)
Package gtk2-debuginfo requires im-multipress.so()(64bit)
Package gtk2-debuginfo requires im-thai.so()(64bit)
Package gtk2-debuginfo requires im-ti-er.so()(64bit)
Package gtk2-debuginfo requires im-ti-et.so()(64bit)
Package gtk2-debuginfo requires im-viqr.so()(64bit)
Package gtk2-debuginfo requires im-xim.so()(64bit)
Package gutenprint-plugin requires gutenprint = 5.0.2-2.fc9
Package qemu requires libgnutls.so.13()(64bit)
Package qemu requires libgnutls.so.13(GNUTLS_1_3)(64bit)
Package qemu requires qemu-img = 0.9.1-6.fc9
Package rhpxl requires libpython2.5.so.1.0()(64bit)
Package rhpxl requires python(abi) = 2.5
Package evolution-conduits requires evolution = 2.22.3.1-1.fc9
Package evolution-conduits requires libcamel-1.2.so.11()(64bit)
Package evolution-conduits requires libedataserver-1.2.so.9()(64bit)
Package systemtap requires librpm-4.4.so()(64bit)
Package systemtap requires librpmdb-4.4.so()(64bit)
Package gnome-python2-gtksourceview requires gnome-python2-desktop = 2.22.0-4.fc9
Package gnome-python2-gtksourceview requires python(abi) = 2.5
Package sos requires python(abi) = 2.5
Package kudzu requires python(abi) = 2.5
Package gwenhywfar requires libcrypto.so.7()(64bit)
Package gwenhywfar requires libssl.so.7()(64bit)
Package libopensync requires python(abi) = 2.5
Package deluge requires libboost_date_time-mt.so.3()(64bit)
Package deluge requires libboost_filesystem-mt.so.3()(64bit)
Package deluge requires libboost_iostreams-mt.so.3()(64bit)
Package deluge requires libboost_python-mt.so.3()(64bit)
Package deluge requires libboost_thread-mt.so.3()(64bit)
Package deluge requires libpython2.5.so.1.0()(64bit)
Package deluge requires libssl.so.7()(64bit)
Package deluge requires python(abi) = 2.5
Package pidgin requires libedataserver-1.2.so.9()(64bit)
Package python-genshi requires libpython2.5.so.1.0()(64bit)
Package python-genshi requires python(abi) = 2.5
Package texlive requires libpoppler.so.3()(64bit)
Package glib-java requires libgcj.so.9()(64bit)
Package libgnomeui-debuginfo requires libgio.so()(64bit)
Package libgnomeui-debuginfo requires libgnome-vfs.so()(64bit)
Package librsvg2-devel requires librsvg2 = 2.22.2-1.fc9
Package libgnomeprint22-devel requires libgnomeprint22 = 2.18.4-1.fc9
Package asc requires libboost_regex.so.3()(64bit)
Package vlc-core requires libcdio.so.7()(64bit)
Package vlc-core requires libcdio.so.7(CDIO_7)(64bit)
Package vlc-core requires libgnutls.so.13()(64bit)
Package vlc-core requires libgnutls.so.13(GNUTLS_1_3)(64bit)
Package dsniff requires libcrypto.so.7()(64bit)
Package dsniff requires libdb-4.6.so()(64bit)
Package dsniff requires libssl.so.7()(64bit)
Package ImageMagick-perl requires ImageMagick = 6.3.8.1-4.fc9
Package ImageMagick-perl requires libMagick.so.10()(64bit)
Package ImageMagick-perl requires libWand.so.10()(64bit)
Package avahi-compat-libdns_sd requires avahi = 0.6.22-11.fc9
Package dia requires libpython2.5.so.1.0()(64bit)
Package evolution-data-server-debuginfo requires libcamel-1.2.so.11()(64bit)
Package evolution-data-server-debuginfo requires libcamel-provider-1.2.so.11()(64bit)
Package evolution-data-server-debuginfo requires libcamelhula.so()(64bit)
Package evolution-data-server-debuginfo requires libedataserver-1.2.so.9()(64bit)
Package gcc-java requires gcc = 4.3.0-8
Package gcc-java requires libgcj = 4.3.0-8
Package gcc-java requires libgcj-tools.so.9()(64bit)
Package gcc-java requires libgcj.so.9()(64bit)
Package gcc-java requires libgij.so.9()(64bit)
Package mysql-devel requires libmysqlclient.so.15()(64bit)
Package mysql-devel requires libmysqlclient_r.so.15()(64bit)
Package mysql-devel requires mysql = 5.0.77-1.fc9
Package audiofile-devel requires audiofile = 1:0.2.6-8.fc9
Package texinfo-tex requires texinfo = 4.11-8.fc9
Package libcddb requires libcdio.so.7()(64bit)
Package libcddb requires libcdio.so.7(CDIO_7)(64bit)
Package php-mbstring requires php-common = 5.2.9-2.fc9
Package frysk requires libgcj.so.9()(64bit)
Package gftp requires libcrypto.so.7()(64bit)
Package gftp requires libssl.so.7()(64bit)
Package graphviz requires libltdl.so.3
Package pyparted requires python(abi) = 2.5
Package libgdiplus-devel requires libgdiplus = 2.0-4.fc9
Package libgsf-gnome requires libgsf = 1.14.8-1.fc9
Package libssh2-devel requires libssh2 = 0.18-7.fc9
Package libgsf-devel requires libgsf = 1.14.8-1.fc9
Package gpac-libs requires libcrypto.so.7()(64bit)
Package gpac-libs requires libssl.so.7()(64bit)
Package perl-Crypt-SSLeay requires libcrypto.so.7()(64bit)
Package perl-Crypt-SSLeay requires libssl.so.7()(64bit)
Package gmime-sharp requires gmime = 2.2.21-2.fc9
Package vcdimager-libs requires libcdio.so.7()(64bit)
Package vcdimager-libs requires libcdio.so.7(CDIO_7)(64bit)
Package vcdimager-libs requires libiso9660.so.5()(64bit)
Package bogofilter requires libdb-4.6.so()(64bit)
Package PyXML requires libpython2.5.so.1.0()(64bit)
Package PyXML requires python(abi) = 2.5
Package avahi-compat-howl requires avahi = 0.6.22-11.fc9
Package evolution-spamassassin requires evolution = 2.22.3.1-1.fc9
Package xen requires libpython2.5.so.1.0()(64bit)
Package xen requires python(abi) = 2.5
Package anjuta requires libgladeui-1.so.7
Package mysql++ requires libmysqlclient_r.so.15
Package mysql++ requires libmysqlclient_r.so.15(libmysqlclient_15)
Package mysql-administrator requires libcrypto.so.7()(64bit)
Package mysql-administrator requires libmysqlclient_r.so.15()(64bit)
Package mysql-administrator requires libmysqlclient_r.so.15(libmysqlclient_15)(64bit)
Package mysql-administrator requires libssl.so.7()(64bit)
Package libgcj-devel requires libgcj = 4.3.0-8
Package libgcj-devel requires /usr/lib64/libgcj.so.9
Package pcre-devel requires pcre = 7.3-4.fc9
Package perl-ExtUtils-Embed requires perl = 4:5.10.0-68.fc9
Package perl-CPAN requires perl = 4:5.10.0-68.fc9
Package libwiimote requires libbluetooth.so.2()(64bit)
Package anjuta requires libgladeui-1.so.7()(64bit)
Package graphviz requires libltdl.so.3()(64bit)
Package eel2 requires libgnome-desktop-2.so.2
...
Package libgcj-devel requires /usr/lib/libgcj.so.9
Package libcroco-devel requires libcroco = 0.6.1
Package libgnomeprintui22-devel requires libgnomeprintui22 = 2.18.2-1.fc9
Package vnc-server requires libcrypto.so.7()(64bit)
Package vnc-server requires librfb.so.0()(64bit)
Package ruby-libs requires libcrypto.so.7()(64bit)
Package ruby-libs requires libdb-4.6.so()(64bit)
Package ruby-libs requires libssl.so.7()(64bit)
Package tk-devel requires tk = 1:8.5.2-1.fc9
Package xen-runtime requires libcrypto.so.7()(64bit)
Package xen-runtime requires libgnutls.so.13()(64bit)
Package xen-runtime requires libgnutls.so.13(GNUTLS_1_3)(64bit)
Package xen-runtime requires libpython2.5.so.1.0()(64bit)
Package xen-runtime requires python(abi) = 2.5
Package xen-runtime requires xen-hypervisor-abi = 3.2
Package xen-runtime requires xen-libs = 3.2.0-15.fc9
Something is seriously broken here. Is there a quick way to untangle it?

Thanks,

Michael
__________________
Michael S-R

F12 x86_64 -
Dual Opteron 280, Tyan Thunder K8WE (SCSI), 4Gb RAM, 2 x 36Gb Raptor, 3Ware 9500S RAID controller with 5T HDs, GeForce 6600. :cool:
Reply With Quote
  #5  
Old 10th October 2009, 01:29 AM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 46
Posts: 3,936
linuxfedorafirefox
this is why a FRESH install is recommended .
and if you skip a version a fresh install IS A MUST

fedora 11 now uses ext4 for the /, /home ,/usr partitions ( and not the ext3 used by fedora 9 )
the /boot partition layout changed also to use a 256 bit inode ( 128 bit in f9 )

also you still have fedora 9 pachages installed
UNINSTALL EVERY FEDORA 9 PACKAGE FIRST before you will be able to fix anything

to get a list of fedora 9 rpm's on the f11 box do this
Code:
rpm -qa | grep fc9 > ~/fed9list.txt
and read the text file
then UNINSTALL every one of them
and IF and this is a very big if -- if your system still boots then install the fedora 11 versions
__________________
OpenSUSE 13.1-64bit & Scientific Linux 6.5-64bit ( fedora 4 to 11) and 19/20 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10
Reply With Quote
  #6  
Old 11th October 2009, 12:40 PM
MichaelS-R Offline
Registered User
 
Join Date: Sep 2004
Location: Berkshire, UK
Posts: 168
linuxfedorafirefox
John,

Thanks for that. Really not a practical solution - too many cross-dependencies and too much to sort out. I can see it as a monumental waste of time.

Unfortunately the reinstall is the best option - but a real pain for me to do. I have lots of additional apps installed...

However, it seems crazy that there is no warning that skipping a version has such major consequences and basically does not work! Obviously if I had know I would clearly have taken another route.

Michael
__________________
Michael S-R

F12 x86_64 -
Dual Opteron 280, Tyan Thunder K8WE (SCSI), 4Gb RAM, 2 x 36Gb Raptor, 3Ware 9500S RAID controller with 5T HDs, GeForce 6600. :cool:
Reply With Quote
  #7  
Old 11th October 2009, 01:37 PM
troyatlarge Offline
Registered User
 
Join Date: Mar 2009
Location: Ely, NV. - 395 miles round trip to Wal-Mart
Posts: 333
linuxfedorafirefox
Quote:
Originally Posted by MichaelS-R View Post
John,

However, it seems crazy that there is no warning that skipping a version has such major consequences and basically does not work! Obviously if I had know I would clearly have taken another route.

Michael
Where did you get your lead on upgrading? I see the Fedora web site has the upgrade instructions and when you go there, to read them, it states this:
Code:
 While upgrading from Fedora 10 is supported, you are more likely to have a consistent experience by backing up your data and then installing this release of Fedora 11 over your previous Fedora installation.
To upgrade from Fedora 10 you should bring your system up to date before performing the upgrade.

Important

It is not possible to upgrade directly from Fedora 9 to Fedora 11. To upgrade Fedora 9 to Fedora 11, upgrade to Fedora 10 first.
__________________
The longer I run numerous Linux box's, the more I like it.

UUID: 5a0128f0-55b8-11e0-b31d-eb482d4d1d3a
Reply With Quote
  #8  
Old 11th October 2009, 03:18 PM
MichaelS-R Offline
Registered User
 
Join Date: Sep 2004
Location: Berkshire, UK
Posts: 168
linuxfedorafirefox
Clearly I missed the note Troy. What I meant was that the installation software would have benefited from a warning... somewhere one cannot miss it.

Anyway, too late now!

New installation here I come.

Thanks for all of the help everyone.
__________________
Michael S-R

F12 x86_64 -
Dual Opteron 280, Tyan Thunder K8WE (SCSI), 4Gb RAM, 2 x 36Gb Raptor, 3Ware 9500S RAID controller with 5T HDs, GeForce 6600. :cool:
Reply With Quote
Reply

Tags
missing dependency, upgrade problem, yum update

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F9-->10 upgrade & dependency problems Michael Fisher Using Fedora 11 12th April 2009 04:02 AM
Upgrade help; dependency resolutions... buccaneere Installation, Upgrades and Live Media 11 21st February 2009 04:33 AM
FC5: wxGTK upgrade and dependency to 2.2 BertVK EOL (End Of Life) Versions 0 19th November 2006 02:28 PM
FC3 -> FC4 Yum Upgrade Dependency Issue axelseaa EOL (End Of Life) Versions 0 23rd March 2006 02:30 AM


Current GMT-time: 15:43 (Wednesday, 23-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat