Fedora Linux Support Community & Resources Center
  #1  
Old 29th August 2009, 07:17 AM
vbdanl Offline
Registered User
 
Join Date: Mar 2006
Location: Kansas
Posts: 209
linuxfedorafirefox
gnome login sounds distorted

hi. i am running latest fc11. the startup sound (desktop-login.ogg) always plays distorted. it plays a chord or two, slight pause, plays another chord, etc.. skips about as much as it plays. i found if i run canberra-gtk-play with the ogg file from a terminal, it plays fine. i changed it to play /usr/share/sounds/startup3.wav, but it also plays distorted during startup. plays fine from a terminal or thru natilus. i have installed the pulse-audio through the "perfect" guide.
any ideas what i might try to fix it?
Reply With Quote
  #2  
Old 29th August 2009, 12:55 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
windows_vistaopera
This pulse-audio guide fixed it for me.

http://forums.fedoraforum.org/showthread.php?t=225660
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #3  
Old 29th August 2009, 07:04 PM
vbdanl Offline
Registered User
 
Join Date: Mar 2006
Location: Kansas
Posts: 209
linuxubuntufirefox
Quote:
Originally Posted by David Batson View Post
This pulse-audio guide fixed it for me.

http://forums.fedoraforum.org/showthread.php?t=225660
i think i mentioned i went thru the guide.. sound works good once it completes the boot process, just does not sound good when the startup login sound plays.
Reply With Quote
  #4  
Old 29th August 2009, 07:18 PM
Gödel Offline
Registered User
 
Join Date: Jul 2009
Location: London,England
Posts: 1,102
linuxfedorafirefox
The processes executed at login may be interfering with smooth playback of the login audio, I have the same issue, and just live with it, it's one of gnome's many annoyances.

Check it plays smoothly after login with

Code:
/usr/bin/canberra-gtk-play --id="desktop-login"
Then maybe edit System->Preferences->Startup Applications->GNOME Login Sound, to 'sleep 10 && ...' or rename to zzzGNOME Login Sound so perhaps it gets played last.
Reply With Quote
  #5  
Old 30th August 2009, 03:47 PM
vbdanl Offline
Registered User
 
Join Date: Mar 2006
Location: Kansas
Posts: 209
linuxubuntufirefox
yes, i have played it from a terminal, and it plays fine. i had tried to put a sleep 1 in the command, but that made it not play anything at all. i will look into renaming it so it plays later.. thanks.
Reply With Quote
Reply

Tags
distorted, gnome, login, sounds

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome event sounds in a repeating loop... mcmackin Hardware & Laptops 0 6th July 2009 05:43 AM
Gnome System Sounds (only) fail to work smaines Using Fedora 10 19th January 2009 01:44 PM
System sounds in GNOME kbs1 Using Fedora 8 19th November 2008 09:27 PM
F9 gnome system sounds not playing pankajp Using Fedora 0 25th August 2008 11:42 AM
LOGIN sounds for gnome using mplayer. imdeemvp Guides & Solutions (No Questions) 5 31st January 2005 01:38 PM


Current GMT-time: 01:20 (Monday, 24-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Najran Photos on Instagram - Sao Sebastiao do Paraiso Photos - Mairipora