Fedora Linux Support Community & Resources Center
  #1  
Old 7th August 2009, 07:49 PM
3esmit Offline
Registered User
 
Join Date: Aug 2009
Posts: 9
linuxfedorafirefox
Unhappy Destop Effects messed, garbled screen, with update on INTEL driver

In fedora 11, version 2.6.29.4-167, the Destop Effects worked well with my Intel GMA 4500MHD.
Since I update it to the last version, the desktop came all messed with non understandable graphics, I dont know how I maneged to disable the Desktop Effects in that state, but I did. Disabling it just brings all back to normal, but reativating it just messes it all.

See the ScreenShot attached.

My installation is Fedora 11 with default graphics (the normal update got me a black screen that never changes).
My Xorg.conf is very simple, I just changed "vesa" to "intel" in order to work my VGA,

I Think is a software problem, not configuration, since before the update everything was working well.

Hardware:
Acer Aspire 5738-6535
Intel Core 2 Duo processor T6400 (2.0GHz, 800 MHz FSB)
Intel GMA 4500MHD (Up to 1695 MB)
15.6'' HD LED LCD
4 GB DDR3 Memory
___
Quote:
glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset GEM 20090114

lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
04:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
Another Topic with the same problem (merge topic suggestion for Mod): http://forums.fedoraforum.org/showthread.php?t=226188

Thank you for reading and for any help...
Attached Thumbnails
Click image for larger version

Name:	Captura_de_tela.jpg
Views:	74
Size:	94.3 KB
ID:	17881  

Last edited by 3esmit; 7th August 2009 at 08:07 PM. Reason: Adding information.
Reply With Quote
  #2  
Old 7th August 2009, 08:53 PM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
linuxfedorafirefox
Could be a kernel modesetting problem with the new intel driver. Try adding the keyword "nomodeset" to the kernel command line in /boot/grub/grub.conf file for your new kernel and see if anything changes.
Reply With Quote
  #3  
Old 8th August 2009, 05:47 AM
3esmit Offline
Registered User
 
Join Date: Aug 2009
Posts: 9
linuxfedorafirefox
Hello JEO, Thank you for the reply.

My grub.conf already had the nomodeset, so I tested without it, and it didnt worked, also I was unable to see anything, just a black screen.
Code:
default=0
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.29.6-217.2.3.fc11.x86_64)
	root (hd0,2)
	kernel /vmlinuz-2.6.29.6-217.2.3.fc11.x86_64 ro root=/dev/mapper/vg_schmidt-lv_root nomodeset rhgb quiet
	initrd /initrd-2.6.29.6-217.2.3.fc11.x86_64.img
#title Fedora (2.6.29.4-167.fc11.x86_64)
#	root (hd0,2)
#	kernel /vmlinuz-2.6.29.4-167.fc11.x86_64 ro root=/dev/mapper/vg_schmidt-#lv_root nomodeset rhgb quiet
#	initrd /initrd-2.6.29.4-167.fc11.x86_64.img
title Windows Vista
	rootnoverify (hd0,1)
	chainloader +1
I have no idea where the problem is, and it looks like its with Intel graphics driver. How do I report this bug to fedora team? And How do I unupdate my driver?
Reply With Quote
  #4  
Old 8th August 2009, 07:00 AM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
linuxfedorafirefox
If you think the intel driver worked when you had the original kernel version 2.6.29.4-167.fc11.x86_64 then you can always download that kernel and reinstall it. (I noticed that you commented it out of your grub.conf). However, if the reason why it does not work now is that you updated the xorg intel driver that's another possibility. Look through your /var/log/yum.log file and see if the intel driver was updated recently. I'd say look there first before deciding what to change.
Reply With Quote
  #5  
Old 8th August 2009, 08:54 PM
3esmit Offline
Registered User
 
Join Date: Aug 2009
Posts: 9
linuxfedorafirefox
There a lot of updates in the log, but I found some that might be.

Aug 06 23:14:34 Updated: kernel-firmware-2.6.29.6-217.2.3.fc11.noarch
Aug 06 23:27:42 Updated: gnome-desktop-2.26.3-2.fc11.x86_64
Aug 06 23:30:33 Updated: compiz-gnome-0.7.8-19.fc11.x86_64

No intel driver updated, just one installed, but this didnt bugged the system.

Aug 05 18:52:03 Installed: xorg-x11-drv-intel-devel-2.7.0-7.fc11.x86_64

This I installed after the bug to see if someting...
Aug 07 22:50:20 Installed: intel-gpu-tools-2.8.0-3.fc12.x86_64
Aug 07 22:51:06 Installed: xorg-x11-drv-intel-debuginfo-2.8.0-3.fc12.x86_64


There are some new updates to the compiz and compiz-fusion, but I cannot install them becouse of some incompactability with the older versions, I think its becouse the updates are just half disponible. I tryed unistalling the old versions and installing the new ones, but then I could not get the menu to enable the Desktop Effects. I think the problem is with the new compiz compactability with intel graphics driver, maybe I need to wait the updates ou send a bug report in order to tell them the problem. I will try unupdateing the compiz-gnome, but I'm not sure how to do it, can you give me some light in how to do it via console?

Thank you.

Last edited by 3esmit; 8th August 2009 at 09:06 PM.
Reply With Quote
  #6  
Old 8th August 2009, 09:32 PM
a_small_cake Offline
Registered User
 
Join Date: Jun 2007
Location: Poland
Posts: 249
linuxfedorafirefox
Hey,
I've got this Intel card too and no problem with Compiz (but I don't use xorg.conf):

rpm -qa |grep intel
Code:
xorg-x11-drv-intel-2.7.0-7.fc11.x86_64
rpm -qa |grep kernel
Code:
kernel-2.6.29.6-213.fc11.x86_64
kernel-devel-2.6.29.6-213.fc11.x86_64
kernel-headers-2.6.29.6-217.2.3.fc11.x86_64
kernel-2.6.29.6-217.2.3.fc11.x86_64
kernel-devel-2.6.29.6-217.2.3.fc11.x86_64
dracut-kernel-0.8-1.fc11.x86_64
kerneloops-0.12-5.fc11.x86_64
rpm -qa |grep compiz
Code:
compiz-fusion-gnome-0.7.8-8.fc11.x86_64
compiz-fusion-0.7.8-8.fc11.x86_64
compiz-gnome-0.7.8-19.fc11.x86_64
compiz-0.7.8-19.fc11.x86_64
glxinfo | grep render
Code:
direct rendering: Yes
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset GEM 20090114
lspci
Code:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Reply With Quote
  #7  
Old 11th August 2009, 03:29 AM
zez Offline
Registered User
 
Join Date: Nov 2008
Location: Oregon, United States
Posts: 11
linuxfedorafirefox
I run F11 + KDE (4.2.4) with an Intel 4500mhd, and I've also been having problems with desktop effects after some recent updates. Basic desktop effects works fine, but some of the effect plugins like arrange windows/expose and coverflow alt-tab cause my laptop to lock up. These problems weren't present when I first installed F11. Additionally, Warcraft 3 under WINE freezes at the menu, but I cannot confirm that Warcraft 3 used to run properly on F11+intel as I just attempted to install it. Nevertheless, something funky is going on with intel 3D support...

rpm -qa|grep intel
Code:
xorg-x11-drv-intel-2.7.0-7.fc11.x86_64
rpm -qa|grep kernel
Code:
kernel-devel-2.6.29.5-191.fc11.x86_64
kernel-2.6.29.5-191.fc11.x86_64
kernel-2.6.29.6-217.2.3.fc11.x86_64
kernel-headers-2.6.29.6-217.2.3.fc11.x86_64
kernel-2.6.29.6-213.fc11.x86_64
kernel-devel-2.6.29.6-213.fc11.x86_64
kernel-devel-2.6.29.6-217.2.3.fc11.x86_64
kernel-firmware-2.6.29.6-217.2.3.fc11.noarch
kerneloops-0.12-5.fc11.x86_64
glxinfo|grep render
Code:
direct rendering: Yes
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset GEM 20090114
lspci
Code:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)                                            
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
EDIT: After looking through my yum log, the kernel was slowly updated from 2.6.29.1 back in April to 2.6.29.6 now. Another suspect package is mesa that was updated at the end of june to 7.6.x from 7.5.x. Even the most recent intel graphics driver bundle (http://intellinuxgraphics.org/2009Q2.html) only recommends mesa 7.5.0, so I'm wondering if either the mesa or kernel updates introduced some of the problems described in this thread.

Last edited by zez; 11th August 2009 at 04:24 AM.
Reply With Quote
  #8  
Old 11th August 2009, 04:56 AM
3esmit Offline
Registered User
 
Join Date: Aug 2009
Posts: 9
linuxfedorafirefox
Thank you for the replies, zez and a_small_cake.

In my case, I cannot enable it and understand the screen, so I have to disable it. I Tryed a lot of things related with the packages, except unupdating the kernel and the driver video.
I'm running F11 + GNOME, all latest updates.

Here my packages
Quote:
rpm -qa|grep intel
xorg-x11-drv-intel-2.7.0-7.fc11.x86_64
Quote:
rpm -qa|grep kernel
kernel-headers-2.6.29.6-217.2.3.fc11.x86_64
kernel-devel-2.6.29.6-217.2.3.fc11.x86_64
dracut-kernel-0.8-1.fc11.x86_64
kerneloops-0.12-5.fc11.x86_64
kernel-2.6.29.4-167.fc11.x86_64
kernel-firmware-2.6.29.6-217.2.3.fc11.noarch
kernel-2.6.29.6-217.2.3.fc11.x86_64
Quote:
rpm -qa |grep compiz
compiz-0.7.8-19.fc11.x86_64
compiz-fusion-0.7.8-8.fc11.x86_64
compiz-gnome-0.7.8-19.fc11.x86_64
compiz-fusion-gnome-0.7.8-8.fc11.x86_64
@a_small_cake
If you dont use X11, what window manager you use? Maybe that could fix my problem too.

Have a good day.
Reply With Quote
  #9  
Old 11th August 2009, 11:04 AM
a_small_cake Offline
Registered User
 
Join Date: Jun 2007
Location: Poland
Posts: 249
linuxfedorafirefox
I'm using standard GNOME installation, installed from LiveCD. I don't have nor use xorg.conf file because it is not present since Fedora 9 or 10 release. I think you could safely delete (but make backup first) your xorg.conf file and try to use Compiz without it.
Reply With Quote
  #10  
Old 15th August 2009, 04:04 AM
zez Offline
Registered User
 
Join Date: Nov 2008
Location: Oregon, United States
Posts: 11
linuxfedorafirefox
I found this bug report that seemed to blame a lot of 3D woe on the new mesa 7.6.0:

https://bugzilla.redhat.com/show_bug.cgi?id=509528

I tried downgrading all of my mesa packages with...

Code:
# yum downgrade mesa-dri-drivers mesa-libGL mesa-libGLU mesa-libGL-devel mesa-libGLU-devel
... and now my desktop effects in KDE work without locking up X. Naturally, I'll have to keep mesa from updating back to 7.6.0 when performing system updates. Hopefully this method works for everyone running Compiz.
Reply With Quote
  #11  
Old 15th August 2009, 12:07 PM
3esmit Offline
Registered User
 
Join Date: Aug 2009
Posts: 9
linuxfedorafirefox
Hello zez.

I did what you did and now its working perfect!
The Red Hat Bugzilla – Bug 509528 , as you posted, is exactaly what is described in this topic.

Thank you for sharing your "fix"!
How can I help Red Hat fixing this issue?
Reply With Quote
Reply

Tags
destop, effects, messed, update

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost Destop Effects Icon.... Gamblor Using Fedora 4 3rd September 2009 04:57 PM
Fedora 11 update (213 kernel) messed up GNOME power management and custom effects gslams Using Fedora 12 24th July 2009 02:49 PM
destop effects oshan1991 Hardware & Laptops 6 25th February 2008 10:37 AM
Can't enable destop effects skullhunterph Hardware & Laptops 2 11th December 2007 07:28 PM
FC6-Test 3 Destop Effects plazman30 Installation, Upgrades and Live Media 3 2nd October 2006 03:47 PM


Current GMT-time: 22:20 (Wednesday, 01-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat