Fedora Linux Support Community & Resources Center
  #1  
Old 29th July 2009, 10:01 PM
xarver Offline
Registered User
 
Join Date: Jul 2009
Posts: 12
linuxopera
Fedora11 Flash10 issues

(also posted on my.opera.com/community/forums)
Hello, guys! I have a problem on Fedora 11 with Flash.
This occurs with all browsers, so opera isn't alone here.

Opera: What happens is the video plays for some time then the audio goes mute but the video persists.
Firefox: it plays for a while, and then skims fastly through the video.

What can I do to fix flash? Please note this a fresh install, I have just installed flash and such.
Fedora 11 is great but this is the only problem. I want to see videos and flash.

I'm suspecting this to be a sound problem or flash, because when I modify my system's sound it does not modify the video's sound.
Can anyone help? I already asked on the fedora irc channel.

P.S. This is probably because I updated all my packages or something.
gnash and swfdec don't work also
Reply With Quote
  #2  
Old 29th July 2009, 10:55 PM
xarver Offline
Registered User
 
Join Date: Jul 2009
Posts: 12
linuxopera
fixed. just follow this http://fedorasolved.org/Members/fenr...nd-workarounds
Reply With Quote
  #3  
Old 30th July 2009, 01:28 AM
xarver Offline
Registered User
 
Join Date: Jul 2009
Posts: 12
linuxopera
Nope, it seemed to work but it doesn't now! help
Reply With Quote
  #4  
Old 1st August 2009, 04:03 AM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,227
linuxopera
Just tried a youtube video in Opera 10 Beta 2 with Fedora 11 (F11 installed a couple of days ago).

Video plays fine with sound for a minute or so, then just stops. Later the video continues without sound. Operapluginwrapper was using >95% CPU when this happened.

FWIW here is the video I tried it on.
http://www.youtube.com/watch?v=K-DdstKANYg
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #5  
Old 1st August 2009, 05:01 AM
xarver Offline
Registered User
 
Join Date: Jul 2009
Posts: 12
linuxopera
I found out just do this: su -c "yum remove alsa-plugins-pulseaudio"
It may be unrecommend im unsure but it works
Reply With Quote
  #6  
Old 1st August 2009, 11:27 AM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,227
linuxopera
Quote:
Originally Posted by xarver View Post
I found out just do this: su -c "yum remove alsa-plugins-pulseaudio"
It may be unrecommend im unsure but it works
I may try that, but I would first like to see if there are other solutions.

Mandriva has something called libflashsupport that is supposed to fix pulse audio problems with Flash. Supposedly it is not needed with Flash 10, but it got installed by default on my Mandriva 2009.1 (Powerpack) system which came with Flash 10. I am not having this problem with Flash using Mandriva...
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #7  
Old 1st August 2009, 11:51 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
linuxopera
Fedora used to have libflashsupport, and it used to be necessary, but shouldn't be anymore. I don't have the issue, so can't really help. (I don't use Gnome or KDE either though, which might be a factor.)
Sometimes, if you open a terminal and type firefox (or opera), then go play the video, you can get useful messages, giving you an idea of what the problem is, or at least giving a message you can try feeding into google to see if anyone's found the solutoin.
__________________
--
http://home.roadrunner.com/~computertaijutsu

Do NOT PM forum members with requests for technical support. Ask your questions on the forum.


"I don't know why there is the constant push to break any semblance of compatibility" --anon
Reply With Quote
  #8  
Old 1st August 2009, 11:56 AM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,227
linuxopera
FWIW I just tried the same youtube video again. I was watching 'top' in terminal while the video was playing. Operapluginwrapper was using about 50% CPU for the first minute or so, then Pulse Audio jumped up to > 70% CPU for some seconds. After that, Pulse Audio dropped out and operapluginwrapper went to ~95% CPU and stayed there. When Pulse Audio jumped to > 70% CPU, the Flash Video basically stopped playing.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)

Last edited by David Batson; 1st August 2009 at 12:44 PM.
Reply With Quote
  #9  
Old 1st August 2009, 01:04 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,227
linuxopera
Just tried that same youtube video (Marcos Valle-Os Grilos) in Mandriva 2009.1 KDE. Using same version of Opera 10 Beta 2 and same version of Adobe Flash 10.0.22.87 on the same computer. Operapluginwrapper uses less % CPU in Mandriva than in Fedora 11. In Mandriva, operapluginwrapper uses 35-38% CPU and the youtube video plays fine to the end (4:53 min.) using Opera. In Fedora 11, operapluginwrapper uses about 50% CPU and the video hangs about 1 minute in.

Using Firefox in Fedora 11, the video plays longer (over 4 minutes) then it stops for some seconds as the % CPU is used up. Next the sound resumes, but the video is stopped. When the sound completes, then the video runs rapidly to the end.

When I ran the video in Opera 10 in Fedora this last time, operapluginwrapper crashed. Following is the crash file: operapluginwrapper-bugreport.txt
http://pastebin.com/mfb96b1e
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #10  
Old 2nd August 2009, 12:09 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,227
linuxopera
Quote:
Originally Posted by xarver View Post
I found out just do this: su -c "yum remove alsa-plugins-pulseaudio"
It may be unrecommend im unsure but it works
In the absence of other solutions I removed alsa-plugins-pulseaudio, and indeed, the youtube videos now play to completion in Opera and Firefox.

I wonder what I am losing by uninstalling alsa-plugins-pulseaudio? Sound still works in Flash. Must be a bug in that plugin.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #11  
Old 2nd August 2009, 12:57 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,227
linuxopera
I just filed a bug report on this: https://bugzilla.redhat.com/show_bug.cgi?id=515121
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #12  
Old 2nd August 2009, 01:08 PM
Svicx Offline
Registered User
 
Join Date: Jul 2009
Posts: 17
linuxfedorafirefox
[Google Translate - reverso.net]
I have the same problem. I have resolved the problem removing alsa-plugins-pulseaudio.

Attached:
- computer.txt: details of my computer (smoltSendProfile -p > computer.txt)
- package.txt: all the installed packages on my computer (rpm -qa > package.txt)
Attached Files
File Type: txt computer.txt (5.3 KB, 32 views)
File Type: txt package.txt (35.6 KB, 38 views)

Last edited by Svicx; 2nd August 2009 at 01:16 PM.
Reply With Quote
  #13  
Old 2nd August 2009, 01:47 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,227
linuxopera
I do not have this problem on my Mandriva 2009.1 installation on this same computer. I just checked, and Mandriva is using alsa-plugins-pulseaudio version 10.0.19 vs Fedora alsa-plugins-pulseaudio 10.0.20. Might be a problem with the newer version...
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #14  
Old 3rd August 2009, 08:09 AM
Iotos Offline
Registered User
 
Join Date: Apr 2009
Posts: 3
linuxfedorafirefox
Disable Pulseaudio

I had the exact same problem, not only with flash, but with all audio players. A backtrace revealed that pulseaudio was to blame, and removing alsa-plugins-pulseaudio didnt always work. I found that even without alsa-plugins-pulseaudio, pulse would still randomly start up at login. Issue the following in your terminal (just as you, not root) and try flash again:
pulseaudio -k
It will only be temporary, but if this fixes it, you have the same issue I did. Note that this will effectively disable gstreamer and gstreamer based apps till you log back in or restart pulseaudio.

Do not remove pulseaudio altogether. I did this out of spite, and now gstreamer will not work (my latest pet project). Note that xine based apps will play sound fine without pulseaudio as long as the pulseaudio plugin for xine is not installed.

If it works, do one of the following:
1) Try fixing pulse with this guide: http://forums.fedoraforum.org/showth...out+pulseaudio
2) Manually disable pulseaudio with the command above every time you want to see flash
3) Add the pulseaudio -k to your run-mozilla.sh file
4) Disable or remove pulseaudio, and get used to xine based players (see above disclaimer)

Last edited by Iotos; 4th August 2009 at 06:29 PM. Reason: Clarification
Reply With Quote
  #15  
Old 11th August 2009, 06:26 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,227
linuxopera
Quote:
Originally Posted by David Batson View Post
In the absence of other solutions I removed alsa-plugins-pulseaudio, and indeed, the youtube videos now play to completion in Opera and Firefox.

I wonder what I am losing by uninstalling alsa-plugins-pulseaudio? Sound still works in Flash. Must be a bug in that plugin.
I found later that I had a similar problem playing a wmv file in VLC. Performing the steps of the following guide fixed all issues for me. Note that alsa-plugins-pulseaudio is now installed and not causing a problem.

Fedora 11: Complete guide to fix PulseAudio and video/audio VLC Media Player issues
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
Reply

Tags
fedora11, flash10, issues

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH to my fedora11 pc-dok Using Fedora 15 23rd August 2009 03:28 PM
how to get D4X for Fedora11 bavireddy.subbu Using Fedora 0 22nd July 2009 06:21 PM
fedora11 types shabakeh Using Fedora 1 14th June 2009 07:17 AM
Fedora11 Names Demz Fedora Focus 46 11th January 2009 08:56 PM


Current GMT-time: 19:35 (Wednesday, 23-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat