Fedora Linux Support Community & Resources Center
  #1  
Old 23rd July 2009, 08:46 AM
Robert2 Offline
Registered User
 
Join Date: Apr 2009
Posts: 138
kernel: [drm:radeon_cp_init_kms] *ERROR* invalid ioctl with kms radeon_cp_init_kms

Since the last batch of xorg-server updates, X has been broken on my ThinkPad T41 with Radeon RV250. The machine boots fine up to when GDM is supposed to take over, then I get the invalid ioctl messages and as a result GDM fails to start because there is no X server

I have been trying to pull updates from koji in the hope that the issue would get fixed, but it has now been like this for more then a week and I have not seen any similar bug reports. Here is what the system has currently

kernel-2.6.31-0.86.rc3.git5.fc12.i686
xorg-x11-server-Xorg-1.6.99-14.20090715.fc12.i586
xorg-x11-drv-ati-6.12.2-19.fc12.1.i586
libdrm-2.4.12-0.2.fc12.i586

Here is part of my syslog, filtered down to only the messages related to video
Code:
Jul 21 09:09:40 t41 kernel: [drm] Initialized drm 1.1.0 20060810
Jul 21 09:09:40 t41 kernel: modprobe used greatest stack depth: 6704 bytes left
Jul 21 09:09:40 t41 kernel: [drm] radeon default to kernel modesetting.
Jul 21 09:09:40 t41 kernel: [drm] radeon kernel modesetting enabled.
Jul 21 09:09:40 t41 kernel: radeon 0000:01:00.0: power state changed by ACPI to D0
Jul 21 09:09:40 t41 kernel: radeon 0000:01:00.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
Jul 21 09:09:40 t41 kernel: [drm] radeon: Initializing kernel modesetting.
Jul 21 09:09:40 t41 kernel: [drm] register mmio base: 0xC0100000
Jul 21 09:09:40 t41 kernel: [drm] register mmio size: 65536
Jul 21 09:09:40 t41 kernel: [drm] GPU reset succeed (RBBM_STATUS=0x00000140)
Jul 21 09:09:40 t41 kernel: [drm] Detected VRAM RAM=32M, BAR=32M
Jul 21 09:09:40 t41 kernel: [drm] RAM width 64bits DDR
Jul 21 09:09:40 t41 kernel: [drm] Clocks initialized !
Jul 21 09:09:40 t41 kernel: agpgart-intel 0000:00:00.0: AGP 2.0 bridge
Jul 21 09:09:40 t41 kernel: agpgart-intel 0000:00:00.0: putting AGP V2 device into 4x mode
Jul 21 09:09:40 t41 kernel: radeon 0000:01:00.0: putting AGP V2 device into 4x mode
Jul 21 09:09:40 t41 kernel: [drm] radeon: VRAM 32M
Jul 21 09:09:40 t41 kernel: [drm] radeon: VRAM from 0x00000000 to 0x01FFFFFF
Jul 21 09:09:40 t41 kernel: [drm] radeon: GTT 256M
Jul 21 09:09:40 t41 kernel: [drm] radeon: GTT from 0xD0000000 to 0xDFFFFFFF
Jul 21 09:09:40 t41 kernel: [drm] radeon: irq initialized.
Jul 21 09:09:40 t41 kernel: [TTM] TTM available graphics memory: 995 MiB
Jul 21 09:09:40 t41 kernel: [TTM] TTM available object memory: 414 MiB
Jul 21 09:09:40 t41 kernel: [drm] radeon: 32M of VRAM memory ready
Jul 21 09:09:40 t41 kernel: [drm] radeon: 256M of GTT memory ready.
Jul 21 09:09:40 t41 kernel: [drm] radeon: cp idle (0x02000603)
Jul 21 09:09:40 t41 kernel: [drm] Loading R200 Microcode
Jul 21 09:09:40 t41 kernel: [drm] radeon: ring at 0x00000000D0000000
Jul 21 09:09:40 t41 kernel: [drm] ring test succeeded in 1 usecs
Jul 21 09:09:40 t41 kernel: [drm] radeon: ib pool ready.
Jul 21 09:09:40 t41 kernel: [drm] ib test succeeded in 0 usecs
Jul 21 09:09:40 t41 kernel: [drm] DFP table revision: 3
Jul 21 09:09:40 t41 kernel: [drm] Panel ID String: SXGA+ Single (85MHz)
Jul 21 09:09:40 t41 kernel: [drm] Panel Size 1400x1050
Jul 21 09:09:40 t41 kernel: [drm] Default TV standard: NTSC
Jul 21 09:09:40 t41 kernel: [drm] 27.000000000 MHz TV ref clk
Jul 21 09:09:40 t41 kernel: [drm] Radeon Display Connectors
Jul 21 09:09:40 t41 kernel: [drm] Connector 0:
Jul 21 09:09:40 t41 kernel: [drm]   VGA
Jul 21 09:09:40 t41 kernel: [drm]   DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
Jul 21 09:09:40 t41 kernel: [drm]   Encoders:
Jul 21 09:09:40 t41 kernel: [drm]     CRT1: INTERNAL_DAC1
Jul 21 09:09:40 t41 kernel: [drm] Connector 1:
Jul 21 09:09:40 t41 kernel: [drm]   DVI-D
Jul 21 09:09:40 t41 kernel: [drm]   DDC: 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64
Jul 21 09:09:40 t41 kernel: [drm]   Encoders:
Jul 21 09:09:40 t41 kernel: [drm]     DFP1: INTERNAL_TMDS1
Jul 21 09:09:40 t41 kernel: [drm] Connector 2:
Jul 21 09:09:40 t41 kernel: [drm]   LVDS
Jul 21 09:09:40 t41 kernel: [drm]   Encoders:
Jul 21 09:09:40 t41 kernel: [drm]     LCD1: INTERNAL_LVDS
Jul 21 09:09:40 t41 kernel: i2c-adapter i2c-0: unable to read EDID block.
Jul 21 09:09:40 t41 kernel: radeon 0000:01:00.0: VGA-1: no EDID data
Jul 21 09:09:40 t41 kernel: i2c-adapter i2c-1: unable to read EDID block.
Jul 21 09:09:40 t41 kernel: radeon 0000:01:00.0: DVI-D-1: no EDID data
Jul 21 09:09:40 t41 kernel: [drm] fb mappable at 0xE0040000
Jul 21 09:09:40 t41 kernel: [drm] vram apper at 0xE0000000
Jul 21 09:09:40 t41 kernel: [drm] size 5913600
Jul 21 09:09:40 t41 kernel: [drm] fb depth is 24
Jul 21 09:09:40 t41 kernel: [drm]    pitch is 5632
Jul 21 09:09:40 t41 kernel: fbcon: radeondrmfb (fb0) is primary device
Jul 21 09:09:40 t41 kernel: Console: switching to colour frame buffer device 175x65
Jul 21 09:09:40 t41 kernel: [drm] LVDS-9: set mode 1400x1050 e
Jul 21 09:09:40 t41 kernel: fb0: radeondrmfb frame buffer device
Jul 21 09:09:40 t41 kernel: registered panic notifier
Jul 21 09:09:40 t41 kernel: [drm] radeon: kernel modesetting successfully initialized.
Jul 21 09:09:40 t41 kernel: [drm] Initialized radeon 2.0.0 20080528 for 0000:01:00.0 on minor 0
Jul 21 09:09:40 t41 kernel: modprobe used greatest stack depth: 4680 bytes left
Jul 21 09:09:40 t41 kernel: input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/device:02/device:03/input/input8
Jul 21 09:09:40 t41 kernel: ACPI: Video Device [VID] (multi-head: yes  rom: no  post: no)
Jul 21 09:09:56 t41 kernel: [drm:radeon_cp_init_kms] *ERROR* invalid ioctl with kms radeon_cp_init_kms
Jul 21 09:09:56 t41 kernel: [drm:radeon_cp_init_kms] *ERROR* invalid ioctl with kms radeon_cp_init_kms
Jul 21 09:09:56 t41 gdm-binary[1212]: WARNING: GdmDisplay: display lasted 1.388139 seconds
Jul 21 09:09:56 t41 kernel: [drm:radeon_cp_init_kms] *ERROR* invalid ioctl with kms radeon_cp_init_kms
Jul 21 09:09:56 t41 kernel: [drm:radeon_cp_init_kms] *ERROR* invalid ioctl with kms radeon_cp_init_kms
Jul 21 09:09:56 t41 gdm-binary[1212]: WARNING: GdmDisplay: display lasted 0.432959 seconds

*cut*

Jul 21 09:10:20 t41 init: prefdm main process (1660) terminated with status 1
Jul 21 09:10:20 t41 init: prefdm main process ended, respawning
Jul 21 09:10:20 t41 init: prefdm respawning too fast, stopped
  #2  
Old 23rd July 2009, 09:06 AM
Robert2 Offline
Registered User
 
Join Date: Apr 2009
Posts: 138
https://bugzilla.redhat.com/show_bug.cgi?id=512757
  #3  
Old 23rd July 2009, 11:11 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
try with the 'nomodeset' kernel parameter and see if it changes things?
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
  #4  
Old 24th July 2009, 09:20 AM
Robert2 Offline
Registered User
 
Join Date: Apr 2009
Posts: 138
nomodeset does not work, as is also mentioned in the bugzilla report, it is being ignored with the 2.6.31 kernel (another bug).

Instead use radeon.modeset=0 which does work, and causes X to start again.
 

Tags
kms, radeon, t41, thinkpad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
device-mapper: reload ioctl failed: Invalid argument Failed to suspend LogVol00 HughB Using Fedora 3 15th October 2009 09:12 PM


Current GMT-time: 23:36 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat