Fedora Linux Support Community & Resources Center
  #1  
Old 24th September 2004, 08:40 PM
gadgervais Offline
Registered User
 
Join Date: Sep 2004
Posts: 9
nForce 2 (audio)

I'm having the MSI k7n2 Dealta with nForce 2....
i had install nvidia drivers like it's write on the web site.... (http://www.nvidia.com/object/linux_nforce_1.0-0283) and now when i start kde it's telling me

Sound server fatal error:
AudioSubSystem::handle0: write failed
lesn = -1, can_write = 4096, errno = 11 (ressource temporarily unavailable
This might be a sound hardware/driver specific problem (see aRts Faq)

this is what i did...

-----------------------------------------
From within a shell with root privileges, type "sh NFORCE-Linux-x86-1.0-0283-pkg1.run" to initiate the installation.
----------------------------------------
and after i did the configuration l
http://download.nvidia.com/XFree86/n...#Configuration
----------------------------------------
After the installation of the drivers, make sure the following lines are in the modules configuration file (it will be named /etc/modules.conf on most current distributions that provide a 2.4 series kernel, and /etc/modprobe.conf on most current distributions that provide a 2.6 series kernel):

* alias eth0 nvnet
* alias sound-slot-0 nvsound (may be snd-card-0 on some distributions)

If there is an entry for the i810_audio, snd-intel8x0, or nvaudio driver (an open-source audio driver that supports the nForce audio controller), that entry needs to be commented out or removed.
--------------------------------------
so i ahve delete every line whit alias "snd_intel" ect...

this is my modprobe.conf
--------------------------------------
alias eth0 sundance
alias eth1 forcedeth
alias scsi_hostadapter sata_promise
alias eth2 sundance
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias snd-card-0 nvsound
install nvsound /sbin/modprobe --ignore-install nvsound && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
--ignore-remove nvsound

so if you have an idea how i can come back whit my old setting or repair this one... please answer me!!!
Reply With Quote
  #2  
Old 3rd October 2004, 12:24 AM
Hurkyl Offline
Registered User
 
Join Date: Sep 2004
Posts: 9
I think it's because arts doesn't work with the nvidia drivers. You need to turn off aRts.
Control Center -> Sound & Multimedia -> Sound Sytem
there you uncheck Enable the sound system.
Reply With Quote
  #3  
Old 12th October 2004, 02:17 AM
benadam777 Offline
Registered User
 
Join Date: Oct 2004
Posts: 1
Hey, I got the same mobo and distro and I 'had' the same problem that you are. I went to Configure->Sound & Multimedia->Sound System->Hardware and changed "select audio device" from autodetect to Advanced Linux Sound Arch. (aka ALSA). After that, I did a 'test sound' on the 'General' tab and sound was kickin!
Reply With Quote
Reply

Tags
audio, nforce

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
audio problem with Fedora core 5 and nForce 430 michaeleekk Hardware & Laptops 10 9th April 2007 05:50 PM
MIDI with nForce onboard audio icydog Hardware & Laptops 0 28th February 2007 04:49 PM
NVIDIA nForce Audio drivers, FC5. Allieonfire EOL (End Of Life) Versions 1 8th July 2006 05:08 AM
Nvidia Nforce 2 audio Trsto Hardware & Laptops 2 1st May 2005 02:51 PM
Remove Nforce drivers (audio) FC3 ) Zeeker Hardware & Laptops 1 21st November 2004 06:40 PM


Current GMT-time: 20:22 (Tuesday, 23-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat