Fedora Linux Support Community & Resources Center
  #1  
Old 19th July 2009, 05:40 PM
akarcay Offline
Registered User
 
Join Date: Jun 2009
Posts: 10
File does not exist: /var/www/html/~user

Hi all,
I'm running a webserver on Fedora 10 with no problem for the default server.
Recently, I wanted to add some users to Fedora, and allow them to upload their own files.
I checked many times the following:
- Userdir has 711 permission
- public_html directory ( and its content) is set to 755 permission
- modified httpd.conf by removing UserDir disable, and uncommented UserDir public_html
- Uncommented the <Directory>...for alllowing all users to have accces to /~user directory.
- SElinux is disabled (In fact, uninstalled)
- There is no specific info in error_log other then 'File does not exist....'.
- Nothing in the messages log file either.
Any suggestions?
Thanks,
Faruk
Reply With Quote
  #2  
Old 20th July 2009, 06:36 PM
neogranas Offline
Registered User
 
Join Date: Nov 2006
Location: U.S.A.
Age: 29
Posts: 473
What are you using as your FTP daemon?
__________________
Registered linux user: #475337

Never underestimate someone with source code, a text editor, and the willingness to completely hose their system.
Reply With Quote
  #3  
Old 20th July 2009, 06:44 PM
akarcay Offline
Registered User
 
Join Date: Jun 2009
Posts: 10
Quote:
Originally Posted by neogranas View Post
What are you using as your FTP daemon?
Although vsftpd is running, I'm not using any FTP clients, but SSH to upload the files.
Reply With Quote
  #4  
Old 21st July 2009, 12:29 AM
neogranas Offline
Registered User
 
Join Date: Nov 2006
Location: U.S.A.
Age: 29
Posts: 473
What is giving you that error then? Is it a terminal?
__________________
Registered linux user: #475337

Never underestimate someone with source code, a text editor, and the willingness to completely hose their system.
Reply With Quote
  #5  
Old 21st July 2009, 06:17 AM
akarcay Offline
Registered User
 
Join Date: Jun 2009
Posts: 10
Quote:
Originally Posted by neogranas View Post
What is giving you that error then? Is it a terminal?
I'm trying just to visit the user's pages by typing the URL, www.aaa.com/~user, in the browser. Tried from a few PC's, but nothing changed, still can not view the pages.
Reply With Quote
  #6  
Old 21st July 2009, 06:43 AM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
Are there any files in the public_html directory? Apache will throw a 403 or 404 at you if there's not a valid index file (typically index.php or index.html, although this can be configured).

If you do have content in the public_html directory, I know you mentioned you already that you've set permissions and enabled the userdir above but just to double check can you attach/pastebin your httpd.conf here (be sure to remove any sensitive information first)? As well, you can ensure that the permissions are correct by running:
Code:
ls -ld ~
ls -ld ~/public_html
ls -l ~/public_html/index.html
The permissions should be 711, 755 and 644 respectively.

Edit: Also, do have you made any extensive configuration changes to httpd.conf or added a custom file to /etc/httpd/conf.d? One of the config rules could be overriding or changing the behavior of another rule.
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #7  
Old 21st July 2009, 07:34 PM
akarcay Offline
Registered User
 
Join Date: Jun 2009
Posts: 10
Quote:
Originally Posted by Firewing1 View Post
Are there any files in the public_html directory? Apache will throw a 403 or 404 at you if there's not a valid index file (typically index.php or index.html, although this can be configured).

If you do have content in the public_html directory, I know you mentioned you already that you've set permissions and enabled the userdir above but just to double check can you attach/pastebin your httpd.conf here (be sure to remove any sensitive information first)? As well, you can ensure that the permissions are correct by running:
Code:
ls -ld ~
ls -ld ~/public_html
ls -l ~/public_html/index.html
The permissions should be 711, 755 and 644 respectively.

Edit: Also, do have you made any extensive configuration changes to httpd.conf or added a custom file to /etc/httpd/conf.d? One of the config rules could be overriding or changing the behavior of another rule.
- public_html is automatically created with index.htm for each user added to the server, with all permissions set.
- I have checked once again the permissions, but nothing seems wrong. Here is the permissions list:
~test/ = 711
~test/public_html=755
/public_html/index.htm 755 (changed it to 644, but no change)

I have attched the httpd.conf file in use as httpd.txt.
Besides, I did not configure anything but httpd.conf only, so I do not use a second conf file for apache, and finallly: I had uninstalled SElinux completely.
Attached Files
File Type: txt httpd.txt (33.5 KB, 228 views)
Reply With Quote
  #8  
Old 21st July 2009, 08:20 PM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
I think the problem here is that you have two UserDir statements:
Code:
    UserDir enabled all
    # To enable requests to /~user/ to serve the user's public_html
    # directory, remove the "UserDir disabled" line above, and uncomment
    # the following line instead:
    # 
    UserDir public_html
It should read:
Code:
    #UserDir disabled
    # To enable requests to /~user/ to serve the user's public_html
    # directory, remove the "UserDir disabled" line above, and uncomment
    # the following line instead:
    # 
    UserDir public_html
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #9  
Old 21st July 2009, 08:58 PM
akarcay Offline
Registered User
 
Join Date: Jun 2009
Posts: 10
Quote:
Originally Posted by Firewing1 View Post
I think the problem here is that you have two UserDir statements:
Code:
    UserDir enabled all
    # To enable requests to /~user/ to serve the user's public_html
    # directory, remove the "UserDir disabled" line above, and uncomment
    # the following line instead:
    # 
    UserDir public_html
It should read:
Code:
    #UserDir disabled
    # To enable requests to /~user/ to serve the user's public_html
    # directory, remove the "UserDir disabled" line above, and uncomment
    # the following line instead:
    # 
    UserDir public_html
I had tried to access the user pages with
- UserDir enabled all
#UserDir disabled (commented)
-or completetly removed UserDir disbaled line from the httpd.conf file.
Urfortunatetly, nothing changed. Still getting File does not exist: /var/www/html/~test.
Does running the server on a Virtual Machine create any problem for accessing Userdirs?
Any idea?
Reply With Quote
  #10  
Old 8th January 2010, 06:30 PM
printz30 Offline
Registered User
 
Join Date: Jan 2010
Posts: 1
windows_98_nt_2000ie
httpd.conf and files in conf.d

Thought I might add a note here after spending 8 hours pounding keys, checking web yadayadayada.
The information in httpd.conf appears to be replaced/overlooked when there are other .conf files in the conf.d directory, ie my httpd.conf file could be edited, changed, turned blue and there were NO changes to the results. Finaly found that the system-config-httpd.conf file in conf.d directory ALSO had the same section about user directories as the httpd.conf file. changing the values in the system-config-httpd.conf file DID yeild the results we all expect. Nice.
Reply With Quote
  #11  
Old 10th January 2010, 11:00 PM
marcrblevins Offline
Registered User
 
Join Date: Jun 2006
Location: Texas
Age: 43
Posts: 4,168
linuxfedorafirefox
Must be Selinux as well:
Code:
man httpd_selinux
setsebool -P httpd_enable_homedirs 1
chcon -R -t httpd_sys_content_t ~user/public_html
Reply With Quote
  #12  
Old 25th January 2011, 11:38 AM
metsd Offline
Registered User
 
Join Date: Jan 2011
Posts: 1
linuxchrome
Re: File does not exist: /var/www/html/~user

I had the same problem and I found your solution after a couple of hours only! Thanks for saving my 6 hours:-)
Reply With Quote
Reply

Tags
exist, file

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help :- ¨user mockbuild does not exist¨ irbadguyzs Installation, Upgrades and Live Media 3 1st August 2008 04:48 AM
Can not boot new KERNEL > Error 15: File not found > but the file exist marxiano533 Using Fedora 0 22nd June 2006 05:50 PM
How to check whether a user exist cweng Using Fedora 1 1st June 2005 04:32 AM


Current GMT-time: 02:20 (Saturday, 20-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram