Fedora Linux Support Community & Resources Center
  #1  
Old 11th July 2009, 07:14 PM
phoenixpb Offline
Registered User
 
Join Date: Mar 2009
Location: France & Québec
Posts: 173
Question NVIDIA 96.43.13 and FC12

kernel.i586 2.6.31-0.64.rc2.git5.fc12 @koji-i386 installed

i have installed NVIDIA-Linux-x86-96.43.13-pkg1.run (seems oki during installation no errors)

when i run nvidia-settings i have these errors :

ERROR: NV-CONTROL extension not found on this Display.


ERROR: Unable to determine number of NVIDIA GPUs on ':0.0'.


ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ':0.0'.


ERROR: Unable to determine number of NVIDIA VCSCs on ':0.0'.

fusion doesn't work

any idea ??

thanks
__________________
Phoenix. Linux User number 495894

Fedora 21 alpha gnome 3.13
yum update junky

Last edited by phoenixpb; 11th July 2009 at 07:27 PM.
  #2  
Old 11th July 2009, 07:28 PM
leigh123linux
Guest
 
Posts: n/a
Did you edit for Xorg 1.6.99 ?


http://forums.fedoraforum.org/showpo...36&postcount=1



.
  #3  
Old 11th July 2009, 07:40 PM
phoenixpb Offline
Registered User
 
Join Date: Mar 2009
Location: France & Québec
Posts: 173
nvidia 96.43.13 and FC12

just applied the patch for ABI and same thing

thanks anyway for your fast answer
__________________
Phoenix. Linux User number 495894

Fedora 21 alpha gnome 3.13
yum update junky
  #4  
Old 11th July 2009, 07:45 PM
phoenixpb Offline
Registered User
 
Join Date: Mar 2009
Location: France & Québec
Posts: 173
nvidia 96.43.13 and FC12

this is my xorg.conf

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules/drivers"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
Option "AIGLX" "on"
# Needed for "nvidia" driver on new Xorg
Option "IgnoreABI" "true"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "ca_enhanced"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "NEC"
HorizSync 31.0 - 60.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "NVIDIA Corporation"
BoardName "GeForce4 MX 440 with AGP8X"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "CRT-0: 1024x768_75 +0+0"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
__________________
Phoenix. Linux User number 495894

Fedora 21 alpha gnome 3.13
yum update junky
  #5  
Old 11th July 2009, 08:13 PM
leigh123linux
Guest
 
Posts: n/a
Is there a reason why your xorg.conf is set to vesa ?


Code:
Section "Device"
    Identifier  "Videocard0"
    Driver      "vesa"
    VendorName  "NVIDIA Corporation"
    BoardName   "GeForce4 MX 440 with AGP8X"
EndSection
try


Code:
Section "Device"
    Identifier  "Videocard0"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    BoardName   "GeForce4 MX 440 with AGP8X"
EndSection
Is this rawhide install a F11 upgrade?
Code:
# Xorg configuration created by livna-config-display
If so did you remove all the rpmfusion driver rpm's including livna-config-display


Code:
rpm -e livna-config-display
  #6  
Old 15th July 2009, 05:13 PM
phoenixpb Offline
Registered User
 
Join Date: Mar 2009
Location: France & Québec
Posts: 173
nvidia and FC12

nvidia-settings works now but i have no window decorator (windows are placed in upper left corner .... cant maximise or minimise)
fusion-icon hangs and makes the system back to login screen
any idea ?

thanks guys
__________________
Phoenix. Linux User number 495894

Fedora 21 alpha gnome 3.13
yum update junky
  #7  
Old 15th July 2009, 05:49 PM
leigh123linux
Guest
 
Posts: n/a
Post

Code:
cat /var/log/Xorg.0.log |grep EE

Code:
cat /var/log/Xorg.0.log |grep WW
  #8  
Old 16th July 2009, 12:46 AM
phoenixpb Offline
Registered User
 
Join Date: Mar 2009
Location: France & Québec
Posts: 173
FC12 and nvidia

Quote:
Originally Posted by leigh123linux View Post
Post

Code:
cat /var/log/Xorg.0.log |grep EE

Code:
cat /var/log/Xorg.0.log |grep WW

(EE) Failed to load module "type1" (module does not exist, 0)
(EE) Failed to load module "freetype" (module does not exist, 0)
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.

cat /var/log/Xorg.0.log | grep WW
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0
(WW) Warning, couldn't open module type1
(WW) Warning, couldn't open module freetype
(WW) NVIDIA: This server has an unsupported input driver ABI version (have 7.0, need < 5.0). The driver will continue to load, but may behave strangely.
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-1
__________________
Phoenix. Linux User number 495894

Fedora 21 alpha gnome 3.13
yum update junky
  #9  
Old 16th July 2009, 05:39 PM
phoenixpb Offline
Registered User
 
Join Date: Mar 2009
Location: France & Québec
Posts: 173
FC12 and nvidia

after update today i have :

[root@localhost Documents]# cat /var/log/Xorg.0.log | grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) Failed to load module "type1" (module does not exist, 0)
(EE) Failed to load module "freetype" (module does not exist, 0)

[root@localhost Documents]# cat /var/log/Xorg.0.log | grep WW
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0
(WW) Warning, couldn't open module type1
(WW) Warning, couldn't open module freetype
(WW) NVIDIA: This server has an unsupported input driver ABI version (have 7.0, need < 5.0). The driver will continue to load, but may behave strangely.
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-1

nvidia-settings works now (problem with glx seems to be resolved)
windows are now normal it's just compiz which doesn't work

[Phoenix@localhost Documents]$ fusion-icon
* Detected Session: kde

* Searching for installed applications...
Traceback (most recent call last):
File "/usr/bin/fusion-icon", line 57, in <module>
from FusionIcon.interface import choose_interface
File "/usr/lib/python2.6/site-packages/FusionIcon/interface.py", line 22, in <module>
from util import env
File "/usr/lib/python2.6/site-packages/FusionIcon/util.py", line 421, in <module>
decorators = CompizDecorators(_installed)
File "/usr/lib/python2.6/site-packages/FusionIcon/util.py", line 228, in __init__
self.command = context.Plugins['decoration'].Display['command']
KeyError: 'decoration'

thanks guys
__________________
Phoenix. Linux User number 495894

Fedora 21 alpha gnome 3.13
yum update junky
  #10  
Old 16th July 2009, 05:52 PM
leigh123linux
Guest
 
Posts: n/a
Post

Code:
rpm -qa |grep compiz

and replace any 0.7.8 version with 0.8.3 versions from my repo ( i.e libcompizconfig , compizconfig-python & compizconfig-backend-kconfig ) , they are compatible with 0.8.2
  #11  
Old 17th July 2009, 01:29 AM
phoenixpb Offline
Registered User
 
Join Date: Mar 2009
Location: France & Québec
Posts: 173
Quote:
Originally Posted by leigh123linux View Post
Post

Code:
rpm -qa |grep compiz

and replace any 0.7.8 version with 0.8.3 versions from my repo ( i.e libcompizconfig , compizconfig-python & compizconfig-backend-kconfig ) , they are compatible with 0.8.2
[root@localhost Phoenix]# rpm -qa |grep compiz
libcompizconfig-0.8.3-1.fc11.i586
compizconfig-python-0.8.3-1.fc11.i586
compiz-bcop-0.8.3-1.fc11.noarch
compizconfig-backend-kconfig-0.8.3-1.fc11.i586

humm any idea ?
__________________
Phoenix. Linux User number 495894

Fedora 21 alpha gnome 3.13
yum update junky
  #12  
Old 17th July 2009, 08:47 AM
leigh123linux
Guest
 
Posts: n/a
Try installing compiz


Code:
su
yum install ccsm emerald-themes  fusion-icon-qt  emerald compiz-fusion   compiz-bcop compiz  compiz-fusion-extras  compiz-kde compiz-manager
  #13  
Old 17th July 2009, 07:49 PM
phoenixpb Offline
Registered User
 
Join Date: Mar 2009
Location: France & Québec
Posts: 173
FC12 and nvidia

Quote:
Originally Posted by leigh123linux View Post
Try installing compiz


Code:
su
yum install ccsm emerald-themes  fusion-icon-qt  emerald compiz-fusion   compiz-bcop compiz  compiz-fusion-extras  compiz-kde compiz-manager
oki it has updated 7 packages

now i have :

[Phoenix@localhost ~]$ fusion-icon
* Detected Session: kde
* Searching for installed applications...
* NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
* Using the GTK Interface
* Starting Compiz
... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
compiz (core) - Error: Plugin 'core' has ABI version '20090207', expected ABI version '20080828'.

compiz (ccp) - Error: InitObject failed
compiz (core) - Error: Couldn't activate plugin 'ccp'
compiz (core) - Error: Plugin 'core' has ABI version '20090207', expected ABI version '20080828'.

compiz (ccp) - Error: InitObject failed
compiz (core) - Error: Couldn't activate plugin 'ccp'

any ideay ?
__________________
Phoenix. Linux User number 495894

Fedora 21 alpha gnome 3.13
yum update junky
  #14  
Old 17th July 2009, 08:19 PM
leigh123linux
Guest
 
Posts: n/a
Post


Code:
rpm -qa |grep compiz
  #15  
Old 17th July 2009, 10:40 PM
phoenixpb Offline
Registered User
 
Join Date: Mar 2009
Location: France & Québec
Posts: 173
FC12 and nvidia

Quote:
Originally Posted by leigh123linux View Post
Post


Code:
rpm -qa |grep compiz
[root@localhost Phoenix]# rpm -qa |grep compiz
compiz-kde-0.8.2-6.fc12.i586
compiz-fusion-extras-0.8.2-1.fc12.i586
compizconfig-python-0.7.8-3.fc11.i586
compiz-manager-0.6.0-9.fc11.noarch
compiz-fusion-0.8.2-3.fc12.i586
compizconfig-backend-kconfig-0.7.8-2.fc11.i586
compiz-0.8.2-6.fc12.i586
compiz-bcop-0.8.2-1.fc12.noarch
libcompizconfig-0.7.8-3.fc11.i586

humm do i have to update compizconfig-python ?
__________________
Phoenix. Linux User number 495894

Fedora 21 alpha gnome 3.13
yum update junky
 

Tags
fc12, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
compiz fc12 no window decorations... Camberwell Fedora 12 Alpha, Beta & Release Candidates 3 14th October 2009 12:39 PM
FC12 sound is broken phoenixpb Fedora 12 Alpha, Beta & Release Candidates 21 9th September 2009 09:52 PM
FC12 and rpmfusion free phoenixpb Fedora 12 Alpha, Beta & Release Candidates 2 3rd August 2009 05:41 AM
fc12 rc2 livecd unresolved package dependency on kernel-firmware steverino2 Fedora 12 Alpha, Beta & Release Candidates 4 9th July 2009 10:31 PM
New fc12 kernel (2.6.31) has broken VirtualBox typerlc Fedora 12 Alpha, Beta & Release Candidates 4 22nd June 2009 08:18 AM


Current GMT-time: 01:25 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Wancheng Instagram Photos - Glazov Travel Photos - Premia de Mar Travel Photos