Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Servers & Networking
FedoraForum Search

Forgot Password? Join Us!

Servers & Networking Discuss any Fedora server problems and Networking issues such as dhcp, IP numbers, wlan, modems, etc.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 5th July 2009, 03:46 PM
Reworker7 Offline
Registered User
 
Join Date: Jul 2009
Posts: 1
WLAN frequently disconnects with kernel: iwlagn: Microcode SW error detected

I've been using Fedora on the same notebook (HP8710w) since the release of Fedora 9 without any issues. However, now my WLAN frequently disconnects with the message:

kernel: iwlagn: Microcode SW error detected. Restarting 0x2000000. I'm using the 2.6.29.5-191.fc11x86_64 kernel. I experienced no problems under Fedora 9 or 10 with the WLAN - it was very reliable. My WLAN adapter is the Intel 4965AGN, which I use in conjunction with an Edimax router.

ifconfig:

wlan0 Link encap:Ethernet HWaddr 00:21:5C:2F:1A:E5
inet addr:192.168.2.101 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::221:5cff:fe2f:1ae5/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:3900921 errors:0 dropped:0 overruns:0 frame:0
TX packets:3159053 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3857657556 (3.5 GiB) TX bytes:739452534 (705.1 MiB)

iwconfig:

wlan0 IEEE 802.11abgn ESSID:"XXXXX"
Mode:Managed Frequency:2.447 GHz Access Point: 00:1F:1F:1D:04:70
Bit Rate=60 Mb/s Tx-Power=15 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality=100/100 Signal level:-38 dBm Noise level=-90 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Any suggestions for what might be the problem here? Sometimes I can get three or four disconnects in one hour, other times it might be fine for an entire afternoon. There does not appear to be a "trigger" mechanism. Thanks in advance for any help or suggestions.
Reply With Quote
  #2  
Old 20th July 2009, 05:03 AM
tkalfaoglu Offline
Registered User
 
Join Date: Oct 2007
Posts: 300
+1
I have been suffering from the same thing since Fedora 11 upgrade.
I found that rmmod iwlagn && modprobe iwlagn cures it.
However, this also has a "feature" of completely crashing the machine every forth time.
It only happens at full blast - that is, if I copy something > 50 MB from another PC on the LAN..

-turgut
Reply With Quote
  #3  
Old 13th August 2009, 07:10 PM
dca Offline
Registered User
 
Join Date: Aug 2006
Location: /home/dca
Posts: 70
linuxfedorafirefox
I, too, am getting this... Can anyone verify if it has something to do with associating an AP by clicking on 'Edit Connections' and manually adding a wireless network and all info or does the problem happen when clicking on avail AP and then inputting connection info or it doesn't matter, either way causes same result...
__________________
Linux Registered User# 419773
"It Is What It Is"
Reply With Quote
  #4  
Old 23rd August 2009, 01:48 PM
malikons Offline
Registered User
 
Join Date: Aug 2009
Posts: 6
linuxfedorafirefox
same problem

I am seeing exactly the same issue but couldn't figure out the problem from googling. I am running F11 on HP6910p for over a month and was stable. All of a sudden, my wlan started acting up and I have no clue what caused it. I sorta hate these long list of updates every other day but I believe they are somewhat important but they tend to mess up your otherwise fine working OS.

Anyway, coming from Red Hat Enterprise world, I don't think I'll stick to this flaky OS for a long time. I must admit, it works perfectly for everything else but the wireless part. Here is the error message is see:

iwlagn: Microcode SW error detected. Restarting 0x82000000

Not just this, I do now see a lot of other errors too, such as:

wpa_supplicant[1907]: segfault at 900004f ip 0807f9fa sp bf994780 error 4 in wpa_supplicant[8048000+61000]

mac80211-phy0: failed to remove key (0, 00:24:fe:00:b2:96) from hardware (-22)

I have tried almost everything I found on Internet to fix this but nothing worked. One guy has a suggestion to decrease the power of Wifi since he thinks it might be related to over heating of Wireless NIC and that worked for him but not me. The other recommended using rawhide kernel but others trying to do the same screwed their OS, so I won't follow those instructions. My laptop is little more than a fun laptop and it is critical for me to stay up and running with no connectivity issues.

Hope Fedora will come up with a solution sooner than later. If anyone else has a solution, please post here.

Thanks.
Reply With Quote
  #5  
Old 31st August 2009, 11:42 AM
tkalfaoglu Offline
Registered User
 
Join Date: Oct 2007
Posts: 300
linuxfedorafirefox
No solution still? The issue is still going on..
Reply With Quote
  #6  
Old 1st September 2009, 10:21 PM
tkalfaoglu Offline
Registered User
 
Join Date: Oct 2007
Posts: 300
linuxfedorafirefox
This problem seems to be from the temperature of the wifi chip..
You can see the temperature by using:
# cat /sys/bus/pci/drivers/iwlagn/0000\:06\:00.0/temperature

if there is heavy usage, the temp goes up. Over 60, my wifi gets a SW error.
To keep it cool, two things seem to work:

# iwconfig wlan0 power on
and:
# echo 8 > /sys/bus/pci/drivers/iwlagn/0000\:06\:00.0/power_level

Try and see if these help. Note that these are contradictory: power on allows the system to change the card's output level,
and echo 8 > .. command actually sets the power output to its lowest setting. So, do the iwconfig thing first, if it still hangs,
turn off power management with iwconfig wlan0 power off, then try the second command (the echo).

I just downloaded a 700MB file using this, and I kept a close eye on the temperature.. It went up to 59 and then came down. Also try lifting up the laptop to give it more air..

PS: At any time you can see the power level using:
cat /sys/bus/pci/drivers/iwlagn/0000\:06\:00.0/power_level

The highest (hottest) index value is 0, lowest seems to be 8.

-turgut

Last edited by tkalfaoglu; 1st September 2009 at 10:30 PM.
Reply With Quote
  #7  
Old 1st September 2009, 10:36 PM
tkalfaoglu Offline
Registered User
 
Join Date: Oct 2007
Posts: 300
linuxfedorafirefox
I just downloaded several more large files -- no crashes
I just set it to
iwconfig wlan0 power on

and I believe it set its power output to 3, instead of its default 0 (max power).

PS: I also have:

# more /etc/modprobe.d/local.conf
options iwlagn swcrypto50=1

I dont know if that helps or not.

-turgut

Last edited by tkalfaoglu; 2nd September 2009 at 05:51 AM.
Reply With Quote
  #8  
Old 2nd September 2009, 05:50 AM
tkalfaoglu Offline
Registered User
 
Join Date: Oct 2007
Posts: 300
linuxfedorafirefox
it also seems that if I use gnome to do the download, I crash more often!
If I use command line FTP, it seems more resilient..
-turgut
Reply With Quote
  #9  
Old 2nd September 2009, 01:05 PM
malikons Offline
Registered User
 
Join Date: Aug 2009
Posts: 6
linuxfedorafirefox
Transmission is the cause?

With me, it only happens as soon as I fire up Transmission and start downloading some torrent. Is this some crazy anti-piracy tactic from Fedora

I've tried downloading other files using different protocols with the rate up to 1MB/s but my wireless remained connected. Any clue what Transmission might be doing? I'll try some other torrent app and see if I continue to experience the same.

Thanks
Reply With Quote
  #10  
Old 2nd September 2009, 01:34 PM
malikons Offline
Registered User
 
Join Date: Aug 2009
Posts: 6
linuxfedorafirefox
Thanks for the other suggestions of changing the power_level and keeping an eye on temperature. my /sys/bus/pci/drivers/iwlagn/0000\:10\:00.0/temperature give the reading of 341. Any clue how to convert it to a more understandable metric?

I use docking station so my laptop is always lifted from the ground. I never use it on my lap so it

Cheers,
Reply With Quote
  #11  
Old 19th December 2009, 03:26 PM
Szpak Offline
Registered User
 
Join Date: Mar 2004
Location: Poland
Posts: 106
linuxfedorafirefox
You could also check a workaround from bugzilla:
https://bugzilla.redhat.com/show_bug.cgi?id=519154#c11

it seems to work as well.

Note, a file has to named options.conf (instead of options) to not be ignored.

Marcin
__________________
timeoff.wsisiz.edu.pl/rpms.html - Various RPM packages for Fedora Core
solidsoft.wordpress.com - Solid Soft - Working code is not enough
Reply With Quote
Reply

Tags
detected, disconnects, error, frequently, iwlagn, kernel, microcode, wlan

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
intel 5300 wireless - iwlagn driver - and general quesiton about kernel modules sulimir Hardware & Laptops 5 8th October 2009 10:42 PM
Fedora 9 freezes (kernel lockup) frequently Vetal Using Fedora 3 24th September 2008 06:55 AM
While Activating WLan I get error that kernel has crashed in Fedora 9 techman2006 Hardware & Laptops 0 4th June 2008 06:29 AM
No WLAN detected on Compaq C702TU buknoii Servers & Networking 3 23rd December 2007 10:16 AM
All kernel above 2133 disconnects randomly from DSL internet connection rantanplan Servers & Networking 10 31st July 2006 05:36 PM


Current GMT-time: 01:35 (Saturday, 23-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat