Fedora Linux Support Community & Resources Center
  #1  
Old 22nd September 2004, 09:20 PM
wseberger Offline
Registered User
 
Join Date: Sep 2004
Location: Tucson, Arizona, USA
Age: 33
Posts: 12
Photographer Needs Help

Hello,

I'm new to the forum, and an advanced novice (I'd like to think) using Fedora Core 1 on my Compaq Armada M700 notebook.

Professionally, I'm a photojournalist. I switched my laptop from WinXP to FC1 because I was tired of everyone using my laptop at different news/sports events. I figured linux would scare them off.

So enough with the stories.

I am in a bit of a pinch here. I need to get FC1 to recognize and mount a USB card reader. Not one of the fancy x-in-1 card readers, but a simple usb CompactFlash card reader. I haven't purchased one yet, but I was messing around with the one at work last night.

It seems to me that the kernel detects the card reader, but somehow it never makes it to the desktop. Some people have suggested going over to Mandrake (or back to Windows) because the usb support is better in both.

Do you have any ideas how I can make a card reader work in Linux? It needs to be hot-pluggable too; well, I at least don't want to have to reboot between card uploads.

Thank you all,

Will Seberger
Reply With Quote
  #2  
Old 22nd September 2004, 09:29 PM
Optimistic Offline
Registered User
 
Join Date: Jun 2004
Location: Missouri
Age: 37
Posts: 196
It shouldn't be a problem (at least it is not a problem with FC2). I added a line like this to my etc/fstab file:

Code:
/dev/sda1          /mnt/usb/          vfat          noauto,users,rw    0  0
So now when I plug in a usb device I just open the /mnt/usb folder and the device gets mounted automatically. This one line has worked with: my camera (compact flash), two different jumpdrives, an external hard drive, and a mp3 player.

So, I would guess that everythinig will go just fine.
__________________
" I mean, say what you want about the tenets of National Socialism, at least it's an ethos." Walter
Reply With Quote
  #3  
Old 22nd September 2004, 09:53 PM
wseberger Offline
Registered User
 
Join Date: Sep 2004
Location: Tucson, Arizona, USA
Age: 33
Posts: 12
Thanks

I haven't gotten a chance to try it yet, but I appreciate your help with this problem. Thanks for the plain-english response!
Reply With Quote
  #4  
Old 22nd September 2004, 09:56 PM
wseberger Offline
Registered User
 
Join Date: Sep 2004
Location: Tucson, Arizona, USA
Age: 33
Posts: 12
I leapt before I looked. When I look at my fstab, I see other devices there, and I'm not sure of the syntax for adding another one. Does it go at the bottom, and does it need a 'default' tag?
Reply With Quote
  #5  
Old 22nd September 2004, 09:57 PM
CrystalCowboy Offline
Registered User
 
Join Date: Sep 2004
Posts: 539
You can tell if the system is recognizing the presence of the device like this:
cat /proc/scsi/scsi
Here's what that file looks like when it sees my digital camera:

Attached devices:
Host: scsi4 Channel: 00 Id: 00 Lun: 00
Vendor: OLYMPUS Model: X200,D560Z,C350Z Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 02

If the device is recognized properly it should be available for mounting as described by Optimistic.
__________________
Explore the Core!
Reply With Quote
  #6  
Old 22nd September 2004, 09:58 PM
wseberger Offline
Registered User
 
Join Date: Sep 2004
Location: Tucson, Arizona, USA
Age: 33
Posts: 12
here's my fstab now. does this look right?

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
defaults 0 0
/dev/sda1 /mnt/usb vfat
noauto,users,rw 0 0
Reply With Quote
  #7  
Old 22nd September 2004, 10:03 PM
CrystalCowboy Offline
Registered User
 
Join Date: Sep 2004
Posts: 539
Quote:
Originally Posted by wseberger
I leapt before I looked. When I look at my fstab, I see other devices there, and I'm not sure of the syntax for adding another one. Does it go at the bottom, and does it need a 'default' tag?
It should be a separate line. The order of lines does not matter. You can space it off from the more permanent devices by adding a comment line, starting with #
The noauto,users,rw would replace the defaults.
noauto means it doesn't try to mount the device at boot time (when it may not be present)
users indicates that any user, not just root, can mount the device.
rw meand read & write, as opposed to ro, which would be read-only.
I don't off-hand know what the default settings would be, if you're curious you could read the man page on fstab.
__________________
Explore the Core!
Reply With Quote
  #8  
Old 22nd September 2004, 10:04 PM
CrystalCowboy Offline
Registered User
 
Join Date: Sep 2004
Posts: 539
Quote:
Originally Posted by wseberger
here's my fstab now. does this look right?

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
defaults 0 0
/dev/sda1 /mnt/usb vfat
noauto,users,rw 0 0
I hope those line wraps in the last two entries are just on the forum, not in your fstab file! The entry for each device is a single line.
__________________
Explore the Core!
Reply With Quote
  #9  
Old 22nd September 2004, 10:40 PM
wseberger Offline
Registered User
 
Join Date: Sep 2004
Location: Tucson, Arizona, USA
Age: 33
Posts: 12
Thanks for the tip, Cowboy. I had the entries on 2 lines, and the kernel hated it. Boooooo. Now I have a USB option in the (right-click) disks menu on the desktop. I'm going to head over to work and play some usb devices to make sure that it works.

Additionally, I have a USB cd-burner. What do you think the odds are that it will work now?

Thanks a million!

Will Seberger
Reply With Quote
  #10  
Old 22nd September 2004, 10:55 PM
CrystalCowboy Offline
Registered User
 
Join Date: Sep 2004
Posts: 539
Quote:
Originally Posted by wseberger
Additionally, I have a USB cd-burner. What do you think the odds are that it will work now?
Under FC1? I should think the odds are good. Under FC2 with the 2.6.8.1 kernel you have to be root to burn anything, but as far as I know FC1 is OK.
__________________
Explore the Core!
Reply With Quote
  #11  
Old 22nd September 2004, 11:52 PM
wseberger Offline
Registered User
 
Join Date: Sep 2004
Location: Tucson, Arizona, USA
Age: 33
Posts: 12
ok, so I plugged in the USB cardreader and it hit the hdd, but when I try to mount the card, I get an error saying "mount: mount point /mnt/usb does not exist"

here's my current fstab

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/sda1 /mnt/usb vfat noauto,users,rw 0 0

any ideas?
Reply With Quote
  #12  
Old 22nd September 2004, 11:59 PM
wseberger Offline
Registered User
 
Join Date: Sep 2004
Location: Tucson, Arizona, USA
Age: 33
Posts: 12
here's something else that might help

[root@dhcp-80c442e1 will]# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: Generic Model: STORAGE DEVICE Rev: 0119
Type: Direct-Access ANSI SCSI revision: 02

Additionally, the computer has been rebooted since I modified the Fstab.

Thanks!
Reply With Quote
  #13  
Old 23rd September 2004, 12:05 AM
Optimistic Offline
Registered User
 
Join Date: Jun 2004
Location: Missouri
Age: 37
Posts: 196
Quote:
Originally Posted by wseberger
ok, so I plugged in the USB cardreader and it hit the hdd, but when I try to mount the card, I get an error saying "mount: mount point /mnt/usb does not exist"

any ideas?
Sure thing:
Code:
mkdir /mnt/usb
Sorry, I should have said that before. You have to make the directory.
__________________
" I mean, say what you want about the tenets of National Socialism, at least it's an ethos." Walter
Reply With Quote
  #14  
Old 23rd September 2004, 12:10 AM
wseberger Offline
Registered User
 
Join Date: Sep 2004
Location: Tucson, Arizona, USA
Age: 33
Posts: 12
You guys kick a** . If I can help you with anything (probably non-linux related, but who knows) please shoot me an email!

it was the mkdir that made it all work.

thanks again

Will Seberger
Reply With Quote
  #15  
Old 23rd September 2004, 12:14 AM
imdeemvp Offline
Registered User
 
Join Date: Feb 2004
Age: 46
Posts: 8,256
i dont know if this helps: http://www.fedoraforum.org/forum/showthread.php?t=1291
__________________
HELP with JAVA, MP3's, Wireless, Repo's, YUM, Partitions, System Monitors, Nvidia, ATI drivers, LIMEWIRE PRO & MORE!.

Easiest and most friendly desktop ever is PCLinuxOS! Includes all this apps. Just try it.

"The greater the struggle THE greater the achievment."

Do you know HIM?

If you are an idiot click here. NThis will test you linux skills :D
Reply With Quote
Reply

Tags
photographer

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Current GMT-time: 12:14 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Little Rock Instagram Photos - Himatnagar - Samsun