Fedora Linux Support Community & Resources Center
  #1  
Old 24th June 2009, 07:12 PM
blazemore Offline
Registered User
 
Join Date: Jun 2009
Posts: 4
Black screen after bootup with Catalyst driver

Hi all

I just installed the latest Catalyst driver for my Radeon 4800 from the AMD/Ati website.
Now when I boot, after the blue bar, it goes to a black screen, with my monitor light flashing (which means no signal is being sent)

At first I thought it was a simple resolution problem, but now I noticed my keyboard status lights aren't responding.
I can't Ctrl+Alt my way into a different display to run any commands.

Any ideas?
Reply With Quote
  #2  
Old 24th June 2009, 07:32 PM
blazemore Offline
Registered User
 
Join Date: Jun 2009
Posts: 4
Okay new approach.

I'm reinstalling Fedora 11 (KDE btw)

How should I install the driver to make sure this doesn't happen again?
Reply With Quote
  #3  
Old 24th June 2009, 07:34 PM
Oakems Offline
Registered User
 
Join Date: Nov 2008
Location: London
Age: 31
Posts: 157
You should be able to boot into run level 3 (you do this by adding a 3 to the end of the kernel line before booting).

From there, if you login as root and type "system-config-display --reconfig" this will hopefully let you choose your monitor type and reconfigure your X settings for you. Then it's as simple as logging out, logging into your user account and typing "startx"

I don't know why that driver won't work for you, and I'm not sure how to fix that, but you should be able to get X back.
Reply With Quote
  #4  
Old 21st January 2010, 01:33 PM
Journeyman 7 Offline
Registered User
 
Join Date: Jun 2007
Posts: 10
linuxfirefox
Hi, I had this exact same problem with the Catalyst driver for my Radeon X850 XT, but I definitely didn't want to reinstall FC11 so I followed Oakems lead but with a few minor changes i.e. Boot into Runlevel 3 but sign in with your normal user ID then change to SU and type "system-config-display --reconfig" you will likely find you are unable to change the monitor, but if you change the Radeon to a Generic Vesa Card and the resolution to your default desktop setting then click OK you should see a message saying that the xorg.conf file has been changed and the old one backed up. Now if you type exit to get out of SU mode and then type startx (keep your fingers crossed) and hopefully Fedora will start your normal user session. I was afraid I might get totally locked out if I persisted with the Catalyst Driver so I used Yumex to list all of the Catalyst files on the system (Kernel Modules, X11files and the Driver) and I removed the whole lot then rebooted and I was very glad when it did.
There seems to be some problem with the compatibility of Rad X850 XT and the newer X11 files, I use KDE by the way.
Reply With Quote
  #5  
Old 21st January 2010, 01:36 PM
blazemore Offline
Registered User
 
Join Date: Jun 2009
Posts: 4
linuxfirefox
Nope

I'm using Linux Mint 8 KDE now, and it's brilliant.
Nothing crashed, everything works out the box and it's super fast.

Fedora devs could learn a lot.
Reply With Quote
  #6  
Old 21st January 2010, 03:21 PM
Oakems Offline
Registered User
 
Join Date: Nov 2008
Location: London
Age: 31
Posts: 157
linuxfirefox
I'm glad you sorted. I had problems once on a different thread, trying to explain that "system-config-display --reconfig" will actually work outside of X. I kept getting told, "No, because I haven't got x started so it won't work because it is a graphical interface." Sigh, okay then.
Reply With Quote
Reply

Tags
blank screen, boot, graphics

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Black screen after Fedora 10 bootup JBmtk Hardware & Laptops 16 26th February 2009 09:40 PM
[Fedora 10] Black Screen After Catalyst install Iska Hardware & Laptops 1 11th January 2009 07:04 PM
f7 black screen on bootup - xwindows problem 105547111 Installation, Upgrades and Live Media 2 6th June 2007 03:58 AM
Red dots, black screen on bootup Seph2409 Using Fedora 1 7th April 2007 08:47 PM
Black screen on bootup Opettaja Installation, Upgrades and Live Media 5 3rd September 2004 12:17 PM


Current GMT-time: 16:19 (Thursday, 18-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Havana Beach - Codelco Andina Photos - Texas Center for Athletes