Fedora Linux Support Community & Resources Center
  #1  
Old 23rd June 2009, 03:17 AM
typerlc Offline
Registered User
 
Join Date: Apr 2009
Posts: 109
many X drivers broken in Xorg 1.6.99

Since the recent X upgrade in FC12, I can't run the nouveau or nv drivers. I haven't tried the nvidia driver yet.

The symptoms are that the screen just goes black, and the keyboard doesn't respond. There's no mouse pointer. ctrl-alt-bkspc and ctrl-alt-del do nothing. The kernel hasn't crashed because the soft-power button shuts the machine down cleanly.

Running X from the command line (i.e. just the server, no desktop or other clients) has the same problem. Even X -probeonly crashes in the same way. If I run X -showopts, these failed drivers display the following error:

Code:
X.Org X Server 1.6.99.1
Release Date: (unreleased)
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-128.1.6.el5xen i686
Current Operating System: Linux mondo 2.6.31-0.17.rc0.git15.fc12.i686.PAE #1 SMP Sat Jun 20 17:45:02 EDT 2009 i686
Kernel command line: ro root=/dev/mapper/vg_mondo-lv_root rhgb quiet
Build Date: 19 June 2009  03:20:44AM
Build ID: xorg-x11-server 1.6.99-2.20090618.fc12
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun 23 11:59:17 2009
X: symbol lookup error: /usr/lib/xorg/modules/drivers/nouveau_drv.so: undefined symbol: LoaderRefSymLists
The only driver that seems to work is the vesa driver.

Also with this version of X, my keyboard keeps beeping i.e. many keys cause the internal PC speaker to beep. This doesn't happen from the console.

Anyone else see these sorts of issues?
  #2  
Old 23rd June 2009, 05:10 AM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
Yeah, same here with an Intel card.

I hadn't even tried vesa.

The best place to get help for this one is probably the Fedora testing list. I've been quite busy this last week or so--I haven't even been reading the posts---I did see a few with titles like Rawhide hosed the system, and wondered what would happen if I updated. Well, now I know. :-(

I'm not even getting any errors in my X logs--the system seems to freeze, though I can reach it through ssh. I can, from the ssh session, supposedly kill X, but the screen remains frozen. After that I am able to shut it down from the ssh session. However, from the local machine itself, all I can do is a hard shutdown by holding the power button.

So, I don't think it's the noveau driver, since as I said, it's affection me with a cheap onboard Intel card.
__________________
--
http://home.roadrunner.com/~computertaijutsu

Do NOT PM forum members with requests for technical support. Ask your questions on the forum.


"I don't know why there is the constant push to break any semblance of compatibility" --anon
  #3  
Old 23rd June 2009, 05:57 AM
typerlc Offline
Registered User
 
Join Date: Apr 2009
Posts: 109
Yeah, it's not just the nouveau driver, but pretty much all of them except vesa.

I have just finished installing the nvidia proprietary driver, and it is working fine. But I guess that doesn't help you, sorry

The keyboard beeps are annoying though! I'll have to look at that next!

Richard
  #4  
Old 20th July 2009, 04:11 PM
kuroitenshi Offline
Registered User
 
Join Date: Jul 2009
Posts: 1
you can get rid of the system beep this way :

# sudo rmmod pcspkr

# sudo vim /etc/modprobe.d/blacklist.conf

Add the following:
blacklist pcspkr

the last bit makes sure the pesky thing doesn't come back during next boot.

But I stumbled upon broken Xorg drivers on a laptop. I have tried reinstalling all packages that Xorg uses / need but still no luck.
Code:
  (EE) FBDEV(0): FBIOPUT_VSCREENINFO: Invalid argument
(EE) FBDEV(0): mode initialization failed

Fatal server error:
AddScreen/ScreenInit failed for driver 0
Ok. I feel kind of embarrassed. Installed old Kernel again and with that my laptop works
Code:
Linux raputoppu.max 2.6.29.5-191.fc11.i686.PAE #1 SMP Tue Jun 16 23:19:53 EDT 2009 i686 i686 i386 GNU/Linux
So the problem isn't Xorg. It is the Kernel which needs some work. (: When I get home I will compile my own 2.6.31 kernel.

Last edited by kuroitenshi; 20th July 2009 at 04:52 PM. Reason: Adding error from startx and small discovery
  #5  
Old 21st July 2009, 12:12 AM
SlowJet Offline
Registered User
 
Join Date: Jan 2005
Posts: 5,048
My rawhide xorg/gnome is working with all the updates for those using the nouveau drv.

Kernel 31-0.76.rc3

I needed to use
nomodeset rhgb quiet
on the kernel boot line
(that has been there awhile, don't remember putting it there, but I remove it after selinux-policy crash.)

and

I had to rm the /etc/X11/xorg.conf file that was created when I got an bad boot up.

There are a few rpms on koji like gnome-session xsession gdm libXlander that may help also.

My issues are the latest selinux-policy rpm barffed on update.
gnome-settings-daemon and gnome-volume-co are in a cpu fight with each other and need to be killed each boot.
And polkit (policykit) is blocking many functions.
Otherwise it works ok.

SJ
__________________
Do the Math
  #6  
Old 21st July 2009, 03:30 AM
SlowJet Offline
Registered User
 
Join Date: Jan 2005
Posts: 5,048
kernel-2.6.31-0.81.rc3.git4.fc12.i686.PAE
now it doesn't want the nomodeset, to boot, again.
And the change was about frame buffer.

SJ
__________________
Do the Math
 

Tags
broken, drivers, xorg

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg-x11-apps broken iancshay Using Fedora 0 18th September 2009 01:47 PM
Beryl broken afteer xorg-x11-server-Xorg update bowens44 Using Fedora 5 10th June 2007 07:01 PM


Current GMT-time: 13:22 (Sunday, 20-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat