Fedora Linux Support Community & Resources Center
  #1  
Old 22nd June 2009, 11:02 AM
joycesavio Offline
Registered User
 
Join Date: Jun 2009
Posts: 13
Question Yum not working after upgrade from FC10 to FC11

Hi,

I've been running FC10 with all updates and had downloaded the FC11 DVD. Yesterday I upgraded to FC 11 using the DVD and it appeared that everything went fine. However when I tried to do a
yum update
I got the following error.
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

No module named yum

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6 (r26:66714, Mar 17 2009, 11:44:14)
[GCC 4.4.0 20090313 (Red Hat 4.4.0-0.26)]

If you cannot solve this problem yourself, please go to
the yum faq at:
http://wiki.linux.duke.edu/YumFaq
I'm not sure what to do next. I also noticed that all my previously configured repositories are lost.

I'd appreciate any help/ideas/pointers on this. Thanks.

Cheers
Savio
Reply With Quote
  #2  
Old 22nd June 2009, 11:55 AM
glennzo Offline
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,805
Check out this thread, http://forums.fedoraforum.org/showthread.php?t=224308. Post #15, I think Deb has offered a workable solution.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #3  
Old 22nd June 2009, 12:17 PM
joycesavio Offline
Registered User
 
Join Date: Jun 2009
Posts: 13
Hi Glenn,
Thanks a lot for that quick reply. That seemed to have fixed it.
I'm doing a yum update now and it appears to have picked up all the relevant repos.
Cheers.
Savio
Reply With Quote
  #4  
Old 22nd June 2009, 12:24 PM
glennzo Offline
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,805
Glad that it worked Savio, but I only take credit for pointing you to the relevant information. Deb gets the credit for the solution
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Just a couple of old single core units
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / Kingston HyperX 3K SSD 240GB SATA 3.0 / 1TB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
Reply

Tags
fc10, fc11, upgrade, working, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
After Upd FC10 to FC11 Yum not working Turbo13 Using Fedora 1 12th October 2009 08:57 AM
Firefox crashes after FC11 upgrade from FC10 CurtAshendel Using Fedora 1 22nd June 2009 10:55 PM
Upgrade from FC10 x64 to FC11 x64 - Grub Error falc410 Installation, Upgrades and Live Media 0 16th June 2009 03:49 PM
Upgrade from FC10 to FC11 - Cannot browse internet johndubchak Installation, Upgrades and Live Media 9 16th June 2009 05:53 AM
Upgrade to FC11 from FC10 jpm_power Using Fedora 2 14th May 2009 09:35 PM


Current GMT-time: 08:01 (Monday, 24-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Phibun Mangsahan Instagram Photos - Herowabad Travel Photos on Instagram - Maner Photos on Instagram