Fedora Linux Support Community & Resources Center
  #1  
Old 15th June 2009, 11:41 AM
panathcypan Offline
Registered User
 
Join Date: Apr 2009
Location: Cyprus
Posts: 16
Local file conflict between packages

I am trying to install gstreamer-plugins but an error occured.

Test Transaction Errors: file /usr/lib64/gstreamer-0.10/libgstdeinterlace.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.x86_64 conflicts with file from package gstreamer-plugins-good-0.10.15-1.fc11.x86_64
file /usr/lib64/gstreamer-0.10/libgstflv.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.x86_64 conflicts with file from package gstreamer-plugins-good-0.10.15-1.fc11.x86_64
file /usr/lib64/gstreamer-0.10/libgsty4menc.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.x86_64 conflicts with file from package gstreamer-plugins-good-0.10.15-1.fc11.x86_64
Reply With Quote
  #2  
Old 15th June 2009, 11:57 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,623
I don't see gstreamer-plugins-good-0.10.15-1.fc11.x86_64 as being part of the normal repos. If the computer were mine I would remove it and try installing plugins-bad again.
Code:
sudo yum remove gstreamer-plugins-good
sudo yum install gstreamer-plugins-bad
sudo yum install gstreamer-plugins-good
0.10.15-1.fc11.x86_64 is from updates-testing. You may have some repos enabled that shouldn't be enabled.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB

Last edited by glennzo; 15th June 2009 at 11:59 AM.
Reply With Quote
  #3  
Old 15th June 2009, 01:15 PM
panathcypan Offline
Registered User
 
Join Date: Apr 2009
Location: Cyprus
Posts: 16
Quote:
Originally Posted by glennzo View Post
I don't see gstreamer-plugins-good-0.10.15-1.fc11.x86_64 as being part of the normal repos. If the computer were mine I would remove it and try installing plugins-bad again.
Code:
sudo yum remove gstreamer-plugins-good
sudo yum install gstreamer-plugins-bad
sudo yum install gstreamer-plugins-good
Did not work

Enabled repos:
Fedora 11 - x86_64
Fedora 11 - x86_64 - Updates
RPM Fusion for Fedora 11 - Free
RPM Fusion for Fedora 11 - Free - Updates
RPM Fusion for Fedora 11 - Nonfree
RPM Fusion for Fedora 11 - Nonfree - Updates
Reply With Quote
  #4  
Old 15th June 2009, 01:20 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,623
Where did you run into trouble with the commands I suggested?

I may not reply right away. I'm off to work soon.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #5  
Old 15th June 2009, 01:27 PM
panathcypan Offline
Registered User
 
Join Date: Apr 2009
Location: Cyprus
Posts: 16
Quote:
Originally Posted by glennzo View Post
Where did you run into trouble with the commands I suggested?

I may not reply right away. I'm off to work soon.
i run the commands with no problems but when i am trying to execute a .asx file i get an error for missing plugin (gstreamer-plugins) and an option to install it.When i try to install it i get the following:

Test Transaction Errors: file /usr/lib64/gstreamer-0.10/libgstdeinterlace.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.x86_64 conflicts with file from package gstreamer-plugins-good-0.10.15-1.fc11.x86_64
file /usr/lib64/gstreamer-0.10/libgstflv.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.x86_64 conflicts with file from package gstreamer-plugins-good-0.10.15-1.fc11.x86_64
file /usr/lib64/gstreamer-0.10/libgsty4menc.so from install of gstreamer-plugins-bad-0.10.11-4.fc11.x86_64 conflicts with file from package gstreamer-plugins-good-0.10.15-1.fc11.x86_64
Reply With Quote
  #6  
Old 15th June 2009, 01:29 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Age: 57
Posts: 14,623
Then the problem is with the .asx file and not gstreamer.
__________________
Glenn
The Bassinator © ®

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #7  
Old 15th June 2009, 01:39 PM
panathcypan Offline
Registered User
 
Join Date: Apr 2009
Location: Cyprus
Posts: 16
Quote:
Originally Posted by glennzo View Post
Then the problem is with the .asx file and not gstreamer.
i am afraid its not the asx file.Thanks anyway
Reply With Quote
  #8  
Old 16th June 2009, 12:48 PM
undertoad Offline
Registered User
 
Join Date: May 2005
Posts: 36
I ran into the same problem but on x86 (not x86_64)
Transaction Check Error:
file /usr/lib/gstreamer-0.10/libgstdeinterlace.so from install of gstreamer-plugins-good-0.10.15-1.fc11.i586 conflicts with file from package gstreamer-plugins-bad-0.10.11-4.fc11.i586
file /usr/lib/gstreamer-0.10/libgstflv.so from install of gstreamer-plugins-good-0.10.15-1.fc11.i586 conflicts with file from package gstreamer-plugins-bad-0.10.11-4.fc11.i586
file /usr/lib/gstreamer-0.10/libgsty4menc.so from install of gstreamer-plugins-good-0.10.15-1.fc11.i586 conflicts with file from package gstreamer-plugins-bad-0.10.11-4.fc11.i586

Did a google, came up with rpmfusion bugzilla https://bugzilla.rpmfusion.org/show_bug.cgi?id=622 there is an update in rpmfusion-free-updates-testing repo, so this worked for me
Code:
yum update --enablerepo=rpmfusion-free-updates-testing gstreamer-plugins-bad
* I haven't tried to do anything since the update ran.
Reply With Quote
  #9  
Old 16th June 2009, 08:04 PM
Dark Dragoon Offline
Registered User
 
Join Date: May 2008
Location: UK
Posts: 32
I have the same problem, well it was the opposite way round.

Today when an update for gstreamer-plugins-good was released it would not install due to the transaction check error, where gstreamer-plugins-bad conflicts with it. This is on x86.

I removed gstreamer-plugins-bad and fully updated the system, I now want to try and reinstall it. I tried enabling rpmfusion-free-updates-testing but it just gives the same error, I had a look at the repository and couldn't see any updates for gstreamer-plugins-bad in it.
Reply With Quote
  #10  
Old 17th June 2009, 10:59 AM
undertoad Offline
Registered User
 
Join Date: May 2005
Posts: 36
The gstreamer-plugins-bad has moved to the updates repo http://download1.rpmfusion.org/free/...dates/11/i386/

Also, there is a fedora-list thread regarding this problem https://www.redhat.com/archives/fedo.../msg01906.html
Reply With Quote
  #11  
Old 31st July 2009, 02:40 PM
wangmaster Offline
Registered User
 
Join Date: Nov 2008
Posts: 145
linuxfedorafirefox
I constantly run into this problem when trying to update using the packagekit GUIs.

Right now I can't install gstreamer-0.10.23.2-1.fc11 because of i586 and x86_64 conflicts.

However, if I drop down to a shell and run yum update, it just works.

Anyone know if there is an overall problem with packagekit and multiarch packages?
Reply With Quote
  #12  
Old 31st July 2009, 04:17 PM
eyklidis Offline
Registered User
 
Join Date: Jul 2008
Posts: 19
linuxfedorafirefox
Hi there
I did faced similar errors while trying to update in graphic mode but in command line it just works ....
I just want to ask maybe it has something to do with delta-rpms as i noticed this after installing presto ....
Maybe a coincidence though i cant really say as i am an not a Pro
Reply With Quote
Reply

Tags
conflict, file, local, packages

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Local conflict between packages virtualman Using Fedora 1 30th October 2009 04:52 PM
Local file conflict between packages paulcscheung Installation, Upgrades and Live Media 4 12th September 2009 09:51 PM
Local conflict between packages (586 and x86_64) bwjpg Using Fedora 5 16th August 2009 07:33 PM
Local File conflict between packages Garethvr Using Fedora 3 19th April 2009 08:36 PM
Local File Conflict. Update erich_18 Using Fedora 5 24th September 2008 12:22 AM


Current GMT-time: 08:26 (Thursday, 24-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat