Fedora Linux Support Community & Resources Center
  #1  
Old 15th June 2009, 01:52 AM
jeffy5 Offline
Registered User
 
Join Date: Oct 2004
Posts: 41
Sound in Fedora 11

Hello,

I have been able to configure sound in Fedora 11 but I realized that I can only use my headset to hear sound. However, I cannot hear anything once I take out the headset from its jack. I have tried everything - adjust the sliders, etc. I have heard some people removing Pulseaudio altogether to get sound working. I thought about doing this but it takes out too many dependencies with it for other devices that I need. Does anyone know how I can get sound through my internal speakers on my laptop. I have a HP Pavilion dv5 with Fedora 11 with the Gnome desktop.
Reply With Quote
  #2  
Old 15th June 2009, 01:56 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,121
Quote:
Originally Posted by jeffy5 View Post
Hello,

I have been able to configure sound in Fedora 11 but I realized that I can only use my headset to hear sound. However, I cannot hear anything once I take out the headset from its jack. I have tried everything - adjust the sliders, etc. I have heard some people removing Pulseaudio altogether to get sound working. I thought about doing this but it takes out too many dependencies with it for other devices that I need. Does anyone know how I can get sound through my internal speakers on my laptop. I have a HP Pavilion dv5 with Fedora 11 with the Gnome desktop.
run alsamixer -c 0 and make sure the proper channels are active (not muted)

another option is running kmix if you have it, and to the menu:

Settings -> Configure channels and activate them there.
Reply With Quote
  #3  
Old 16th June 2009, 08:00 PM
BLooDMaN Offline
Registered User
 
Join Date: Mar 2007
Location: Latvia
Age: 28
Posts: 91
Quote:
Originally Posted by marko View Post
run alsamixer -c 0 and make sure the proper channels are active (not muted)

another option is running kmix if you have it, and to the menu:

Settings -> Configure channels and activate them there.
Thaaaaanks a lot!
I use Gnome and had problems with sound output to headphones, but after installing kmix and configuring it's ok now. Finally!
Reply With Quote
  #4  
Old 16th June 2009, 11:22 PM
Phantom_Lord Offline
Registered User
 
Join Date: Dec 2007
Location: Sofia, Bulgaria
Posts: 50
To Jeffy 5:

I got the sound working on my hp dv5 by this way:

Quote:
Congratulations andy1126 - you did it!

Ok, as usual - great things are simple - I just changed the options in /etc/modprobe.d/alsa.conf from "options snd-hda-intel index=0 model=hp-m5 position_fix=1" to "options snd-hda-intel model=hp-dv5", removed some of the snd modules from the blacklist.conf and voila - I have sound from speakers!

Thank you very much andy!

I'll post your fix in some related threads, if don't mind.

Regards,
P.L.
Hope will work for you too!

Good luck.

Regards,
P.L.
Reply With Quote
  #5  
Old 17th June 2009, 02:22 AM
jeffy5 Offline
Registered User
 
Join Date: Oct 2004
Posts: 41
Thank You

Hello Phantom Lord,

Thanks for your help. I got my sound going on my HP Pavilion dv5........Thanks a million!
Reply With Quote
  #6  
Old 18th June 2009, 01:57 AM
JoeF Offline
Registered User
 
Join Date: Feb 2007
Location: U.S., Michigan
Posts: 92
"Ok, as usual - great things are simple - I just changed the options in /etc/modprobe.d/alsa.conf from "options snd-hda-intel index=0 model=hp-m5 position_fix=1" to "options snd-hda-intel model=hp-dv5", removed some of the snd modules from the blacklist.conf and voila - I have sound from speakers!"

I have this EXACT same problem but all this you are suggesting to do... I haven't got too much of a clue as to how to do that. I'm still learning the command line references. I have a dv5 and as of reading this thread (jeffy's post), I now know I have sound from the jack but not the speakers. Will you put this in 'step by step' info for me please?

thanks in advance.

JoeF
Reply With Quote
  #7  
Old 18th June 2009, 08:09 AM
Phantom_Lord Offline
Registered User
 
Join Date: Dec 2007
Location: Sofia, Bulgaria
Posts: 50
Hi JoeF.

I saw that you have posted later and in another related thread: http://forums.fedoraforum.org/showth...06#post1228706 but I don't know if you have succeeded to cope with the problem, so I'll simply describe what to do in order to have sound and from the speakers.

First of all - did you try to fix the problem by adding options in /etc/modprobe.d/alsa.base or some other modprobe.d related files? If you have, and they are related to sound - either remove the options or put a comment (#) before them to make them inactive.

NB! THIS IS NOT WORKING!!!
For example - I have first found a decision (maybe from an Ubuntu forum) that suggested creating the file /etc/modprobe.conf and putting inside: options snd-hda-intel enable_msi=1 . Now it looks like:
Code:
 $ cat /etc/modprobe.conf

#options snd-hda-intel enable_msi=1
/END OF NOT WORKING!

After that you have to create (if don't already) the file alsa.conf in the /etc/modprobe.d/ directory. You can do it from the command line by:
Code:
 # touch /etc/modprobe.d/alsa.conf
As you can see - you have to be root to do it, as well as for the file edit that follows (and for the previously mentioned edits too). The next step depends on what you prefer to use for text edit - I usually use vi, but I think gedit might be better sometimes, so I suggest using gedit:
Code:
 # gedit /etc/modprobe.d/alsa.conf &
By the way, if the file is not created by the previous step by clicking on the save button in the gedit menu you will automatically create it, so you could skip step "file creation".
After that - just put in the already opened file (alsa.conf) the following option:
options snd-hda-intel model=hp-dv5
Save & close the file, reboot and you should have sound from the speakers of your dv5.

Good luck and pleasant listening to music .

Regards,
P.L.
Reply With Quote
  #8  
Old 18th June 2009, 01:23 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,121
Quote:
Originally Posted by Phantom_Lord View Post
Hi JoeF.

I saw that you have posted later and in another related thread: http://forums.fedoraforum.org/showth...06#post1228706 but I don't know if you have succeeded to cope with the problem, so I'll simply describe what to do in order to have sound and from the speakers.

First of all - did you try to fix the problem by adding options in /etc/modprobe.d/alsa.base or some other modprobe.d related files? If you have, and they are related to sound - either remove the options or put a comment (#) before them to make them inactive.

NB! THIS IS NOT WORKING!!!
For example - I have first found a decision (maybe from an Ubuntu forum) that suggested creating the file /etc/modprobe.conf and putting inside: options snd-hda-intel enable_msi=1 . Now it looks like:
Code:
 $ cat /etc/modprobe.conf

#options snd-hda-intel enable_msi=1
/END OF NOT WORKING!

After that you have to create (if don't already) the file alsa.conf in the /etc/modprobe.d/ directory. You can do it from the command line by:
Code:
 # touch /etc/modprobe.d/alsa.conf
As you can see - you have to be root to do it, as well as for the file edit that follows (and for the previously mentioned edits too). The next step depends on what you prefer to use for text edit - I usually use vi, but I think gedit might be better sometimes, so I suggest using gedit:
Code:
 # gedit /etc/modprobe.d/alsa.conf &
By the way, if the file is not created by the previous step by clicking on the save button in the gedit menu you will automatically create it, so you could skip step "file creation".
After that - just put in the already opened file (alsa.conf) the following option:
options snd-hda-intel model=hp-dv5
Save & close the file, reboot and you should have sound from the speakers of your dv5.

Good luck and pleasant listening to music .

Regards,
P.L.
The /etc/modprobe.conf file is obsolete, it should not be used in Fedora 11
(in fact if you do the bootup logging will contain complaints about it)
Reply With Quote
  #9  
Old 22nd June 2009, 04:13 PM
eliashickman Offline
Registered User
 
Join Date: Dec 2007
Location: Seoul, South Korea
Age: 39
Posts: 202
Model

@ marko.

How did you get the model number for the /etc/modprobe.d/alsa.conf file?

My soundcard's information is http://www.alsa-project.org/db/?f=03...12aa30779d7932

I also have this problem of only hearing sound out of one speaker.
When I was using Fedora 8 everything was sweet. That's been a while, obviously.
__________________
It does not require a majority to prevail, but rather an irate, tireless minority keen to set brush fires in people’s minds. —Samuel Adams
Reply With Quote
  #10  
Old 23rd June 2009, 06:25 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,121
Quote:
Originally Posted by eliashickman View Post
@ marko.

How did you get the model number for the /etc/modprobe.d/alsa.conf file?

My soundcard's information is http://www.alsa-project.org/db/?f=03...12aa30779d7932

I also have this problem of only hearing sound out of one speaker.
When I was using Fedora 8 everything was sweet. That's been a while, obviously.
I don't have an alsa.conf file in there, it might be a good idea to run the alsamixer command to confirm if a channel is muted or install kmix or whatever mixer gnome has and try the same thing.
Reply With Quote
  #11  
Old 23rd June 2009, 02:23 PM
eliashickman Offline
Registered User
 
Join Date: Dec 2007
Location: Seoul, South Korea
Age: 39
Posts: 202
Thanks. I noticed Fedora was complaining about it when I booted up. So I just removed the file.
I check alsamixer and put everything at max but still there is more sound out of the left speaker than the right.
I compiled my own sound driver and am trying to figure it out but it seems like I'm going to have to just settle for what I have.
__________________
It does not require a majority to prevail, but rather an irate, tireless minority keen to set brush fires in people’s minds. —Samuel Adams
Reply With Quote
  #12  
Old 29th June 2009, 11:03 PM
commonplace Offline
Registered User
 
Join Date: May 2006
Location: Bardstown, KY, USA
Age: 35
Posts: 134
In Fedora 11, what file DO we put the 'options' in? I have a Lenovo IdeaPad Y530. In Ubuntu I had to compile ALSA but then I was able to put "options snd-hda-intel model=lenovo-sky" at the end of my /etc/modprobe.d/alsa-base and that fixed my surround sound issues.

How do I do this in Fedora 11 (x64, if that changes anything)?

/Kevin
Reply With Quote
  #13  
Old 2nd July 2009, 02:31 AM
pmanasranjan Offline
Registered User
 
Join Date: Jul 2009
Posts: 2
No Sound on my HP dv5118tx notebook after installing fedora 11

There is no sound after installing fedora 11 on my HP notebook dv5118tx model. I tried various options but no luck. Even I created the alsa.conf under modprobe.d folder, still no sound.

When I type alsaunmute from the command prompt, I get this message:

Unknown hardware: "HDA-Intel" "Conexant CX20551 (Waikiki)" "HDA:14f15047,103c30a5,00100000" "0x103c" "0x30a5"
Hardware is initialized using a guess method

I am not sure, whether I am missing something or I need to add / remove any package. I would really appreciate if someone can help me out.

--
Manas
Reply With Quote
  #14  
Old 4th July 2009, 10:15 PM
rkline1963 Offline
Registered User
 
Join Date: May 2005
Posts: 7
For anyone whose sound hardware appears to be working but doesn't hear any (or very low volume sound), I have twice after Fedora distro upgrades including to Fedora 11 had this low sound problem. In both cases the side channel had to be increased to get normal sound levels.

I did it via:
alsamixer -c0
Note that the side channel doesn't appear until you right arrow over several times.

The kmix approach noted about probably fixes the problem as well.
Reply With Quote
  #15  
Old 6th July 2009, 03:15 AM
pmanasranjan Offline
Registered User
 
Join Date: Jul 2009
Posts: 2
I tried this from my terminal:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

The output of above scipt is updated in following URL:

http://www.alsa-project.org/db/?f=70...967702855b0ced

Please let me know, if I need to do anything after taking a look the output. Hope this output will give you some solution.

--
Manas
Reply With Quote
Reply

Tags
fedora, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11- Sound fails, but when I run the test. it works -microsoft sound system 80 dericbytes Alpha, Beta & Snapshots Discussions (Fedora 11 Only) 1 21st April 2009 04:48 PM
fedora 8 - no sound - sound card detection test works - help! alexmachine Hardware & Laptops 7 16th May 2008 12:48 AM


Current GMT-time: 04:27 (Tuesday, 23-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Sec-3, Vaishali - Pantai kijing, Mempawah (Pontianak) - the biostation - Moscow Harlem Shake! Travel Photos on Instagram - Miami Downtown Travel Photos on Instagram