Fedora Linux Support Community & Resources Center
  #1  
Old 11th June 2009, 05:16 PM
mpolo Offline
Registered User
 
Join Date: Jun 2005
Posts: 197
F11: After upgrade, HAL refuses to automount USB sticks

After upgrading from F10 to F11, upon inserting a USB stick, I get:

Code:
Unable to mount KINGSTON

org.freedesktop.PolicyKit.Error.NotAuthorized:
org.freedesktop.devicekit.disks.filesystem-mount no
I can manually mount (without escalating privileges) with gnome-mount -d /dev/sdc1 .

How can I resolve this?
Reply With Quote
  #2  
Old 11th June 2009, 10:30 PM
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,176
Run 'polkit-gnome-authorization' and look at the settings for freedesktop / devicekit / disks. This is the joy of PolicyKit. I wrote a blog post on it a while back...

http://www.happyassassin.net/2009/01...avit-and-more/

that might help you understand. Or, y'know, not.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #3  
Old 12th June 2009, 12:08 PM
placentiusz Offline
Registered User
 
Join Date: Jul 2005
Posts: 12
when i run in textmode(3) and run Xwindiws manual i have similar problem. In x11 mode(5) all works fine.
Reply With Quote
  #4  
Old 25th June 2009, 08:03 AM
hectordavie Offline
Registered User
 
Join Date: Jun 2009
Location: Switzerland
Posts: 4
I have the same problem. 'polkit-gnome-authorization' indeed works, but it would be good if it were accessible directly from the Gnome System menu...
Reply With Quote
  #5  
Old 2nd July 2009, 07:15 PM
EdN Offline
Registered User
 
Join Date: Feb 2009
Location: Temecula, CA
Posts: 42
I downloaded Fedora 11 and put it on a DVD. Then I booted from the DVD and did an upgrade (from existing Fedora 10 which was updated and working fine). It appeared to load successfully with no error messages. I rebooted to the installed Fedora 11 and that's when the trouble started. When I try to mount any internal drive or removable drive (flashdrive) from the file manager I get the following message:
org.freedesktop.PolicyKit.Error.NotAuthorized: org.freedesktop.devicekit.disks.filesystem-mount no

this happens whether I'm logged in as root or as a regular user.

Another problem: From within a terminal window I tried to use yum and I get the following message:
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

No module named yum

What should I do?
Also is there any way I can go back to my previous Fedora 10 without reloading from scratch?
Needless to say I'm not very pleased with Fedora 11.
Edit/Delete Message
Reply With Quote
  #6  
Old 3rd July 2009, 04:41 PM
mpolo Offline
Registered User
 
Join Date: Jun 2005
Posts: 197
The solution cited above -- 'polkit-gnome-authorization' -- should work for the first problem. Fedora 11 just changed the defaults to values that make the system very hard to use as a desktop.

For yum, maybe you could go to a mirror through your Internet browser, then download a new yum package, then install it with rpm -Uvh . Hopefully this updates the python modules you need. (I don't know why yours got messed up there -- my yum had no problems after upgrade...)
Reply With Quote
  #7  
Old 5th July 2009, 01:06 AM
EdN Offline
Registered User
 
Join Date: Feb 2009
Location: Temecula, CA
Posts: 42
Quote:
Originally Posted by mpolo View Post
The solution cited above -- 'polkit-gnome-authorization' -- should work for the first problem. Fedora 11 just changed the defaults to values that make the system very hard to use as a desktop.

For yum, maybe you could go to a mirror through your Internet browser, then download a new yum package, then install it with rpm -Uvh . Hopefully this updates the python modules you need. (I don't know why yours got messed up there -- my yum had no problems after upgrade...)
Hi mpolo,
I followed your advise and after a lot of fiddling with "polkit-gnome-authorization" I solved my first problem.
Also I solved the second problem by reloading yum from "http://rpmfind.net".
There's just one more problem left - Google Earth no longer displays correctly. It randomly splashes the globe with variously shaped dark blotches. Must be something with the video, although it was fine with Fedora 10.
Anyways, thanks a lot for your help.
Reply With Quote
  #8  
Old 14th July 2009, 03:44 PM
ootttoo Offline
Registered User
 
Join Date: Jul 2009
Posts: 4
Still unable to mount

Hi,

Has anyone been able to resolve this?

F11 will not allow a USB drive to be mounted.

I edited authorizations in polkit-gnome-authorization.
now they read:
Mount filesystems from removable drives: anyone:yes, console:yes, active console (whatever that means??!): Admin Auth. (keep indef)

AlanW's blog didn't address this for me b/c "grant" buttons aren't working (can't select users)

I am utterly confused with this.
Why did I ever upgrade?! What a mistake.

Thanks
Mark
Reply With Quote
  #9  
Old 15th July 2009, 04:38 AM
EdN Offline
Registered User
 
Join Date: Feb 2009
Location: Temecula, CA
Posts: 42
Quote:
Originally Posted by ootttoo View Post
Hi,

Has anyone been able to resolve this?

F11 will not allow a USB drive to be mounted.

I edited authorizations in polkit-gnome-authorization.
now they read:
Mount filesystems from removable drives: anyone:yes, console:yes, active console (whatever that means??!): Admin Auth. (keep indef)

AlanW's blog didn't address this for me b/c "grant" buttons aren't working (can't select users)

I am utterly confused with this.
Why did I ever upgrade?! What a mistake.

Thanks
Mark
Get the following article "PolicyKit (and KDE), Navit and more" by HappyAssassin

http://www.happyassassin.net/2009/01...avit-and-more/

and follow the instructions given in the 12th paragraph or so. The paragraph begins with 'Click on "Mount file systems from internal drives." ...'
Apparently when you run polkit-gnome-authorization you need to do Explicit Authorizations rather than Implicit Authorizations. It worked for me.
Hope it helps.
Ed
Reply With Quote
  #10  
Old 15th July 2009, 04:27 PM
ootttoo Offline
Registered User
 
Join Date: Jul 2009
Posts: 4
Still unable to mount

Hi Ed,

Thanks for the reply.

My problems is that under the "explicit authorizations", I click on "Grant", but no users are visible in the pulldown -- not "anyone" or myself-- I can't select any users.

Any ideas how to fix this?

Thank you,
Mark
Reply With Quote
  #11  
Old 15th July 2009, 10:14 PM
ootttoo Offline
Registered User
 
Join Date: Jul 2009
Posts: 4
To get the users to show up in the drop-down, I reverted the implicit auth. to default (via the push button). Then I was able to view the user list and add myself under "explicit authorization".


But it still doesn't work...

Cheers
Reply With Quote
  #12  
Old 16th July 2009, 03:09 AM
imabug Offline
Registered User
 
Join Date: Nov 2007
Posts: 41
I've run into the same problem following the latest round of updates. None of my USB storage devices automount like they used to upon logging in. After logging in, if I remove the devices and plug them back in, they're detected and mount but having to do this every time is a PITA.

I've tried the polkit-gnome-authorization thing (org.freedesktop.devicekit.disks and org.freedesktop.hal.storage) and granted myself explicit authorization but it hasn't helped in my case.
__________________
-----BEGIN GEEK CODE BLOCK-----
Version: 3.12
GS d-(+) s: a C++ UX++++V++S++L++ P+>+++ L+++ E+>++ W++ N++(+++) o? K? w !O !M V-- PS PE Y+ PGP++ t++ 5++ X++ R+ tv++ b++(+++) DI++++ D+ G++ e+++>++++ h--- r+++ y?
-----END GEEK CODE BLOCK-----
Reply With Quote
  #13  
Old 16th July 2009, 09:08 PM
EdN Offline
Registered User
 
Join Date: Feb 2009
Location: Temecula, CA
Posts: 42
Quote:
Originally Posted by ootttoo View Post
Hi Ed,

Thanks for the reply.

My problems is that under the "explicit authorizations", I click on "Grant", but no users are visible in the pulldown -- not "anyone" or myself-- I can't select any users.

Any ideas how to fix this?

Thank you,
Mark
All I can say is the following is the procedure I went through:
When I click on "Grant" a "Grant Authorization" box comes up. Under "Beneficiary" I checked the "Show system users" box and then click on the Select user.." down arrow and a large user list appears. I select the user I want to grant permission to, and under "Constraints" click on "None". I then click on the "Grant" box in the bottom right hand corner and the Authorization screen adds that user to the "Explicit Authorizations" box. That's it.
I hope this helps.
Ed
Reply With Quote
  #14  
Old 25th July 2009, 05:04 PM
link_gaetz Offline
Registered User
 
Join Date: Jul 2009
Posts: 2
I already had an explicit authorization to mount internal drives (because I got tired of entering the root password to mount NTFS partitions every time I logged in). For some reason after upgrading from Fedora 10 to 11 this doesn't work anymore. Any ideas?
Reply With Quote
  #15  
Old 12th August 2009, 01:23 AM
toddbailey Offline
Registered User
 
Join Date: Aug 2009
Posts: 146
linuxfedorafirefox
any ideas what this means:

[root@M2 todd]# polkit-gnome-authorization

** (polkit-gnome-authorization:3607): WARNING **: Couldn't connect to session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
** (polkit-gnome-authorization:3607): DEBUG: Already running
[root@M2 todd]# polkit-gnome-authorization

** (polkit-gnome-authorization:3609): WARNING **: Couldn't connect to session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
** (polkit-gnome-authorization:3609): DEBUG: Already running


Do I need to enable some service?
Reply With Quote
Reply

Tags
automount, f11, hal, refuses, sticks, upgrade, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to automount USB Storage after Fedora 10 Upgrade tsangcn Hardware & Laptops 17 5th April 2009 02:55 PM
automount usb drive failed after upgrade to F9 from F8 cranium2003 Using Fedora 11 4th July 2008 04:35 PM
FC8 automount crashes after upgrade from fc7 spribyl Using Fedora 0 2nd July 2008 04:11 PM
Unable to automount USB Storage after FC6 Upgrade Whip-lash Hardware & Laptops 54 11th April 2008 10:48 PM
Ipod will not automount after upgrade to Fedora 7 nitroblast Hardware & Laptops 7 24th July 2007 10:20 PM


Current GMT-time: 13:03 (Wednesday, 16-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat