Fedora Linux Support Community & Resources Center
  #1  
Old 17th May 2009, 03:18 AM
DeadPark121 Offline
Registered User
 
Join Date: Sep 2008
Posts: 121
How to increase text size in virtual terminal?

i was wondering, how do you increase the text size in the virtual terminal (the one you get to when you press ctrl+alt F1-6)?

my monitor is pretty old and kind of small, so i need the bigger text size to really be able to use it at all.

i tried to find the answer in google, but i couldn't find the answer. i found answers for suse and ubuntu and tried to use those. they said to edit part of the boot loader config file, but i couldn't find a similar line in the grub.conf file. and i don't want to play with it without knowing what i'm doing

so, any advice?
__________________
03/16/09 - A+ Technician Certified
04/07/09 - Network + Certified
05/01/09 - Microsoft Certified Desktop Support Technician
09/23/09 - Microsoft Certified Systems Administrator
Reply With Quote
  #2  
Old 17th May 2009, 03:37 AM
RupertPupkin Offline
Registered User
 
Join Date: Nov 2006
Location: Detroit
Posts: 5,652
You could do it by decreasing the resolution and keeping the current font size, or by keeping the current resolution and increasing the font size. The first option is easier. This chart may help you pick the resolution you want.
Reply With Quote
  #3  
Old 17th May 2009, 07:00 AM
RupertPupkin Offline
Registered User
 
Join Date: Nov 2006
Location: Detroit
Posts: 5,652
By the way, if you do decide you want to keep your current resolution but increase the font size, you need to edit the /etc/sysconfig/i18n file. In F10 the default is to use an 8x16 console font. You can switch to the larger Sun 12x22 console font by changing this line
Code:
SYSFONT="latarcyrheb-sun16"
to this
Code:
SYSFONT="sun12x22"
You may want to comment out the current SYSFONT line and add the new one, just in case you decide you want to go back to the old one. Use # at the beginning of a line to comment it out.

By the way, you can find all the available console fonts in the /lib/kbd/consolefonts directory. Most of the names will let you know what size the font is (e.g. LatArCyrHeb-14.psfu.gz is an 8x14 font, Agafari-16.psfu.gz is an 8x16 font). When you set SYSFONT in /etc/sysconfig/i18n you just omit the .psfu.gz extension. I think sun12x22 is the biggest console font that comes with Fedora.

I use the Terminus console font, which you can get here. Here's a pic of what it looks like on my F7 system with a 1024x768 console; the top part shows the 8x16 font and the bottom part shows the 10x20 font:



And here's what the Sun 12x22 font looks like:

Reply With Quote
  #4  
Old 18th May 2009, 01:38 PM
DeadPark121 Offline
Registered User
 
Join Date: Sep 2008
Posts: 121
thank you. ^_^ i'll try that tonight and see if it works
__________________
03/16/09 - A+ Technician Certified
04/07/09 - Network + Certified
05/01/09 - Microsoft Certified Desktop Support Technician
09/23/09 - Microsoft Certified Systems Administrator
Reply With Quote
  #5  
Old 18th May 2009, 04:02 PM
RupertPupkin Offline
Registered User
 
Join Date: Nov 2006
Location: Detroit
Posts: 5,652
By the way, if you want to try the Terminus console font, it's available in the Fedora repos:
yum install terminus-font-console.noarch

Then put this line in /etc/sysconfig/i18n:
Code:
SYSFONT="ter-120b"
That will give you a 10x20 font. You can get 12x24, 14x28, or 16x32 fonts by changing 120b to 124b, 128b, or 132b, respectively, in that SYSFONT setting.
Reply With Quote
  #6  
Old 10th October 2010, 02:41 PM
nomnex Offline
Registered User
 
Join Date: Aug 2010
Location: Japan
Posts: 47
linuxfedorafirefox
Re: How to increase text size in virtual terminal?

That's the thread I was looking for, but that does not work for me on Fedora 13 (Gnome).
When I pass

Code:
SYSFONT="sun12x22"
in

Code:
/etc/sysconfig/i18n
the boot splash screen expends its size, however when I login a tty console (Ctrl+Alt+F2~F6), the font size does not change (my notebook 15' LCD as default res. of 1400x1052).
__________________
# rm -rf earth/usa/washington/redmond/m$

Last edited by nomnex; 10th October 2010 at 02:50 PM.
Reply With Quote
  #7  
Old 10th October 2010, 02:46 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,514
linuxopera
Re: How to increase text size in virtual terminal?

You might try adding nomodeset to the kernel line in grub. That will take framebuffer out of it. If, after booting, you get a message about mode not set, pick one, you can experiment, or just hit space bar for the default. (Not sure if you get that message on default boots, since you don't see the terminal and messages while booting.)
Reply With Quote
  #8  
Old 10th October 2010, 03:02 PM
nomnex Offline
Registered User
 
Join Date: Aug 2010
Location: Japan
Posts: 47
linuxfedorafirefox
Re: How to increase text size in virtual terminal?

I already had the nomodset parameter in the gurb. No change.

After I modify the i18n config file with a different console font size, the boot splash font changes. But, as soon as I enter the console, the font size is the same (default) and the screen resolution (default) 1400x1050.
__________________
# rm -rf earth/usa/washington/redmond/m$
Reply With Quote
  #9  
Old 10th October 2010, 03:51 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,514
linuxopera
Re: How to increase text size in virtual terminal?

If you typed it as you have it here, nomodset, I doubt it would do anything. It should be nomodeset (with an e after mod).
Reply With Quote
  #10  
Old 10th October 2010, 04:01 PM
nomnex Offline
Registered User
 
Join Date: Aug 2010
Location: Japan
Posts: 47
linuxfedorafirefox
Re: How to increase text size in virtual terminal?

that was just a typo in my comment.
__________________
# rm -rf earth/usa/washington/redmond/m$
Reply With Quote
  #11  
Old 10th October 2010, 04:48 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,514
linuxopera
Re: How to increase text size in virtual terminal?

Darn, thought we had the problem solved. Mou shiwake gozaimasen.
Reply With Quote
  #12  
Old 10th October 2010, 05:06 PM
nomnex Offline
Registered User
 
Join Date: Aug 2010
Location: Japan
Posts: 47
linuxfedorafirefox
Re: How to increase text size in virtual terminal?

Quote:
Originally Posted by smr54 View Post
Darn, thought we had the problem solved.
Not yet
__________________
# rm -rf earth/usa/washington/redmond/m$
Reply With Quote
  #13  
Old 13th October 2010, 12:14 AM
nomnex Offline
Registered User
 
Join Date: Aug 2010
Location: Japan
Posts: 47
linuxfedorafirefox
Re: How to increase text size in virtual terminal?

anybody to help?

There is maybe some confusion on my side. When I follow the instruction on the thread, the PC boot splash screen (the one with my computer logo + options <F2> to set bios setting <F12> to set screen resolution, etc.) - changes: its definition gets bigger. This splash screen appears a few seconds after I push the power button. Following this PC boot splash screen, there is no console message, or Fedora grub message (maybe it is hidden)?

Then Fedora 13 loads (i.e. Fedroa default blue background screen, then Fedora GUI log-in window with the same default blue background screen).

At this moment, if I enter a virtual terminal <Ctrl><Alt><F2> instead of log-in in the GUI window, the terminal font display is tinny (it uses the default screen resolution 1400x1050). The file config. modification on this thread has not effect on any of the tty console I enter.

Does it make sens? I wonder if I understand the tread correctly and why that does not work for me. I need to have larger font in the virtual terminal anytime I switch to it using <Ctrl><Alt><F2>.

I have tried the command "setfont", not to avail.
__________________
# rm -rf earth/usa/washington/redmond/m$

Last edited by nomnex; 13th October 2010 at 03:11 AM.
Reply With Quote
  #14  
Old 5th January 2011, 03:44 AM
Yahn1 Offline
Registered User
 
Join Date: Jan 2011
Posts: 1
linuxfedorafirefox
Re: How to increase text size in virtual terminal?

I tested below two way, it works in Fedora-12 :

one :
make sure have nomodeset in /boot/grub/grub.conf
a Example:

title Fedora (2.6.31.5-127.fc12.i686)
root (hd0,4)
kernel /vmlinuz-2.6.31.5-127.fc12.i686 ro root=/dev/mapper/VolGroup-lv_root LANG=en_US.UTF-8 SYSFONT=sun12x22 KEYBOARDTYPE=pc KEYTABLE=us nomodeset quiet
initrd /initramfs-2.6.31.5-127.fc12.i686.img

two:
make sure not have nomodeset in /boot/grub/grub.conf

after login, type
setfont=sun12x22 or setfont=iso01-12x22

Note:
In the first method, you can set vga
a Example:

title Fedora (2.6.31.5-127.fc12.i686)
root (hd0,4)
kernel /vmlinuz-2.6.31.5-127.fc12.i686 ro root=/dev/mapper/VolGroup-lv_root LANG=en_US.UTF-8 SYSFONT=sun12x22 KEYBOARDTYPE=pc KEYTABLE=us nomodeset vga=0x303 quiet
initrd /initramfs-2.6.31.5-127.fc12.i686.img

about howto set vga , see
http://www.g-loaded.eu/2005/09/30/ch...le-resolution/
Reply With Quote
  #15  
Old 5th January 2011, 07:41 AM
Mariusz W Offline
Registered User
 
Join Date: Nov 2007
Location: Berkeley, California
Posts: 690
windows_vistafirefox
Re: How to increase text size in virtual terminal?

One solution could be to use in the Linux console fbterm.

I tried it. To install it takes 2 minutes. It looks very attractive. It provides a few additional niceties besides controlling the font and its size: it provides also color and allows in text web browsers like w3m to display images (!), it also fully supports Unicode.

And her I have my own questions, or better say, requests.

There is a package available in current Fedora repositories, called ibus-fbterm. I would love to use it since I have no idea how otherwise to input text in various languages in Linux console (when an X server is running, then I use the keymap switching mechanism provided by X).

If smr54 by chance is reading this message, can I ask him to kindly check ibus-fbterm? try to use it? and to write a tutorial on how to type into the frame buffer terminal in various languages? I will be truly grateful for this.

Can I also request that he either updates or produces a current version of his excellent (but dated) tutorials on his personal webpage, devoted to input methods like ibus.

I find it difficult to locate sources of clear information on using ibus on a modern OS like Fedora 14, which is directed at beginners like me.
Reply With Quote
Reply

Tags
increase, size, terminal, text, virtual

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LVM increase size question DubJohn Installation, Upgrades and Live Media 1 2nd July 2009 04:08 PM
Increase RFS size kirubakonig Hardware & Laptops 1 23rd February 2009 06:28 AM
garbled text in virtual terminal dmccallie Using Fedora 0 1st June 2005 06:06 AM


Current GMT-time: 17:52 (Friday, 19-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat