Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 13th September 2004, 05:19 AM
krazibon3 Offline
Registered User
 
Join Date: Aug 2004
Posts: 38
Mplayer clashing with xmms or other programs = mplayer not working

Heya

I've installed mplayer via yum and it works a treat and also managed to set up my beautiful OS on a new HD in a couple of hours when it took me a month or so when i first started using linux. Now i've read somewhere that
mplayer sometimes refuses to work because it clashes with a couple a programs like xmms. I solve this problem by logging out and logging back in again. Just wondering if someone has a solution to this problem or point me to the right direction to fix this? That is without logging out and logging back in again.

I'm sorry if this a repeated post., but any help would be apprecicated.
Reply With Quote
  #2  
Old 13th September 2004, 05:28 AM
superbnerd
Guest
 
Posts: n/a
you have to give us more information. what does "clash" mean? I assume you mean you can't play two files at the same time? is there an error message?
Reply With Quote
  #3  
Old 15th September 2004, 04:52 AM
krazibon3 Offline
Registered User
 
Join Date: Aug 2004
Posts: 38
Sorry for the late reply i jwas just waiting for the right time for it to crash on me. Here is wat i get in console when i try to load an .avi file.

Quote:
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/mike/.mplayer/config
Reading /home/mike/.mplayer/codecs.conf: Can't open '/home/mike/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/mike/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/mike/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick

Playing [Lunar] Samurai 7 - 11 [4A6A8717].avi.
AVI file format detected.
VIDEO: [XVID] 640x360 24bpp 23.976 fps 839.7 kbps (102.5 kbyte/s)
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 16000->192000 (128.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
vo: X11 running at 1600x1200 with depth 24 and 32 bpp (":0" => local display)
================================================== ========================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
================================================== ========================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 640 x 360 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 640x360 => 640x360 Planar YV12
[mpeg4 @ 0x85a2968]vop not coded: 0.008 3/ 3 0% 0% 0.0% 2 0 99%
X11 error: BadAlloc (insufficient resources for operation) 0.0% 2 0 99%


MPlayer interrupted by signal 6 in module: flip_page
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
Xlib: unexpected async reply (sequence 0x5c)!
If i logged out and logged back in again this won't occur
Reply With Quote
  #4  
Old 15th September 2004, 05:17 AM
imdeemvp Offline
Registered User
 
Join Date: Feb 2004
Age: 45
Posts: 8,256
now have you installed the codecs?

this thread here may help you: http://www.fedoraforum.org/forum/showthread.php?t=21630
__________________
HELP with JAVA, MP3's, Wireless, Repo's, YUM, Partitions, System Monitors, Nvidia, ATI drivers, LIMEWIRE PRO & MORE!.

Easiest and most friendly desktop ever is PCLinuxOS! Includes all this apps. Just try it.

"The greater the struggle THE greater the achievment."

Do you know HIM?

If you are an idiot click here. NThis will test you linux skills :D
Reply With Quote
  #5  
Old 15th September 2004, 05:25 AM
krazibon3 Offline
Registered User
 
Join Date: Aug 2004
Posts: 38
yeh i grabbed every codec available. I can watch my files but sometimes i get that error message. If i log out and log back in again the problem disappears.
Reply With Quote
  #6  
Old 15th September 2004, 05:35 AM
imdeemvp Offline
Registered User
 
Join Date: Feb 2004
Age: 45
Posts: 8,256
well that weird....which kernel are you using?
__________________
HELP with JAVA, MP3's, Wireless, Repo's, YUM, Partitions, System Monitors, Nvidia, ATI drivers, LIMEWIRE PRO & MORE!.

Easiest and most friendly desktop ever is PCLinuxOS! Includes all this apps. Just try it.

"The greater the struggle THE greater the achievment."

Do you know HIM?

If you are an idiot click here. NThis will test you linux skills :D
Reply With Quote
  #7  
Old 15th September 2004, 06:50 AM
Shadow Skill Offline
Registered User
 
Join Date: Aug 2004
Posts: 1,317
Have you tried it in other players capable of handling such an avi, like totem, or videolan to see if those break as well? This is one strange error indeed I haven't experienced that sort of problem with Mplayer ever, you might also want to try uninstalling all of the codecs and mplayer and then reinstall them. I know on Windows codec conflicts can produce some rather strange effects like a brutally slow system for example.
__________________
Ware wa mutekinari.
Wa ga kage waza ni kanau mono nashi.
Wa ga ichigeki wa mutekinari.



Please vote for this bug and help me make GAYT [Go As You Type ]a standard option in Firefox.
Reply With Quote
  #8  
Old 15th September 2004, 09:00 AM
krazibon3 Offline
Registered User
 
Join Date: Aug 2004
Posts: 38
I'm using 2.6.8 its happened on the previous kernel as well. I like this kernel as it doesn'tseem to freeze nor lag the computer to much. It might just be the windows media files but i'll give other video formats ago and see how it goes from there.
Reply With Quote
  #9  
Old 15th September 2004, 10:54 AM
imdeemvp Offline
Registered User
 
Join Date: Feb 2004
Age: 45
Posts: 8,256
what happens if you try playing under ogle, my personal choice for dvd playback is ogle and for music i like zinf and of course xmms

to install ogle open terminal and as root type: yum -y install ogle_gui and see if you get same results some people had more problems with mplayer then ogle and i know this is not what you need for a solution i just want you to try it to see if you get same issue.
__________________
HELP with JAVA, MP3's, Wireless, Repo's, YUM, Partitions, System Monitors, Nvidia, ATI drivers, LIMEWIRE PRO & MORE!.

Easiest and most friendly desktop ever is PCLinuxOS! Includes all this apps. Just try it.

"The greater the struggle THE greater the achievment."

Do you know HIM?

If you are an idiot click here. NThis will test you linux skills :D
Reply With Quote
  #10  
Old 15th September 2004, 04:18 PM
krazibon3 Offline
Registered User
 
Join Date: Aug 2004
Posts: 38
no harm trying it out thanks mate
Reply With Quote
Reply

Tags
clashing, mplayer, programs, working, xmms

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
About installation for XMMS &Mplayer help! Edward.Huang Using Fedora 4 29th December 2006 08:38 AM
xmms and mplayer and mp3 and dvd Mikecore Using Fedora 0 17th June 2006 04:55 PM
FC5: mplayer and xmms mp3 - where ? PompeyBlue Using Fedora 15 21st March 2006 08:18 PM
Just curious about XMMS and mplayer DGF Using Fedora 2 3rd March 2006 03:38 AM
XMMS, Mplayer and other rpms... seww Using Fedora 2 26th December 2005 07:49 AM


Current GMT-time: 08:14 (Thursday, 21-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat