Fedora Linux Support Community & Resources Center
  #1  
Old 12th April 2009, 01:57 AM
Cassanova Offline
Registered User
 
Join Date: Feb 2009
Location: An Evil City in Indiana
Posts: 85
Internet only slow on Fedora

Hi! I just got high speed (10 Megabit) Cable internet in my apartment; and at first all was quite well, and the internet was Coming into my home nice and fast; loading LQ and FedoraForum VERY quickly. But now, my Two Fedora computers (one desktop wired, and one laptop wireless) load pages VERY slowly; sometimes even slower than the DSL (1.5 Megabit) I'm coming off of... The odd thing is, that my Fiancée's Vista Desktop is loading pages just fine... and super fast. I HAVE made a few minor changes, since they set me up, but I don't know why they would only be affecting my Fed
__________________
Thanks to everyone in the Fedora Forum Community! It's because of your willingness to assist even the newest users and treat them with respect and patience that keeps me coming back to Fedora Every time!
Reply With Quote
  #2  
Old 13th April 2009, 01:06 AM
philo565 Offline
Registered User
 
Join Date: Mar 2009
Posts: 18
Slow connectivity

I had a slightly similar problem recently of limited connectivity.


Long story but it turned out that my DNS numbers had changed
and that DHCPv6 had assigned an incorrect primary DNS.

As a work-around I setup my my internet connection manually

First right click on your network icon and look at
connection information and write down all settings

Now...you can go to your network icon and opt to "edit connections"

then under IPv4 change the connection from DHCP to manual

and enter the settings from the Vista machine

all settings should be the same except for address
where you will have to enter your specific router
address...and that would be the same as it presently is


Note: before you do anything, you may want to wait for other
replies...as though this did work for me...there may very well
be someone who has a superior solution
Reply With Quote
  #3  
Old 13th April 2009, 01:17 AM
Demz
Guest
 
Posts: n/a
did you try turning off ipv6 ?
Reply With Quote
  #4  
Old 13th April 2009, 08:07 PM
Cassanova Offline
Registered User
 
Join Date: Feb 2009
Location: An Evil City in Indiana
Posts: 85
Quote:
Originally Posted by Demz View Post
did you try turning off ipv6 ?
How would I go about disabling IPv6? So far, in my experience, all I've seen is IPv4
__________________
Thanks to everyone in the Fedora Forum Community! It's because of your willingness to assist even the newest users and treat them with respect and patience that keeps me coming back to Fedora Every time!

Last edited by Cassanova; 14th April 2009 at 04:41 AM.
Reply With Quote
  #5  
Old 16th April 2009, 08:03 PM
Cassanova Offline
Registered User
 
Join Date: Feb 2009
Location: An Evil City in Indiana
Posts: 85
I found instructions to turn off IPv6, but I seem to lack the correct file in the correct location.

Also, I followed some advice I got on an LQ post:

Quote:
Originally Posted by anomie View Post
For the sake of testing possible causes, back up your /etc/resolv.conf and then replace its contents with only this:
Code:
nameserver 208.67.222.222
nameserver 208.67.220.220
Do you see an improvement with your problem? (Those are OpenDNS's nameservers, BTW.)
and I found that my speed was back to where it was supposed to be, however, I have not yet \learned what this indicates, or what to do now. so if anyone has an idea where this is going, or what changing my resolv.conf says about my problem, please feel free to chime in.
__________________
Thanks to everyone in the Fedora Forum Community! It's because of your willingness to assist even the newest users and treat them with respect and patience that keeps me coming back to Fedora Every time!
Reply With Quote
  #6  
Old 16th April 2009, 10:23 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,000
Quote:
Originally Posted by Cassanova View Post
I found instructions to turn off IPv6, but I seem to lack the correct file in the correct location.
There's no need to need to find any files, just run system-config-network
and uncheck the ipv6 checkbox to turn it off

http://fedorasolved.org/Members/MrHa...config-network

the checkbox is visible there in picture 2
Reply With Quote
  #7  
Old 17th April 2009, 06:16 PM
Cassanova Offline
Registered User
 
Join Date: Feb 2009
Location: An Evil City in Indiana
Posts: 85
Updade:
Thanks to marko, I've discovered that my IPv6 is already off. so now I get to figure out the next possible cause of my slow connection. The other lead that I've got, is that editing my /etc/resolv.conf file, and replacing the IPs in it (with IPs from OpenDNS), fixes it... but IDK why, and re-editing the file every time I boot, is annoying, and I'm not entirely comfortable with the whole idea of borrowing someone else's IPs anyway
__________________
Thanks to everyone in the Fedora Forum Community! It's because of your willingness to assist even the newest users and treat them with respect and patience that keeps me coming back to Fedora Every time!

Last edited by Cassanova; 17th April 2009 at 06:23 PM.
Reply With Quote
  #8  
Old 18th April 2009, 02:35 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,000
Quote:
Originally Posted by Cassanova View Post
Updade:
Thanks to marko, I've discovered that my IPv6 is already off. so now I get to figure out the next possible cause of my slow connection. The other lead that I've got, is that editing my /etc/resolv.conf file, and replacing the IPs in it (with IPs from OpenDNS), fixes it... but IDK why, and re-editing the file every time I boot, is annoying, and I'm not entirely comfortable with the whole idea of borrowing someone else's IPs anyway
Well, you're trusting your ISP's DNS to be correct, why are they more trustworthy than opendns?
I will say, the main reason I won't use opendns is they manipulate certain things related to web searches.
Basically when you do a search to google, they proxy the search through one of their own hosts,
namely google.navigation.opendns.com

I guess with the intent of web ad targeting or data mining:

REF:
http://forums.opendns.com/comments.p...nID=226&page=2



Another thing that might really help is make sure your "dnsmasq" is on:

run this and make sure it says dnsmasq is running:
Quote:
service dnsmasq status
What dnsmasq will do is cache IP addresses as you get them, then the 2nd, 3rd, etc times you
go back you can avoid that possibly slow ISP dns and get the address from your own cache.
Reply With Quote
Reply

Tags
fedora, internet, slow

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 8 x86_64 and slow internet. paralizer Servers & Networking 3 13th February 2008 05:02 PM
Slow internet in fedora 7 (not in windows) leonloopik Servers & Networking 11 19th December 2007 05:24 PM
why my internet is slow in Fedora? green-cat-fed Security and Privacy 31 14th June 2006 03:36 AM
slow internet with fedora bazzoon Using Fedora 9 17th December 2004 01:25 AM


Current GMT-time: 02:28 (Saturday, 02-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat