Fedora Linux Support Community & Resources Center
  #1  
Old 10th March 2009, 09:39 PM
Krellan Offline
Registered User
 
Join Date: Jan 2009
Posts: 19
Network Manager settings all grayed out

Sorry if this is a FAQ, but I searched and couldn't really come up with an answer.

I'm running Fedora 10. My Network Manager settings are all grayed out. They are uneditable. I can see the detected settings, but not change them. All of the settings fields are disabled.

Is there a way to enable these, so that they can be edited?

Starting with the menu in the upper left corner of the GNOME screen:

System/Preferences/Internet And Network/Network Connections

The Network Manager window appears correctly. I see all automatically generated settings that were created for my various devices:

Auto eth0
Auto eth1
Auto vmnet1
Auto vmnet8

In particular, I want to be able to edit "Auto vmnet8", for VMware usage.

I know about the workaround of going back to the manual network configuration as used in older versions of Fedora, such as editing the files in /etc/sysconfig/network-scripts/ifcfg-* and then enabling the old "network" service and disabling the "NetworkManager" service.

However, this workaround really won't work in this situation. The VMware interfaces, vmnet1 and vmnet8, are virtual interfaces that *only* exist when the VMware services are running. The VMware services are started *after* the old manual network configuration would be applied. So, at the time the scripts in /etc/sysconfig/network-scripts are processed, the vmnet1 and vmnet8 devices do not yet exist! I'm hesitant to change the numbering of services, lest other things break (VMware on Fedora 10 is rather fragile already).

I love the feature of NetworkManager to be able to automatically apply settings to newly materialized network devices (such as vmnet1 and vmnet8 when VMware is loaded). However, I need to also be able to edit those settings.

Is there a solution that will make my Network Manager "Edit" window not be entirely grayed out? I can see the settings pages just fine, but unfortunately, they are all disabled and I can't edit them at all.

Thanks!

Josh
Reply With Quote
  #2  
Old 11th March 2009, 03:35 PM
nt4cats Offline
Registered User
 
Join Date: Aug 2005
Location: Philadelphia, PA
Posts: 99
Josh:

This problem isn't just you -- and it isn't just for VMWare (which I use, too).

A recent update to NetworkManager broke something. My eth0 used to show up in the NetworkManager "edit connections..." dialog as "Auto eth0". When I powered on my laptop it would automatically fire up eth0 (with DHCP) if a cable was connected. After this NetworkManager update eth0 now shows up as "System eth0" -- and it no longer auto-connects. I went to the "edit connections..." dialog to tell NetworkManager to "auto connect" to eth0 all of the options are grayed out.
Reply With Quote
  #3  
Old 11th March 2009, 08:06 PM
Krellan Offline
Registered User
 
Join Date: Jan 2009
Posts: 19
A brute force solution worked for me: a cron job, ran every minute, that manually did an "ifconfig" command on the device to configure it!

That way, once the device appeared on the system, I needed to only wait one minute before using it, and if the device hadn't appeared yet, the "ifconfig" command would just silently fail without popping up any error boxes or otherwise getting in the way.

An ugly solution, but it works.

Any word on when we can expect a fix? It looks like the NetworkManager folks have had their hands full recently
Reply With Quote
  #4  
Old 11th March 2009, 08:23 PM
nt4cats Offline
Registered User
 
Join Date: Aug 2005
Location: Philadelphia, PA
Posts: 99
I'm a bit less brutish ... I just click on the little applet on my gnome panel and then click on the "System eth0" interface to get it connected. My situation is a bit easier than yours, though.
Reply With Quote
  #5  
Old 13th March 2009, 07:56 AM
Krellan Offline
Registered User
 
Join Date: Jan 2009
Posts: 19
Quote:
Originally Posted by nt4cats View Post
I'm a bit less brutish ... I just click on the little applet on my gnome panel and then click on the "System eth0" interface to get it connected. My situation is a bit easier than yours, though.
Interesting. Was all of the settings still grayed out? When I click on it, I can see the information it autodetected, but I can't do anything to change it in any way, because it's all grayed out.
Reply With Quote
  #6  
Old 13th March 2009, 04:44 PM
nt4cats Offline
Registered User
 
Join Date: Aug 2005
Location: Philadelphia, PA
Posts: 99
Yes -- everything is grayed out.
Reply With Quote
  #7  
Old 18th March 2009, 10:24 AM
Jawloms Offline
Registered User
 
Join Date: Mar 2009
Posts: 4
Has anyone found a different fix for this yet as if I click on my "System eth0" nothing happens at all.

Thank you
Reply With Quote
  #8  
Old 18th March 2009, 10:54 AM
Jawloms Offline
Registered User
 
Join Date: Mar 2009
Posts: 4
Nevermind - found it! I went to System => Administration => Network and edited eth0 and checked the option "activatve device when computer starts". I then did "service network restart" from a terminal as root and it has connected! Hope that helps someone else.
Reply With Quote
  #9  
Old 18th March 2009, 06:28 PM
Krellan Offline
Registered User
 
Join Date: Jan 2009
Posts: 19
Quote:
Originally Posted by Jawloms View Post
Nevermind - found it! I went to System => Administration => Network and edited eth0 and checked the option "activatve device when computer starts". I then did "service network restart" from a terminal as root and it has connected! Hope that helps someone else.
Unfortunately, the System/Administration/Network control panel only controls the old "network" service. As you found, that still works just fine. However, it isn't NetworkManager, which is what I wanted to use. Among other things, the old "network" service can't see network devices that don't exist at boot time (e.g. virtual network devices for things like VMware).

Since you're using the old "network" service, be sure to uncheck the checkbox "Controlled by NetworkManager" for the eth0 device in System/Administration/Network, so that NetworkManager won't try to take over the device and fight with the old "network" service. Also, run "/sbin/chkconfig network on" as root. This will ensure the old "network" service is started at startup, for the next time you reboot.

It's a shame that NetworkManager has no similar control panel! It's frustrating to not be able to edit the settings all in one place. Maybe it's a permissions problem: somehow NetworkManager thinks the device "belongs" to only root, so it's not letting the user edit it, hence the settings are all grayed out. It should then prompt for the password, then, to unlock the settings, just like everything else. Maybe it will be fixed in Fedora 11? Who knows....
Reply With Quote
  #10  
Old 19th March 2009, 03:38 AM
BushRat Offline
Registered User
 
Join Date: Mar 2009
Posts: 10
Well I have a different problem. After booting up my system from cold start, my network is unavailable. It seems like it won't remember my DNS settings. I have to go to System>Admin>Network, (eth0 and eth0:1 is inactive) click on DNS tab, and enter the IP. After I close the window, it asks me to save or cancel (save of course) and it tells me to reboot. Is there any way to actually save those settings and make them work straight from cold boot ?
Reply With Quote
  #11  
Old 19th March 2009, 04:11 AM
Krellan Offline
Registered User
 
Join Date: Jan 2009
Posts: 19
Quote:
Originally Posted by BushRat View Post
Well I have a different problem. After booting up my system from cold start, my network is unavailable. It seems like it won't remember my DNS settings. I have to go to System>Admin>Network, (eth0 and eth0:1 is inactive) click on DNS tab, and enter the IP. After I close the window, it asks me to save or cancel (save of course) and it tells me to reboot. Is there any way to actually save those settings and make them work straight from cold boot ?
The System/Admin/Network page is for the old "network" service, not NetworkManager.

Make sure to check "Activate device when computer starts".

Make sure to NOT CHECK the "Controlled by NetworkManager" box.

Now, make sure the old "network" service is started at boot. It isn't anymore, by default. That's why you're not getting your settings to take effect when you next have to reboot.

Run this command as root:

Code:
/sbin/chkconfig network on
That will make it start at boot.

You can also start the old "network" service anytime you want, by running this command, also as root:

Code:
/sbin/service network restart
I'm still stuck with my original problem with NetworkManager! Has anybody figured out a solution yet, for this bug?
Reply With Quote
  #12  
Old 19th March 2009, 04:54 PM
nt4cats Offline
Registered User
 
Join Date: Aug 2005
Location: Philadelphia, PA
Posts: 99
I was able to work around this (for eth0). I used the NetworkManager->Edit Connections page, and added a new connection. I called it "Auto eth0", gave the the MAC address of my eth0, and clicked on "connect automatically". Now it works like it should. I still have a silly "System eth0" entry that I can't edit, but when I plug in an Ethernet cable to my laptop NetworkManager does its thing, so I'm happy.
Reply With Quote
Reply

Tags
grayed, manager, network, settings

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where is compiz-settings-manager? vinoman Using Fedora 3 14th March 2009 04:40 PM
install media grayed out in virt-manager angryfirelord Using Fedora 1 5th October 2007 12:34 AM
Network Manager Settings Graham1 Servers & Networking 5 11th February 2007 12:48 PM
a possible fix for gnome-settings-manager galatei Using Fedora 0 18th November 2006 10:33 PM


Current GMT-time: 14:15 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Gran Alacant, Spain Photos on Instagram - Cancun, Quintana Roo - The Link, Asiatown IT Park