Fedora Linux Support Community & Resources Center
  #1  
Old 3rd February 2009, 10:28 PM
mafc Offline
Registered User
 
Join Date: Jul 2008
Posts: 16
Angry How to uninstall ati driver

Hi,

I have a Fedora 10 - 32bit with an Ati 9200. I have installed the new drivers of ati ati-driver-installer-9-1-x86.x86_64.run (now I know that this driver only works with ati >9250) and the X aren't works fine. If I run startx i get an error and the X server isn't start. The only way to run the X is execute the fglrx-config-display disable command. When I run this command the X works but the compiz doen't works.

I want to uninstall the driver and put the system how is it before I installed the driver. Can anyone to help me?

Thanks

Last edited by mafc; 3rd February 2009 at 11:07 PM.
Reply With Quote
  #2  
Old 3rd February 2009, 11:41 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by mafc View Post
Hi,

I have a Fedora 10 - 32bit with an Ati 9200. I have installed the new drivers of ati ati-driver-installer-9-1-x86.x86_64.run (now I know that this driver only works with ati >9250) and the X aren't works fine. If I run startx i get an error and the X server isn't start. The only way to run the X is execute the fglrx-config-display disable command. When I run this command the X works but the compiz doen't works.

I want to uninstall the driver and put the system how is it before I installed the driver. Can anyone to help me?

Thanks
Taken from https://a248.e.akamai.net/f/674/9206...cat91-inst.pdf

Code:
Uninstalling the ATI Linux Proprietary Driver
          Uninstalling the ATI Linux Proprietary Driver is dependent on the mode of the
          initial installation.
Automatic or Custom Driver Installations
          If the ATI Proprietary Linux Driver was installed using either the Automatic or
          Custom options, then do the following:
          1 Launch the Terminal Application/Window and navigate to the /usr/share/ati
               folder
          2 With superuser permissions, enter the command "sh ./fglrx-uninstall.sh"
          You have now successfully uninstalled the ATI Linux Proprietary Driver.
Reply With Quote
  #3  
Old 4th February 2009, 12:14 AM
mafc Offline
Registered User
 
Join Date: Jul 2008
Posts: 16
I have executed the fglrx-uninstall.sh and I have the same problems. If I want to run the X I have to execute the fglrx-config-display disable. This is the /var/log/Xorg.0.log.

Code:
X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-92.1.18.el5 i686 
Current Operating System: Linux AQUA 2.6.27.12-170.2.5.fc10.i686 #1 SMP Wed Jan 21 02:09:37 EST 2009 i686
Build Date: 11 December 2008  05:27:37PM
Build ID: xorg-x11-server 1.5.3-6.fc10 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb  4 00:55:40 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "single head configuration"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Videocard0"
(==) No monitor specified for screen "Screen0".
	Using a default monitor configuration.
(**) |-->Input Device "Keyboard0"
(**) Option "AIGLX" "off"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
	catalogue:/etc/X11/fontpath.d,
	built-ins
(**) ModulePath set to "/usr/lib/xorg/modules/extensions/fglrx,/usr/lib/xorg/modules"
(**) Extension "Composite" is disabled
(II) Cannot locate a core pointer device.
(II) The server relies on HAL to provide the list of input devices.
	If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(WW) Disabling Keyboard0
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81f4400
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.4
	X.Org Video Driver: 4.1
	X.Org XInput driver : 2.1
	X.Org Server Extension : 1.1
	X.Org Font Renderer : 0.6
(II) Loader running on linux
(--) using VT number 7

(--) PCI: (0@0:9:0) Brooktree Corporation Bt878 Video Capture rev 17, Mem @ 0xdf000000/0
(--) PCI:*(0@1:0:0) ATI Technologies Inc RV280 [Radeon 9200 SE] rev 1, Mem @ 0xe0000000/0, 0xd7800000/0, I/O @ 0x0000d800/0, BIOS @ 0x????????/131072
(II) System resource ranges:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.5.3, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SELinux
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 1.5.3, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions/fglrx//libglx.so
(II) Module glx: vendor="X.Org Foundation"
	compiled for 7.4.0, module version = 1.0.0
	ABI class: X.Org Server Extension, version 1.1
(--) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules/fonts//libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
	compiled for 1.5.3, module version = 2.1.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "dri"

(II) Loading /usr/lib/xorg/modules/extensions/fglrx//libdri.so
(II) Module dri: vendor="X.Org Foundation"
	compiled for 7.4.0, module version = 1.0.0
	ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "fglrx"

(WW) Warning, couldn't open module fglrx
(II) UnloadModule: "fglrx"
(EE) Failed to load module "fglrx" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found
Reply With Quote
  #4  
Old 4th February 2009, 07:24 AM
leigh123linux
Guest
 
Posts: n/a
Try this , you still have the old config file

Code:
su
rm -f /etc/X11/xorg.conf
reboot
Reply With Quote
  #5  
Old 4th February 2009, 11:34 PM
mafc Offline
Registered User
 
Join Date: Jul 2008
Posts: 16
After uninstall with fglrx-uninstall all works fine but only if I run fglrx-config-display disable before startx.

After that, I have dropped the xorg.conf but the problem still continue.
Reply With Quote
Reply

Tags
ati, driver

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I uninstall orinoco driver? arozar Servers & Networking 2 4th November 2007 10:11 PM
How do I uninstall the Nvidia Driver? Vansolrick Using Fedora 2 12th September 2007 07:34 AM
how do i uninstall a driver grandpa2390 Servers & Networking 2 25th August 2007 08:08 PM
How to uninstall my Nvidia driver microo Installation, Upgrades and Live Media 1 5th July 2006 01:26 PM
nvidia driver uninstall crzyone9584 Using Fedora 33 28th May 2006 03:20 AM


Current GMT-time: 17:25 (Saturday, 24-06-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat