Fedora Linux Support Community & Resources Center
  #1  
Old 22nd December 2008, 02:43 AM
totalnoob Offline
Registered User
 
Join Date: Dec 2008
Posts: 8
Belkin F5D7050E running Realtek 8187b chipset under 2.6.27 (FC9)

Started new thread because it was suggested to me that it was ruder to threadjack somebody else's thread on a related issue

Hi all. First off, I understand that I'm just a dumb noob when it comes to linux, so I might say something stupid or not include critical information in this post. If I do that feel free to let me know and I'll try to fix it. I've been running Fedora 9 for about 6 months now. I'm running 2.6.27. Output for uname -a is:

Code:
Linux localhost.localdomain 2.6.27.7-53.fc9.i686 #1 SMP Thu Nov 27 02:29:03 EST 2008 i686 i686 i386 GNU/Linux
I've never managed to get my wireless adapter to work under linux. Today I bought a Belkin F5D7050E USB wireless adapter to see if I would have any better luck with it. So I plug it in, and there's no joy straight out of box (part of me was hoping...but I'm willing to do some work to get it working). The little light on the adapter doesn't light up or anything. Googling around, I learn that I should look at the output for lsusb:

Code:
Bus 001 Device 004: ID 050d:705e Belkin Components 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
So I google the Belkin Device ID and it turns out that it uses the Realtek 8187b chipset http://ubuntuforums.org/showthread.php?t=665847

I found somebody who claimed to have a workaround to make it run, but he says the workaround doesn't play well with the latest kernels http://steveth45.net/blog/?p=67

So that's no good. But then, I find out that the Realtek 8187b chipset is supposed to be natively supported under 2.6.27. Great! But I also find this http://www.heise-online.co.uk/open/K...--/news/111749

Quote:
rtl8187: Add USB ID for Belkin F5D7050 with RTL8187B chip

The Belkin F5D7050rev5000de (id 050d:705e) has the Realtek RTL8187B chip
and works with the 2.6.27 driver.
which tells me that there's some problem because the USB ID doesn't really match (don't understand this bit)

Okay, fine. But maybe this is just a cosmetic issue or a documentation issue (?) so I google up a description of how the RTL8187b chipset works for other people. I find out that people need to add the 8187b module by using modprobe http://ubuntuforums.org/showthread.php?t=944292, so I do it (as root):

Code:
modprobe rtl8187
and then when I

Code:
modprobe -l | grep rtl
I get:

Code:
/lib/modules/2.6.27.7-53.fc9.i686/kernel/drivers/net/wireless/rtl8180.ko
/lib/modules/2.6.27.7-53.fc9.i686/kernel/drivers/net/wireless/rtl8187.ko
/lib/modules/2.6.27.7-53.fc9.i686/kernel/drivers/net/usb/rtl8150.ko
so the module is there (right?)

But when I go to System->Administration->Network and then Hardware->New->Wireless the list of available adapters does not include rtl8187b. Is there a non-GUI way to do this? Anyway, here's the output for iwconfig:

Code:
lo        no wireless extensions.

eth0      no wireless extensions.

pan0      no wireless extensions.
and for ifconfig:

Code:
eth0      Link encap:Ethernet  HWaddr 00:06:1B:C4:B4:9F  
          inet addr:192.168.15.102  Bcast:192.168.15.255  Mask:255.255.255.0
          inet6 addr: fe80::206:1bff:fec4:b49f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8741 errors:28 dropped:0 overruns:0 frame:28
          TX packets:8875 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7712175 (7.3 MiB)  TX bytes:1717035 (1.6 MiB)
          Interrupt:11 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:5156 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5156 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:258088 (252.0 KiB)  TX bytes:258088 (252.0 KiB)
What should I do now? I'm stuck.
Thanks in advance for all your help.
Reply With Quote
  #2  
Old 22nd December 2008, 02:52 AM
totalnoob Offline
Registered User
 
Join Date: Dec 2008
Posts: 8
So, I think my problem is basically that loading the rtl8187 module doesn't tell the System->Administration->Network->Hardware->New->Wireless GUI that I should be able to add a new rtl8187 device AND I don't know how to do this via the command line. It seems like maybe this is what ifconfig is supposed to do (?) but I can't figure it out (I've been reading the man page for it, as well as tutorials. Still having a hard time).

Reply With Quote
  #3  
Old 22nd December 2008, 03:32 AM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
Hello totalnoob,

I don't use that card, so I don't really know anything based on personal experience with it. But from just reading your information and the links in your post, some things came to my mind. At least two people in your links successfully used the rt8187 driver with the 2.6.27 kernel and this chipset. They manually loaded the driver module with modprobe (like you did). But one of them then immediately used some unspecified network manager and got connected. The other one didn't say what they did next, but they got connected. You went into the Network Configuration utility to do things.

Alright. First, I recommend that for now you forget the Network Configuration utility. It's that System->Administration->Network GUI that you mentioned. It's also invoked with system-config-network in the terminal. Anyway, try your modprobe rt8187 command again. But try confirming that it loaded. It should be in the list generated by this...
Code:
/sbin/lsmod | sort
Then immediately check your NetworkManager system tray icon. Left-click it and look for your network in the available networks. It may help to restart NetworkManager...
Code:
su
/sbin/service NetworkManager restart
Anyway, if you now see your network, click on it and enter the requested information. If your router is not broadcasting its SSID, then left-click the NM tray icon and choose "Connect to other wireless network" or "Connect to hidden wireless network" and then enter the information.

No promises, of course. But things often go just that way. It does for me (with a different card, of course). But I don't enter anything in the Network Configuration utility any more. I don't even have a wireless connection in that, and yet I am connected with NetworkManager now. If nothing I said helped, at least I bumped your thread back to the top.

P.S.: I forgot to say that if the modprobe command and NetworkManager work, but the module does not load automatically when you reboot, then you may have enter that modprobe command in one of the startup scripts. People sometimes do that.

Last edited by stoat; 25th December 2008 at 02:52 PM.
Reply With Quote
  #4  
Old 22nd December 2008, 04:11 AM
totalnoob Offline
Registered User
 
Join Date: Dec 2008
Posts: 8
Thanks for the reply stoat!

If I do lsmod it gives (all the lines which have rtl in them):

Code:
cfg80211               23816  2 rtl8187,mac80211
eeprom_93cx6            5888  1 rtl8187
mac80211              173668  1 rtl8187
rtl8187                40192  0
However your hint to use network manager to access my wireless network doesn't help, unfortunately. I have a linksys router which (for now, to make it easy to connect) I have disabled all security on, which is broadcasting its name and whose name is the default (linksys). I added a wireless connection in NM with this info, but it doesn't seem to connect at all.

I think that the problem is that my wireless NIC is simply not functioning at all right now because my system doesn't understand that I want to use the rtl8187 module with it.

One of the steps to make this happen seems to be to add the following line:

alias wlan0 rtl8187

to the /etc/modprobe.conf file (?)

and then to restart. I'm a bit nervous about doing this.
Reply With Quote
  #5  
Old 22nd December 2008, 04:21 AM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
Quote:
Originally Posted by totalnoob

alias wlan0 rtl8187

to the /etc/modprobe.conf file (?)

and then to restart. I'm a bit nervous about doing this.
Do it. It's done all the time to help modules load at boot time. It's routinely done with ndiswrapper. Besides, it's easy to reverse.
Reply With Quote
  #6  
Old 22nd December 2008, 04:24 AM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
One other thing to consider is a radio switch somewhere. Either a real physical switch somewhere on the card or the computer, or maybe something that can be enabled/disabled in BIOS. Maybe something that Windows disables on shutdown making the card not work when Fedora boots. I see things like that all the time. Saw one today.
Reply With Quote
  #7  
Old 22nd December 2008, 04:29 AM
totalnoob Offline
Registered User
 
Join Date: Dec 2008
Posts: 8
All right. I just made SOME progress (but not much)

I added the line

alias wlan0 rtl8187

to the /etc/modprobe.conf file

and saved.

Then I did modprobe rtl8187 again

Now when I go to the Network Configuration GUI under the Hardware tab there is an entry that looks like:

rtl8187 Wireless wlan0 configured

Then I add a new device (wireless connection -> rtl8187 (wlan0) -> configure) and hit okay. It shows up as inactive. When I try to activate it I get:

system-config-network:
cannot activate device wlan0!
rtl8187 device wlan0 does not seem to be present, delaying initialization.

So I think that my system doesn't understand that wlan0 is supposed to be the Belkin USB stick (maybe because of the USB ID problem I mentioned previously which is supposed to be fixed in 2.6.28?)
Reply With Quote
  #8  
Old 22nd December 2008, 04:31 AM
totalnoob Offline
Registered User
 
Join Date: Dec 2008
Posts: 8
Thanks for all your help, stoat!

I'm gong to try a reboot now and see if that changes anything.

Be back in a few.

EDIT: reboot doesn't seem to help. Still stuck in same place. Also, it seems that if I want rtl8187 to show up in lsmod I need to redo modprobe rtl8187 after reboots. That's fine for now (I can add to one of my startup files later)

Last edited by totalnoob; 22nd December 2008 at 04:40 AM.
Reply With Quote
  #9  
Old 22nd December 2008, 05:12 AM
totalnoob Offline
Registered User
 
Join Date: Dec 2008
Posts: 8
So, I found this: http://lkml.indiana.edu/hypermail/li...2.0/01222.html

Which seems to say that if he recompiles the module with some changes (telling the module that my Belkin usb card is a rtl8187b chipset) then everything works properly.

There are only two problems with this solution:

a) I don't have the development files for the module
b) Even if I did, I'd be too stupid to recompile the module

Can anybody help me out? Perhaps there's a patched, compiled of the module I can get somewhere?

Reply With Quote
  #10  
Old 22nd December 2008, 08:53 AM
totalnoob Offline
Registered User
 
Join Date: Dec 2008
Posts: 8
Holy crud it works

I followed http://ubuntuforums.org/showthread.php?t=1012054

Wow. That only took 11 hours.
Reply With Quote
Reply

Tags
8187b, belkin, chipset, fc9, realtek, running

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with Realtek wireless 8187b and Marvell Yukon 88E8040T noiz354 Hardware & Laptops 2 17th April 2009 05:31 PM
Belkin F5D7000, Realtek 8185 hdensley Servers & Networking 0 1st July 2007 05:10 AM
Realtek 8180 chipset problems pep411 Servers & Networking 0 27th June 2005 06:43 PM


Current GMT-time: 05:42 (Sunday, 20-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat