Fedora Linux Support Community & Resources Center
  #1  
Old 10th December 2008, 09:31 PM
ontognosy Offline
Registered User
 
Join Date: Dec 2008
Posts: 2
SOLVED f10 x86_64 dvd installs, boots to single user prompt

hi there,

just installed Fedora 10 x86_64 from the dvd. install proceeded just fine, but upon boot i get no licences to agree to, no prompt to create a user, etc. i get the plymouth boot (now that i fixed it) and then i'm dropped straight to single user login, text only.

at first if i logged in as root and tried to 'startx' i'd get a no screens found error. then i noticed xorg.conf was blank, so i typed in the default stuff and i could start X. once i'd set up a user i could 'gdm.' but still, upon boot i get text, not gdm.

i noticed that /etc/inittab had only 'id:3:initdefault:' in it, so i changed it to 'id:3:initdefault:5' which as far as i understand should, after the initial boot, boot to gui level (5). but nothing happened.

installed the nvidia driver for my card (geforce 7000m) and when i try to run nvidia-settings i get, "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server." so i run nvidia-xconfig and restart X, which i can normally do, but after running nvidia-xconfig it drops back to text mode and throws an error saying,

gdm-binary[2512]: WARNING: GdmDisplay: display lasted [something] seconds
gdm-binary[2512]: WARNING: GdmDisplay: display lasted [something] seconds
gdm-binary[2512]: WARNING: GdmDisplay: display lasted [something] seconds
gdm-binary[2512]: WARNING: GdmDisplay: display lasted [something] seconds
gdm-binary[2512]: WARNING: GdmDisplay: display lasted [something] seconds
gdm-binary[2512]: WARNING: GdmDisplay: display lasted [something] seconds
gdm-binary[2512]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached . . .

if i try to 'gdm' again i get the same errors, and if i try to 'startx' after that i get back to the same no screens found error. don't know if it's related, it seems like it could be.

just in case, here's dmesg: http://www.hex49.net/random/dmesg.txt
and here's the xorg log file: http://www.hex49.net/random/Xorg.5.log

any ideas? been searching around for a few days now to no avail. thanks!

ONTOS

Last edited by ontognosy; 11th December 2008 at 05:42 PM. Reason: typos :)
Reply With Quote
  #2  
Old 11th December 2008, 05:40 PM
ontognosy Offline
Registered User
 
Join Date: Dec 2008
Posts: 2
Quote:
Originally Posted by ontognosy View Post
i noticed that /etc/inittab had only 'id:3:initdefault:' in it, so i changed it to 'id:3:initdefault:5' which as far as i understand should, after the initial boot, boot to gui level (5). but nothing happened.
oops. disregard this whole mess. in /etc/inittab, 'id:3:initdefault:' should become 'id:5:initdefault:' in order to boot into gui, as per this site: http://fedorasolved.org/post-install-solutions/runlevel, which is tremendously helpful in general.

the problem in the first place was being forced into text mode install and then not knowing what to configure afterward. i ended up reinstalling completely just to get it right, and after reading this: http://www.mjmwired.net/resources/mj...-f10.html#rhgb, i was able to install in graphical mode and everything went very smoothly.

wireless out of the box! f10ftw!

thanks
Reply With Quote
Reply

Tags
boot problem, dvd, f10, install, x86_64

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11 only boots to GRUB> prompt daddio Installation, Upgrades and Live Media 14 27th August 2009 12:15 AM
prompt or not prompt for password depending on user & client powah Security and Privacy 0 21st June 2007 04:28 AM
Keyboard disabled at log in prompt for anything but single user mode xellos Using Fedora 3 21st June 2005 03:13 PM
FC2: Boots to Grub Prompt; won't proceed penguinboy EOL (End Of Life) Versions 3 22nd January 2005 03:43 PM
Fedora boots, but I only get sh, no login prompt lars_eivind Using Fedora 3 5th November 2004 11:24 AM


Current GMT-time: 21:00 (Friday, 19-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin Copyright 2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram