Fedora Linux Support Community & Resources Center
  #1  
Old 8th December 2008, 12:07 AM
bjornp Offline
Registered User
 
Join Date: Dec 2008
Posts: 5
No network connection

I have my heart set on switching from Winbloze to linux, and fedora seems to have everything I want and need with pleasant interface and all. I downloaded the latest live cd to test it out, but couldn't connect to the Internet.

When I started system-config-network (or whatever it's name is) and went to the hardware tab, my NIC is there, as eth0, and some other thing called "pan0". I then checked the devices tab and attempted to create a new device, but it won't let me add an Ethernet device. When I choose Ethernet in the list and press "forward", nothing happens. When I click on the network-icon in the tray and choose "auto eth0", again nothing happens.

Any one able to tell me what to do?

Thanks in advance
Reply With Quote
  #2  
Old 8th December 2008, 12:12 AM
distress Offline
Registered User
 
Join Date: Dec 2008
Posts: 5
Quote:
Originally Posted by bjornp View Post
....
...and some other thing called "pan0".
...
same thing... can't find out what is it... i see it in "Network Configuration" GUI in GNOME.
but eth0 works fine
Reply With Quote
  #3  
Old 10th December 2008, 10:54 PM
bjornp Offline
Registered User
 
Join Date: Dec 2008
Posts: 5
Since I have received no answers, I'll try and give some more detailed information. I decided to go ahead and install from the liveCD to a spare IDE-disk (normally i only run SATA-disks) to be able to experiment a bit more.

The NIC is an integrated RTL 8110/8169-chip on a MSI K8T Neo FISR2 mobo.

I checked /etc/sysconfig/network-scripts/ifcfg-eth0 and found it contained only two lines, mac-address and device=eth0. I added bootproto=dhcp, onboot=yes and type=ethernet after reading other threads on this forum.

I added "alias eth0 r8169" to modprobe.conf which was empty when i checked it. I then issued "modprobe r8169" also after reading other threads on this forum, and restarted the network service.

This is what I got:
Code:
[root@fedora B]# system-config-network 
Error in sys.excepthook:               
Traceback (most recent call last):     
  File "/usr/share/system-config-network/netconfpkg/exception.py", line 363, in <lambda>                                                                        
    progname, version, gui, debug)                                              
  File "/usr/share/system-config-network/netconfpkg/exception.py", line 285, in handleMyException                                                               
    while trace.tb_next:                                                        
AttributeError: 'NoneType' object has no attribute 'tb_next'                    

Original exception was:
ImportError: could not import bonobo.ui
Traceback (most recent call last):     
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 805, in on_activateButton_clicked                                                  
    self.activateButtonFunc[self.active_page](button)                           
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 1021, in on_deviceActivateButton_clicked                                           
    if self.save() != 0:                                                        
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 406, in save                                                                       
    self.appBar.refresh()                                                       
AttributeError: '__main__.GnomeAppBar' object has no attribute 'refresh'
These are screenshots from system-config-network during the error-messages above:

[IMG=http://img248.imageshack.us/my.php?image=systemconfignetworkscrenn2.png"][/IMG]

[IMG=http://img150.imageshack.us/my.php?image=systemconfignetworkscreru2.png][/IMG]

Before I did the changes described above, there was no devices listed in the devices-tab, but both the units listed in the hardware-tab were there. When I tried to add a device, s-c-network didn't let me choose what type of device to add.

Now, any good ideas about why I can't get it to work?

Last edited by bjornp; 10th December 2008 at 10:57 PM.
Reply With Quote
  #4  
Old 10th December 2008, 11:04 PM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Posts: 14,537
Try starting NetworkManager using system-config-services from the command line. There is a menu item for it but it's been troublesome for some users lately. Find it under System > Administration > Services. When you get NetworkManager started there will be an icon in the top panel. Ethernet should be working at this point. If not I believe that you can select it and start it. Haven't used it with wired networking all that much.

I don't believe that you need to create a new device if ETH0 is already showing. Also, from the command line what does /sbin/ifconfig eth0 show? Is there an IP address like 192.168.x.x ??
__________________
Glenn
The Bassinator

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #5  
Old 10th December 2008, 11:54 PM
rclark Online
Registered User
 
Join Date: Nov 2004
Location: here
Posts: 648
Two steps to do.

1) Go to a command prompt window and type ifconfig<enter> May need to be root access.

If there isn't a eth0 listed then

2) type ifup eth0<enter>

This should bring up your network connection. type ifconfig<enter> and you should see the connection up and running. If not then there is something else going on other than activating the connection.

What I had to do after doing above is disable 'NetworkManager' service and enable the 'network' service. Then all is well. System boots and my network connections are active after boot.

Note: To get root access at the command prompt type: su -<enter>
Reply With Quote
  #6  
Old 11th December 2008, 03:02 AM
bjornp Offline
Registered User
 
Join Date: Dec 2008
Posts: 5
glennzo: tried it, but no go. this is the output i get from ifconfig eth0:

Code:
[b@fedora ~]$ /sbin/ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:11:09:95:6F:B6
          inet6 addr: fe80::211:9ff:fe95:6fb6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:11 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:16 Base address:0xa700

[b@fedora ~]$
No ip-address there. A new hardware-device has shown up in NetworkManager though, "virbr0", that does have an ip-address, although not a valid one for my network.

rclark: there is an eth0 listed. I disabled NetworkManager and enabled network service instead, but no go this time either
Reply With Quote
  #7  
Old 11th December 2008, 03:04 AM
bjornp Offline
Registered User
 
Join Date: Dec 2008
Posts: 5
I forgot to mention that before my last post I decided to install from the installer-dvd instead of the live-cd. I'm absolutely determined to get this thing working.

Oh, and I just found out what "virbr0" is, as well as "pan0" that i mentioned in an earlier post.
Reply With Quote
  #8  
Old 11th December 2008, 04:28 AM
doctorwhite Offline
Registered User
 
Join Date: May 2005
Posts: 108
You can't get past the 'Forward' button when adding a connection type? I believe you are missing a package, gnome-python2-bonobo. So do a yum install gnome-python2-bonobo and that should fix it. The installer forgot to add it during your installation.

There has been a bug filed on this issue:https://bugzilla.redhat.com/show_bug.cgi?id=470365
__________________
Fedora 14 x86_64 - Lenovo Thinkpad T400
Reply With Quote
  #9  
Old 11th December 2008, 10:15 AM
glennzo Online
Un-Retired Administrator
 
Join Date: Mar 2004
Location: Salem, Mass USA
Posts: 14,537
Quote:
Originally Posted by bjornp View Post
glennzo: tried it, but no go. this is the output i get from ifconfig eth0:

Code:
[b@fedora ~]$ /sbin/ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:11:09:95:6F:B6
          inet6 addr: fe80::211:9ff:fe95:6fb6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:11 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:16 Base address:0xa700

[b@fedora ~]$
No ip-address there. A new hardware-device has shown up in NetworkManager though, "virbr0", that does have an ip-address, although not a valid one for my network.

rclark: there is an eth0 listed. I disabled NetworkManager and enabled network service instead, but no go this time either
This is all becoming much clearer now. No solution from me, just a confirmation that I had the same issue with a box I was installing Fedora 10 on the other day. I could not for the life of me get eth0 to work no matter what I did. I even changed out the network card and that didn't help. I tried everything I could possibly think of to get it working and finally gave up, grabbed another computer and installed Fedora on it. I'm with doctorwhite in the thinking that the sytstem was missing a package or two. For what it's worth, the computer in question was running Fedora 9 with no ethernet problems what so ever.
__________________
Glenn
The Bassinator

[SIGPIC][/SIGPIC]
Laptop: Toshiba Satellite / Intel Core 2 Duo 1.73 GHz / 2GB / 160GB / Intel Mobile 945GM/GMS/GME/943/940GML Integrated Graphics
Desktop: BioStar MCP6PB M2+ / AMD Phenom 9750 Quad Core / 4GB / 1TB SATA / 500GB SATA / EVGA GeForce 8400 GS 1GB
Reply With Quote
  #10  
Old 11th December 2008, 01:12 PM
bjornp Offline
Registered User
 
Join Date: Dec 2008
Posts: 5
doctorwhite:
Quote:
You can't get past the 'Forward' button when adding a connection type? I believe you are missing a package, gnome-python2-bonobo. So do a yum install gnome-python2-bonobo and that should fix it. The installer forgot to add it during your installation.
Except of course for the fact that yum wants to install from the net, which I can't access And I have no idea how to make it grab the package from the DVD or locally instead :/

glennzo:
Quote:
This is all becoming much clearer now. No solution from me, just a confirmation that I had the same issue with a box I was installing Fedora 10 on the other day. I could not for the life of me get eth0 to work no matter what I did. I even changed out the network card and that didn't help. I tried everything I could possibly think of to get it working and finally gave up, grabbed another computer and installed Fedora on it. I'm with doctorwhite in the thinking that the sytstem was missing a package or two. For what it's worth, the computer in question was running Fedora 9 with no ethernet problems what so ever.
I installed F10 on my girlfriends computer, and it worked perfectly right away. Annoying. Really, really annoying. I'm giving up for now. I've tried Ubuntu, Puppy, OpenSolaris and a few others, and none of them have this problem. So I'll just install Ubuntu for now and keep my eyes open for updates to Fedora.

If I was a girl, I'd be crying now :'(
Reply With Quote
  #11  
Old 11th December 2008, 10:31 PM
cndean Offline
Registered User
 
Join Date: Nov 2008
Location: Columbia, MD
Age: 48
Posts: 1
I'm having a similar problem. I can access the internet and use Firefox and Evolution with no problem. However, the icon up in the top panel shows that the network connection is broken. When I try to do any kind of updates, the computer thinks it's network connection is broken.

When I right-click on the network icon up in the panel, I've deselected/reselected the Enable Networking checkbox several times. When I select it, I get an alert that says "The network connection has been disconnected."

I've tried to update to Fedora 10 (hoping that would fix this problem) but I'm having issues with that, too (I'll post that in a different subject line).
Reply With Quote
  #12  
Old 12th December 2008, 05:30 AM
saa_1973 Offline
Registered User
 
Join Date: May 2005
Posts: 90
I have also had a few hours of hard time getting the network work. The problem I faced was, I could not set the subnetmask address in the system-config-network. What ever value I used to put it used to default it with the gateway address. After spending 4 hours I could manage to get the network by changing the values in /etc/syscong/ne/etc/syscong/networking/devices/ifcfg-eth0 instead. Before doing all this I had disabled NetworkManager from services.

But still I feel something is wrong with network in Fedora 10 as the speed seems to be slow compared with what I had with Fedore 9 earlier.
Reply With Quote
  #13  
Old 26th December 2008, 09:01 PM
PaulNauman Offline
Registered User
 
Join Date: Aug 2007
Posts: 1
Quote:
Originally Posted by doctorwhite View Post
You can't get past the 'Forward' button when adding a connection type? I believe you are missing a package, gnome-python2-bonobo. So do a yum install gnome-python2-bonobo and that should fix it. The installer forgot to add it during your installation.

There has been a bug filed on this issue:https://bugzilla.redhat.com/show_bug.cgi?id=470365
Thank you, I could not get any network configuration changes to "save", I was also getting this error:

system-config-network
Error in sys.excepthook:
Traceback (most recent call last):
File "/usr/share/system-config-network/netconfpkg/exception.py", line 363, in <lambda>
progname, version, gui, debug)
File "/usr/share/system-config-network/netconfpkg/exception.py", line 285, in handleMyException
while trace.tb_next:
AttributeError: 'NoneType' object has no attribute 'tb_next'

Original exception was:
ImportError: could not import bonobo.ui

After I installed gnome-python2-bonobo, everything worked as expected. Thank you
Reply With Quote
  #14  
Old 15th June 2009, 06:51 PM
zridling Offline
Registered User
 
Join Date: Jun 2007
Location: Chicago
Posts: 10
Newbie here. Same problem here with Fedora 11 -- no network connection. I'm running the KDE version from the DVD. Tried

sudo yum install kde-python2-bonobo and
sudo yum install gnome-python2-bonobo

and that didn't work, saying the file wasn't in the "repository metadata (repond.xml)." It also said I wasn't in the Sudoers file, so I tried to fix that, but even after adding my name and parameters to the file, logout/login, it said the file was still in use. Dang!

I'm at a loss. What to do next?
Reply With Quote
  #15  
Old 20th June 2009, 06:32 AM
Murl Offline
Registered User
 
Join Date: Jun 2009
Posts: 1
My problem started with Errno -3. After a text install i was having trouble using yum.
And i ended up here! I and i got my problem solved...
I'm new to linux and i don't know if this will help but it wont hurt trying.

After i saw a post in this topic i entered system-config-network.
Edit a device params > eht0 (eth0) - r8169 >

I added the DNS Servers to this connection. Chose ok > save > save&quit.
ifup eth0
turned on my connection!
Before i tried this i used ifconfig and there was no ip on my eth0 connection it just worked after i did this changes to system-config-network!

Well, i hope it helps =P
Reply With Quote
Reply

Tags
connection, network

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow/Lose Network History Receiving, Network Connection squirtmph Linux Chat 7 20th October 2009 05:16 AM
Network connection has stopped working, Cant activate network, see error msg below... LithiumKid1976 Servers & Networking 11 5th October 2007 09:23 AM
Installing Wireless Network Driver Without a Network Connection??? bcnweb Installation, Upgrades and Live Media 0 10th April 2007 09:30 PM
How do I get my wireless connection to see a hotel network connection margni Using Fedora 7 26th February 2006 11:57 PM
Connection refused until in network connection JJS Servers & Networking 5 2nd November 2004 07:27 PM


Current GMT-time: 21:56 (Wednesday, 16-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin Copyright 2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat