Fedora Linux Support Community & Resources Center
  #1  
Old 7th December 2008, 04:05 PM
coelurus Offline
Registered User
 
Join Date: Dec 2008
Posts: 6
glxgears stutters in Fedora, not in Ubuntu

I'm trying out Fedora 10 as an option to Ubuntu 8.10 on my "workstation" (X2 3GHz, 4GB RAM, GF8600GT) and things have gone pretty well so far. I installed Fedora 10, did the usual hw setup using NVidia drivers from rpmfusion, tried glxgears and got about 4500 FPS but it also stuttered pretty badly. I thought this was kind of low and the stuttering was pretty horrible, so I installed Ubuntu 8.10 and glxgears pumped out 7500 FPS with no stuttering at all, using NVidia drivers from Ubuntu repos. I then reinstalled Fedora 10, because I really would like to get it to work, and needless to say the stuttering is still there.

Obviously, from the FPS, I do not have software rendering on so that's not the problem. I also disabled desktop effects in all test cases. What could cause the stuttering in Fedora, or what could I try to make it go away?
Reply With Quote
  #2  
Old 7th December 2008, 04:28 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
glxgears stutters a little for me with a mobile nvidia 8600GT. It's not the greatest benchmarking tool in the world, try

Code:
yum install glaxium
press f3 to benchmark, if you get several hundred fps then don't worry anymore
Reply With Quote
  #3  
Old 7th December 2008, 04:44 PM
coelurus Offline
Registered User
 
Join Date: Dec 2008
Posts: 6
Everybody tells me glxgears is not a benchmarking tool and I'm very well aware of that, thank you very much

The issue is really very simple: glxgears runs smoothly under Ubuntu but not under Fedora. It's not an issue of cranking out FPS, it's an issue about throughput using the same application. Fedora does something to stop glxgears from performing as well as under Ubuntu, what is this "something"?
Reply With Quote
  #4  
Old 7th December 2008, 05:09 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
Quote:
Originally Posted by coelurus View Post
Everybody tells me glxgears is not a benchmarking tool and I'm very well aware of that, thank you very much

The issue is really very simple: glxgears runs smoothly under Ubuntu but not under Fedora. It's not an issue of cranking out FPS, it's an issue about throughput using the same application. Fedora does something to stop glxgears from performing as well as under Ubuntu, what is this "something"?
Your query is really lame.

You need to come with more info than 'glxgears stutters' to get a useful response. Try posting in bugzilla to the relevant developers section, don't bring attitude here boy.

edit

the point of doing the glaxium benchmark is to see if it's just a glxgears issue, ok?

Last edited by sideways; 7th December 2008 at 05:16 PM.
Reply With Quote
  #5  
Old 7th December 2008, 06:04 PM
coelurus Offline
Registered User
 
Join Date: Dec 2008
Posts: 6
I actually tried a couple of other OpenGL demos before to verify the problem and saw the same thing. But just to be nice, I tried Glaxium. Got the same result, decent frame rate (almost 500) but pretty horrible stuttering.

Oh, and the stuttering occurs even if I use an xterm only session.

The pesky thing with this "bug" is that it's pretty hard to figure out where it comes from and I thought somebody here maybe could have an idea what I should look for.
Reply With Quote
  #6  
Old 7th December 2008, 06:15 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
Quote:
Originally Posted by coelurus View Post
I actually tried a couple of other OpenGL demos before to verify the problem and saw the same thing. But just to be nice, I tried Glaxium. Got the same result, decent frame rate (almost 500) but pretty horrible stuttering.

Oh, and the stuttering occurs even if I use an xterm only session.

The pesky thing with this "bug" is that it's pretty hard to figure out where it comes from and I thought somebody here maybe could have an idea what I should look for.
ok, so you're getting it generally - that's better info Maybe we can determine whether it's a driver issue or related to some fedora specifc setting.

Are you running compiz desktop effects?

post your xorg.conf
Reply With Quote
  #7  
Old 7th December 2008, 06:27 PM
coelurus Offline
Registered User
 
Join Date: Dec 2008
Posts: 6
As I said in my first post, I disabled desktop effects in all tests.

I've tried a whole host of different xorg.conf files, from only having the device section specifying the nvidia driver to having AIGLX, enabling/disabling the composite extension, explicitly specifying module paths, adding a bunch of options to the device section, with no positive results.

For the record, this didn't work:
Code:
Section "Files"
    ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath "/usr/lib/xorg/modules/drivers"
    ModulePath "/usr/lib/xorg/modules"
EndSection
Section "ServerFlags"
    Option "AIGLX" "on"
EndSection
Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    Option "AddARGBGLXVisuals" "True"
EndSection
Section "Extensions"
    Option "Composite" "Enable"
EndSection
Reply With Quote
  #8  
Old 7th December 2008, 06:44 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
Run 'nvidia-settings', is there a different NVIDIA Driver Version than you have in Ubuntu? I have v 177.82 in Fedora 10

Also, does Ubuntu have selinux enabled? That's another possible difference.

And one more difference between Ubuntu and Fedora would be Kernel Mode Setting, try disabling it by appending 'nomodeset' to the kernel line in grub.

also, copy the ubuntu xorg.conf if possible
Reply With Quote
  #9  
Old 7th December 2008, 07:02 PM
coelurus Offline
Registered User
 
Join Date: Dec 2008
Posts: 6
I checked the drivers versions before, they were identical.
I tried with selinux disabled, didn't help.
I tried with "nomodeset" in Grub, didn't help either.

Unfortunately, I did not save the Ubuntu xorg.conf file, but since I used that system fresh just minutes from a complete install, it was probably as empty as it could be, possibly with the extra things that nvidia-xconfig throws in which I also tried in Fedora.

Thanks for your suggestions btw, it would be nice to understand what is causing the problem, considering the heat that this little issue brings forth (not only on these forums ).
Reply With Quote
  #10  
Old 7th December 2008, 07:09 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
Quote:
Originally Posted by coelurus View Post
I checked the drivers versions before, they were identical.
I tried with selinux disabled, didn't help.
I tried with "nomodeset" in Grub, didn't help either.

Unfortunately, I did not save the Ubuntu xorg.conf file, but since I used that system fresh just minutes from a complete install, it was probably as empty as it could be, possibly with the extra things that nvidia-xconfig throws in which I also tried in Fedora.

Thanks for your suggestions btw, it would be nice to understand what is causing the problem, considering the heat that this little issue brings forth (not only on these forums ).
,

Well we've got to pin down the differences between Ubuntu and fedora so you're gonna have to confirm the Ubuntu xorg.conf.

As I've said, I'm also running an nvidia 8600GT (albeit the mobile version) and it works fine in both 32bit and 64bit F10 without any configuration, so your experience seems unlucky.

Problem is, you won't get too much sympathy from the developers since it's a proprietary driver. Did you try the default driver "nv" at all
Reply With Quote
  #11  
Old 7th December 2008, 07:12 PM
brebs Offline
Banned
 
Join Date: Apr 2008
Posts: 558
Here's some threads for further scraps of info:

http://bbs.archlinux.org/viewtopic.php?id=54944
http://bbs.archlinux.org/viewtopic.php?id=56231
http://forums.gentoo.org/viewtopic-t-701119.html

The inter-relationship between the kernel (versions, miscellaneous patches and configuration options), different xorg versions and different nvidia versions is a PITA unfortunately.

All that the imbeciles can say is, "glxgears is not a benchmark, therefore your problem does not exist." Ignore those imbeciles.
Reply With Quote
  #12  
Old 7th December 2008, 07:42 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
Quote:
Originally Posted by brebs View Post

All that the imbeciles can say is, "glxgears is not a benchmark, therefore your problem does not exist." Ignore those imbeciles.
Shutup brebs, If the initial post is so lame then it deserves that sort of response.

Ubuntu is a different OS with a different kernel, different config files.

If something works smooth in Windows but not fedora we're not gonna suggest install windows are we?

If your solution is to install the ubuntu kernel and config files (ie basically make it more like Ubuntu) then suggest that and how to go about it, don't call people imbecile. Or work out the kernel patch that makes it work.

I'm gonna be watching your posts in future, you better be technically accurate or you're gonna getta stevea type drumming down.

Last edited by sideways; 7th December 2008 at 07:45 PM.
Reply With Quote
  #13  
Old 7th December 2008, 07:58 PM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
hoooooooooooooooooooold up everyone. Let's keep it nice when we can.

Firstly, let's focus on the important issue here. Sideways, do you UK people use "gonna" too? I thought that was just on the North American continent.
Ok, to be serious for a moment.....let's all try to not call names, because that's usually the start of a thread deteriorating from interesting and helpful to getting closed.

I don't know if we can handle two stevea's here either.

I'm being a bit whimsical, obviously, but I'm serious. Let's all keep it friendly--as my mom used to say, (and probably still does) if you can't say something nice, don't say anything. (Until she gets mad, Mom's a terror sometimes.)

I would say though, that something working in Ubuntu and not Fedora is common--no, no, just still trying to be funny.

Actually, if something works in Ubuntu and not Fedora, I would think there's a better chance of getting it working in Fedora as well--it's not like something working in Windows but not Linux--there's far less difference.

Anyway, back the to the regularly scheduled program, but please keep it nice.

Thanks to all, from someone who has frequently benefited from posts by both Brebs and Sideways. Also, sideways is the only one who ever rickrolled me, so he will always merit a certain amount of respect from me.

<Goes off into rant about years of Internet surfing and avoiding viruses and malware while in Windows, but no.....he types with a 2 year old on his lap and his avatar is a panda!! A panda fercryinoutloud, who would have suspected.....>

<Senile rant fades away>
Reply With Quote
  #14  
Old 7th December 2008, 08:03 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
scottro, you scare me with just how nice you are, here in England amiability is a lost cause

I'll be good, I promise, just don't call me stupid (see "A Fish called Wanda")

Last edited by sideways; 7th December 2008 at 08:05 PM.
Reply With Quote
  #15  
Old 7th December 2008, 08:28 PM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
Here in the US too. The late Leo Durocher, a baseball manager, (it's sort of like cricket but with round bats) , was once told he wasn't nice. His answer was, "Nice guys finish last," which, unfortunately, has become a bit of an adage in the US.

I *still* want to know about your use of gonna.

As for calling you stupid, well, if *I* call *you* stupid, you can always say, "rickrolled by a stupid person--what does that make you?"

Although as a comedian (I've forgotten who) once said, there are advantages to being stupid, it takes away the responsibility.

What are you, stupid????

Well, errm, yeah. Is that a problem?

(It doesn't work in fights with wives though. As someone once said, and women probably say the same about us, there are two schools of thought in arguing with a woman. Neither one works.)

Still whimsically yours....
Reply With Quote
Reply

Tags
fedora, glxgears, stutters, ubuntu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 9 - sound playback stutters genci Using Fedora 9 14th April 2009 08:49 AM
Dual-boot Ubuntu/XP, Replace Ubuntu w/ Fedora safetycopy Installation, Upgrades and Live Media 20 26th February 2009 09:11 AM
Triple boot option for Fedora 10, Ubuntu 8.10 and Ubuntu 8.04 Wilsonsway Installation, Upgrades and Live Media 20 4th December 2008 04:47 AM
glxgears and glxinfo in fedora core 5? markg85 Using Fedora 6 24th March 2006 06:47 PM
glxgears suse 9.2 and fedora core 3 nkjsat2 Using Fedora 5 3rd April 2005 01:08 PM


Current GMT-time: 20:10 (Sunday, 21-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Mexico Lindo - Parco Castello, Legnano - Myeongdong Photos - Zocalo de la Ciudad de Cuernavaca Travel Photos - Party Bar Shokolad Instagram Photos