Fedora Linux Support Community & Resources Center
  #1  
Old 2nd December 2008, 06:54 PM
bulava Offline
Registered User
 
Join Date: Dec 2008
Posts: 58
Unhappy GRUB woes with FC9 - Multi-boot system

Hi All,

I do use Linux distros regularly along with Solaris and Windows. This is the disk Geometry:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2a642a63

Device Boot Start End Blocks Id System
/dev/sda1 * 1 1958 15727603+ 7 HPFS/NTFS
/dev/sda2 1959 3133 9438187+ bf Solaris
/dev/sda3 3134 9729 52982370 f W95 Ext'd (LBA)
/dev/sda5 3134 3198 522081 82 Linux swap / Solaris
/dev/sda6 3199 4112 7341673+ 83 Linux
/dev/sda7 4113 4765 5245191 83 Linux (PCQLinux, not in the MBR)
/dev/sda8 4766 5548 6289416 83 Linux
/dev/sda9 5549 7115 12586896 83 Linux (FC9, not in the MBR)
/dev/sda10 7116 8159 8385898+ 83 Linux (this OpenSUSE10 & other OSes in MBR)
/dev/sda11 8160 9729 12610993+ 7 HPFS/NTFS


After working a lot with FC8, recently I've downloaded FC9 and installed freshly in:

/dev/sda9 5549 7115 12586896 83 Linux

Strangely, I've got a problem with FC9 as the GRUB throws up the error as bad file or directory blah blah.

Here is the grub.conf and fstab:


title Fedora Core 9 Linux (2.6.25-14.fc9.i686)
root (hd0,8)
kernel /boot/vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=a57acf67-35ed-4ce6-bc88-11809cf33ec1 rhgb quiet
initrd /boot/initrd-2.6.25-14.fc9.i686.img


UUID=a57acf67-35ed-4ce6-bc88-11809cf33ec1 / ext3 defaults 1 1
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
UUID=98fc4ef6-61e1-4df9-a608-df0d3e3717a2 swap swap defaults 0 0


I fail to understand why FC9's GRUB refuses to boot, it never happened to me earlier. Am actually puzzled with this problem

Please provide inputs in this regard.

Thanks,
bulava

Last edited by bulava; 2nd December 2008 at 09:43 PM.
Reply With Quote
  #2  
Old 2nd December 2008, 07:31 PM
arttalbert Offline
Registered User
 
Join Date: Nov 2008
Location: Colorado
Posts: 11
Did you happen to go into grub.conf in the boot dir and see if grub has the address's of the other OS's?


Sorry, I guess now that I read the complete post. You already tried what I would have.

Last edited by arttalbert; 2nd December 2008 at 07:39 PM. Reason: Didn't read the complete post.
Reply With Quote
  #3  
Old 2nd December 2008, 07:39 PM
bulava Offline
Registered User
 
Join Date: Dec 2008
Posts: 58
Quote:
Originally Posted by arttalbert View Post
Did you happen to go into grub.conf in the boot dir and see if grub has the address's of the other OS's?
grub.conf has only Windows entry because I'd chosen it at install time as Default Boot OS. FC9 boot loader i choose to install in that particular disk chunk (dev/sda9), not in the MBR (because to save my existing boot loader).

In the MBR, opensuse boot loader resides (have added here the entries of all the OSes). Since yesterday i fail to understand what's the problem or i've messed it up
Reply With Quote
  #4  
Old 2nd December 2008, 08:01 PM
arvinddeshpande Offline
Registered User
 
Join Date: Jun 2007
Posts: 122
Quote:
Originally Posted by bulava View Post

title Fedora Core 9 Linux (2.6.25-14.fc9.i686)
root (hd0,8)
kernel /boot/vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=a57acf67-35ed-4ce6-bc88-11809cf33ec1 rhgb quiet
initrd /boot/initrd-2.6.25-14.fc9.i686.img

Thanks,
bulava
Can you try changing
kernel /boot/vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=a57acf67-35ed-4ce6-bc88-11809cf33ec1 rhgb quiet
to
kernel /vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=a57acf67-35ed-4ce6-bc88-11809cf33ec1 rhgb quiet

And
initrd /boot/initrd-2.6.25-14.fc9.i686.img
to
initrd /initrd-2.6.25-14.fc9.i686.img

I read /etc/grub.conf and it says all locations are relative to /boot.

HTH
Reply With Quote
  #5  
Old 2nd December 2008, 08:18 PM
bulava Offline
Registered User
 
Join Date: Dec 2008
Posts: 58
Quote:
Originally Posted by arvinddeshpande View Post
I read /etc/grub.conf and it says all locations are relative to /boot.
HTH
Yep, tried that but no use. Still the same Error 2: Bad file or directory type.

I suspect OpenSUSE10 GRUB in the MBR (stage 1.5) not passing the FC9 GRUB parameters rightly to the underlying FC9 OS (sda9), unable to figure it out the problem.
Reply With Quote
  #6  
Old 2nd December 2008, 08:26 PM
arvinddeshpande Offline
Registered User
 
Join Date: Jun 2007
Posts: 122
So you do see FC9 when you boot up your system, right?
If you scroll to the FC9 menu and type 'e' it takes you to the lines that you have in your grub.
Those lines look ok to you?
Also you can type boot to try to boot in the same grub screen.
I am somehow sure that there is a typo involved as far as Opensuse grub.conf is concerned
Reply With Quote
  #7  
Old 2nd December 2008, 08:36 PM
bulava Offline
Registered User
 
Join Date: Dec 2008
Posts: 58
Quote:
Originally Posted by arvinddeshpande View Post
So you do see FC9 when you boot up your system, right?
If you scroll to the FC9 menu and type 'e' it takes you to the lines that you have in your grub.
Those lines look ok to you?
Also you can type boot to try to boot in the same grub screen.
I am somehow sure that there is a typo involved as far as Opensuse grub.conf is concerned
Nopes, I see only OpenSUSE10.3 GRUB (that's how specifically i've made this desktop). Earlier I used to run FC8 very nicely, added the GRUB boot parameters into the OpenSUSE grub menu.lst. That's how I run all the OSes by selecting from the OpenSUSE GRUB screen. Example, choosing FC8 or Solaris and so on).

Check this grub.conf trny of FC8:

title Fedora (2.6.26-Tualatin)
root (hd0,8)
kernel /boot/vmlinuz-2.6.26-Tualatin ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.26-Tualatin.img

If you see in that entry, there's a LABEL in the FC8.

and, so on....in the grub.conf of FC8


title Windows XP Professional - SP2
rootnoverify (hd0,0)
chainloader +1
title KUbuntu KDE version - 7.10
rootnoverify (hd0,5)
chainloader +1
title PCLinuxOS 2007 Final
rootnoverify (hd0,6)
chainloader +1
title Sun Solaris x86 - Dev. Express
rootnoverify (hd0,1)
chainloader +1
title Sabayon 3.4 KDE Mini Edition
rootnoverify (hd0,7)
chainloader +1
Reply With Quote
  #8  
Old 2nd December 2008, 08:41 PM
bulava Offline
Registered User
 
Join Date: Dec 2008
Posts: 58
Quote:
Originally Posted by arvinddeshpande View Post
If you scroll to the FC9 menu and type 'e' it takes you to the lines that you have in your grub.
Those lines look ok to you?
Also you can type boot to try to boot in the same grub screen.
Yep, I've tried using 'e' and 'b' options from the GRUB console of FC9 (after passing through the OpenSUSE GRUB). Still unable this figure it out what to try out next.

I know we can do grubinstall from the rescue disk feature but me don't wanna do that to protect the existing OpenSUSE GRUB, fear it might get erased (and that's why I've installed FC9 boot loader into that particular hard disk slice).
Reply With Quote
  #9  
Old 2nd December 2008, 10:10 PM
lynnevan Offline
Registered User
 
Join Date: May 2005
Location: boise,id
Age: 73
Posts: 92
Although this might just duplicate some of what you've already tried, you might try this script from Mandriva (copy it to your suse /boot/grub dir): name it "install.sh" -
Code:
grub --device-map=/boot/grub/device.map --batch <<EOF
root (hd0,5)
setup --stage2=/boot/grub/stage2 (hd0)
quit
EOF
It will re-write your suse menu.lst to the mbr. Change the "root (0,5)" to (I think in your case) "root (0,9)" and make sure yr device.map is correct. Then run
Code:
sh install.sh
This is my menu.lst from Mandriva:
Code:
timeout 15
color black/cyan yellow/cyan
gfxmenu (hd0,5)/boot/gfxmenu
default 0

title Fedora (Sulphur)
root (hd0,0)
configfile /boot/grub/menu.lst

title openSUSE 11.0 (i586)
root (hd0,1)
configfile /boot/grub/menu.lst

title Ubuntu 8.10
root (hd0,2)
configfile /boot/grub/menu.lst

title linux
kernel (hd0,5)/boot/vmlinuz BOOT_IMAGE=linux root=LABEL=mandi resume=UUID=f1ebbbd7-cc7c-4426-b2ea-0776324112a7 splash=silent vga=788
initrd (hd0,5)/boot/initrd.img

title linux-nonfb
kernel (hd0,5)/boot/vmlinuz BOOT_IMAGE=linux-nonfb root=LABEL=mandi resume=UUID=f1ebbbd7-cc7c-4426-b2ea-0776324112a7
initrd (hd0,5)/boot/initrd.img

title failsafe
kernel (hd0,5)/boot/vmlinuz BOOT_IMAGE=failsafe root=LABEL=mandi failsafe
initrd (hd0,5)/boot/initrd.img
I'm also curious to know what you get if you run
Code:
df -h
Does it show fc9 in the proper place? Can you mount it and "cd" into it?

Just a few ideas.

luck

lynnevan
Reply With Quote
  #10  
Old 3rd December 2008, 02:54 PM
bulava Offline
Registered User
 
Join Date: Dec 2008
Posts: 58
Quote:
Originally Posted by lynnevan View Post
Although this might just duplicate some of what you've already tried, you might try this script from Mandriva (copy it to your suse /boot/grub dir): name it "install.sh" -

I'm also curious to know what you get if you run
Code:
df -h
Does it show fc9 in the proper place? Can you mount it and "cd" into it?
lynnevan
I haven't tried install.sh yet, do have the those lines in the menu.lst of OpenSUSE. This is the entry of FC9 in the OpenSUSE menu.lst:

default 6
timeout 8
gfxmenu (hd0,9)/boot/message

title Fedora Core 9 Linux - 2.6.25-14.fc9.i686
root (hd0,8)
kernel /boot/vmlinuz-2.6.25-14.fc9.i686 root=UUID=a57acf67-35ed-4ce6-bc88-11809cf33ec1 rhgb quiet
initrd /boot/initrd-2.6.25-14.fc9.i686.img

(also tried booting by removing UUID parameter and replacing with device, /dev/hda9)

All partitions are mounted except Solaris from OpenSUSE's fstab:


/dev/disk/by-id/scsi-SATA_ST380215A_6QZ142WK-part10 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST380215A_6QZ142WK-part5 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0

# /dev/sda2 /mnt/Solaris ext3 defaults 0 0

/dev/sda1 /mnt/WinXP_C ntfs-3g rw,defaults,umask=0000 0 0
/dev/sda11 /mnt/WinXP_D ntfs-3g rw,defaults,umask=0000 0 0

/dev/sda6 /mnt/KUbuntu ext3 defaults 0 0
/dev/sda7 /mnt/PCLinuxOS ext3 defaults 0 0
/dev/sda8 /mnt/Sabayon ext3 defaults 0 0
/dev/sda9 /mnt/FC9 ext3 defaults 0 0


Obviously I can see the mounted FC9. Here is the df -h

Filesystem Size Used Avail Use% Mounted on
/dev/sda10 7.9G 2.3G 5.3G 30% /
udev 252M 124K 252M 1% /dev
/dev/sda1 15G 11G 4.9G 68% /mnt/WinXP_C
/dev/sda11 13G 12G 867M 93% /mnt/WinXP_D
/dev/sda6 6.9G 3.0G 3.7G 45% /mnt/KUbuntu
/dev/sda7 5.0G 2.9G 1.8G 62% /mnt/PCLinuxOS
/dev/sda8 5.9G 3.0G 2.6G 55% /mnt/Sabayon
/dev/sda9 12G 4.7G 6.7G 42% /mnt/FC9


Sill I couldn't able to figure it out where am going wrong or is there anything wrong with my FC9 installation (which I don't think so). Not getting any clue
Reply With Quote
  #11  
Old 3rd December 2008, 03:34 PM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
Quote:
Originally Posted by bulava

I fail to understand why FC9's GRUB refuses to boot, it never happened to me earlier.
Quote:
Originally Posted by bulava

Error 2: Bad file or directory type.
Quote:
Originally Posted by bulava

FC9 boot loader i choose to install in that particular disk chunk (dev/sda9), not in the MBR (because to save my existing boot loader).
Quote:
Originally Posted by bulava

In the MBR, opensuse boot loader resides (have added here the entries of all the OSes).
That right there is probably why.

Hello bulava,

Fedora 9 was the first Fedora version to create file systems with 256-byte inodes in preparation for the coming transition to the ext4 file system. Last summer, this issue surfaced when people discovered that they sometimes could not boot Fedora 9 with the GRUB of earlier versions of Fedora or other distros. It all had to do with the grub package which was eventually patched for this inode issue with grub-0.97-21. So if the version of the grub package in the system that you are using to boot Fedora 9 is earlier than grub-0.97-21, then you need to update its grub package. But even after you update its grub package, you also have to re-install its GRUB boot loader for it to make any difference with this inode issue booting Fedora 9.

An alternative is to use the chainloader command to boot Fedora 9 from the old version of GRUB. I found that the 256-byte inode issue does not affect the chainloader command because it does not involve finding a file in the file system. It merely loads and executes the boot sector code.

You can read more about this incident last summer in another thread here.



P.S.: Someday this will stop coming up as the last traces of grub packages older than v0.97-21 gradually disappear. For now though, it is still happening every now and then..

Last edited by stoat; 3rd December 2008 at 05:55 PM.
Reply With Quote
  #12  
Old 3rd December 2008, 06:20 PM
bulava Offline
Registered User
 
Join Date: Dec 2008
Posts: 58
Quote:
Originally Posted by stoat View Post
An alternative is to use the chainloader command to boot Fedora 9 from the old version of GRUB. I found that the 256-byte inode issue does not affect the chainloader command because it does not involve finding a file in the file system. It merely loads and executes the boot sector code.
Hi stoat,

Thank you very much for this new input

OK. What you mean is since I've installed FC9 boot loader in that particular disk slice (/dev/sda9), so I need to add chainloader+1 to the FC9 boot loader.

Something like this:

title Fedora Core 9 Linux - 2.6.25-14.fc9.i686
root (hd0,8)
kernel /boot/vmlinuz-2.6.25-14.fc9.i686 root=UUID=a57acf67-35ed-4ce6-bc88-11809cf33ec1 rhgb quiet
initrd /boot/initrd-2.6.25-14.fc9.i686.img
chainloader +1

Isn't it Please correct me...thanks.
Reply With Quote
  #13  
Old 3rd December 2008, 06:54 PM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
Quote:
Originally Posted by bulava

OK. What you mean is since I've installed FC9 boot loader in that particular disk slice (/dev/sda9), so I need to add chainloader+1 to the FC9 boot loader.

Something like this:

title Fedora Core 9 Linux - 2.6.25-14.fc9.i686
root (hd0,8)
kernel /boot/vmlinuz-2.6.25-14.fc9.i686 root=UUID=a57acf67-35ed-4ce6-bc88-11809cf33ec1 rhgb quiet
initrd /boot/initrd-2.6.25-14.fc9.i686.img
chainloader +1
Using the chainloader GRUB menu command to boot F9 is a simple alternative to updating the openSUSE grub package and re-installing its GRUB boot loader. In my experiments with this last summer, the chainloader command worked to boot Fedora 9 even from the GRUB boot loader of an older system using an older version of grub that was not patched for this 256-byte inode issue. I predict that the chainloader GRUB menu command will work in the openSUSE menu.lst to boot your Fedora 9 system. But it should look simply like this in the openSUSE menu.lst...
Code:
title Fedora 9
chainloader (hd0,8)+1
It should work if you installed Fedora 9's GRUB in the first sector of the Fedora boot partition, and if you are right about it being (hd0,8).

Last edited by stoat; 3rd December 2008 at 07:08 PM.
Reply With Quote
  #14  
Old 3rd December 2008, 07:41 PM
bulava Offline
Registered User
 
Join Date: Dec 2008
Posts: 58
Quote:
Originally Posted by stoat View Post
the chainloader command worked to boot Fedora 9 even from the GRUB boot loader of an older system using an older version of grub that was not patched for this 256-byte inode issue. I predict that the chainloader GRUB menu command will work in the openSUSE menu.lst to boot your Fedora 9 system.

It should work if you installed Fedora 9's GRUB in the first sector of the Fedora boot partition, and if you are right about it being (hd0,8).
At last, after so many days, this problem got solved

First, after passing through the OpenSUSE boot screen, I did hit the FC9 boot after adding new line (chainloader +1). But this failed FC9 to boot. So, I've realized that let me try the other way around with the OpenSUSE GRUB. That's it, FC9 baby started rolling in

You are correct, all I did just added these lines into the OpenSUSE GRUB:

title Fedora Core 9 Linux - 2.6.25-14.fc9.i686
rootnoverify (hd0,9)
chainloader (hd0,8)+1

Also please suggest should I need to repeat the same step with FC10 too (will install in by end of Jan 2009 or so)

Anyway it was an annoying experience for me, thank you very much to everyone out there
Reply With Quote
  #15  
Old 3rd December 2008, 08:07 PM
arvinddeshpande Offline
Registered User
 
Join Date: Jun 2007
Posts: 122
Just check up the grub version. If it is already updated in FC-10 you should be all right, right?
Glad it worked for you finally. And I learned something too.....
Reply With Quote
Reply

Tags
fc9, grub, multiboot, woes

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The multi-OS, multi-boot GRUB guide (Windows included!) Firewing1 Guides & Solutions (No Questions) 35 14th July 2009 08:03 AM
adding fedora 7 grub to multi boot system terry_g Using Fedora 1 16th August 2007 03:44 PM
GRUB Multi boot FC5 & FC6 cplutis EOL (End Of Life) Versions 13 24th January 2007 09:48 AM
grub multi boot terry_g Installation, Upgrades and Live Media 0 1st October 2006 04:00 PM


Current GMT-time: 02:22 (Thursday, 21-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat