Fedora Linux Support Community & Resources Center
  #1  
Old 1st December 2008, 03:27 AM
tsangcn Offline
Registered User
 
Join Date: Apr 2005
Posts: 70
Unable to automount USB Storage after Fedora 10 Upgrade

After upgrading from Fedora 9 to Fedora 10 (using DVD) on my Thinkpad X61, external USB storage will no longer automatically mount. But I can mount them manually using the mount or halevt-mount command. So far I have tried flash disks, external hard disk, and external DVD burner. They mount automatically when I inserted them in Fedora 9 but not in Fedora 10.

I found this thread of similar issue http://forums.fedoraforum.org/showthread.php?t=135961

But the information was around FC6 and not so relevant. So I start a new thread.

Does anyone have any recommendations?
Reply With Quote
  #2  
Old 3rd December 2008, 08:30 AM
tsangcn Offline
Registered User
 
Join Date: Apr 2005
Posts: 70
Hi, I found that the automount I was using last time in Fedora 9 was a function of GNOME. But it seems that it is disabled in Fedora 10. I can found the labels of the partitions in my USB drive in Places --> Removable Media. And when I put the mouse pointer over the label, the help message showing "mount" that label. But when I click on the label, nothing happened.

Is this a bug in GNOME ?
Reply With Quote
  #3  
Old 3rd December 2008, 06:58 PM
chl Offline
Registered User
 
Join Date: Apr 2006
Location: Los Angeles
Posts: 4
FYI: I'm seeing the exact same behaviour as tsangcn. I see the drive in Places -> Removable Media, but clicking on it doesn't mount it. I have to find it using fdisk -l and then mount it manually as root (which is annoying). Note this is with selinux totally disabled if that matters. When I manually mount it to /media/disk (or /media/<anything>) then it does pop up on the Gnome desktop.

Hoping this is a bug and that it'll get fixed soon.
Reply With Quote
  #4  
Old 3rd December 2008, 09:47 PM
chl Offline
Registered User
 
Join Date: Apr 2006
Location: Los Angeles
Posts: 4
I also note that putting a CD ROM in the CD drive doesn't bring anything up. Again, it shows up in Places -> Removable Media, but clicking on it doesn't do anything and I can't access it. So it appears this is a more generic problem than just USB drives.

Does anybody know if there's a bugzilla bug for this? I looked but didn't find one. Should we open one?
Reply With Quote
  #5  
Old 4th December 2008, 07:59 AM
enciam Offline
Registered User
 
Join Date: Sep 2006
Posts: 11
Quote:
Originally Posted by chl View Post
I also note that putting a CD ROM in the CD drive doesn't bring anything up. Again, it shows up in Places -> Removable Media, but clicking on it doesn't do anything and I can't access it. So it appears this is a more generic problem than just USB drives.

Does anybody know if there's a bugzilla bug for this? I looked but didn't find one. Should we open one?
I have the same problem
Reply With Quote
  #6  
Old 4th December 2008, 11:21 AM
youknowwho Offline
Registered User
 
Join Date: Nov 2008
Posts: 21
Well, there's something that seemed to worked out for me, and that was back up the data from the USB storage device, and then formate it with an FAT 32 file system. Then, when I stick the USB storage device, Fedora automounts it, try it, it may work, and as far as CD's go, I have no idea, those get perfectly mounted for me.
Hope it helps.
Reply With Quote
  #7  
Old 5th December 2008, 07:28 AM
tsangcn Offline
Registered User
 
Join Date: Apr 2005
Posts: 70
Thanks YouKnowWho, but my hard disk was ext3 format and I have lots of data in it. It is impossible to format it to FAT32. Besides, I don't like FAT32 or NTFS format.

I think this is a bug in Gnome and need to be fixed.
Reply With Quote
  #8  
Old 5th December 2008, 09:25 PM
fpm1703 Offline
Registered User
 
Join Date: Dec 2008
Posts: 1
This worked for me. From the Gnome desktop:
System -> Preferences -> System -> Authorizations -> Hal -> Storage -> "Mount file systems from external drives".
Edit "Console" under "Implicit Authorizations" and change "No" to "Yes".
Reply With Quote
  #9  
Old 7th December 2008, 01:43 PM
tsangcn Offline
Registered User
 
Join Date: Apr 2005
Posts: 70
Thanks fpm1703. Your solution worked for me.
Reply With Quote
  #10  
Old 10th December 2008, 05:06 PM
enciam Offline
Registered User
 
Join Date: Sep 2006
Posts: 11
This solution doesn't work for me :-(

Any other option?

Quote:
Originally Posted by tsangcn View Post
Thanks fpm1703. Your solution worked for me.
Reply With Quote
  #11  
Old 10th December 2008, 06:22 PM
kirikokis Offline
Registered User
 
Join Date: Sep 2008
Posts: 25
Quote:
Originally Posted by fpm1703 View Post
This worked for me. From the Gnome desktop:
System -> Preferences -> System -> Authorizations -> Hal -> Storage -> "Mount file systems from external drives".
Edit "Console" under "Implicit Authorizations" and change "No" to "Yes".

Ok, can anyone explain it how to make this from the console? Because it doesn't change as a user.
Thank you!
Reply With Quote
  #12  
Old 10th December 2008, 10:17 PM
kirikokis Offline
Registered User
 
Join Date: Sep 2008
Posts: 25
Quote:
Originally Posted by kirikokis View Post
Ok, can anyone explain it how to make this from the console? Because it doesn't change as a user.
Thank you!
Noone knows?
Reply With Quote
  #13  
Old 21st January 2009, 12:14 PM
vladbr Offline
Registered User
 
Join Date: Jan 2009
Posts: 1
You can use the comand gnome-volume-properties
Reply With Quote
  #14  
Old 22nd January 2009, 10:18 AM
tsangcn Offline
Registered User
 
Join Date: Apr 2005
Posts: 70
There is nothing in the gnome-volume-properties about external hard drives.
Reply With Quote
  #15  
Old 28th January 2009, 12:24 AM
MissyB Offline
Registered User
 
Join Date: Oct 2008
Location: UK
Posts: 16
A few hours ago I updated to kernel version 2.6.27.12-170.2.5.fc10.i686 . Then I lost usb automount.

lsusb shows:

Bus 001 Device 007: ID 0951:1603 Kingston Technology Data Traveler 1GB/2GB Pen Drive

However I do know how to translate this into mounting it.

Does anyone have any suggestions pls??
Reply With Quote
Reply

Tags
automount, fedora, storage, unable, upgrade, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boots into TTY1 and won't automount Mass storage Device barf Using Fedora 2 29th June 2009 10:08 PM
Unable to automount USB Storage after FC6 Upgrade Whip-lash Hardware & Laptops 54 11th April 2008 10:48 PM
Ipod will not automount after upgrade to Fedora 7 nitroblast Hardware & Laptops 7 24th July 2007 10:20 PM


Current GMT-time: 03:44 (Tuesday, 27-06-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat