Fedora Linux Support Community & Resources Center
  #1  
Old 28th November 2008, 07:28 AM
yogeshnachnani Offline
Registered User
 
Join Date: Nov 2008
Posts: 8
Exclamation Cannot install in Graphical Mode, Forced into Text mode, an stuck with text mode!!

Hi ppl, i have an Acer Aspire 4530 laptop - AMD Athlon X2 64 bit processor and an Nvidia 9100 M chipset.
(this is one of the latest acer models)

Now, i tried installing Fedora core 8 on this lappy, but it could not detect my Hard drive or my CD/DVD drive.
I figured that probably the installation DVD does not have the necessary drivers for my hard disk and CD/DVD drive

I turned to fedora 10 (i had heard bad reviews of F9) because i thot this one might have the necessary drivers

after the preliminaries, it showed me the message "Running anaconda (.....)

then, my screen goes off for a sec and then comes back, with a message saying X server initialization failed (or something like that, dont remember the exact words)

Then, having no other choice, i finished my installation through the text mode thinking that my Nvidia graphic card driver was not supported, and i would intsall that later using the livna repo.

After my install, F10 booted in text mode (not surprising)
what actually happened is that when it comes to "Starting udev :", the screen switches off for a moment and then i see the message "Starting udev : ^@"
and then, it proceeds to boot in text mode
(now i know that after getting the message Starting udev, the boot should goto graphical mode, but IT DOESNT)

then, using rpmfusion (still in text mode) , i installed the nvidia graphic drivers. I finished installation, then rebooted.. but it doesnt help!!! im still stuck with text mode.
During boot, it also gives the message "enabling nvidia driver : nvidia driver already enabled" but if the driver is enabled, why not goto graphic mode?????

When i boot(in text mode), it obvi gives me the login screen

i logged in as root(since no other user is setup) and tried using the startx command
It works and im immediately taken to graphics mode
But it loads the graphics pretty slowly.. almost takes 6-7 seconds, besides i can SEE it repaint the dektop everytime i try to open a new window

My problem is : WILL I HAVE TO CONTINUE LOGGING IN TEXT MODE AND THEN GOTO GRAPHICS ENVIORNMENT??
BESIDES, THE GRAPHICS PERFOMANCE IS REALLY NOT UPTO THE MARK, I CAN SEE THE DESKTOP BEING REPAINTED.!!

please help me out, what do i do?? is there a way to get thro to graphics enviornment directly? i have a feeling it'll increase graphic performance bec i wont be starting xserver manually.. kindly help me..

P.s : i downloaded the ISO of the DVD for i386, but in my grub loader it says i686.f10 .. is there a problem?? did i download the wrong dvd??

Last edited by yogeshnachnani; 28th November 2008 at 07:30 AM. Reason: Forgot to mention a small thing :-)
Reply With Quote
  #2  
Old 28th November 2008, 02:29 PM
yogeshnachnani Offline
Registered User
 
Join Date: Nov 2008
Posts: 8
does no1 have any suggestions??
Reply With Quote
  #3  
Old 29th November 2008, 04:45 AM
yogeshnachnani Offline
Registered User
 
Join Date: Nov 2008
Posts: 8
guess i'll just install Ubuntu
Reply With Quote
  #4  
Old 29th November 2008, 05:13 AM
furrito Offline
Registered User
 
Join Date: Nov 2008
Location: California, USA
Posts: 18
[QUOTE=P.s : i downloaded the ISO of the DVD for i386, but in my grub loader it says i686.f10 .. is there a problem?? did i download the wrong dvd??[/QUOTE]

You have the correct DVD. i396, i486, i586, i686 are all the same (32 bit) arch. I don't really know what the differences are, though.

I have a similar laptop, Acer 5520 and F10 does not install in graphical mode for me, either. I wanted to do a fresh install but ended up upgrading my existing F9 with the DVD.
Reply With Quote
  #5  
Old 29th November 2008, 05:59 AM
yogeshnachnani Offline
Registered User
 
Join Date: Nov 2008
Posts: 8
thanx for replying furrito.. guess i'll have to install F9 and then upgrade to F10.. but the thing is, i donno if i'll be able to run f9 either.. bec my graphic card might not be supported by F9... think i'll try that
Reply With Quote
  #6  
Old 29th November 2008, 06:19 AM
furrito Offline
Registered User
 
Join Date: Nov 2008
Location: California, USA
Posts: 18
Hey, best of luck! I was personally happy with F9 64 bit. It's much better now than when it first came out. For me, there's very little difference between F9 and F10.
Reply With Quote
  #7  
Old 11th December 2008, 12:31 PM
DrewP Offline
Registered User
 
Join Date: Mar 2008
Location: France
Posts: 70
To make your computer boot direct to graphics mode edit /etc/inittab

Change the line:
id:3:initdefault:

To:
id:5:initdefault:

If you need step by step instructions see step 7 of this entry:

http://forums.fedoraforum.org/showthread.php?t=207320
Reply With Quote
  #8  
Old 12th December 2008, 08:41 AM
mhungry Offline
Registered User
 
Join Date: Dec 2008
Posts: 6
try this...

Try adding xdriver=vesa to the initial screen when the CD first boots.

Select Install, hit tab, and add that command. I had to do this with ubuntu too. x doesn't like my radeon 4870 too much.

Here's where that info can be found, and other helpful commands:
http://docs.fedoraproject.org/instal...ns-hwdetection

BWS
Reply With Quote
  #9  
Old 12th December 2008, 02:33 PM
furrito Offline
Registered User
 
Join Date: Nov 2008
Location: California, USA
Posts: 18
Quote:
Originally Posted by mhungry View Post
Try adding xdriver=vesa to the initial screen when the CD first boots.

Select Install, hit tab, and add that command. I had to do this with ubuntu too. x doesn't like my radeon 4870 too much.

Here's where that info can be found, and other helpful commands:
http://docs.fedoraproject.org/instal...ns-hwdetection

BWS
I knew there had to be something you could add to grub. Do you know if firstboot still runs after installing with the vesa driver? That's the only hurdle I've been having.
Reply With Quote
  #10  
Old 13th December 2008, 09:36 AM
mhungry Offline
Registered User
 
Join Date: Dec 2008
Posts: 6
firstboot

Yes, firstboot runs just fine. The xdriver=vesa command simply forces X.org to use the standard VESA-compliant video driver, rather than whatever it thinks it should be running instead... which.. as we've seen... can be far from the right one. Part of the issue here is that the graphical configuration runs on top of X, but there are no X configuration files on the DVD/CDs (Live, x64, x86, doesn't matter which, they all have the error). That means X is left to it's own devices to attempt to probe the hardware for the right drivers. Well... the latest X versions seem to have a hell of a time figuring this out, and get it wrong more often than they get it right. It's really a problem with X, not with Fedora or Ubuntu or whatever other linux flavors are having this issue. However, that said, Linux vendors would do well to incorporate a "Safe Graphics Mode Install" option by default. Ubuntu actually does do this (you hit F4 on their installations), and the same option allows you to pick textmode without having to resort to knowing a bunch of obscure command line options.

Last edited by mhungry; 13th December 2008 at 09:43 AM.
Reply With Quote
  #11  
Old 1st February 2009, 06:17 PM
subimal Offline
Registered User
 
Join Date: Aug 2006
Posts: 3
With FC10 You need to install nvidia's driver. Get it from

http://www.nvidia.com/object/linux_d...32_180.22.html

Boot your system (in the text mode) and install the driver. Reboot. Your system will be fine.
Reply With Quote
  #12  
Old 1st February 2009, 06:23 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,062
Quote:
Originally Posted by subimal View Post
With FC10 You need to install nvidia's driver. Get it from

http://www.nvidia.com/object/linux_d...32_180.22.html

Boot your system (in the text mode) and install the driver. Reboot. Your system will be fine.
No Do not use the nvidia binary driver, use the rpmfusion rpm for Nvidia:

http://forums.fedoraforum.org/showthread.php?t=204752
http://www.mjmwired.net/resources/mj...idia_rpmfusion

using the rpmfusion allows you to track the driver via the package manager and you
can install akmod-nvidia so that each time the kernel is updated, the video driver is automatically rebuilt.
(if you also have the kernel-devel package set to update). This is way handier than slogging through with re-getting the
nvidia driver from nvidia's site

Last edited by marko; 1st February 2009 at 06:26 PM.
Reply With Quote
  #13  
Old 2nd February 2009, 02:52 AM
mhungry Offline
Registered User
 
Join Date: Dec 2008
Posts: 6
There's a better way to force it into vesa mode without going into text mode that I found. It should've be an available option from the getgo. Suse had no issues like this; Ubuntu had the issue, but they provided a builtin choice to bypass into vesa compliance on the boot menu.

Your suggestions are great... except that i'm not running an nVidia card. I'm running an ATI 4870. And i'm running a 64 bit install, so 32 bit drivers do me no good. Thanks for the try though. :P
Reply With Quote
  #14  
Old 10th February 2009, 06:29 PM
subimal Offline
Registered User
 
Join Date: Aug 2006
Posts: 3
marko and mhungry are right. The nvidia link provides the beta driver. rpmfusion will keep track of the changes. Suse boots well while Ubuntu 8.10(even FC8, FC9 and Debian) refuses to recognize the cd/dvd drive after showing the initial boot options.

My reply was for the Acer Aspire 4530 model that yogeshnachnani spoke about. I got the driver from the link I posted. It recompiled the module(in the absence of internet connectivity). I'm using the 32-bit version of FC10. It is working absolutely fine for me, but for sure, marko's advice is better.
Reply With Quote
  #15  
Old 11th February 2009, 06:57 AM
wt6g Offline
Registered User
 
Join Date: Jun 2005
Posts: 179
I had the same problem and fixed it by hitting tab when the install screen came up, and adding:

linux xdriver=vesa nousbstorage

to the end of the line. It comes up and works, but the max video mode is 1280x1024 until you install the right driver.

Beware that FC10 will force a disk check and not tell you about it. If it seems to be hanging hit F1 and you'll see what it's doing. My disk had been mounted 42 times without a disk check so it ran one on my large hard drives.

Also during the install if it loads the PAE kernel, which is 50MB it seems to take a very long time...like its hung, but its not.

Finally, I found that FC9 had an issue when my bios was in "failsafe" mode. I changed to "optimized" defaults and everything was fine. Don't know if this has any effect on FC10, but thought I'd mention it.

/Len Umina
WT6G
__________________
Len Umina
El Dorado Hills, CA
WT6G
Reply With Quote
Reply

Tags
graphics driver issue, install issue, laptop

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stuck in text mode after updates installed tke1now Using Fedora 2 14th August 2008 03:05 PM
How to convert FC installed in text mode to graphical mode vnykr Alpha - Beta (Fedora 9 Only) 2 2nd May 2008 08:38 AM
Fedora text mode to GUI mode problem - Help -! koolbuddy4u Using Fedora 0 28th March 2008 11:13 AM
Can't install monitor, forced to use text mode... fpoole Installation, Upgrades and Live Media 14 19th July 2005 02:47 PM
Change boot to text mode from graphic mode qhasxeem Installation, Upgrades and Live Media 1 10th July 2004 02:33 AM


Current GMT-time: 08:00 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Bagnolet - Silverdale Photos - Vrangel Instagram Photos