Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #91  
Old 21st December 2008, 01:11 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by simta View Post
i keep getting the following errors everytime i try to install the nvidia drivers,

Code:
  --> Missing Dependency: python(abi) = 2.6 is needed by package livna-config-display-0.0.22-2.fc11.noarch (rpmfusion-nonfree-rawhide)         

Error: Missing Dependency: system-release >= 10.90 is needed by package rpmfusion-nonfree-release-10.90-1.noarch (rpmfusion-nonfree-rawhide)
how do i fix this?

Why are you trying to install the rawhide release key ?

.

Last edited by leigh123linux; 21st December 2008 at 01:17 PM.
  #92  
Old 21st December 2008, 04:22 PM
simta Offline
Registered User
 
Join Date: Nov 2008
Location: uk
Posts: 35
the errors were thrown up when trying to go through your command list, i did a full reinstall and went through again and everything is fine now
  #93  
Old 22nd December 2008, 02:14 AM
beaker_ Offline
Registered User
 
Join Date: Nov 2008
Location: Canada
Posts: 2,400
Hi Subinfinity

Forgive me but I think your problem is a blank screen or thin line. I'm not an expert but here's what I've run into wrt 1280x1024 resolution (your 17" monitor); try adding nomodeset or vga=ask, then select your resolution, to grub's configuration. I have a 1280x1024 lcd monitor that won't fly without vga=0x31B or vga=0x317, I also have a 1440x900 monitor who won't fly without nomodeset and I believe they're plymouth issues (I'm sure someone will correct me).

good luck
  #94  
Old 23rd December 2008, 04:46 AM
Demz
Guest
 
Posts: n/a
Nvidia Driver Update ftp://download.nvidia.com/XFree86/Linux-x86/180.18/ & ftp://download.nvidia.com/XFree86/Linux-x86_64/180.18/

wonder if they'll have these drivers ready before new years
  #95  
Old 23rd December 2008, 12:06 PM
jonathonp Offline
Registered User
 
Join Date: Oct 2006
Location: Melbourne
Age: 43
Posts: 532
EDIT: the nvidia driver in ubuntu did not work either. maybe the card is faulty.


i have tried all 3 Nvidia drivers for a Nvidia-GeForce 420 (toshiba) graphics card.

None of them work. I assume the following driver is the correct one but it hangs everytime:

yum install kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx-libs


I checked the driver support list and the card is supported by nvidia. If i can't find a fix then i will try ubuntu.

Last edited by jonathonp; 30th December 2008 at 10:02 AM.
  #96  
Old 24th December 2008, 01:30 AM
psyklops Offline
Registered User
 
Join Date: Apr 2005
Posts: 346
Hi All,

Just need to confirm the 'upgrade' procedure to the new 177.xx driver.

I'm currently running fedora 9 with the following nvidia modules:
Code:
# rpm -qa | grep -i nvidia
xorg-x11-drv-nvidia-libs-173.14.15-2.fc9.x86_64
xorg-x11-drv-nvidia-173.14.15-2.fc9.x86_64
kmod-nvidia-173.14.15-1.fc9.7.x86_64
kmod-nvidia-2.6.26.6-79.fc9.x86_64-173.14.12-6.fc9.2.x86_64
xorg-x11-drv-nvidia-libs-173.14.15-2.fc9.i386
kmod-nvidia-2.6.27.5-41.fc9.x86_64-173.14.15-1.fc9.6.x86_64
kmod-nvidia-2.6.27.7-53.fc9.x86_64-173.14.15-1.fc9.7.x86_64
I'm running an nVidia 8800 GTS as per:
Code:
$/sbin/lspci -nn | grep 'VGA\|NV'
01:00.0 VGA compatible controller [0300]: nVidia Corporation G80 [GeForce 8800 GTS] [10de:0193] (rev a2)
with kernel
Code:
uname -r
2.6.27.7-53.fc9.x86_64
Is it simply a matter of removing the existing nvidia components with a:
Code:
1. yum erase *nvidia*
...and then installing as per leighs message?:
Quote:
Code:
su
rpm -Uvh http://www.lordmorgul.net/pub/fedora/rpmfusion/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm http://www.lordmorgul.net/pub/fedora/rpmfusion/free/fedora/rpmfusion-free-release-stable.noarch.rpm
yum install kmod-nvidia-newest xorg-x11-drv-nvidia-newest-libs.i386 xorg-x11-drv-nvidia-newest-libs.x86_64
reboot
  #97  
Old 29th December 2008, 11:48 AM
seashell Offline
Registered User
 
Join Date: Dec 2008
Posts: 1
nvidia driver support

Hi - I'm trying to install the appropriate drivers for FC 10 for my nvidia 6800 ultra card, but the kmod-nvidia packages don't appear to be available - any idea how or where I might find them?

cheers
-manwyddan
  #98  
Old 29th December 2008, 02:30 PM
blueskynis Offline
Registered User
 
Join Date: Jun 2008
Location: Serbia, Nis
Age: 31
Posts: 36
Quote:
Originally Posted by seashell View Post
Hi - I'm trying to install the appropriate drivers for FC 10 for my nvidia 6800 ultra card, but the kmod-nvidia packages don't appear to be available - any idea how or where I might find them?

cheers
-manwyddan
You probably didn't add RPMfusion repositories, look at the first post of this thread.
__________________
=========================================
  #99  
Old 30th December 2008, 04:29 PM
liquidfunk Offline
Registered User
 
Join Date: Mar 2007
Location: Middle of Uk
Posts: 46
I'm just trying to update my drivers to the current version, I've done the:-

Code:
 yum install akmod-nvidia-newest xorg-x11-drv-nvidia-newest-libs.i386 xorg-x11-drv-nvidia-newest-libs.x86_64
But all I get in response is: -

Code:
 Resolving Dependencies
--> Running transaction check
---> Package akmod-nvidia-newest.x86_64 0:177.82-1.fc9.2 set to be updated
--> Processing Dependency: nvidia-newest-kmod-common >= 177.82 for package: akmod-nvidia-newest
---> Package xorg-x11-drv-nvidia-newest-libs.i386 0:177.82-1.fc9 set to be updated
---> Package xorg-x11-drv-nvidia-newest-libs.x86_64 0:177.82-1.fc9 set to be updated
--> Running transaction check
---> Package xorg-x11-drv-nvidia-newest.x86_64 0:177.82-1.fc9 set to be updated
--> Processing Conflict: xorg-x11-drv-nvidia conflicts xorg-x11-drv-nvidia-newest
--> Processing Conflict: xorg-x11-drv-nvidia-newest conflicts xorg-x11-drv-nvidia
--> Finished Dependency Resolution
xorg-x11-drv-nvidia-newest-177.82-1.fc9.x86_64 from rpmfusion-nonfree-updates has depsolving problems
  --> xorg-x11-drv-nvidia-newest conflicts with xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-173.14.15-2.fc9.x86_64 from installed has depsolving problems
  --> xorg-x11-drv-nvidia conflicts with xorg-x11-drv-nvidia-newest
Error: xorg-x11-drv-nvidia-newest conflicts with xorg-x11-drv-nvidia
Error: xorg-x11-drv-nvidia conflicts with xorg-x11-drv-nvidia-newest
[root@localhost josh]#

Ideas?
__________________
-[Discipline] - Macbook Pro 5,3 - Intel Core2Duo 2.66Ghz, 4Gb RAM, Nvidia 9400M + 9600GT, 320Gb HDD, Mac OSX 10.6 Snow Leopard / Fedora 13
-Windows free since May 2007.
  #100  
Old 30th December 2008, 05:06 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by liquidfunk View Post
I'm just trying to update my drivers to the current version, I've done the:-

Code:
 yum install akmod-nvidia-newest xorg-x11-drv-nvidia-newest-libs.i386 xorg-x11-drv-nvidia-newest-libs.x86_64
But all I get in response is: -

Code:
 Resolving Dependencies
--> Running transaction check
---> Package akmod-nvidia-newest.x86_64 0:177.82-1.fc9.2 set to be updated
--> Processing Dependency: nvidia-newest-kmod-common >= 177.82 for package: akmod-nvidia-newest
---> Package xorg-x11-drv-nvidia-newest-libs.i386 0:177.82-1.fc9 set to be updated
---> Package xorg-x11-drv-nvidia-newest-libs.x86_64 0:177.82-1.fc9 set to be updated
--> Running transaction check
---> Package xorg-x11-drv-nvidia-newest.x86_64 0:177.82-1.fc9 set to be updated
--> Processing Conflict: xorg-x11-drv-nvidia conflicts xorg-x11-drv-nvidia-newest
--> Processing Conflict: xorg-x11-drv-nvidia-newest conflicts xorg-x11-drv-nvidia
--> Finished Dependency Resolution
xorg-x11-drv-nvidia-newest-177.82-1.fc9.x86_64 from rpmfusion-nonfree-updates has depsolving problems
  --> xorg-x11-drv-nvidia-newest conflicts with xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-173.14.15-2.fc9.x86_64 from installed has depsolving problems
  --> xorg-x11-drv-nvidia conflicts with xorg-x11-drv-nvidia-newest
Error: xorg-x11-drv-nvidia-newest conflicts with xorg-x11-drv-nvidia
Error: xorg-x11-drv-nvidia conflicts with xorg-x11-drv-nvidia-newest
[root@localhost josh]#

Ideas?

Post

Code:
rpm -qa |grep nvidia
  #101  
Old 30th December 2008, 05:24 PM
liquidfunk Offline
Registered User
 
Join Date: Mar 2007
Location: Middle of Uk
Posts: 46
Code:
[josh@localhost ~]$ rpm -qa |grep nvidia
kmod-nvidia-2.6.27.9-73.fc9.x86_64-173.14.15-1.fc9.8.x86_64
xorg-x11-drv-nvidia-libs-173.14.15-2.fc9.i386
xorg-x11-drv-nvidia-173.14.15-2.fc9.x86_64
akmod-nvidia-173.14.15-1.fc9.5.x86_64
kmod-nvidia-173.14.15-1.fc9.8.x86_64
xorg-x11-drv-nvidia-libs-173.14.15-2.fc9.x86_64
kmod-nvidia-2.6.27.7-53.fc9.x86_64-173.14.15-1.fc9.7.x86_64
kmod-nvidia-2.6.27.5-41.fc9.x86_64-173.14.15-1.fc9.6.x86_64
[josh@localhost ~]$
__________________
-[Discipline] - Macbook Pro 5,3 - Intel Core2Duo 2.66Ghz, 4Gb RAM, Nvidia 9400M + 9600GT, 320Gb HDD, Mac OSX 10.6 Snow Leopard / Fedora 13
-Windows free since May 2007.
  #102  
Old 30th December 2008, 05:35 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by liquidfunk View Post
Code:
[josh@localhost ~]$ rpm -qa |grep nvidia
kmod-nvidia-2.6.27.9-73.fc9.x86_64-173.14.15-1.fc9.8.x86_64
xorg-x11-drv-nvidia-libs-173.14.15-2.fc9.i386
xorg-x11-drv-nvidia-173.14.15-2.fc9.x86_64
akmod-nvidia-173.14.15-1.fc9.5.x86_64
kmod-nvidia-173.14.15-1.fc9.8.x86_64
xorg-x11-drv-nvidia-libs-173.14.15-2.fc9.x86_64
kmod-nvidia-2.6.27.7-53.fc9.x86_64-173.14.15-1.fc9.7.x86_64
kmod-nvidia-2.6.27.5-41.fc9.x86_64-173.14.15-1.fc9.6.x86_64
[josh@localhost ~]$

Try


Code:
su
yum erase *nvidia* -y
yum install akmod-nvidia-newest xorg-x11-drv-nvidia-newest-libs.i386 xorg-x11-drv-nvidia-newest-libs.x86_64 -y
  #103  
Old 30th December 2008, 05:45 PM
liquidfunk Offline
Registered User
 
Join Date: Mar 2007
Location: Middle of Uk
Posts: 46
Now I lose the ability to use Compiz and Emerald?
__________________
-[Discipline] - Macbook Pro 5,3 - Intel Core2Duo 2.66Ghz, 4Gb RAM, Nvidia 9400M + 9600GT, 320Gb HDD, Mac OSX 10.6 Snow Leopard / Fedora 13
-Windows free since May 2007.
  #104  
Old 30th December 2008, 06:06 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by liquidfunk View Post
Now I lose the ability to use Compiz and Emerald?

Did you reboot?


post

Code:
cat /etc/X11/xorg.conf

and


Code:
glxinfo |grep direct
  #105  
Old 30th December 2008, 06:08 PM
liquidfunk Offline
Registered User
 
Join Date: Mar 2007
Location: Middle of Uk
Posts: 46
I did reboot, and it built the modules. I can use everything else fine, apart from Compiz and emerald.


Code:
[josh@localhost ~]$ cat /etc/X11/xorg.conf
# Xorg configuration created by livna-config-display

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib64/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib64/xorg/modules/drivers"
	ModulePath   "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "gb"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	Option	    "Coolbits" "1"
	Option	    "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection

[josh@localhost ~]$ glxinfo |grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
[josh@localhost ~]$
Thanks so much for helping!
__________________
-[Discipline] - Macbook Pro 5,3 - Intel Core2Duo 2.66Ghz, 4Gb RAM, Nvidia 9400M + 9600GT, 320Gb HDD, Mac OSX 10.6 Snow Leopard / Fedora 13
-Windows free since May 2007.
Closed Thread

Tags
drivers, fedora 14, fedora 15, fedora 16, guide, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rescue after failed nvidia driver install? restore nouveau or basic video driver? Icm76 Using Fedora 11 14th January 2012 03:23 AM
Nvidia set up guides. sepoto Using Fedora 2 5th March 2011 05:11 AM
nVidia Driver Guides & Autoten: Thanks! Hobashira Fedora Focus 0 12th November 2010 07:29 AM
msi n220gt series not working with Nvidia driver guides top of page davidvandoren Hardware & Laptops 0 7th September 2010 06:52 PM
FC11 nVidia No Sound After RPMFusion nVidia Driver Load basimmer Using Fedora 0 16th October 2009 12:46 AM


Current GMT-time: 18:58 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Khalandrion Travel Photos on Instagram - Haiti - Markala