Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > The Dungeon > Archived (Click Header To See Sub-Forums) > Alpha, Beta & Snapshots Discussions (Fedora 10 Only)
FedoraForum Search

Forgot Password? Join Us!

Alpha, Beta & Snapshots Discussions (Fedora 10 Only) Post Development Version comments and questions that don't belong in Bugzilla here. These posts will be moved or deleted once the Final version is released

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 14th November 2008, 07:29 PM
its4mreddy Offline
Registered User
 
Join Date: Mar 2006
Posts: 19
Unhappy FATAL: Error inserting fglrx

I have installed ati 8.11 driver from ATI website and installed the *.run file. It installed well with build return code 0. I have checked the /usr/share/ati/fglrx-install.log and found to run make-install file fro, /lib/modules/fglrx. And on running the script I am getting the error

FATAL: Error inserting fglrx (/lib/modules/2.6.27.5-109.fc10.x86_64/kernel/drivers/char/drm/fglrx.ko): Operation not permitted

My fedora 9 is working like charm with ati 8.11 driver, but fedora 10 is with blank screen with a system hang.

Your help is much appreciated on this.

Thanks,
Satish
  #2  
Old 14th November 2008, 07:35 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,292
The error message seems to indicate that you do not have permission to load the FGLRX kmod. Try executing as root user.

V
  #3  
Old 14th November 2008, 07:38 PM
its4mreddy Offline
Registered User
 
Join Date: Mar 2006
Posts: 19
I carried out all the installation and executed all commands as root. I googled about this error, i found some links of this error for older ati drivers, but did not find any steps to fix.
  #4  
Old 14th November 2008, 08:07 PM
BobNutfield Offline
Registered User
 
Join Date: May 2008
Location: United Kingdom
Posts: 90
I was about to start a new thread, but this thread and another one today seems to answer my question. I too have been waiting for FGLRX to work in F10 for weeks now. The best I have been able to determine is that the most recent FGLRX (8.5) does not work with Xorg 1.5 which is what is installed with F10. It was driving me crazy trying to figure out why the driver shows up for download in the Add/Remove software for the lastest kernels, but wil not work.

Apparently this is still the case. FGLRX does not work with this version of Xorg.
  #5  
Old 14th November 2008, 08:27 PM
its4mreddy Offline
Registered User
 
Join Date: Mar 2006
Posts: 19
if it is the case why it is working (along with compiz cube) in my f9, its also having the Xorg 1.5 like f10. I believe, it is something else that is causing the issue.... a blank screen in f10... I even copied the xorg.conf from f9 to f10....

This is driving me crazy... I cant use my compiz in f10, the open source ati driver is too slow to run compiz and restarts the X many times
  #6  
Old 14th November 2008, 08:44 PM
BobNutfield Offline
Registered User
 
Join Date: May 2008
Location: United Kingdom
Posts: 90
Well, I know I could be wrong, but I have not yet seen anyone post an experience with a working FGLRX in F10,
  #7  
Old 14th November 2008, 10:00 PM
its4mreddy Offline
Registered User
 
Join Date: Mar 2006
Posts: 19
I too really surprised on this.. no ATI user dared to install f10 cause of fglrx mess....! Hope some masterminds will throw some light on at ati 8.11 driver installation for f10...
 

Tags
error, fatal, fglrx, inserting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FATAL: Error inserting padlock_sha with 2.6.29.5-191 kernel jwmueller Using Fedora 13 8th June 2011 08:16 PM
Madwifi error: FATAL: Error inserting ath_pci bluedragontao Servers & Networking 6 27th February 2008 08:08 PM
Error inserting freq_table fpschill Hardware & Laptops 5 8th March 2007 01:04 AM
need help on Fatal: error inserting acpi_cpufreq ... No such device diamond Using Fedora 13 2nd March 2006 12:56 PM
FATAL: Error inserting ndiswrapper h00ty Servers & Networking 2 3rd May 2005 09:22 AM


Current GMT-time: 11:19 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat