Fedora Linux Support Community & Resources Center
  #1  
Old 10th November 2008, 03:25 AM
djmwj Offline
Registered User
 
Join Date: Nov 2008
Posts: 8
Fedora 10 Sound Issues

Using Fedora 10, the sound will cut in and out randomly and there is alot of sound artifacting. I am usind a SB live sound card and pulseaudio. The sound card works fine with pulseasudio in other distros, but having trouble in fedora 10. Is there any configuration that can be done? I am using fedora 10 64 bit. I know they changed the way pulseaudio works in this verison to avoid such issues. Has this solution not been implemented yet in the preview?

It appears that the artifacting and sound cutting is much less noticible when i added my user to the group pulse-rt so pulse could run at a higher priority

Last edited by Demz; 10th November 2008 at 08:02 AM. Reason: added more info
Reply With Quote
  #2  
Old 10th November 2008, 07:51 AM
interele Offline
Registered User
 
Join Date: Sep 2006
Posts: 45
Fedora 10 Sound Issues

Interesting - I have a Sound Blaster too

I have the beta of F10 at work ( with Intel sound chips ) and it is fine ??

I will experiment today and post any earth shattering news ;-)

M
Reply With Quote
  #3  
Old 10th November 2008, 05:53 PM
djmwj Offline
Registered User
 
Join Date: Nov 2008
Posts: 8
I decided to try and use the config files from a ubuntu install for pulseaudio on the fedora system, however it had no noticeable difference. I wonder why it works perfect in ubuntu and yet stumbles all over itself in fedora.... they are the same engine aren't they?
Reply With Quote
  #4  
Old 10th November 2008, 06:21 PM
interele Offline
Registered User
 
Join Date: Sep 2006
Posts: 45
Fedora 10 Sound Issues

As far as I know Suse 11 uses pulse audio and thats what I had on this machines a few
days ago and it was OK

I tried taking the sound blaster out of the machines but Fedora 10 didn't recognise the on
board sound card and I couldn't work out how to reconfigure it manually

Unfortunately, work was most inconsiderate today and they insisted I do things
vaguely work related so I didn't get a chance to experiment

My work PC dual boots to F10 and that has the Beta with a Intel on board sound
card and that works fine - I'll dig out a soundblaster and see if I can make it go la la

M
Reply With Quote
  #5  
Old 10th November 2008, 06:40 PM
djmwj Offline
Registered User
 
Join Date: Nov 2008
Posts: 8
my configuration includes two different sound cards, one sound blaster and one Nvidia onboard. Both have the same artifacting and choppy audio. so i wonder if my problem is beyond just pulse if it is not sound card specific....i have no idea... i had this problem in ubuntu gutsy.... but its been a long time and ubuntu has fixed whatever the problem was in all subsequent verisions. thanks for the help, let me know how things go
Reply With Quote
  #6  
Old 10th November 2008, 07:01 PM
interele Offline
Registered User
 
Join Date: Sep 2006
Posts: 45
I think I might have fixed it

The fact that openSuse worked made me think So I went to openSuse
and they have a link to the pulse audio site

http://pulseaudio.org/wiki/PerfectSetup

I did the install the utils bit and the load modules bit

re booted and everything seems to work

OK I confess I'm not quite sure what that does but at least I can watch
flash stuff now

regards

M
Reply With Quote
  #7  
Old 10th November 2008, 07:20 PM
hiberphoptik Offline
Registered User
 
Join Date: Apr 2004
Posts: 1,186
i ge the choppy or cut outs with sound too on an nviida sound chipset... happens if i choose Alsa or pulse for my sound engine.. seems to happen with only wave files because watching a movie in mplayer or making a call in skype does not have this issue, but skype sound effects or pidgin sound effect are messy
Reply With Quote
  #8  
Old 13th November 2008, 02:02 AM
djmwj Offline
Registered User
 
Join Date: Nov 2008
Posts: 8
I have been messing with the pulse config file /etc/daemon.conf specifically the default fragments and fragment size.... initially it seemed to help but after installing updates it is bad again. here is my current config:

# $Id: daemon.conf.in 2175 2008-03-27 23:39:10Z lennart $
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values a commented out. Use either ; or # for
## commenting.

; daemonize = no
; fail = yes
; disallow-module-loading = no
; use-pid-file = yes
; system-instance = no
; disable-shm = no
shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; high-priority = yes
nice-level = -11

realtime-scheduling = yes
realtime-priority = 5

exit-idle-time = -1
; module-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; default-script-file =

; log-target = auto
; log-level = notice

resample-method = speex-float-3
; disable-remixing = no
disable-lfe-remixing = yes

; no-cpu-limit = no

; rlimit-as = -1
; rlimit-core = -1
; rlimit-data = -1
; rlimit-fsize = -1
; rlimit-nofile = 256
; rlimit-stack = -1
; rlimit-nproc = -1
; rlimit-memlock = -1
; rlimit-nice = 31
; rlimit-rtprio = 9

; default-sample-format = s16le
default-sample-rate = 48000
; default-sample-channels = 2

default-fragments = 8
default-fragment-size-msec = 10
Reply With Quote
  #9  
Old 15th November 2008, 12:51 PM
interele Offline
Registered User
 
Join Date: Sep 2006
Posts: 45
Have you tried KDE - For me when KDE is running pulseaudio
doesn't work so KDE falls back to talking to the sound card
and the sound is perfect

It will tell if pulseaudio is really the culprit

M
Reply With Quote
  #10  
Old 15th November 2008, 01:10 PM
leigh123linux Online
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,109
This bug report maybe of interest.

https://bugzilla.redhat.com/show_bug.cgi?id=469335



Code:
polkit-gnome-authorization
then add yourself to pulseaudio real time and high priority
__________________
https://admin.fedoraproject.org/pkgdb/users/packages/leigh123linux

https://badges.fedoraproject.org/user/leigh123linux

Last edited by leigh123linux; 15th November 2008 at 01:32 PM.
Reply With Quote
  #11  
Old 17th November 2008, 06:01 PM
ultra magnus Offline
Registered User
 
Join Date: Nov 2007
Location: Finland
Age: 31
Posts: 313
Seems to have fixed the issue, Thanks.
Correction: audio is less choppy, but still ... chops? Just not as often.
Audigy2 zs soundcard here

Last edited by ultra magnus; 17th November 2008 at 06:04 PM.
Reply With Quote
  #12  
Old 17th November 2008, 06:40 PM
neat Offline
Registered User
 
Join Date: Nov 2008
Posts: 8
I have the same problems with f10 KDE audigy2 ZS and pulseaudio. Sometimes very lagy whens playing mp3s.
Never had this before in fc8 and fc9.
Reply With Quote
  #13  
Old 17th November 2008, 07:04 PM
leigh123linux Online
Retired Administrator
 
Join Date: Oct 2006
Posts: 22,109
Quote:
Originally Posted by ultra magnus View Post
Seems to have fixed the issue, Thanks.
Correction: audio is less choppy, but still ... chops? Just not as often.
Audigy2 zs soundcard here

I have a SB live sound card affected by this problem , the above fix reduced the problem for me .
I am still looking a solution
__________________
https://admin.fedoraproject.org/pkgdb/users/packages/leigh123linux

https://badges.fedoraproject.org/user/leigh123linux
Reply With Quote
  #14  
Old 21st November 2008, 10:15 PM
interele Offline
Registered User
 
Join Date: Sep 2006
Posts: 45
Interestingly, this now happens on opensuse 11.1 beta 5
the fix from the pulse audio site I posted earlier works
on opensuse too

M
Reply With Quote
  #15  
Old 22nd November 2008, 11:42 PM
bharat211 Offline
Registered User
 
Join Date: Jun 2005
Posts: 90
I've got the same problem. I tried Leigh's tip, but wasn't of much help. The choppiness remains.
__________________
"No word is true until it is eaten" - 36 Lessons of Vivec, Sermon 27
Reply With Quote
Reply

Tags
fedora, issues, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Sound Issues AnimeFreak Using Fedora 6 2nd March 2009 08:34 PM
Fedora 8 issues with sound on laptop Prospect Hardware & Laptops 1 30th May 2008 05:51 AM
GlQuake (Quake 1) Sound issues in Fedora 7 thx11384eb Gamers' Lounge 1 10th September 2007 07:26 PM
FC4 Sound Issues From FC3 surfingdude41 EOL (End Of Life) Versions 1 18th June 2005 08:49 PM


Current GMT-time: 09:31 (Saturday, 19-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat