Fedora Linux Support Community & Resources Center
  #1  
Old 9th November 2008, 12:17 PM
axelmangr Offline
Registered User
 
Join Date: Nov 2004
Posts: 29
extremely slow first boot of fedora 9

Hi all,

a few days ago I installed at my laptop the fedora 9. Everything was ok. I decided to upgrade the desktop as well. The desktop is a Pentium 4 3GHz with 3 GB of RAM. The installation has now problem at all. But when I take the dvd out and reboot, the first boot is extremely slow. The first services start ok, but at the end (after cups or near them) the situation is horrible. Once I let it finish. It took more than 30 minutes. I finally got the login screen (KDE) but logging in was impossible. The thing is that I don't know what to do. Where to start looking. I would appreciate any help.

thanx
/axelmangr
Reply With Quote
  #2  
Old 9th November 2008, 02:48 PM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
What's happening during boot? It's probably having trouble with something or another. (Doh).
I would boot into runlevel 3 (just add a "3", without the quotes, to the end of the kernel line in grub. Then, look at the messages while it boots and see where it hangs.

(Also, while editing, temporarily remove the rhgb and quiet from the kernel line.)
Hopefully, it's only hanging on one thing which will give clues on where to start troubleshooting.

If you're not familiar on how to edit the grub line when the system boots, do a quick google, there are tutorials all over the place--in short, you'll hit e as in edit when the menu shows, use the arrow key to get to the kernel line and hit e again. Then you'll be able to backspace out the rhgb and quiet and also put in the 3.

That will boot you into text mode, so don't worry about X not starting. I'm guessing the problem begins before KDE starts. If it boots right away and brings you to a prompt saying login (just a console) that's fine, then you know that the problem starts with X.
Reply With Quote
  #3  
Old 9th November 2008, 02:56 PM
axelmangr Offline
Registered User
 
Join Date: Nov 2004
Posts: 29
thanx for the quick reply. But I don't think it's kde fault. If I wait long enough KDE starts. I get to the login screen. I can enter username and password. But then I have to wait for more. The longest I did was two hours. The task bar loaded without any apps. Brobably if I could wait a bit more it would load but I think this is irrational. In any case I ll boot it in run level 3 and let you know
Reply With Quote
  #4  
Old 9th November 2008, 03:30 PM
axelmangr Offline
Registered User
 
Join Date: Nov 2004
Posts: 29
All services run fine. Even if I start in level 5 all services take the normal time to start. The delay now starts from the last service until kde initializes. It needs 30 mins or more to get the login screen. I checked dmesg and /var/log/messages and nothing looked suspicious (although something could be there and I didn't see it .
Reply With Quote
  #5  
Old 9th November 2008, 09:51 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 5,997
I'm looking at a "rawhide" Fedora so it might not be exactly like Fedora 9, but the only two services started after cups for runlevel 5 are anacron and rc.local (which isn't really a service but a script that's for putting stuff that should be run dead last).

So maybe there's a problem with anacron ?

Another good idea, when you get to the login screen, instead of logging into the full desktop, try to go to a virtual terminal and run top to see if something is running out of control:

press Alt + Ctrl + F1 which goes to the 1st console and log in as your normal user, then run

top

the first line will be the highest %CPU user

Last edited by marko; 9th November 2008 at 09:55 PM.
Reply With Quote
  #6  
Old 9th November 2008, 10:25 PM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
Just for fun.
Boot into runlevel 3.
Log in as yourself.

See if you have an .xinitrc file--you might or might, I don't know if the default installation gives it to you. (Note the dot in front of the name, it's a hidden file.)
If you don't, do


echo 'exec startkde' >> .xinitrc

Then type

startx

See if that also takes forever.
Reply With Quote
  #7  
Old 10th November 2008, 08:38 AM
axelmangr Offline
Registered User
 
Join Date: Nov 2004
Posts: 29
Hi,

I am at work at the moment so I can't try out the things that you suggested, but I'll give them a shot at the afternoon.

However, there are a few new things I noticed yesterday:
a) It takes forever to boot at runlevel 5. Finally it boots (after a couple of hours) and even opening a terminal is very slow
b) It takes forever to boot at runlevel 3. Finally it does. Then I can startx but the situation is as above
c) I can boot at runlevel 2 normally. Then I can startx normally. Working inside kde is without problems. Everything is normal (as far as I can see)

If I remember correctly the difference between runlevel 2 and 3 is the networking. Also runlevel 5 is the same as runlevel 3 with X. Thus, I was led to the conclusion that there is something wrong with networking. So I booted at runlevel 5. After a few hours, when kde had started, the network was operational. I even updated a few things with yum. Which ruled out my theory of problem with networking.

As far as the services after cups are concerned, I really don't think that there's something wrong with them, since now, whatever runlevel I choose, they all start up normally.

I checked dmesg and /var/log/messages and didn't see anything suspicious. Also top didn't show anything that was occupying more than 10% of cpu

Before I go back at home any other advice I should pay attention to?

Just to point out again, that from the same dvd I installed fedora 9 at my laptop a few weeks ago and everything worked swell.

thanx again for the prompt responses

/axelmangr

Last edited by axelmangr; 10th November 2008 at 08:43 AM.
Reply With Quote
  #8  
Old 10th November 2008, 02:46 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 5,997
It sounds like what you really should do is reboot, then in the grub menu edit the kernel line to add a
'1' to the end (no quotes). This will make it boot to single user with all the services including networking stripped to a minimum. When it gets to the console login, login as root user and do:


init 3

so the system will go from RL 1 to RL 3 and watch the services as they start. The init scripts should report to the display each success and failure, note down what those are. Probably one of those is the problem because you said even level 3 will hang for quite a while. So you'll probably get a long pause and then

Starting blah blah [FAILED]


That should point out the problem service
Reply With Quote
  #9  
Old 10th November 2008, 02:53 PM
axelmangr Offline
Registered User
 
Join Date: Nov 2004
Posts: 29
I've already done that. Maybe I mislead you. When I enter RL3 all services start normally. It takes about 10-15 seconds. When the last service starts successfully (I think it's anacron but I am not so sure) then I am directed to a terminal with a login prompt. Then even if I hit the user name I get no password callback for 10 or so minutes. And when I hit the password I get the varification after a long time. So, services start all [OK] but after the last service starts until I login it takes forever. That's what I meant. Sorry if I mislead you
Reply With Quote
  #10  
Old 10th November 2008, 09:31 PM
axelmangr Offline
Registered User
 
Join Date: Nov 2004
Posts: 29
The situation is horrible. As I said there is no problem booting at runlevel 2. From there I enter as root and then start the runlevel 5. Everything is swell (apart from the mouse which stops responding and I unplug it and plug it to a new usb port) I am updating the system from yum as we speak (from laptop). The thing is that if I let grub boot normally it takes for ever. The situation as mentioned in my second post remains as is. Services load ok in whatever level, but kde takes forever.
I am a bit lost here. Any help?

thanx
/axel
Reply With Quote
  #11  
Old 10th November 2008, 10:44 PM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 46
Posts: 3,936
i have a similar problem if i install fedora with IP6 turned on and enabled during the install .
if i leave this on then boot level 2,3,5 takes 2 hours for EVERYTHING to time out .
but your system is a laptop ( right?) so it may be this or the wireless card you have
__________________
OpenSUSE 13.1-64bit & Scientific Linux 6.5-64bit ( fedora 4 to 11) and 19/20 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10
Reply With Quote
  #12  
Old 11th November 2008, 01:05 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 5,997
Sounds like a kdm problem and not kde, what if you bypass kdm by going to rulevel 3, then
run startx directly?

You can setup startx easily by using yum to install 'switchdesk' then run switchdesk:
Quote:
su -
<root password>
yum install switchdesk
exit
(back to normal user here)
Quote:
switchdesk kde
startx
This way works around kdm

Another thing to check is make sure the 'lo' loopback interface is setup
correctly. The lo interface is used for X and if not working correctly you can
get poor performance. The lo interface should have address 127.0.0.1,
should not have lots of errors, drops or overruns (see these statistics with
"ifconfig lo" )
Reply With Quote
  #13  
Old 11th November 2008, 07:34 AM
axelmangr Offline
Registered User
 
Join Date: Nov 2004
Posts: 29
Quote:
Originally Posted by JohnVV View Post
but your system is a laptop ( right?) so it may be this or the wireless card you have
Nope, it's a desktop (Pentium 4, eGHz, 1.5 GB RAM). I had no problem installing Fedora 9 from the same medium at my laptop a few days ago
Reply With Quote
  #14  
Old 11th November 2008, 07:42 AM
axelmangr Offline
Registered User
 
Join Date: Nov 2004
Posts: 29
lo reports:

Code:
Link encap:Local Loopback
Inet addr:127.0.0.1 Mask:255.0.0.0
Inet addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU 16436 Metric:1
PX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txtqueuelen:0
PX bytes:(0.0 b) TX bytes(0.0 b)
I don't quite get how this can be the source of the problem since I have installed from the same dvd the same distribution at my laptop and faced no problem.

Regarding level 3, it is impossible to boot into it. If I change grubs boot parameters and boot into level 3 then although services start up fine at the expected amount of time I am directed into a login console. There although I write my username and hit enter, it disappears and it takes forever to relaunch the login console. After a couple of hours, when I can finally login I can startx but everything is very slow. I checked for error messages but could not identify something hardcore.

But... yesterday accidentally I discovered that from runlevel 2 I can start runlevel 5 (as root). Everything goes swell if you disregard the fact that the mouse stops responding and I have to unplug it and plug it in to a new usb.

Appreciating all your help.
/axelmangr
Reply With Quote
  #15  
Old 11th November 2008, 07:56 PM
axelmangr Offline
Registered User
 
Join Date: Nov 2004
Posts: 29
Hi all,

as I said yesterday I managed to log in t kde and run yum to update the system. On top of the existing 2.2.25-15 kernel the 2.2.26.6-79 was added. Now the "slowness" (lol) has gone away. I can normally boot into runlevel 5. Plz don't ask me to boot with the previous kernel. I am really afraid....

But I am facing the following situation: After I enter username and password at the login screen of kde (sometimes even during entering them) one of the following happens:
a) The mouse stops responding
b) The keyboard stops responding
c) Both are working fine but when I hit a key at the keyboard it never stops repeating

Below you may find the xorg.conf that is used. (The mouse section was not there so I added it myself)

Code:
Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
	Identifier  "Keyboard0"
	# I played with both below drivers but nothing changed
        Driver      "kbd"
        #Driver      "keyboard"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
        Driver      "mouse"
	Option      "Protocol" "auto"
	Option      "Device" "/dev/input/mice" #I also experiment with mouse0 but no change
        Option      "Emulate3Buttons" "yes"
        Option      ZAxisMapping" "4 5"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nv"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes     "1280x1024"
	EndSubSection
EndSection
The mouse is a standard microsoft optical usb one, and the keyboard is again a usb one

Again, I would really appreciate any help
thanx
/axel

Last edited by axelmangr; 11th November 2008 at 08:03 PM.
Reply With Quote
Reply

Tags
boot, extremely, fedora, slow

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sony Vaio a517m fedora 10 runs extremely slow and takes a long time to boot cataj Hardware & Laptops 0 15th May 2009 04:22 PM
Fedora 8 extremely slow black_hawk97 Using Fedora 5 29th August 2008 09:07 PM
Extremely slow boot and login in F7 tuna Using Fedora 13 11th June 2007 06:38 PM
Extremely slow boot and IRQ error after adding drives to RAID card brent_strong Hardware & Laptops 11 10th October 2006 03:07 AM
Extremely Slow Boot! BrokenKingpin Using Fedora 4 5th August 2005 03:34 PM


Current GMT-time: 23:21 (Tuesday, 22-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat