Fedora Linux Support Community & Resources Center
  #1  
Old 28th October 2008, 11:13 AM
yellow Offline
Registered User
 
Join Date: Oct 2008
Posts: 7
gedit problems with root

hey

i very recently shifted to linux : fedora . I am using 2.6.25-14.fc9.i686.

The tweaking on linux requires to edit some system config file and that requires switching to root (while i am actually logged in as normal user).
I do it by typing 'su -' command in terminal. But then i cannot open gedit to edit the files. it says

No protocol specified
cannot open display:
Run 'gedit --help' to see a full list of available command line options.


If i login as root and then try to open gedit through terminal - it works..

whats wrong...

thanks for help
Reply With Quote
  #2  
Old 28th October 2008, 11:57 AM
Dangermouse Offline
Administrator - (On Leave)
 
Join Date: Aug 2007
Location: London Postbox (the red one)
Age: 48
Posts: 3,864
Hi and welcome to the forum
I suspect you just did a typo thats all, might be worth rechecking a common mistake,
there is also another way you can browse and open the files in root for editing by
Quote:
su
nautilus
Reply With Quote
  #3  
Old 28th October 2008, 12:29 PM
yellow Offline
Registered User
 
Join Date: Oct 2008
Posts: 7
hey thanks but it is no typo
and same happens with nautilus.
if i donot switch to root and in terminal i try to use gedit or nautilus then its fine... it works
Reply With Quote
  #4  
Old 28th October 2008, 12:38 PM
bee Offline
Banned
 
Join Date: Jun 2008
Posts: 1,315
i don't see any error in what you are doing there.
So, why don't you post a screenshot!?

When you've solved your issue. I would also suggest you to install beesu in order to don't have to open your terminal each time you need to browser as root.

bye!!
Reply With Quote
  #5  
Old 28th October 2008, 01:56 PM
yellow Offline
Registered User
 
Join Date: Oct 2008
Posts: 7
i am sorry but its not uploading my files
Reply With Quote
  #6  
Old 28th October 2008, 02:14 PM
bee Offline
Banned
 
Join Date: Jun 2008
Posts: 1,315
Quote:
Originally Posted by yellow View Post
i am sorry but its not uploading my files
ah!! it's not a problem, there are online free services, like http://rapidshare.com/ to upload files!! it's good because u don't need to take one account, but you can just upload!

bye!
Reply With Quote
  #7  
Old 28th October 2008, 02:21 PM
Dangermouse Offline
Administrator - (On Leave)
 
Join Date: Aug 2007
Location: London Postbox (the red one)
Age: 48
Posts: 3,864
There does seem to be a problem with uploading files (investigating)at the moment, but Bee has given a excellent solution, or as its in a terminal you could just copy paste the output.


Howdy bee got any spare honey
Reply With Quote
  #8  
Old 28th October 2008, 02:25 PM
yellow Offline
Registered User
 
Join Date: Oct 2008
Posts: 7
a million thanks beee

herez the link
http://rapidshare.com/files/15834070...nshot.png.html
i used 'uname' as well so that you can see my kernel ver and stuff

i am stuck coz i can just move on without this stuff
Reply With Quote
  #9  
Old 28th October 2008, 02:37 PM
bee Offline
Banned
 
Join Date: Jun 2008
Posts: 1,315
i'm here

Well, looks like your console (gnome terminal) is working good.
I was thinking there were something of wrong with your "display"...
If you type "su" without "-" will it work?
You can type as user "env" and as root "env" and look there what is "DISPLAY=" set to... maybe the problem is there (MAYBE!) lol
if you don't see it, you could try to type: export DISPLAY=:0.0 when you are root...

bye!
Reply With Quote
  #10  
Old 28th October 2008, 02:43 PM
Dangermouse Offline
Administrator - (On Leave)
 
Join Date: Aug 2007
Location: London Postbox (the red one)
Age: 48
Posts: 3,864
Hi you also typed just gedit
it should be
gedit /path/to/thefile
Reply With Quote
  #11  
Old 28th October 2008, 02:47 PM
bee Offline
Banned
 
Join Date: Jun 2008
Posts: 1,315
Quote:
Originally Posted by Dangermouse View Post
Hi you also typed just gedit
it should be
gedit /path/to/thefile
well, also typing just "gedit" have to work (if all is okay it must work)...it'll just starting the program with a new blank unsaved file.

bye!!
Reply With Quote
  #12  
Old 28th October 2008, 03:09 PM
yellow Offline
Registered User
 
Join Date: Oct 2008
Posts: 7
gedit problems with root

thankssss bee

ok let me write the complete thing...
logged in as normal user i typed 'env' and noted that DISPLAY=:0.0.
I switched to (typing su) root, typed env and still it gives the environment variables for normal user which is actually logged in.
So i logged out ( and for me it meant rebooting : see my logout problem) I logged in as root and typed env in terminal and noticed that DISPLAY=:0.0. Even then i typed
export DISPLAY=:0.0
logged out and logged in as normal user. and switched to root in terminal and opened gedit. now it works, i even opens files, i checked it but on terminal it gives this error...


(gedit:3462): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.



though the problem is solved but what is this error....

i tried with 'su' as well (instead of 'su -') but it didnt work..

For DangerMouse: it was not opening files as well thats how i found it coz i was trying to edit some config file...

thanks again but do look into this message
Reply With Quote
  #13  
Old 28th October 2008, 04:01 PM
bee Offline
Banned
 
Join Date: Jun 2008
Posts: 1,315
Code:
(gedit:3462): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
it isn't a critical error... software are usual to print in your terminal warning messages...

so, if you type and read:
Code:
[bee@localhost ~]$ su
Password: 
[root@localhost bee]# gedit
(gedit:30355): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
[root@localhost bee]#
the solution is:
Code:
[bee@localhost ~]$ su -
Password: 
[root@localhost ~]# gedit
[root@localhost ~]#
as you can see....(if all is okay) you need to add the "-" in su to avoid that warning...

I don't have understand, except that GnomeUI-WARNING, is your problem solved or there are something that doesn't work!?

bye!
Reply With Quote
  #14  
Old 28th October 2008, 04:04 PM
fedoraman08 Offline
Banned
 
Join Date: Oct 2008
Posts: 34
Quote:
Originally Posted by bee View Post
ah!! it's not a problem, there are online free services, like http://rapidshare.com/ to upload files!! it's good because u don't need to take one account, but you can just upload!

bye!
mediafire.com, turboupload.com is good for small file too
Reply With Quote
  #15  
Old 28th October 2008, 05:14 PM
yellow Offline
Registered User
 
Join Date: Oct 2008
Posts: 7
yup thanks its solves my problem but i dont understand a bit about this

MOREOVER it means i HAVE to first login as root and export my DISPLAY variable and then log in as normal user and proceed.
BECAUSE i rebooted my computer and logged in as normal user and switched to root and tried to export DISPLAY but that didnt work..

thanks a million
Reply With Quote
Reply

Tags
gedit, problems, root

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't change gedit preferences when logged in as root ( su ). opencraft Using Fedora 3 23rd September 2009 09:07 AM
Gedit gives error when no write access - ImportError: No module named gedit wpyung Using Fedora 0 15th June 2006 09:54 AM
problems with gedit and httpd.conf ffenliv Installation, Upgrades and Live Media 1 9th August 2005 11:52 PM


Current GMT-time: 09:51 (Wednesday, 23-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat