Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 16th October 2008, 02:42 PM
openSauce Offline
Registered User
 
Join Date: Oct 2007
Posts: 50
Using yum to install older version of software (ndiswrapper) for kernel compatibility

Hi,

I'm using Fedora 8 and I'd like to install ndiswrapper via yum. Ndiswrapper requires a kernel module, and there are many versions available at livna:

Code:
$ yum list available | grep ndiswrapper
kmod-ndiswrapper.x86_64                  1.53-4.lvn8.1          livna           
kmod-ndiswrapper-2.6.21-2950.fc8xen.x86_ 1.48-15.lvn8           livna           
kmod-ndiswrapper-2.6.21-2952.fc8xen.x86_ 1.48-17.lvn8           livna           
kmod-ndiswrapper-2.6.21.7-2.fc8xen.x86_6 1.52-2.lvn8.1          livna           
kmod-ndiswrapper-2.6.21.7-3.fc8xen.x86_6 1.52-6.lvn8.1          livna           
kmod-ndiswrapper-2.6.23.1-42.fc8.x86_64  1.48-15.lvn8           livna           
kmod-ndiswrapper-2.6.23.1-49.fc8.x86_64  1.48-16.lvn8           livna           
kmod-ndiswrapper-2.6.23.14-107.fc8.x86_6 1.48-19.lvn8           livna           
kmod-ndiswrapper-2.6.23.14-115.fc8.x86_6 1.48-20.lvn8           livna           
kmod-ndiswrapper-2.6.23.15-137.fc8.x86_6 1.52-1.lvn8.1          livna           
kmod-ndiswrapper-2.6.23.8-63.fc8.x86_64  1.48-17.lvn8           livna           
kmod-ndiswrapper-2.6.23.9-85.fc8.x86_64  1.48-18.lvn8           livna           
kmod-ndiswrapper-2.6.24.3-12.fc8.x86_64  1.52-2.lvn8.1          livna           
kmod-ndiswrapper-2.6.24.3-34.fc8.x86_64  1.52-3.lvn8.1          livna           
kmod-ndiswrapper-2.6.24.3-50.fc8.x86_64  1.52-5.lvn8.1          livna           
kmod-ndiswrapper-2.6.24.4-64.fc8.x86_64  1.52-6.lvn8.1          livna           
kmod-ndiswrapper-2.6.24.5-85.fc8.x86_64  1.52-7.lvn8.1          livna           
kmod-ndiswrapper-2.6.24.7-92.fc8.x86_64  1.52-8.lvn8.1          livna           
kmod-ndiswrapper-2.6.25.10-47.fc8.x86_64 1.53-1.lvn8            livna           
kmod-ndiswrapper-2.6.25.11-60.fc8.x86_64 1.53-2.lvn8            livna           
kmod-ndiswrapper-2.6.25.14-69.fc8.x86_64 1.53-3.lvn8            livna           
kmod-ndiswrapper-2.6.25.4-10.fc8.x86_64  1.52-9.lvn8.1          livna           
kmod-ndiswrapper-2.6.25.6-27.fc8.x86_64  1.52-10.lvn8.1         livna           
kmod-ndiswrapper-2.6.25.9-40.fc8.x86_64  1.52-11.lvn8.1         livna           
kmod-ndiswrapper-2.6.26.3-14.fc8.x86_64  1.53-3.lvn8.1          livna           
kmod-ndiswrapper-2.6.26.5-28.fc8.x86_64  1.53-4.lvn8.1          livna           
kmod-ndiswrapper-xen.x86_64              1.52-6.lvn8.1          livna           
ndiswrapper.x86_64                       1.53-1.lvn8            livna
My kernel is 2.6.21.7-3.fc8xen, so I try to install the module for that version. However the error message tells me I have to have the latest version, and therefore have to upgrade my kernel to go with it:

Code:
Resolving Dependencies
--> Running transaction check
---> Package kmod-ndiswrapper-2.6.21.7-3.fc8xen.x86_64 0:1.52-6.lvn8.1 set to be updated
--> Processing Dependency: kmod-ndiswrapper-xen >= 1.52-6.lvn8.1 for package: kmod-ndiswrapper-2.6.21.7-3.fc8xen
--> Processing Dependency: ndiswrapper-kmod-common >= 1.52 for package: kmod-ndiswrapper-2.6.21.7-3.fc8xen
--> Running transaction check
---> Package ndiswrapper.x86_64 0:1.53-1.lvn8 set to be updated
--> Processing Dependency: ndiswrapper-kmod >= 1.53 for package: ndiswrapper
---> Package kmod-ndiswrapper-xen.x86_64 0:1.52-6.lvn8.1 set to be updated
--> Running transaction check
---> Package kmod-ndiswrapper.x86_64 0:1.53-4.lvn8.1 set to be updated
--> Processing Dependency: kmod-ndiswrapper-2.6.26.5-28.fc8 = 1.53-4.lvn8.1 for package: kmod-ndiswrapper
--> Running transaction check
---> Package kmod-ndiswrapper-2.6.26.5-28.fc8.x86_64 0:1.53-4.lvn8.1 set to be updated
--> Processing Dependency: kernel-x86_64 = 2.6.26.5-28.fc8 for package: kmod-ndiswrapper-2.6.26.5-28.fc8
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-x86_64 = 2.6.26.5-28.fc8 is needed by package kmod-ndiswrapper-2.6.26.5-28.fc8
Is there any way to persuade yum to install the earlier version of the module? I tried downloading the rpm direct from livna and using yum localinstall, but it still went and looked for the latest version. And I tried the same thing with the livna repo disabled, but then there were other dependencies it couldn't get.
Reply With Quote
  #2  
Old 16th October 2008, 02:55 PM
openSauce Offline
Registered User
 
Join Date: Oct 2007
Posts: 50
Sigh, long day. Forget the question, I just manually downloaded the rpm and the dependencies and installed with rpm.

Out of interest, would there have been any way to do what I wanted with yum?
Reply With Quote
  #3  
Old 16th October 2008, 03:24 PM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
Quote:
Originally Posted by openSauce

Out of interest, would there have been any way to do what I wanted with yum?
Hello openSauce,

Yeah, it's the yum-allowdowngrade plugin. See how Psycho figured that out in another thread here.
Reply With Quote
Reply

Tags
compatibility, install, kernel, ndiswrapper, older, software, version, yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How install older version of boost? 6tr6tr Using Fedora 2 4th September 2009 05:26 AM
F10 compatibility with older glibc (2.3, 2.4, 2.5) ordinary Using Fedora 0 4th April 2009 04:12 PM
ndiswrapper/kernel version mismatch for yum update ? elmerfud Installation, Upgrades and Live Media 31 11th December 2007 01:25 AM


Current GMT-time: 23:45 (Tuesday, 02-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat