Fedora Linux Support Community & Resources Center
  #1  
Old 13th October 2008, 10:00 PM
Riverbanks Offline
Registered User
 
Join Date: Aug 2008
Location: Virginia, USA
Posts: 10
Question Disableing tap to click on Thinkpad R61

Up until recently, I have had no problems with my trackpad, but a little while ago, tap to touch suddenly got enabled for no obvious reason. Its really intrusive, and it clicks almost every time I put my finger on the trackpad. I just want to disable it, but have only found tutorials on how to enable tap to touch, which of course don't help me.

Here is my output from cat /proc/bus/input/devices:

Code:
I: Bus=0019 Vendor=0000 Product=0002 Version=0000
N: Name="Power Button (FF)"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
U: Uniq=
H: Handlers=kbd event0 
B: EV=3
B: KEY=10000000000000 0

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input1
U: Uniq=
H: Handlers=event1 
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button (CM)"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input2
U: Uniq=
H: Handlers=kbd event2 
B: EV=3
B: KEY=4000 0 0

I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/devices/virtual/input/input3
U: Uniq=
H: Handlers=mouse0 event3 
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0001 Product=0001 Version=ab54
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input4
U: Uniq=
H: Handlers=kbd event4 
B: EV=120013
B: KEY=402000000 3803078f800d001 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="DualPoint Stick"
P: Phys=isa0060/serio1/input1
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse1 event5 
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=7301
N: Name="AlpsPS/2 ALPS DualPoint TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse2 event6 
B: EV=f
B: KEY=420 70000 0 0 0 0
B: REL=3
B: ABS=1000003

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=/video/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:02/input/input7
U: Uniq=
H: Handlers=kbd event7 
B: EV=3
B: KEY=3f000b00000000 0 0 0

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=/video/input0
S: Sysfs=/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:07/device:08/input/input8
U: Uniq=
H: Handlers=kbd event8 
B: EV=3
B: KEY=3f000b00000000 0 0 0

I: Bus=0010 Vendor=001f Product=0001 Version=0100
N: Name="PC Speaker"
P: Phys=isa0061/input0
S: Sysfs=/devices/platform/pcspkr/input/input9
U: Uniq=
H: Handlers=kbd event9 
B: EV=40001
B: SND=6

I: Bus=0019 Vendor=17aa Product=5054 Version=4101
N: Name="ThinkPad Extra Buttons"
P: Phys=thinkpad_acpi/input0
S: Sysfs=/devices/virtual/input/input10
U: Uniq=
H: Handlers=kbd event10 
B: EV=33
B: KEY=18840000 2 10010000000000 0 1100b00002000 201104000 0 1
B: MSC=10
B: SW=8
And my xorg.conf:

Code:
# Xorg configuration created by livna-config-display

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 238
	Screen      1  "Screen1" 1280 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib64/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
	Option	    "Xinerama" "1"
EndSection

Section "InputDevice"

    # generated from default
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "Emulate3Buttons" "no"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Unknown"
	ModelName    "LEN"
	HorizSync    42.1 - 49.3
	VertRefresh  52.0 - 60.0
	Option	    "DPMS"
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Unknown"
	ModelName    "HSD iF191D"
	HorizSync    30.0 - 83.0
	VertRefresh  50.0 - 76.0
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "NVIDIA Corporation"
	BoardName   "Quadro NVS 140M"
	Option	    "AddARGBGLXVisuals" "True"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
	Identifier  "Videocard1"
	Driver      "nvidia"
	VendorName  "NVIDIA Corporation"
	BoardName   "Quadro NVS 140M"
	Option	    "AddARGBGLXVisuals" "True"
	BusID       "PCI:1:0:0"
	Screen      1
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	Option	    "AddARGBGLXVisuals" "True"
	Option	    "TwinView" "0"
	Option	    "metamodes" "DFP: 1280x800 +0+0; DFP: nvidia-auto-select +0+0"
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Videocard1"
	Monitor    "Monitor1"
	DefaultDepth     24
	Option	    "TwinView" "0"
	Option	    "metamodes" "CRT: nvidia-auto-select +0+0"
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection
I've already tried things like adding '"TapButton1" "0"' to my xorg.conf in the section for mouse0, but everything I've tried has broken X, forcing me to restore it from the command line.

I just want to disable tap to click, is there a way?
__________________
Fedora 9 64 Bit
Lenovo Thinkpad R61
2.4GHz Intel Core 2 Duo
3GB PC2-5300 2DIMM
Nvidia NVS 140M
160GB 5400RPM

----------------------

"My mallory heart is sure to fail
I could crawl around the floor just like I'm real
Like you" - Gary Numan
Reply With Quote
  #2  
Old 13th October 2008, 10:44 PM
gthill Offline
Registered User
 
Join Date: May 2005
Location: g-land, east java
Age: 50
Posts: 387
If you install gsynaptics you can adjust the sensitivity of the touchpad or disable it all together.
Reply With Quote
  #3  
Old 13th October 2008, 10:56 PM
Riverbanks Offline
Registered User
 
Join Date: Aug 2008
Location: Virginia, USA
Posts: 10
I installed gsynaptics, but when I try to run it, it says that SHMConfig needs to be enabled in xorg.conf. So I added the line "SHMConfig" "true" (I also tried "SHMConfig" "on") to the mouse0 section of my xorg.conf, which broke X in both cases. How do I enable SHMConfig?
__________________
Fedora 9 64 Bit
Lenovo Thinkpad R61
2.4GHz Intel Core 2 Duo
3GB PC2-5300 2DIMM
Nvidia NVS 140M
160GB 5400RPM

----------------------

"My mallory heart is sure to fail
I could crawl around the floor just like I'm real
Like you" - Gary Numan
Reply With Quote
  #4  
Old 13th October 2008, 11:02 PM
gthill Offline
Registered User
 
Join Date: May 2005
Location: g-land, east java
Age: 50
Posts: 387
This works for me.

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
Option "SHMConfig" "true"
EndSection
Reply With Quote
  #5  
Old 14th October 2008, 01:17 AM
Riverbanks Offline
Registered User
 
Join Date: Aug 2008
Location: Virginia, USA
Posts: 10
Nope, that still breaks X.
__________________
Fedora 9 64 Bit
Lenovo Thinkpad R61
2.4GHz Intel Core 2 Duo
3GB PC2-5300 2DIMM
Nvidia NVS 140M
160GB 5400RPM

----------------------

"My mallory heart is sure to fail
I could crawl around the floor just like I'm real
Like you" - Gary Numan
Reply With Quote
  #6  
Old 14th October 2008, 10:50 PM
Riverbanks Offline
Registered User
 
Join Date: Aug 2008
Location: Virginia, USA
Posts: 10
Oh wait, I fixed it. Apparently just restarting X breaks it, while rebooting makes it work for some reason.

My xorg.conf now looks like this:

Code:
# Xorg configuration created by livna-config-display

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 238
	Screen      1  "Screen1" 1280 0
	InputDevice    "TouchPad" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib64/xorg/modules/extensions/nvidia"
	ModulePath   "/usr/lib64/xorg/modules"
EndSection

Section "ServerFlags"
	Option	    "AIGLX" "on"
	Option	    "Xinerama" "1"
EndSection

Section "InputDevice"

    # generated from default
	Driver      "synaptics"
	Identifier  "TouchPad"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "SHMConfig" "on"
	Option	    "Emulate3Buttons" "no"
	Option	    "ZAxisMapping" "4 5"
	Option      "UpDownScrolling" "1"
	Option	    "VertScrollDelta" "20"
	Option	    "VertEdgeScroll" "on"	
EndSection

Section "InputDevice"

# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Unknown"
	ModelName    "LEN"
	HorizSync    42.1 - 49.3
	VertRefresh  52.0 - 60.0
	Option	    "DPMS"
EndSection

Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Unknown"
	ModelName    "HSD iF191D"
	HorizSync    30.0 - 83.0
	VertRefresh  50.0 - 76.0
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "NVIDIA Corporation"
	BoardName   "Quadro NVS 140M"
	Option	    "AddARGBGLXVisuals" "True"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
	Identifier  "Videocard1"
	Driver      "nvidia"
	VendorName  "NVIDIA Corporation"
	BoardName   "Quadro NVS 140M"
	Option	    "AddARGBGLXVisuals" "True"
	BusID       "PCI:1:0:0"
	Screen      1
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	Option	    "AddARGBGLXVisuals" "True"
	Option	    "TwinView" "0"
	Option	    "metamodes" "DFP: 1280x800 +0+0; DFP: nvidia-auto-select +0+0"
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Videocard1"
	Monitor    "Monitor1"
	DefaultDepth     24
	Option	    "TwinView" "0"
	Option	    "metamodes" "CRT: nvidia-auto-select +0+0"
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection
The only problem now is it seems to have broken scrolling with the edges of the trackpad, but I'll fix that later.
__________________
Fedora 9 64 Bit
Lenovo Thinkpad R61
2.4GHz Intel Core 2 Duo
3GB PC2-5300 2DIMM
Nvidia NVS 140M
160GB 5400RPM

----------------------

"My mallory heart is sure to fail
I could crawl around the floor just like I'm real
Like you" - Gary Numan
Reply With Quote
Reply

Tags
click, disableing, r61, tap, thinkpad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Needing left-click to open files upon single-click theAdmiral Hardware & Laptops 6 30th October 2009 04:55 AM
Disableing livna HvHaxor Using Fedora 4 8th June 2008 02:40 AM
How do I right-click azzazus Mac Chat 9 19th December 2007 03:51 PM
i click on dc++ but nothing has done _baris_ Using Fedora 3 27th December 2006 06:17 AM


Current GMT-time: 05:06 (Wednesday, 26-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Siaya Instagram Photos - Wevelgem Photos on Instagram - Conchal Photos on Instagram