Fedora Linux Support Community & Resources Center
  #1  
Old 29th September 2008, 09:15 PM
ssaad Offline
Registered User
 
Join Date: Sep 2008
Posts: 3
Enabling ftp in Fedora 9

I'm a Linux novice and need some help configuring my fedora 9 installation. I'd like to be able to ftp to my fedora 9 system from my windows box. The network connection is fine and I can ping and the hostname is correctly resolved by dns but when I attempt to ftp I get the following


ftp mybox
Connected to mybox.mydomain.mycompany.com.
Connection closed by remote host.

Any ideas?

Thanks
Reply With Quote
  #2  
Old 29th September 2008, 09:21 PM
jrummy27 Offline
Registered User
 
Join Date: May 2007
Location: Raleigh, NC
Age: 31
Posts: 304
You'll need to have the vsftpd package installed and the service running
Code:
# yum install vsftpd
# service vsftpd start
There are many configuration options that you'll want to check out. See /etc/vsftpd/vsftpd.conf and the vsftpd manpage. Google also returns a ton of guides on how to set up a linux ftp server.
__________________
"Ooh, they have the internet on computers now" -Homer
Reply With Quote
  #3  
Old 29th September 2008, 10:50 PM
ssaad Offline
Registered User
 
Join Date: Sep 2008
Posts: 3
Still having issues

Thanks for the tips. I really appreciate the help. I set up and started vsftpd (this wasn't easy since SELinux was blocking it and I had to futz around to configure that). It appears to be running fine but I still cannot ftp from my Windows box. It no longer times out but I get this instead

Connected to mybox.mydomain.mycompany.com.
Connection closed by remote host.
Reply With Quote
  #4  
Old 29th September 2008, 11:39 PM
jrummy27 Offline
Registered User
 
Join Date: May 2007
Location: Raleigh, NC
Age: 31
Posts: 304
Do you have a firewall running?
Code:
# iptables -L
That should show you your current firewall settings. You may need to open the ports for ftp. Google iptables to see how to use it, or run system-config-securitylevel for a configuration GUI.
__________________
"Ooh, they have the internet on computers now" -Homer
Reply With Quote
  #5  
Old 30th September 2008, 12:42 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,068
Quote:
or run system-config-securitylevel for a configuration GUI.
I think you mean system-config-firewall .... I think system-config-securitylevel doesn't exist in F9, it probably died off in a previous version of Fedora

Also, just running service vsftpd start will only work until the next reboot. If ssaad wants to keep the ftp going, also use system-config-services to permanently turn on ftp

Last edited by marko; 30th September 2008 at 12:44 AM.
Reply With Quote
  #6  
Old 30th September 2008, 02:38 AM
jrummy27 Offline
Registered User
 
Join Date: May 2007
Location: Raleigh, NC
Age: 31
Posts: 304
Yea you're right. s-c-securitylevel is F7/RHEL. Thanks
__________________
"Ooh, they have the internet on computers now" -Homer
Reply With Quote
  #7  
Old 30th September 2008, 10:32 PM
ssaad Offline
Registered User
 
Join Date: Sep 2008
Posts: 3
thanks

I have it all working now. I used the freindly admin gui in fedora to configure iptables to let ftp requests in and I have vsftpd running as a service that starts when the system boots up. Exactly how I wanted it to be working. Thanks so much!
Reply With Quote
  #8  
Old 2nd October 2008, 06:38 AM
A.Serbinski Offline
Registered User
 
Join Date: Jul 2006
Posts: 1,123
Just don't be running FTP over untrusted networks since it isn't secure. If you're going to work over untrusted networks, use SSH/SFTP.
Reply With Quote
  #9  
Old 4th October 2008, 06:10 AM
Vector Offline
Banned
 
Join Date: Jul 2006
Location: Transgression
Age: 34
Posts: 1,183
vsftp also has a gui package. To find it, try:
yum list *vsftp*
Reply With Quote
  #10  
Old 4th October 2008, 06:14 AM
Vector Offline
Banned
 
Join Date: Jul 2006
Location: Transgression
Age: 34
Posts: 1,183
Question

Quote:
Originally Posted by A.Serbinski View Post
Just don't be running FTP over untrusted networks since it isn't secure. If you're going to work over untrusted networks, use SSH/SFTP.
vsftp uses ssh, doesn't it? I use vsftp, and i remember when i set it up that it did have some kind of option for secure communication... You can also require a password from each user, but that does not make the connection secure, it only limits who can access the files. DO NOT publish them publicly. If you need help to do this, let me know.
Reply With Quote
  #11  
Old 8th October 2008, 06:55 AM
vginov Offline
Registered User
 
Join Date: Aug 2008
Posts: 16
Ristrict access for FTP

Dear All

I have installed vsftp in fedora 9 and i am able to use it. But all the users can go to the root and change all the folders. But i do not want to allow that. I want to restrict the use to access only a particular folder. I do not even want them to access the user home folder. Cab you please give me the guidelines to achieve this.

Thanks in advance
Reply With Quote
  #12  
Old 8th October 2008, 07:10 AM
satyajit.r Offline
Registered User
 
Join Date: Feb 2007
Posts: 83
use this link:
http://www.redhat.com/docs/en-US/Red...de/ch-ftp.html
this is the redhat documentation for RHEL5.2
should work for fedora
__________________
For more in depth articles and tutorials visit:
/bin/bash
You can find me in #fedora in freenode IRC as satyajit
Reply With Quote
  #13  
Old 8th October 2008, 08:40 AM
vginov Offline
Registered User
 
Join Date: Aug 2008
Posts: 16
Thanks but need more

Dear satyajit.r

Thanks a lot

I found some information about the configuration from the bellow link with your assistance.

http://www.redhat.com/docs/en-US/Red...opt-login.html

I am reading and trying to set it up with the help of this link.

Once again thanks a lot

But if you know the exact path to correct it plz tell hlep me

For example

I have a user named as guest and i want the user to access only the folder in /var/guest out side of that the user should not have a privilege to access

Thanks a lot

Last edited by vginov; 8th October 2008 at 08:44 AM.
Reply With Quote
  #14  
Old 8th October 2008, 08:46 AM
satyajit.r Offline
Registered User
 
Join Date: Feb 2007
Posts: 83
can you tell me how did you set up vsftpd, as in a general setup, and that too in Linux your situation should not occur. As in the normal file permissions will not allow you to do this and above it SELinux should disable it too.
__________________
For more in depth articles and tutorials visit:
/bin/bash
You can find me in #fedora in freenode IRC as satyajit
Reply With Quote
  #15  
Old 8th October 2008, 09:21 AM
Vector Offline
Banned
 
Join Date: Jul 2006
Location: Transgression
Age: 34
Posts: 1,183
I just made a video for how to do ALL of the setup. Give me about 20 minutes to have it up on my site ( http://LinuxIntro.com )
Reply With Quote
Reply

Tags
enabling, fedora, ftp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem enabling network in Fedora 11 albertspade Servers & Networking 2 26th July 2009 12:44 AM
Help with enabling Desktop effects on fedora 6 ryb37 Installation, Upgrades and Live Media 1 23rd January 2008 02:39 AM
Enabling ScummVM In Fedora Core 4 Fragile Avatar Using Fedora 0 10th July 2005 01:55 PM
Enabling /dev/cua0 on Fedora jimtwest3 Using Fedora 0 5th June 2005 09:00 PM


Current GMT-time: 09:08 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Chiautla Travel Photos - Dandeli - Bilgram Instagram Photos