Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Servers & Networking
FedoraForum Search

Forgot Password? Join Us!

Servers & Networking Discuss any Fedora server problems and Networking issues such as dhcp, IP numbers, wlan, modems, etc.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 19th September 2008, 12:03 AM
fashionhat Offline
Registered User
 
Join Date: Jun 2008
Posts: 38
NetworkManager insists "wireless is disabled", but wpa_supplicant cli connects

I'm going crazy again with F9 (this post is one of several problems I am having, but I am isolating this one for a separate post)

I've installed Fedora 9 on a Dell Latitude notebook.

I am using an external buscard card, with an atheros chip, with the ath5k module. There is also an internal wifi card, but it must stay disabled in the BIOS for now.

The said external card (wlan1) connects fine using wpa_supplicant

( wpa_supplicant -Dwext -c /etc/wpa_supplicant/blah.conf -i wlan1 )

However, no matter what I do with NetworkManager, it keeps saying "wireless is disabled" (under the drop-down list in the system-tray nm-applet)

Sometimes there is a brief time period -- about 2-3 seconds -- during which it detects and displays available networks, but then always goes into "wireless is disabled" and everything wireless is grayed out.

when I right-click on the NM applet, "Enable Networking" is normal and checkable, but "Enable Wireless" is grayed out.

I have tried using chkconfig but to no avail.

Please help!!!

thanks

andrew
Reply With Quote
  #2  
Old 22nd September 2008, 05:00 PM
fashionhat Offline
Registered User
 
Join Date: Jun 2008
Posts: 38
Anyone?

I've googled around but the closest cases i found were opposite: people couldn't DISable NetworkManager.
Could NetworkManager be getting something from the BIOS which tells it that the hardware is there but is disabled? That seems unlikely, in my understanding, and so the disabled internal card is a mere inconsequential coincidence to my problem (or is it?). I have installed/upgraded to Fedora 9 on about 6 distinct systems, and never had this problem except now. The successful NetworkManager operations included systems using an external WiFi card (although they did not have one disabled in the BIOS)

Furthermore, if wpa_supplicant (CLI) is capable of using the external card, wouldn't it be reasonable to assume that NetworkManager can be FORCED to use it also? That the "wireless is disabled" switch can be manually overridden??

Where would one do this? Pleeeease help!

andrew
Reply With Quote
  #3  
Old 22nd September 2008, 06:11 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
Open a terminal window, change to root with su - (su dash) and type:

system-config-network

Make sure there is a check mark for "Controlled by NetworkManager", "Allow users to enable/disable device". Also remove the check mark from the "Activate on boot" if so enabled. Then check NM again.

Mike
Reply With Quote
  #4  
Old 23rd September 2008, 07:44 PM
fashionhat Offline
Registered User
 
Join Date: Jun 2008
Posts: 38
Quote:
Originally Posted by Iron_Mike
Open a terminal window, change to root with su - (su dash) and type:

system-config-network

Make sure there is a check mark for "Controlled by NetworkManager", "Allow users to enable/disable device". Also remove the check mark from the "Activate on boot" if so enabled. Then check NM again.
Thank you, Mike, for replying

I have tried what you said numerously before. Apologies for not having mentioned that initially.

Additional observation: Upon boot, without the external atheros card inserted, the NM applet drop-down menu does not mention wireless -- only "wired network". When I physically insert the atheros card, the "Wireless Networks" division (eventually) appears, and it's all grayed out, and it says "wireless is disabled".

The right-click menu of the NM has "Enable Networking", and I can check and uncheck this. The line below that is "Enable Wireless"; it is unchecked, and grayed out.

(And, again: when the card is inserted, device wlan1 is automatically created, and I can issue "iwconfig", "iwlist scan" (with perfect scan results), and connect with wpa_supplicant cli.)

Thanks in advance.

andrew
Reply With Quote
  #5  
Old 23rd September 2008, 10:56 PM
fashionhat Offline
Registered User
 
Join Date: Jun 2008
Posts: 38
new findings/clues !

I discovered that my wpa_supplicant service wasn't really running and can't be started, in spite of system-config-services (gui listing) reporting that it was enabled and running
Code:
[root@... init.d]# /etc/init.d/wpa_supplicant start
Starting wpa_supplicant: /etc/wpa_supplicant/wpa_supplicant.conf, , dbus_bus_get[ctrl_iface_dbus]: Connection refused
Failed to initialize wpa_supplicant
                                                           [FAILED]
Also, thinking that perhaps wpa_gui could provide some type of newbie-friendliness (this system is for a newbie who would find CLI stuff painful just yet), I tried wpa_gui and got the following:

Code:
[root@... init.d]# wpa_gui
Failed to open control connection to wpa_supplicant.
PING failed - trying to reconnect
PING failed - trying to reconnect
<...repeated every second or so...>
(the wpa_gui GUI window does pop up, but doesn't list any interfaces)

I hope these are breakthrough clues.

Googling for the "wpa_supplicant start" error I'm only getting a handful of hits, including the below, from this forum

http://www.fedoraforum.org/forum/sho...d.php?t=197142

It says that it was resolved by starting the messagebus service BEFORE wpa_supplicant service. But for me, (re)starting my messagebus only got me out of X into console mode

please help!

Last edited by fashionhat; 23rd September 2008 at 11:03 PM. Reason: put a smilie in the wrong place (head of post)
Reply With Quote
  #6  
Old 24th September 2008, 02:34 AM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
See if this helps. If using NetworkManager, these 2 services should be disabled, "Network" and "wpa_supplicant". The reason being, NM will control the network and start the wpa_supplicant as network.

Mike
Reply With Quote
  #7  
Old 24th September 2008, 03:09 AM
fashionhat Offline
Registered User
 
Join Date: Jun 2008
Posts: 38
Iron_Mike

I followed your most recent instruction: disabled both "network" and "wpa_supplicant" (also rebooted)

Now, the first 7 seconds after I restart the "NetworkManager" service, the second line in the right-click NM menu ("Enable Wireless") is not grayed out, the checkbox is checked and un/checkable. After about seven seconds it is again grayed out.

Left-click drop-down now gives me four redundant "Wireless Networks" sections, with "wireless is disabled" in each of them (all grayed out)

(since my last post i stuck in an rt73 usb card as well. So, it's these two cards, i think, times two (as NetworkManager doubles everything for some strange reason))

Another thought: If I am getting an error trying to start the wpa_supplicant service, how likely is it that NetworkManager is running into the same error when it tries to start the wpa_supplicant service?

EDIT: OK. This seems to answer the above question, in the negative:

Code:
/etc/init.d/wpa_supplicant status
wpa_supplicant (pid 2059) is running...
(apparently started by NetworkManager)

still, all is gray.

Last edited by fashionhat; 24th September 2008 at 02:20 PM. Reason: additional finding of my own, prior to anyone's reply (NM does start wpa_supplicant service apparently)
Reply With Quote
  #8  
Old 14th November 2008, 11:30 AM
wajda Offline
Registered User
 
Join Date: Nov 2008
Location: Prague, CZ
Posts: 31
Resolved! :)

Hey, fashionhat.

It seems I found a solution how to fix the problem!
I'm running F9 on Dell Latitude as well and recently encountered absolutely the same problem that you described in this topic.
After several unsuccessful attempts to do some magic playing with services, config files, bla-bla-bla, I got mad and just angrily turned my laptop aside....
Surprisingly I immediately realized that this was exactly what I needed to do - to turn the laptop aside, as I notices a small slider at its left side that switches the wifi on and off (hardwarily I suppose). And of course it was accidentally switched off!
Try it yourself. Hope it'll be working for you as well!

Alex.
Reply With Quote
  #9  
Old 14th November 2008, 09:19 PM
fashionhat Offline
Registered User
 
Join Date: Jun 2008
Posts: 38
Thank you, wajda, for responding.

Apologies to the forum for not returning to this thread sooner. So far, the only way I have found to keep the on-board WiFi disabled in the BIOS and, at the same time, have an external (removable) WiFi card enabled and working with NetworkManager, is to alter the NetworkManager source code.

After not getting answers in this forum i inquired at the NetworkManager mailing list, and got the above information. I was told that NetworkManager code "honors" and checks the HAL killswitch, with no user option to make it NOT honor it (software author's decision).

however, the author(s) were kind enough to share a quick hack of the source code to disable the honoring of the killswitch, which worked like a charm, making NetworkManager detect and control my removable WiFi card.

----

in response to wajda's solution: Your physical toggle switch may produce the same HAL killswitch status as does my disabling the onboard WiFi in the BIOS -- just a guess.

Thanks again

Andrew
Reply With Quote
Reply

Tags
cli, connects, insists, networkmanager, wireless is disabled, wpasupplicant

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Manager connects with "auto eth 0" piet85 Servers & Networking 15 2nd July 2009 01:32 PM
Fedora 8 Test 3 << INIT : "x" respawining too fast: disabled for 5 minutes >> mikhael Using Fedora 4 31st October 2007 06:47 PM
intel 3945 wireless connects but is "buggy" extendedping Hardware & Laptops 1 13th December 2006 03:11 AM
"Association request to the Driver failed" error with wpa_supplicant snakeyes30 Servers & Networking 1 7th August 2006 04:42 PM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 05:59 AM


Current GMT-time: 23:04 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Formentor Instagram Photos - St. Louis Zoo Instagram Photos - Mandarmani, West Bengal Travel Photos on Instagram