Fedora Linux Support Community & Resources Center
  #1  
Old 27th August 2008, 01:55 AM
testlinux4ever Offline
Registered User
 
Join Date: Jun 2008
Location: Virginia Beach,VA
Age: 34
Posts: 18
Angry .gvfs bug in Fedora 9

So I am a semi-noob to the linux thing, I started with Fedora8, tried Ubuntu8, and decided on Fedora9.
I love it, but I found this bug with the /home/drew/.gvfs file.
I cannot access it or change the permissions even when logged in as root (su). I need to access this in order to run certain commands.

Does anyone know how to fix this? I have been researching forums for hours and cannot seem to find a fix.

I have rpm-4.4.2.3-2.fc9.x86_64
Kernel 2.6.25.14-108.fc9.x86_64
If you need anymore info let me know thanks.
Drew
__________________
Drew (noobcake)
Transitioning from M$ to Open Source
A+, MCSA (like it matters here!)

Last edited by testlinux4ever; 27th August 2008 at 02:01 AM.
Reply With Quote
  #2  
Old 27th August 2008, 02:47 AM
pete_1967 Offline
Clueless in a Cuckooland
 
Join Date: Mar 2006
Location: Here now, elsewhere tomorrow.
Posts: 4,360
It's a directory with dr-x------ permissions. Normal chmod can change the permissions. (-R option for directories, `man chmod` for more detail)
__________________
A Drink is Not Just For Christmas - SaskyCom :thumb:


“Give a man a fish; you have fed him for today. Teach a man to fish; and you have fed him for a lifetime” so now go and...
RTFM FIRST: http://docs.fedoraproject.org/ & http://rute.2038bug.com/index.html.gz
Reply With Quote
  #3  
Old 27th August 2008, 03:49 AM
testlinux4ever Offline
Registered User
 
Join Date: Jun 2008
Location: Virginia Beach,VA
Age: 34
Posts: 18
ok so I did a
"chmod -R 0700 .gvfs"
and then tried "chown root .gvfs"

I am still getting permissions denied with root and I couldnt make it owner.
I also did a "chmod -R 0770 .gvfs"
and still nothing.

Work with me here I am still noobish and I doing anything wrong?
I notice you are using the same flavor that I am "with better specs", did you have the same problem?
Help.
__________________
Drew (noobcake)
Transitioning from M$ to Open Source
A+, MCSA (like it matters here!)
Reply With Quote
  #4  
Old 27th August 2008, 08:22 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 37
Posts: 4,423
What exactly do you want to do with the directory? And why would you want it to be root the owner? The fact that you are specifically messing with .gvfs indicates that it has something to do with virtual filesystems support in GNOME... To what end?
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
Reply With Quote
  #5  
Old 27th August 2008, 11:12 PM
testlinux4ever Offline
Registered User
 
Join Date: Jun 2008
Location: Virginia Beach,VA
Age: 34
Posts: 18
In order for some commands to work (su) needs permissions to home/drew/.gvfs
I didnt really care about being the owner, I just wanted the thing to give root permissions (which it should have permissions to anyways).
I found the permissions by doing a 'find / -name pidof'
and it came back
find: /home/drew/.gvfs: Permission DENIED
And this is logged in as SU

Any suggestions? It is a known bug but I cannot find a fix to it NEwhere lol
__________________
Drew (noobcake)
Transitioning from M$ to Open Source
A+, MCSA (like it matters here!)
Reply With Quote
  #6  
Old 28th August 2008, 12:07 AM
A.Serbinski Offline
Registered User
 
Join Date: Jul 2006
Posts: 1,123
I don't see how this is a bug.
You're using gvfs to mount some filesystem, presumably a remote NETWORK filesystem.
In order to have permission to read, write, or anything else, the user that you are using to log in to the remote system MUST HAVE SUCH RIGHTS.

In addition, your LOCAL ROOT is not the same as the REMOTE ROOT and therefore has no privileges whatsoever on the remote system. gvfs is doing exactly what it should do and preventing access to ALL users besides the one who actually has permission to access it.

If you mount a remote filesystem with some user, lets say "sam", then you do NOT get permission to portions of that filesystem unless "sam" has such permissions.
Reply With Quote
  #7  
Old 28th August 2008, 02:42 AM
testlinux4ever Offline
Registered User
 
Join Date: Jun 2008
Location: Virginia Beach,VA
Age: 34
Posts: 18
I really appreciate the assistance but who said anything about a remote host?
It is a laptop.
I cannot run ifconfig, because of this issue.
if I do a 'find / -name ifconfig'
I get the same permission error as listed above.

http://www.linuxforums.org/forum/lin...emove-dir.html
This is another person who has had the issue.
I dont like to post with out doing a LOT of research.
Thanks,
__________________
Drew (noobcake)
Transitioning from M$ to Open Source
A+, MCSA (like it matters here!)
Reply With Quote
  #8  
Old 28th August 2008, 03:05 AM
A.Serbinski Offline
Registered User
 
Join Date: Jul 2006
Posts: 1,123
YOU did. What do you think gvfs does? You asked a question about gvfs, now it turns out that your question had nothing at all to do with gvfs, but rather file permissions in general.

If you're running a command like "find", it is not going to scan through directories for which it lacks read permissions and will spit out an error when such is encountered. THIS DOES NOT MEAN that the program isn't working. 'find' will still go through all the other directories that it DOES have permission to read.

Yes, it will spit out a bunch of "permission denied" errors, but those are only to tell you that there are places where it has no permission to read. It will still output the result of your query.

If you just don't want the errors showing up, slap on a 2>/dev/null "find / -name ifconfig 2>/dev/null"

And again, this is NOT a bug. You certainly CAN run ifconfig as doing so is absolutely in no way related to this message.
Reply With Quote
  #9  
Old 28th August 2008, 03:19 AM
Wayne
Guest
 
Posts: n/a
If you want to run ifconfig after issuing the su command then you have to use the full path to the executable. If you don't want to do that then you have to use:

su -

su space dash, then give the root password before typing ifconfig

Wayne
Reply With Quote
  #10  
Old 28th August 2008, 03:32 AM
testlinux4ever Offline
Registered User
 
Join Date: Jun 2008
Location: Virginia Beach,VA
Age: 34
Posts: 18
Ok dude,
I cannot run ifconfig
I get a 'command not found'
so in fact the program DOESNT WORK.
With all due respect, dont just reply to flex.
If you are going to help I appreciate it, if not dont waste my time.
I dont mind the errors showing up because that is why I ran the command, to see if it was a PATH error or in this case a Permissions error.
And I am a noob at this OK.
BTW I am doing this as SU, which SHOULD have access to .gvfs
__________________
Drew (noobcake)
Transitioning from M$ to Open Source
A+, MCSA (like it matters here!)
Reply With Quote
  #11  
Old 28th August 2008, 03:33 AM
testlinux4ever Offline
Registered User
 
Join Date: Jun 2008
Location: Virginia Beach,VA
Age: 34
Posts: 18
ty Wayne I am doing just that
__________________
Drew (noobcake)
Transitioning from M$ to Open Source
A+, MCSA (like it matters here!)
Reply With Quote
  #12  
Old 28th August 2008, 03:35 AM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,204
[bob@localhost ~]$ su - <don't forget the minus sign!
Password:
[root@localhost ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:13:D4:C6:E0:DD
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::213:d4ff:fec6:e0dd/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:69370 errors:0 dropped:0 overruns:0 frame:0
TX packets:63583 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:41323854 (39.4 MiB) TX bytes:10897936 (10.3 MiB)
Interrupt:23 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:7382 errors:0 dropped:0 overruns:0 frame:0
TX packets:7382 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2577361 (2.4 MiB) TX bytes:2577361 (2.4 MiB)
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #13  
Old 28th August 2008, 03:43 AM
testlinux4ever Offline
Registered User
 
Join Date: Jun 2008
Location: Virginia Beach,VA
Age: 34
Posts: 18
Wow you are awsome I feel dumb now I never put the - in after the su and that was my problem
I didnt know you HAD to do that
Thanks so very much.
To Wayne and BOB
I really appreciate the help
__________________
Drew (noobcake)
Transitioning from M$ to Open Source
A+, MCSA (like it matters here!)
Reply With Quote
  #14  
Old 28th August 2008, 03:48 AM
testlinux4ever Offline
Registered User
 
Join Date: Jun 2008
Location: Virginia Beach,VA
Age: 34
Posts: 18
again thanks all my programs I wanted to try in bash are working now
__________________
Drew (noobcake)
Transitioning from M$ to Open Source
A+, MCSA (like it matters here!)
Reply With Quote
  #15  
Old 28th August 2008, 05:08 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 37
Posts: 4,423
Actually the problem you had with ifconfig relates to the fact that admin programs are usually located under /sbin and /usr/sbin/, those paths are not part of the PATH variable of regular users. you can still use these commands if you use their full path, with the restrictions they may have from not being run by UID=0 (root), for example:

Code:
/sbin/ifconfig
To check upon the network status of the different interfaces

Code:
/sbin/lspci
To check upon the PCI bus and oder of devices (running any more verbose mode would require root's privs, though)

Code:
/sbin/lsusb
To check those devices in the USB bus.

And many others.

Edit

Some other useful programs that can be run as a regular user to find out stuff or to maximize use of the system.

Code:
/usr/sbin/lsof
To find out what programs are accessing what parts of the filesystem at any one time (ever wanted to unmount a CD ROM drive, only find out you couldn't and didn't know what program was accessing it?)

Code:
/usr/sbin/alternatives
This is indeed very useful, though limited with regular user privs, as you can't alter anything, but you can check things up. This program is used to be able to have multiple different versions or types of the same application, but only have one at a time active, and you can configure multiple instances, for example, is how Java has been managed in Fedora since as far back as Core 4 (Stentz), and is how you can leave OpenJVM, GCJ and Sun Java installed on the system and only use one default JVM system-wide or have a launcher program use a particular version.
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.

Last edited by Thetargos; 28th August 2008 at 05:13 AM. Reason: Typo huntin'
Reply With Quote
Reply

Tags
bug, fedora, gvfs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable gvfs P4rD0nM3 Using Fedora 10 22nd September 2010 09:39 PM
GVFS mountpoint /home/$USER/.gvfs problem yuhuntero Using Fedora 3 11th September 2009 03:08 PM
Problem with GVFS brunoadm Using Fedora 0 19th August 2009 12:07 AM
OpenOffice anf gvfs karel.hudan Using Fedora 1 9th January 2009 11:32 AM
.gvfs permission denied jideck Using Fedora 2 14th November 2008 11:46 AM


Current GMT-time: 18:42 (Sunday, 23-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Cypress - Schkeuditz Instagram Photos - Saveh